[Need Help] Bricked Lenovo D30 System after having flashed a Modded BIOS

Ok, I have a Lenovo D30 system that I am trying to do this mod to provide me with NVMe support. I have seen one of two others in this thread say they had a D30 as well and were able to get this working. However I keep running into the “Secure flash rom verify fail” issue. I have followed the directions about putting the NVMe .ffs file into the bios file correctly. I have tried using the afudos and afuwin and get the same error in both. I have tried a capsule file, a capsule file with the header removed from the UEFI tool, and .bin and .rom files…all provide the same result. Any help getting around this secure flash issue and what I might be doing wrong? Below is a link to the latest bios from LENOVO, i’ve tried modifying this one as well as dumping the one on my system and modifying that with the NVMe.ffs file…both give the same issue.

https://support.lenovo.com/us/en/downloads/ds035725

@Mercennarius - Find those posts where users flashed mod BIOS on your same system, and tag them (Like I did you here w/ @ directly followed by exact name) or send them PM to ask how they flashed in mod BIOS.
It’s not about how you made your mod BIOS, as long as the mod looks to be done OK, it’s just that flashing mod BIOS using normal methods such as you mention is not normally possible.
They may used certain special method or tool, or recovery flash procedure etc. You will have to ask them directly

@Lost_N_BIOS thanks for the reply. Here is the post where @jkloepping was able to flash their Lenovo D30 successfully, I followed their procedure and I am still getting the secure flash rom verify fail error.

[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS (68)

@Mercennarius - Did you download that BIOS package A1KT59A bios for the 4223 he’s talking about, and are using that AFUWinGUI now? Was that package still dated 2016? If not, maybe they removed the AFUWinGUI version that used to be included.
Program all the block is not ideal, but if it worked for him them OK. Hopefully he will reply here to you soon, and maybe repackage a quick flash package for you with your mod BIOS.

Please link me to both BIOS download pages, your exact model/system (I assume link above so OK) and the A1KT59A bios for the 4223 he mentioned.

Is this Intel system, if yes, do below and let me know what error you get at step #2

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below


If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required
> CLICK HERE TO DOWNLOAD CMD PROMPT REGISTRY ENTRY <

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

@Lost_N_BIOS Thanks for the reply. Yes I downloaded the A1KT59A bios



I was able to get through the first 2 steps no problem, dumping and reloading the original bios was no issue, it was loading any of the modified bioses i’d try gave the secure flash rom errors.

Well after some more testing I think I bricked my board…I was able to get AFUWIN to load the modded bios wth “Afuwin modbios /p /b /n /k /capsule /recovery” It said to hit “Y” to restart after it loaded for a minute and then now the computer just beeps with no video output…tried resetting CMOS and it didn’t help.

------------------------

@Lost_N_BIOS Anyway to recover this or am I better off buying a new board now? Just beeps now when I turn it on with no video.

@Mercennarius - What you mention is unrelated to what I gave you outlined info on how to do. I gave you Intel FPT info/method, you replied with AFU error info “secure flash rom errors”, these two things are unrelated and should not be used together in any discussion or edits etc.
If you passed step #1 and #2 in the FPT spoiler I gave you, then all is unlocked and you can easily flash mod BIOS this way. Once you told me that I would have told you then this is simple, edit file from step #1 and flash back again via step #2 - all would be done and no issues

Yes, if you use Capsule or Recovery with AFU that usually = brick. You will need CH341A + SOIC8 test clip with cable to fix now, let me know if you need links (Actually, I will put examples below)
And once you get these items DO NOT erase or write to chip until I tell you OK, and that your dumped BIOS is OK/valid and safe to move forward, otherwise you may loose your original UUID forever and it will be much harder to put back serial, windows key, system info etc.
Main thing to take away from this is SLOW WAY DOWN when messing with BIOS, especially after you ask for help, wait for replies, what to do next, what not to do etc. If you would have waited for me to reply your board would not be bricked now, and you’d have your mod BIOS flashed in already.
Here’s what you need, as example, you can find these in many other places, or shipped faster for more $$, or in bundled kits etc
https://www.ebay.com/itm/123255178089
https://www.ebay.com/itm/183425731977

@Mercennarius @Lost_N_BIOS
Since this discussion has not much to do with the topic of >this< thread, I have moved your posts into a separate thread and gave it a hopefully meaningful title (you can change it whenever you want by editing the start post).
Hoping, that this is ok for you
Dieter (alias Fernando)



I passed steps #1 and #2, however when I would then try to flash my modded bios it wouldn’t work. Given that the only person who had posted they got this working did so with the AFU utlity I went back and tried it here again and was getting the secure flash rom errors until I disabled capsule and recovery. I should have just taken this step by step here…



That’s what I have done. I ordered the CH341A and test clip and will be doing this. Thank you the recommendation.



Will do. Below is a thread I found with someone who did some research/work with the same motherboard. Hoping I won’t have much issue with the hardware method:

Lenovo D30 Thinkstation C602 chipset ME7 Sandy Bridge to ME8 Ivy Bridge support



Certainly. Learned the hard way here. I appreciate your help here and hopefully will be able to get the board up and running again soon with the CH341A.




Thanks Fernando.




OK @Lost_N_BIOS I am back to this point, I just downloaded the correct ME FPTW tools, completed step 1 and 2. Was able to backup rom file fine, when I try to flash the backup back it says ““RESULT: the data is identical” FPT Operation Passed”. Before I go any further I would appreciate your guidance so I don’t brick this board. Thank you.