[OFFER] ASUS B150 Pro Gaming D3 - modded BIOS and dump

Hello guys. Here i upload my modded bios for b150 pro gaming d3 and full dump from my CH341A programmer.
I’ve inserted the last available EFI and OROM modules into it using UBU 1.70 RC10. BIOS contains
EFI and OROM IRST RAID for Sata, ver. Honestly, dunno if this module works well, no RAID options for this MoBo. But running windows 10 without any errors with heavy diskload for a week.
EFI GOP Driver from CannonLake ver. 11.0.1014 - need to check and comment that later.
OROM VBIOS ver. 1059, with all settings transfered from old vbios correctly. Works perfect.
Network EFI Intel Gigabit UNDI - ver. 0.0.19
Network OROM Intel Gigabit CL - ver. 0.1.13
And all updated CPU microcodes.

Beware, full dump from my bios contains my mac-adress and bios settings. So it might need some ME region cleaning or smth like that.

Modded bios is made from clear 2604 bios from asus website, it needs at least insertion of unique mac adress before flashing (or win10 will give you smth like 88:88:87:88). To do so, you must open bin file with HxD a.e., go to offset 2D4818 and paste your mac. So the 2D4818-2D481D offset with length of 6 (in hex) must contain your mac (like 00 13 8F A6 E2 28). Or you can do it after flashing with mac tool from ASRock.

Also ill post decoded list of setup variables, so system can be tuned through efi shell. As example, to enable intel speed shift, you must enter efi shell and set variable 0x5F to 0x1.

Here i upload my full dump from bios chip (W25Q128FV from winbond, 16MB SPI). I think it should be used only in emergency to recover failed bios when nothing software-based works. It must be flashed with hardware SPI programmer. Mac is set to 00 13 8F A6 E2 28. It also contains some tunings in bios settings from my system, so i think its necessary to clean CMOS. This image has updated CSE ME firmware (, i believe its the lastest one at this moment). Archive should be unpacked with RAR5 compatible archivator (forum limits of filesize).

W25Q128FV B150 Pro Gaming D3 modded.rar (5.98 MB)

Here i upload modded bioses (original images taken from asus.com). Ideally, it must not change your mac and other settings, but it depends on method of flashing.
Two versions 'cause one with kaby lake EFI GOP ver. 9.0.1080 (B150 Pro Gaming D3 skl1080) and second one with cannon lake EFI GOP ver. 11.0.1014 (B150 Pro Gaming D3 cnl1014). All other modules as i stated in post #1. I dont know a way to flash it from software, so use a forum to find one.

Please note two thins.
First, you can flash this images as dump via hardware programmer, but i dont take any responsibility for the consequences.
Second, these images have outdated CSE ME firmware. Firmware is ver., so you need to use utility from ASUS support website to update it.

B150 Pro Gaming D3 cnl1014.rar (5.96 MB)

B150 Pro Gaming D3 skl1080.rar (5.96 MB)

Lastly - setup variables from universal IFR extractor. As i said in main post, to modify it use efi shell (file attached too). Just extract efi folder to FAT-32 usb stick, boot into it and use

setup_var 0xoffset
to check value and
setup_var 0xoffset 0xvalue
to set value.

Hope this will help somebody, if any help is needed feel free to contact me, i will be glad to help if i can.

B150 Pro Gaming D3 IFR.txt (1.43 MB)

efi-shell.rar (651 KB)

Did somebody thought of unlocking raid by taking some part of bios from Z170?

Sorry, but bad news here. I’ve tried to take out z170 raid module and put it in b150 about 10-15 times. It’s more Intel Management Engine related thing, I think. I’ve googled a lot about it, and nobody as I know really made it.

@SithisSir - what is the issue with RAID, maybe I can help? I see RAID Option in BIOS @ Advanced >>> PCH Storage Config >> SATA Mode Selection. Can you not see this setting, or submenu?
I can unlock for you if you can’t see it. If you can’t see, please tell me how far in that string of menus you can view, ie can you see PCH Storage Config in Advanced, if not then I will enable that. If you can see PCH Storage config, but not the SATA mode selection setting, then I’ll enable that.


Hi @Lost_N_BIOS Following this in BIOS @ Advanced >>> PCH Storage Config >> I have no "Sata mode selection". Only M2 enable in one place and hot swap enable-disable for each of 6 Sata channels. I am on 2203 bios, but this feature is claimed to be disabled for the entire chipset at all.

I dont have any devices to flash bios at the moment, but Ill be really happy to get raid there. Will I be able to flash your mode via standard tools?

Also, one important thing. I have a few ECC Reg sticks. They don`t work on this board, but this also might be a disabled feature of the chipset. If would be really useful to make Reg memory work as it is twice cheaper than a standard memory. However, it also may require to do something with CPU pins because the memory controller is there.

If the chipset doesn’t support it then enabling the setting to be visble to you wont help, but I can make it visible if you want? For mod BIOS with Asus, you need to either flash a certain way (USB flashback if board has it), or use certain AFU version/method, or Intel FPT (my preferred method)
ECC support may be disabled in BIOS too, unsure about chipset, but I can check and enable that in BIOS for you too if it’s there.

Please find your ME FW version from BIOS main page, or via HWINFO64 on large window expand motherboard, go to ME section and get ME Firmware version and then from this thread in section “C” download matching ME System Tools package
Intel Management Engine: Drivers, Firmware & System Tools

Inside you will find Flash Programming Tool folder, and inside that a windows or win/win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (not power shell)
Then type the following command and send me the created file >> FPTw.exe -bios -d biosreg.bin

If this board has USB Flashback, none of the above is needed, let me know and I will modify the stock BIOS instead.

Thank you for your readiness to help.

Unfortunately, my board has no USB Flashback.
My ME FW version is

We don`t know on what level those limitations implemented. If at least anything might be unlocked from Bios I would be happy to test it. Both Raid and REG memory support will be big deals for lots of people.

@ZAC - OK, download ME System Tools V11 from the page I linked above, down in section "C".
Inside that package you will find Flash Programming Tool folder, and inside that a windows or Win or Win32 folder, select that Win/Win32 folder and hold shift, then press right click and choose open command windows here (Not power shell)
Then type the following command, zip the created file and send to me for modification >> FPTw.exe -bios -d biosreg.bin


Thank you for the instructions. Please find the attached archive.

If I will get a brick after all, just in case, what device would you recommend to flash it back?

biosreg.rar (4.57 MB)

@ZAC - You wont get a brick, but if you do you need CH341A and SOIC8 test clip cable, both total around $5 shipped on ebay.
Did you modify this BIOS after the edits done at post #2? If not, is that the BIOS you are using, from post #2, or some other BIOS? I ask because this BIOS has broken FIT Table, someone updated microcodes and didn’t fix the FIT table after that.
This causes CPU microcodes not to load properly, and then will either be ran without microcode, or windows will install one that’s used within windows.

Ohh! never mind, I compared your dump to the BIOS in #2 for microcodes, and I see yours are all out of date (All from 2016) and the BIOS in post #2 has two updated and only one out of date but still from 2018.
So this may be some other persons mod BIOS, or you did, or Asus stock with broken FIT Table? I doubt that Asus did, but it happens when engineer is lazy, I didn’t check stock BIOS for this board only your dump and BIOS from post #2

ECC Support is already enabled by default, when optimal defaults have been loaded.
If you can tell me how far into this menu string you can see, I can enable the page that has the ECC setting for you if you want, so you can see it and enable/disable >> Advanced >> System Agent >> Memory Config << (This page, can you see that) If not, then I enable the page, if you can see it, but no ECC setting then I can enable the setting

I enabled to be visible to you SPD Write setting @ AI Tweaker >> DRAM Timing Control (Bottom of page) + Advanced >>> PCH Storage Config >> SATA Mode Selection setting

Flash this back via >> FPTw.exe -bios -f biosregm.bin


My dump was a virgin one coming with the board. Not sure about previously uploaded version, it seems some mistake was there.

I have flashed your bios, tried everything, and have only bad news.

Now I can see RAID Option in BIOS @ Advanced >>> PCH Storage Config >> SATA Mode Selection. However, the only option there is AHCI. No Raid, no nothing whatsoever.

Now I can see AI Tweaker >> DRAM Timing Control with lots of locked options and a few unlocked. However, there is nothing about both ECC and Reg. None of my memory modules worked with the new bios.
I can see AI Tweaker >> DRAM Timing Control >> SPD Write.
I can see Advanced >> System Agent >> Memory Config, but the only available setting there is Memory Remap.

Also, I noticed a new bad thing. I use DDR3 not L memory, which works on 1.5V. This is not recommended by Intel due to a possibility of damaging CPU. I used to manually set negative offset to the memory via AI Tweaker >> DRAM Voltage. Now I have no options there, only unchangeable Auto. However, I figured that I may set the value manually by + and - buttons on the keyboard, and this value works.

Please take a look at what else could be enabled for memory settings and add new microcodes. Seems, about unlocking Raid I will have to forget. Or, it will require some hard modes.

@ZAC - No mistakes in the other one, only yours, so maybe it is Asus mistake which could be due to an early BIOS version? I didn’t check, was that an early BIOS, not latest? If it’s not latest, then you should definitely update the BIOS.

On the RAID, good you can see, let me check the options out outside of AMIBCP, I didn’t even look since RAID was visible I didn’t think it could be suppressed from you. I bet that’s what’s going on, easy fix! Yes, checked, this is the issue, sorry I didn’t check this before!

At Dram timing control, I only enabled one setting, rest was left alone/as-is/defaults you should have already been able to see. I should have asked you for some images of these sections, that would have made this quicker and easier on us both , can you see me some images of all these pages (Not RAID one)
I did not change AI Tweaker Dram voltage? Did you load optimal defaults after reflashing? This should be a direct key in voltage thing I think, or +/- also as you mentioned, did you try with both unlock on and off? Auto should go away once you hit enter on it and change the values.
If we find this to be a continued issue, I can undue the only change I made in that area (the SPD write, especially if you never edit your memory SPD you don’t need this anyway)

Anyway, lets get you on the latest BIOS first and then figure all this out once rest of options are working that you wanted. If you have not already, please update to latest BIOS and send me a new dump to work on.

I’ll look at the RAID setting and see if it’s being suppressed from you now that you can see the option area, sorry for not checking this before * See above!
On SATA/RAID etc, do you have another place that has this controller mode selection? I see 3 controller options outside of advanced section, which could be set this way instead/too, so need to know if you already could see those or not so there’s not a double setting option for this.
If you do have, add it to the images. Ohh yes, I forgot to mention too, put a USB stick in before you boot to BIOS, then you can take screenshots via F12 on each page I wanted an image of (All those mentioned above). Then zip those up and attach or upload

Edit - I checked, your on old BIOS and if you never modified this in any way then Asus must have updated it since you last downloaded it (to fix the FIT issue), since it’s correct in the stock one now. Looks like their last edit was 3/1/17 at 5:12 AM.
Here is latest BIOS 2604, lets get you updated to that and then send me new FPT dump
Update to this BIOS the normal way, via EZ Flash. Do not use this BIOS at all with FPT Or, if you do not want to update to latest BIOS, I can fix the FIT issue before I send you next mod update? Up to you

* Edit 2 - @ZAC - here is new mod BIOS, with only the Advanced >>> PCH Storage Config >> SATA Mode Selection setting option enabled (And I unsuppressed the RAID option). I removed the SPD write edit previously enabled, in case that was what was causing the issue for you on memory voltage setting.
I also corrected the FIT Table, but did not update the CPU microcodes (Left at 2016 versions, but windows will replace likely in OS, for security concerns due to Meltdown/Spectre unless you stop that)

Flash this back via >> FPTw.exe -bios -f biosregm2.bin

And yes, we can still do all this the same if you decide you want to go ahead and update to latest BIOS as I mentioned

Thank you so much for this huge work! I really appreciate it.

Well, my board has bios from 2017, yes. Not sure how did it get that bios (probably from Asus factory), but nearly 100% sure this is original Asus, what makes me thinking if there is any mistake this is their mistake. I previously had Asus ROG mobo which bricked because of their official bios. I went with it to the service, they didnt believe me, removed bios chip, flashed it to a default version, and bricked themselves again with the latest official version of Bios. So no surprises with their Bios quality :)<br /><br />Prior I will flash to the newer bios, may you please let me know if I will be able to move between version freely after that? I saw a warning message somewhere here that having latest versions on Asus there is no way back without programmer (which I havent even order yet).

@ZAC - You’re welcome!

Probably Asus posted that BIOS long ago, and then later at some time after you downloaded it the y fixed the FIT table and reposted it with same version info etc.
Yes, it’s their mistake if you never flashed mod BIOS, I see it from time to time on manufacturer BIOS, they either fix later and repost same link, or leave and fix on next version. That’s funny about them bricking it with their own BIOS

I don’t know about BIOS version going back and forth, but often you can’t due to ME security locks, this only applies to official method (EZ Flash). You can flash back any time you want to whatever BIOS region via FPT, so no worries there.
The BIOS I posted above is same version I gave you before, only your edited backup dump with the changes I mentioned. So you’ll still be on that same version if you don’t want to update now it’s OK you can stay on that one.


Yep, Asus later replaced the bricking bios with another one having same version and name. But since that I prefer to not update anything without a real reason :slight_smile:

I flashed the second edition. Yes, I see the Raid option now and able to select it. Although, I have no idea what to do next to use it. Usually, if Raid is enabled you have the second boot menu after the main Bios. It shows you keys to press, like Ctrl+O, and after pressing them you open Raid config utility. Here I see nothing has changed after setting the Raid enabled in Bios. I am not sure how it supposed to work on this mobo, but watching this video https://www.youtube.com/watch?v=Z7XpK-5WgLU from similar motherboard (probably on the nearly same Bios) I see Intel Rapid Storage Technology in the center of Bios home page, which I don`t have. Is there any chance to enable it too? Also, in this video they have another EZ Tuning.

I am attaching DRAM settings screenshots. Yes, I did reset Bios settings, but the only one which lost ability to select offset is DRAM Voltage. Anyway, it is not a big deal as I can use manual setup even though it is not present in visible options.


The main thing about memory is to enable Reg support, no matter on what voltage it will happen.

@ZAC - Manufacturers often do that if they find an issue soon after release, try to do it quietly which is bad because then users might not notice there’s an issue with BIOS they’re already using. Bad form!

Let me look at BIOS more, you may need other option enabled to allow the Control+I menu option for the RAID config menu. I did not watch video, sorry limited bandwidth, but EZ Tuning?
If you mean screen that shows fans and simply GUI click type BIOS, if yes, no that’s only for other models, I can’t add that. Most people instantly hit F7 to get out of that to go to the BIOS you have anyway

I put back the dram change in this last BIOS, meaning I did not enable SPD Write option this time, that was the only change I made their before. ECC support is already enabled by default
For dram offset voltage you have to change from Auto to + or - then enter a value, this is normal way it works if you are using offset setting instead of manual.
In your BIOS, I do not see offset option for DRAM, only direct voltage value input, this is on the stock BIOS, so you may be thinking of vcore, turbo voltage, or other setting you were using offset on previously, it’s not normally a way to set DRAM voltage anyway so I’m not surprised to see this.
Flash back your original FPT backup, then you will be back at square one, and you’ll see this was not ever an option for DRAM voltage.

Now, if you want BIOS with lots more options on the memory page, so you can see/change ECC setting I can do for you.

On the RAID, I checked and RST roms are already there 15.2 EFI and orom version (Was thinking maybe these were missing), so it’s not that why you can’t enter control+I. You did try Control+I at bootup correct, not Control+O as you mentioned
Can you show me image of all the settings you can see inside >> Advanced >> PCH Storage Configuration >> Software Feature Mask Configuration Orom and UI banner is already enabled, this is what allows you to enter Control+I option (it’s enabled with only 2 second delay so maybe you missed it at startup?)


By some crazy luck I have 8gb ECC memory module. Now I have a standard stick, ECC stick, and ECC Reg 3 sticks. I expected to see some memory settings for ECC specifically, but haven`t noticed anything new. May be now this is stuck in cpu support of ECC memory, just a wild guess. Please, unlock everything related to memory.

I did try Control+I, nothing happened. Everything under Advanced >> PCH Storage Configuration is below


Should I go for the latest official bios version prior you will add any changes to my old version?