[OFFER] ASUS P8Z77-V Series BIOSes modded with latest modules

No NVMe bios mod for the P8Z77-V LE Plus ??? Damm, follow the guide: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS

Hello all.

I know this is a bit of a zombie thread, but I’m continuing the old conversation as I was unable to find another recent Asus P8Z77-V Pro thread specifically.

I am posting late in the game on this because the download links to the modded BIOS files through-out the thread seem inactive/dead.

I wanted to help with that, at least for NVMe.

Following the excellent guide for Full NVMe Support for all Systems with an AMI UEFI BIOS, I was able to successfully update to use NVMe drives.

I’m including a link to a modified BIOS to use NVMe and NO other changes.

Please be aware this file is for adding NVMe only!

I named the mod file following the “Z77/H77 Series BIOS Renaming Rule” guide; the modified file is named Z77VP.CAP

The link below for this mod file is active as of 3/16/2023 and should help anyone that desires to update this old board for NVMe but doesn’t want to go through all those guide steps to make their own file. Of course, like everyone, you use at your own risk, but it worked to give my BIOS NVMe support for this board, so it should for you, too.

Please know that even if you forgo using that guide, you SHOULD read it anyway (and the other information threads linked within) as it helps in understanding what this process is sort of doing. This is regarding your own hardware after all, and it’s super great knowledge and alleviates many BIOS updating fears, so go read it =)

File details:

I updated the Asus P8Z77-V Pro BIOS 2104 (released back on 2013/09/16) to use an NVMe drive and nothing else. Should probably update to this BIOS first before using the modded BIOS. Should also probably turn back to defaults any Over Clocking if you already have 2104 installed, just to be safe.

Modded P8Z77-V Pro BIOS for NVMe support as of 3/16/2023:

I installed this using the USB BIOS Flashback port on the rear of the motherboard.

Power down PC, leave plugged in, connect drive to Flashback port, press and hold BIOS FLBK button on actual board for 3 seconds (refer to Full NVMe Support guide for detailed step by step instructions)

I used a formatted USB 2.0 thumb drive (as guide states to use) with the .CAP file as only file at root (not in sub-folder)

Be aware that, per the guide, USB 3.0 may cause issues, so use USB 2.0 to be safe/correct

Watched the light blink, took about a minute or two for completion, light stopped, and rebooted computer into BIOS fine. NVMe drive now visible.

Then I followed the guide for installing Windows 10 to new NVMe drive; it’s very fast for how old the hardware is, and was well worth doing.

Fresh install seems to be the recommended way forward for stability rather than using utility software to move an old NTFS Windows installation over, but that will be up to you to confront and solve.

I hope this helps someone out there in the universal ether get their old hardware running =)

Also, a big thanks to all of you fine people in this community that figure it all out, you are appreciated!

1 Like

@DonutFiend99 Hi and welcome to Win-RAID Forums.

Thank you for keeping the thread alive and providing your updated BIOS with NVMe support for use with Asus USB BIOS Flashback so that others may also benefit.

I have the same board Asus P8Z77-V Pro with BIOS 2104 and have just got a NVMe SSD with PCI-E Express card.
So all I need to do is use your supplied BIOS Z77VP.CAP and copy to a USB2 stick and plug into USB BIOS Flashback port and do the same as you would normally do when updating the BIOS?
I am fairly competent when it comes to PC’s as I have built a few of my own but with BIOS updates you can never be to sure especially this one.

Has any one used the bios update from DonutFiend99 without issues?
Looking to try this I have already asked but got no response from Donut.

The user reports that the mod done is only concerning NVMe.
If your suspicious of user mod files, you can try to do the mod yourself, as thousands of users already made it.
[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

[Guide] How to flash a modded AMI UEFI BIOS - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

Your motherboard has USB BFB feature so its easy to recover from a fail mod.
-Make backup/dump of the current bios (has the motherboard original SN, UUID, MAC)
AFUWIN or FPTtool dump.
-Put a side a prepared rescue USB with the original CAP bios (current bios version)
-Make the mod
-Use a 2nd USB to flash the mod, with the regular procedure of USB BFB

Install OS according the 1rst guide linked.

Hi Meat War,

If I use a PCEM2-D PCIe 3.0 adapter, 1x M.2 NVMe, 1x M.2 SATA will the Mod work for the M.2 SATA as well?

The M.2 SATA will not use the mod for standard storage drive or boot, as it uses AHCI protocol, not NVMe.
The NVMe is needed only for M.2 NVMe disks, only for booting, for standard NVMe storage also doesnt need the mod on moderns OS.
So if the objective is to boot from the NVMe, then the mod is required…ring a bell?

Yes that is what I want so I will use the Mod. Surprised nobody has chimed in to say they have tried the latest Mod that is what is concerning me that was all.

Sorry to be so insensitive… but like you maybe, most of users get served and bail out and ignore further msgs in forum, typical around general forum use.
Your mod is very simple and 100% successful rate on that mb model.
You can share your prepared mod for a simple verification, before the flash.
Good luck.

My Flashback Bios usb port is not recognising the USB stick when plugged in as no light flashes on USB stick so nothing happens when I press the Flashback button on Motherboard. The USB stick works fine as I have used it many times in the past to update the Bios on my other PC using Flashback usb port.
Any suggestions on using another method as looks like my Flasback port is dead?

The USB BFB feature can be very “picky” regarding USB drive models and size.
The older and smallest are the best, the rest you’re already familiar with it.

EDIT: Glad you made it, enjoy the NVMe, still i forgot to ask…you did renamed the mod file as Asus standard CAP name (Z77VB.CAP) right?
I had in the past also this model… i vaguely remember that i had a similar issue as you and had to remove 1 ram stick and clear the CMOS, then the BFB started detecting the USB plugged.

It’s not the USB sticks as I tried a number of different size and types the Flashback USB port for some unknown reason is just not recognising any USB sticks when powered down. If I try the Flasback USB port with the PC booted into windows the Flasback USB port works and can be used as an aditional USB port. I had to use AISuite_II in Windows and select the Update Bios option from there to update the BIOS this worked and I now have a bootable NVMe.

I kept the mod file the same name Z77VP.CAP when trying to use the Flashback should I have renamed it Z77VB.CAP then and that is why I was having issues with it not working?
I did not realise that my i7 2600k CPU only supports PCIE Gen 2 so only getting write speeds on the NVMe of 1860MB/s
Would I haved gained much if the CPU would have supported PCIE Gen 3 or not really worth it?

No no, sry you have the Pro, i thought it was the V only, looking at the thread tittle, the CAP name is correct for the Pro version.

Not really… you wont get much more speed from it, on a PCIe2.0 x4 vs PCIe3.0 x4.
And on the Z77 we can only have PCIe3.0 with PCIe M.2 adaptor when using iGPU and the NVMe on the PCIex16_1.
Dont think you can get the advertised speeds from a NVMe disk model by the vendor, its always lower.
The main advantage of an Ivy Bridge cpu is for a PCIe 3.0 GPU card…here its advisable.

With this Bios mod are you not able to boot from say an SSD drive that has Windows on as when I try to boot from my old Windows drive that is on a SSD it will not show up in the Bios.
So does the Mod only allow for NVMe drives to show in the Bios? I am a little confused as to why no other bootable drives like SSD are not showing up in bios I have changed all relevent settings to do this but no success?

Probably because now for NVMe/GPT OS the settings in bios are for PURE UEFI (CSM Off / Secure boot On) and the old SSD/HHD has a Legacy/MBR OS on it.
The mod doesnt prevent nothing and all that was possible before is still possible now.

EDIT: It should be… do i know or did your reported your previous OS and config sin bios… no guessing wizards here sir… for Christ sake.
Confirm what… that you and i will die one of this days…sure i can, unbelievable.
Users cant expect help based on remote answers on a forum when some one is trying to guess the steps/actions that were made on a system…and we cant give a “crash course” on all scenarios to unexperienced users, a little “culture” is needed to who comes to a forum for mods.

A regular SSD/Legacy OS should use AHCI and but default it should be CSM AUTO in bios or ON.
Also in the bios boot manager theres entries of all drives and boot OS installed, old ones and new ones.
Unless the boot partition of old OS was modified. Thas why a new standalone OS install should be made without any other old OS disks connected, preventing boot partition modifications… this is an advice for unexperienced users, not a general rule.
Dont like the comments…welcome to fan club.

So can you confirm that what you are saying is with the mod bios I should still be able to boot from my other HDD that are not NVMe that have Windows on and that it is just a case of altering the bios?
I have tried changing a lot of the settings but having no joy.
What settings do you recommend?

I resolved the issue with having boot issues with other HDD/SSD drives not showing in the Bios. I had made changes in the Bios to have my Graphics card run on maximum in the PCI slot but I did not realise that it disables two of the 6GB Sata ports. The 2.5" SSD Disk I was trying to boot from happened to be plugged into one of the disabled Sata Ports.
I plugged it into one of the other Sata Ports that had not been disabled and it can now be seen in the bios as an additional boot option along with the NVMe boot option.

So was the info i provided correct or not, by your point of view???
Since this is a user error… as i said before, were not there with you do know user actions…

And the info on SATA is not true, (its shares resources IRQ, not disable) i had a LX2, a V, a Sabertooth, an M-Pro and Maximus, all 8 ports work with dedicated GPU.

EDIT: Correction

So glad you made and all the best, issue concluded, cheers.