[OFFER] Asus Rampage IV Extreme - Nvme Bios mod (4901)

Hi all! (sorry for my little english)

Equipment used:

  • Asus RIVE Nvme Bios mod (4901) with uncompressed NvmExpressDxE_2 module GUID 9A4713C2
  • Asus HYPER M.2 Mini
  • Samsung SM961 Polaris 128GB M.2-2280 PCI-e 3.0 x 4 NVMe (MZVPW128HEGM-00000)

  1. Asus HYPER M.2 Mini connected on last red slot PCIe x16 3.0.
  2. After Asus FlashBack with 4901 Mod Nvme :
    • First boot in bios, just appeared “PATA SS:”…
    • I boot on other ssd (windows 10) and i see that the SM961 is formatted to NTFS/MBR.
    • Always on Win10, i converted SM961 to GPT/UEFI Disk.
    • Boot on usb key (win10Pro) make with RUFUS tool GPT/UEFI.
    • Install windows 10 and after reboot (in bios) see “Windows Boot Manager” and "PATA SS:"

CrystalDiskMark :

All Work Perfectly!
Thank’s Fernando!

Attached file : modded bios 4901 Nvme for RIVE (R4E.CAP ready for Asus FlashBack)

R4E.zip (3.73 MB)

@Plop :
Welcome at Win-RAID Forum and congratulations for having succeeded to get full NVMe support for your X79 chipset mainboard!
On behalf of other users with a similar mainboard I want to thank you for offering your modded BIOS inclusive a description of the procedure how you got everything working.

Off topic:

As you probably have realized, I have slightly re-formatted and customized the content of your post for a better readability and hope, that this is ok for you. If not, you can change it yourself bay editing the post.
Furthermore I have moved this thread into the better matching Sub-Forum, where the users can offer their successfully modded BIOS for other users with a similar mainboard.

Dieter (alias Fernando)

It’s with pleasure if that can help other people.

Thanks for your work!

Equipment used:

  • Asus RIVE Nvme Bios mod (4901) with uncompressed NvmExpressDxE_2 module GUID 9A4713C2
  • AquaComputer Kryom.2 evo (Replace Asus HYPER M.2 Mini)
  • Samsung SM961 Polaris 128GB M.2-2280 PCI-e 3.0 x 4 NVMe (MZVPW128HEGM-00000)

New result:



fist of all thank you all for sharing your experiences your efforts and supporting.

I am owning a ASUS RAMPAGE 4 Extreme (FW 4901) and i bought a "Samsung 960 EVO MZ-V6E250BW 250 GB" and "kryoM.2 evo PCIe 3.0 x4 Adapter for M.2 NGFF PCIe SSD, M-Key"
Here is what I did.
My PC is currently running on SATA RAID Mode. I disconnected my Samsung 840 PRO including my RAID 1 storage system, so just the 2 DVD Drives are connected to the SATA.
I used AFUDOS.EXE to create a backup of the BIOS.

I tried to use the "ASUS EZ Flash 2" App, but it gives me "Security Verification Failed error"
Then i tried AFUDOS.EXE R4E.CAP /GAN (by the way /GAN only works for me with an older version of AFUDOS. I checked google for an older version "AFUDOS Flasher 5.05.04") but it gives me "3-Error: ROM file size does not match existing BIOS size"

So i reasearched google and found the procedure where you have to put the file on an FAT 32 USB stick, Put it to the white USB Plug at the back of the motherboard and press the ROG button 3 seconds. It starts flashing and takes appox. 3 Minutes then it stops. (Done while pc was shut off by the way).

First thing is that i dont know if i was successful. I plugged the SSD to the last RED PCI x16 slot as described above. I started the PC, but in BIOS it just shows me my two DVD-Rom drives.

What am I doing wrong here?
I was thinking of doing the CAP file by my own, i have seeen a turorial from fernando. but i cant find the "uncompressed" File you mentioned above.
Do i have to reset bios to default settings?
Do i have to switch from RAID on SATA config to something else?
What about CSM Module? Its active and for SATA UEFI drivers will be loaded.
How can i make sure that my BIOS Flash was successful?

thank you very much for your answers



Check selector 4 is on for enable the pcie slot

Reset your bios and check :

SATA Mode : AHCI Mode

Fast Boot : Disabled

Launch CSM : Enabled
Boot Device Control : UEFI and Legacy
Boot from Network Devices : UEFI
Boot from Storage Devices : UEFI
Boot from PCIe Expansion Devices : UEFI

Secure Boot state Enabled
Platform Key (PK) State Unloaded

Save and reboot

Create your USB Key with Rufus tool for UEFI Boot

Launch install Win7/8/10 or linux distrib

I have test with Win10 and CentOS 7 ok

Good luck!|addpics|fo0-4-fd10.jpg-invaddpicsinvv,fo0-5-baaf.jpg-invaddpicsinvv,fo0-6-4a9c.jpg-invaddpicsinvv,fo0-7-d387.jpg-invaddpicsinvv,fo0-8-57ac.jpg-invaddpicsinvv,fo0-9-45fc.jpg-invaddpicsinvv|/addpics|

Hey, thanks for the quick reply.

Switches are all on “ON”.
I did “Load opimized default values” which is facory defaults i guess.
–>RAID switched to AHCI automatically
Fast Boot Disabled CHECK
CSM Enabled
all switched to UEFI
I cant change secure boot status and platform Key (PK) Status but it is the same as on your screenshot.
Other OS is selected as well.

I cant see the device on the BOOT Tab. There is just 1 DVD Drive and the WIN 10 USB stick.

So what happens is, that i start WIN10 from an USB stick, it boots and brings me to the wizard where i can select on which HDD i want to install. (see picture attached, unfortunately its in german and i cant change it)
Windows tells me “windows can not be installed on this drive. The hardware of the pc does not support starting from this device. Make sure that the drive is active in BIOS”.

@Plop ,
How did you flash the BIOS, EZ Flash, AFUDOS, ROG CONNECT or something else?
I am still not sure since i got the “Security verification” error when using EZ Flash if it works with the ROG Connect method.

Any other suggestions?



You have to convert your EVO to GPT.

Boot on other disk (ex. ssd with windows 10, gparted live… ) and convert EVO to GPT/UEFI Disk.

After you Boot on usb key (Win10 Rufus UEFI)

I use Asus FlashBack to flash my motherbord bios


I Downloaded Windows 10 PE edition, installed it on an external SSD and started the PC from it.
In Windows i can see SAMSUNG 860 250GB NVME.
I went to “DISK Management” Rightklicked on the grey field to the left hand side and said " CONVERT TO GPT DISK" (you can only do that if there is no partition defined yet [unallocated space])
After that i bootet with the settings from above from my kingstong Usb Stick with windows 10 x64 on it.

Windows says "Windows cant be installed on this drive. The choosen drive matches the GPT Partition style."
The error message below is still the same like before changing to GTP, it says that its not active in BIOS.

The second screenshot is from the BIOS, it still does not show me the drive in the “boot” section.

Any other suggestions?



some short success storry in between.
What I did wrong:
I did not select GPT while creating the WIN 10 USB stick in RUFUS Tool.
The thing, with booting into windows with an mobile windows version and convert to GP,T is not required i think because i had to delete the partition it in the setup.
The Warning messages are gone, windows files are copied and after the copy wizard windows asks to reboot.
What happens is, that it returns to the begin of the installation instead of continuing the installation from the M.2SSD with the copied files. so its a never ending loop.

I still cant see the SSD in the BIOS under BOOT.

My opinion is, that the bios flash is not successful. After starting the flashing procedure, i am entering bios and the settings are still the same, there are no default values and thats strange in my opinion.
So i think the issue is the bios flash.


I tried AFUDOS aswell, here is the error message… any ideas?



today i tried something different.
The bios was set to the newest version 4901 with the original .CAP file.
I used AFUWINx64.exe (version 5.05.04) while running windows and extracted the firmware with “AFUWINx64.exe bios.bin /O” in DOS window.
After that i used the UBU Tool “UEFITool.exe” and implemented the “uncompressed NvmExpressDxE_2 module GUID 9A4713C2” driver at the bottom of the “DXE” Group.

Then i saved the file and reopened it to check if the DXE driver is present and it was as you can see above.
After that i used “AFUWINx64.exe bios.bin /gan” and flashed the bios successful.

Then i rebootet, set all bios settings as discussed before (AHCI, CSM, FAST BOOT, UFEI Diver, etc.)

First Message: "The current BIOS setting do not fully support the boot device."

The BIOS does not show me any bootable HDD

Other Settings:

After that i replugged my HDDs and entered windows. I reused AFUWINx64 and wanted to check, if i can find the NVMExpress driver in the flahsed bios.
So i used “AFUWINx64.exe bios2.bin /O” and reopened it with UEFITOOL.exe.
I used the search function and looked for “NVME” but i was not able to find the driver. So i searched the DXE location manually and looked at the bottom and there was nothing.


Starting the PC after flashing i noticed that the PC started loading the bios (but did not show anything on the screen yet) and the pc Re-Rebooted after 2-5 seconds.
Can it be, that the Motherboard does not like the driver and resets the BIOS to the version before?
If i am flahsing the BIOS with the AFUWIN, which one does it replace? BIOS 1 or BIOS 2? or just the current active one?
Can it be, that the NVME Driver is to old for the new SAMSUNG 860?

Any suggestions, would be nice if any one can help out here.

Thank you in advance


Have you other slot occupied?

Your GPU have an UEFI bios?

Have you disable the second sata controller? (not an Intel sata controller)


I have extract my bios and upload here.

Check bios : R4E.CAP

SHA-1 : D3344D88D97BDE08A14800CCA4604ED6ED09A9F5
MD5 : B4A6A9789EDF863D9389E14DE2584EE1


I upload my stock bios configuration (no OC) for Nvme : StockCFGNvme.CMO

SHA-1 : 047DEEC8C2B1BF5D7142A60577C2F7625A9236A2
MD5 : 78576B20BE02A1BB2D11C7C5B2D6DF73
CRC32 : B1DF383D


i have 3 slots occupied.

first red slot = GTX1080 UEFI bios

Central black slot = STRIX RAID DLX (SoundCard)

Last red slot = Nvme SSD

R4E.zip (3.73 MB)

StockCFGNvme.zip (773 Bytes)


I am only using a Graphics card in my pc, there are no additional cards used besides the new PCIe SSD. Please find the picture attached.

I got a NVIDIA Quadro 2000D Graphics card. According to LINK, UEFI is not supported.

No seconed SATA controller is present (no additional PCI card)
Long time ago, I updated my BIOS to 4901 because i had an issue that i was clicking “shutdown” in windows, but sometimes the PC rebooted instead of shutting down. So i went for the newer version. (It did not resolve my problem its still there but i live with it).

I am really happy at the moment, because i managed to get the SSD working and it shows up in BOOT section!!!
Unfortunately i dont know what brought the success but here is what I did:
I used the Button CMOS RESET above the ROG Connect Button.
After that i change to German and made some changes to be able to see if the flash is successful because it should reset to default settings after flashing.
I Switched to BIOS 2 (Forced BIOS 2 Boot)
I reflashed with the OEM 4901 Firmware named “Rampage-IV-Extreme-ASUS-4901.CAP” but VIA EZ Flash. -->Successful
I changed the USB Stick, I used an USB Card Reader with a 2GB SD card formated FAT 32. If i plugged it, in BIOS / Boot section i have seen more than just 1 thing where i can boot from… so maybe ROG connect did not get the right drive. (I used a 4GB Kingston USB stick FAT32 and I unchecked “quick format”)
Then i used a firmware from this LINK
There was a folder LINK
And i downloaded the Firmware from NVME Testing folder (thanks to "BOLTS4BREKFAST ").
Then i put the File named “R4E.CAP” onto the FAT32 USB stick and made sure that there is only this file on the USB stick.
Then i plugged it into the white USB Port and pressed the ROG Connect Button for 3 seconds, the Orange light started flashing. After 3 Mins it was finsished (orange light was not flashing anymore but constant orange light) and i booted the PC. Now the BIOS set back to DEFAULT settings.
Then i was able to see “PATA SS” in the Boot devices list.
I Booted from the SSD and since the files were already copied from previous steps it continued the installation.
In windows I made a test with “crystal disk mark” please find the results attached.

My working BIOS settings:
Fastboot -->Enabled
CSM: Enabled
Boot Devices control “UEFI and Legacy”
Boot from Network Devices “Legacy”
Boot from Storage Devices “Legacy”
Boot from PCIe Expansion Devices "Legacy"
Secure Boot Menue
OS Type "Windows UEFI"
STATA Configuration -->AHCI Mode

So its basically the Default settings of the BIOS

Ill try to use RAID Mode next, maybe it works aswell.

Thank you so much for your help

Ok now other things i have tried:

I switched the position of the SSD on the PCI lanes from the last one to the seconed one. It sill works.
I switched from AHCI Mode to RAID, and it still shows me " PATA SS" in the Boot menue. Then i reinstalled Windows while RAID Mode on to make sure it boots.

Now i am running RAID + NVME on windows 10! WORKS PERFERCT!!!


NVMe Mod Bios: Rampage IV Extreme 4901 MOD.0.95.1

Hello everybody,

I’ve got some questions regarding flashing/updating the bios. i’m not 100% if i am doing it right…
or that maybe the bios flash you guys made isent compatible with my NVME drive.

I have updated my bios to 4901, after that i have installed windows 10 on the ssd.
But my motherboard does not recognize it as a boot device as you guys write it down.

My setup;
CPU: i7-3930K
Mobo: Rampage IV Extreme
BIOS: 4901 (tryd to flash it but i’m not sure if that worked, don’t know how to check if it worked)
SSD: Corsair Neutron NX500 NVMe SSD

Please help/assist me.

With kind regards,

Hello :blush: first of all happy new year!
I am three days I read everything and do tests, I bought a samsung ssd 250 GB and a pci Asus evo 960 M2 mini and wanted to put it on this Board. It seems that many did after installing the bios modified 4901.
I did the update to this bios, have appeared more menu including the MSM and now I also see the evo in peripheral 960 called pata SS.
I created a usb install Windows pro 64 10 with Rufus gpt Efi-mode as per guide. The usb you start regularly and arrive at the choice of the drive on which to install the operating system. I see regularly the evo, so far so smooth. When I click the install button to install Windows but stays off without any words. I can only choose between delete partition and format, but I can not install. The disc is so gpt, I disabled the safe boot to be able to start the drive. All smooth as as a guide but upon installation cannot move forward. Does anyone have any ideas? Sorry for my English

I didn’t got to the point of Pata SS sadly though.
What do guys think, should i downgrade to an older version and then try to upgrade to the modified 4901?
That’s one of the only things i haven’t tried yet.

Back to your topic though:
If you delete the partition, can you then install it?
I’ve installed many windows 7 machines but windows 10 is quite new for me too

With kind regards,

Hi good forums.
I have Asus RiVE, I use Jeyi SK7 with 960 evo. But I have a problem,
I have modified the Bios NvMe module to the original Bios and Flash.
I did the test with the test programs on Windows, as seen in the appendix,
but it does not appear to be booting via Bios.
I format the SSD as GPT and start up with a USB stick for UEFI Windows setup, and I do not see any SSD over Bios and it is not booting.
I have tried the Bios of my friends who have the same motherland on the forum but I want the same result again my forum brothers.
I’m sorry for my bad english.