[OFFER] P9X79 PRO BIOS Modded for NVMe SSD

Hi guys,
i’ve modify my ASUS P9X79 PRO for NVMe SSD support.
I’ve attached my current modified BIOS.
Currently, i’ve installed on my PCI 3.0 the ASUS Hyper M.2 x4 MINI with the NVMe SSD Samsung 960 EVO, Window 10 PRO x64 and all peripheries work fine.

P9X79PRO.rar (4.3 MB)

super! can you post an ‘anvil’ bench result (stock application settings) of your evo, and which nvme driver are you using? thanks.

also curious to know what results you getting with that board…

Dont work for me :frowning: I have also the x79 pro / 3960x but a 960 pro.Win10 won´t install.What are your Bios Settings?Ssd is displayed in the Bios but Win 10 dont want to create a Partition.Bios is the same as yours.

@WolleG :
Welcome to the Win-RAID Forum!

Have you disabled the “Secure Boot” and “Fast Boot” options within the BIOS? Did you install Win10 in UEFI mode? Did you unplug all other HDDs/SSDs except the NVMe SSD, before you started with the Win10 installation? Did you delete all existing partitions from your NVMe SSD, before you created a new partition on your NVMe SSD?

Dieter (alias Fernando)

I told myself that if I ever got the NVMe drive to work with my Asus P9X79 Deluxe mobo that I would register here to share my experience because it took a lot of tries to get this to work. Thanks first of all to Fernando for figuring out how to make this work and for sharing his knowledge on this forum. Without his help, there’s no way I would’ve been able to enable NVMe on my motherboard. If you have an P9X79 Deluxe motherboard, then you should know that you can most certainly get an NVMe drive to work. Here’re my specific recommendations:

1) I’m using a Vantec UGT-M2PC200 adapter to plug into the first (counting from the size furthest from the memory slots) blue PCIe slot. The brand of the PCIe to NVMe adapter board doesn’t matter b/c if you look at the actual board, there’re just direct wires running from the PC bus to the NVMe stick. There’re absolutely no circuits of any kind on the board so what brand you buy doesn’t matter. My NVMe drive is the OCZ RD400 512 GB.

2) Downloading from ASUS the latest 4801 beta BIOS and injecting either Fernando’s NvmExpressDxE_2.ffs, NvmExpressDxE_3.ffs, or SAMSUNG_M2_DXE.ffs works. You use the UEFITool (download from this site) to open the Asus BIOS file and then insert ONE of the above modules. You basically open the BIOS and from File>Search look for (text tab of the search dialog) “DXE” without the quotes. Double-click on any of the matches in the lower “Messages” window then in the main “Structure” window you want to scroll down till you see the last DXE driver. It’s the last one b/c the next row says “Volume Free Space”. Click on that last DXE driver row (doesn’t matter which driver that happens to be) and right-click to select “insert after”. This is where you insert ONE of the above .ffs modules. Save the updated BIOS and flash using the USB on the back of the mobo. You won’t be able to flash this BIOS from Windows or the BIOS interface b/c this BIOS has been modified and fails the hash check. The USB port flash is at the hardware level and no hash checking is done. BIOS file HAS to be called P9X79D.CAP or flashing will not work. DO NOT unplug your usb stick while the blue light is flashing or you’ll brick your mobo. If there’s a constant blue light flashing after you flash the bios, then the flash failed but that doesn’t matter b/c P9X79 will use the default bios and there’s no damage to your mobo. I can tell you that most downloadable bioses out there including the 8105 that you can download did NOT work for me and failed to flash (constant blue light after flashing).

3) The first sign that this worked is that in BIOS you’ll see “PATA SS:” drive as a boot-from option. So basically you only need to tweak the “boot” section of BIOS. You want to disable “fast boot”, setup mode is “advanced”, secure boot “is another non-windows OS”, since you cannot turn off CSM, your Boot Device Control is “UEFI and Legacy OPROM”, boot from network is “ignore”, both boot from storage devices and boot from PCIe expansion devices is “UEFI driver first”.

4) Run your Win7 (or whichever version you’re installing) install USB, or DVD. I downloaded the dos level NVMe drivers from OCZ’s web site so when you come up to the install screen where you select the installation partition, install those NVMe drivers. Now you can see the NVMe drive. DO NOT partition the NVMe drive ahead of time. It needs to be empty and it needs to be an GPT (not MBR!) drive. If windows complains that it’s not a GPT drive, hit Shift+F10 and use the DOS window to run DISKPART. From DISKPART you can clean the drive and switch it to GPT. Windows from here should install with no problems.

5) Unplug ALL other hard drives from your computer. I actually physically unplugged them. Why? Because after windows installs and reboots, you won’t see the newly installed drive and partitions. I kept getting the “Bootloader Failed to find OS” DOS screen. BTW after windows installs and reboots, you need to go into BIOS and again from the Boot menu go to the “Hard Drive BBS priorities” menu. Make sure that the “PATA SS:” option is #1. I disabled all other options here. Then go to the “Boot Option Priorities” section. Here you will now see “Windows Boot Manager ( HARDWARE ID of NVMe stick)” as an option. Make sure that that’s option #1.

6) Windows should now boot up and you should be able to complete the install. Turn on the other harddrives one by one as needed. I literally hot-plugged them in after Windows came up and deleted the MBR and OS partition from my other drive to ensure that BIOS doesn’t even see it as a bootable option.

That’s it and good luck.

EDIT: I’m attaching the final result of my efforts.



@gi1 :
Welcome to the Win-RAID Forum and thanks for your detailed success report, which may help other users with a similar mainboard model, who want to get NVMe support.


  1. It may be irritating for the Forum visitors, that your mainboard is the “Deluxe” variant of the ASUS P9X79 series, whereas this thread topic title is about the “PRO” variant. That is why I recommend, that you start a new thread with a title like “ASUS P9X79 Deluxe BIOS modded for NVMe SSDs” and just copy and paste the content of your post into the new thread. If you even want to offer your modded BIOS for other users with a similar mainboard model, you can start the thread within >this< Sub-Forum.
  2. Within your guide there is a little mistake, which should be corrected by you to avoid frustration by users, who will follow your advices:

    The EFI BIOS module named “SAMSUNG_M2_DXE” supports only the AHCI protocol, but not the NVMe one. A user, who inserts only the EFI module named “SAMSUNG_M2_DXE”, will not be able to boot off the NVMe SSD.

Dieter (alias Fernando)

I’ll do that. Please note that the download rar for the P9X79 Deluxe *_3.ffs file is corrupt so I had to use the _2 version.

I do not offer anymore the NvmExpressDxE_2.ffs file.
Where is the broken link? Please give me the link to the related thread and post.

Link works now. Another thing worth mentioning is that if you want to do a raw partition backup after you do a clean Win7 install and get everything working, you can read the NVMe partition using Akronis. I tried a number of other backup apps and none of them (such as the ones on a typical Bart PE restore disc/USB) can recognize the NVMe partition after a DOS boot. I used Rufus to create a USB bootable disk (formatted as GPT) with the Akronis image on it.

BiOS tools and procedure was posted by Fernando here:
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Hi, Sorry for my late reply.
I’ve attached my Anvil Benchmark.

Samsung SSD 960 EVO 250GB_250GB_1GB-20180310-1029.png

I’ve recently modded the latest ASUS P9X79 PRO (Version 4801 Beta) to add the microcode updates for Meltdown/Spectre fixes.

Changes to the UEFI/BIOS File:

· updated cpu microcodes to latest versions

· updated Intel Management Engine ->
only updated the image in the file, needs to be
flashed seperatly (if you choose to update your IME)
see: Intel Management Engine: Drivers, Firmware & System Tools

· updated OROM IRST RAID for SATA ->
updated OROM IRSTe RAID for SATA ->
updated EFI IRST RAID for SATA ->

· updated OROM Marvell 88SE9128 ->
updated EFI Marvell SATA AHCI ->

- removed OROM Intel Boot Agent GE 1.3.72
+ added OROM Intel Boot Agent CL 0.1.13

- removed EFI Intel PRO/1000 UNDI 5.5.23
+ added EFI Intel Gigabit UNDI 0.0.19

+ added NVMe support by NvmExpressDxe_4 module
see: [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

P9X79-PRO-ASUS-4801-modded.zip (5.06 MB)

Thanks for offering. Did you notice that the intel nic card stop working with a cold restart?
It only happens with a code restart (shutdown, and start).
It’s more like a bug in the newest 4801 bios. Is it possible to mod the bios base on a previous version?

Hello Mak387,

I downloaded and installed your bios on my P9X79 Pro. That enabled me to smoothly install a WD Black PC SN500 500GB Nvme SSD on a PCI 3.0 adapter and Windows 10 Pro. After installing my apps and updating everything, there came a time when I noticed a slow boot from computer off status and loss of the internet connection at start up. I rarely do a shut down, but usually use the sleep mode, which coming out of is fast with no problem.

Anyway, in short, the Intel Management Engine Interface is the problem. It shows the cannot start, and it won’t start, with the power issue. Is there a way to fix this? I deleted it and the only effect is booting from an off status, which takes up well over a minute to do and the LAN driver has to be dis and re-enabled to work. However, when putting the machine in sleep, coming out of sleep is no problem. Just wondering if you encounter this issue, if it can be fixed or should I just ignore it. Any advice is appreciated.

@ClarenceE - did you test these two things? First, update the ME region of the BIOS? Then, update to latest ME drivers, and see if issue persists? If you did not do both of those things, I would do that now, before any further troubleshooting.

Thank you for the fast and good advice. I did not do those two things. I did look around for updated ME (I assume that is the Intel Management Engine Interface) and tried to update what is on my machine. That totally did not work so I pretty much think its a bios issue, and your questions confirms that.

I also see there are numerous discussions on this super intense technical website about the ME. As it is apparent from what I read on this website here and there ASUS no longer provides updated drivers for this 9X79 Pro board so I am left with the enormous task of determining the right ME. The other problem for me is although thanks to the clear and precise instructions given on the website about how to modify the bios by inserting the right driver (ME in this case), I not know how to find the right ME driver and extract what is needed to insert in the Bios. I’ve been building my machines for over 20 years now, but thanks to this website only recently have I delved into modifying the bios. I followed the instructs found on this website for 2 different P9X79 Pro ones and they all work, but they all also result in the same ME issue failed LAN connect at startup from shut down (no LAN problem at all coming out of sleep).

I think the ME problem in bios causes the breakdown of the LAN connection on a boot from shut off completely, but am not confident that is the case.

Would be very kind of you to point me in the right direction to finding the appropriate Intel ME and that portion to insert in the bios.

Thank you for your instructs and thank you to everybody on this most interesting website.

I wrote a reply, but it seems it disappeared.

How do I determine what is the latest ME (I assume that is Intel Management Engine Interface) that works on my P9X79 Pro? Once I find it, do I need to extract the portion to use to insert in the bios? Please expound on how to do that.

Thanks to the specific instruction and downloads I’ve found on this technically intense website I was able to modify the latest (goes back many years) 4801 (beta) ASUS has for downloading on its website. All of the mods I did involve on the modules to have the Nvme SSD captured. I suppose inserting the right ME module is the same procedure, but finding the right ME is my problem.

Please offer your guidance.


I feel like a nut, being new to this website. after I wrote this post, I was taken to my previous response to you. Please excuse me for double posting.

@ClarenceE - it’s OK, I can help, don’t let it all stress you out too much… yet You are using BIOS from post #1 correct? I can update the ME in that for you, but we need to check some things first, so I can help you use the correct tools and methods etc to update everything.

Can you check on your main page of the BIOS, what version ME shows as. When I mention main page, I mean the main page after you hit F7 (I think) after your in the BIOS graphical summary, to get to the individual settings pages type BIOS interface

As for sleep, resuming all the time vs shutting down often, this can cause all kinds of issues the longer you sleep/wake and never shut down, some of which you describe (slow startup, slow shut down, LAN issues).
You are talking about using the onboard LAN Ethernet connection, correct? Not a USB wireless dongle? Those are often more trouble with prolonged sleep/resume or loss of power

Anyway, don’t worry, I think we can fix all of this for you!

Hello Lost:

Thank you for the encouragement. Went into bios and discovered this: ME N/A. I would conclude there is no ME module in the bios.

edited to add: Yes I am referring to the on board LAN, works fine.

No, that means ME is corrupted which is what I expected. P9X79 uses ME 7.1 in old BIOS, and 8.1 in latest round of BIOS. LAN works fine??? but you just said it didn’t, which is it?

Which BIOS are you using, so I can start trying to help you fix the ME? Have you used USB Flashback before, and have a known working USB stick compatible with USB Flashback? If you have not, please find all your small cheap USB sticks