onboard LAN MAC 00:00:00:00:00:00 after BIOS update

hi, I have a Gigabyte MB10-DS1 which had a “Datto” branding and F01 BIOS.
I downloaded the official F06 and updated BIOS+ME via BMC web interface, and also updated the BMC itself.

I now see both LAN having have MAC all zeros.

After some googling I thought i’d give this a try:

dmi236 /o 1"0123456789ab"

however I cannot find anywhere what is the correct way to use this command for 2 MAC addresses?


afudos /M[MACID]

but how to specify 2 MAC? could not find examples.

Already tried Asrock MAC Tool (from FreeDOS USB stick)
C:\>mac c [mac ID1] [mac ID2]

which does NOT work for me!

Any help please!
I wish I had never touched that BIOS update.





I replied to you over at BIOS-mods forum, if one of those get it please post back here with correct method too for next user looking in the future.

If we cannot get it that way, please dump your BIOS with programmer if you have one, or if not with Intel FPT and upload here (With a text file with both of your correct MAC ID’s on it, and the current incorrect values in the text as well)

hi, thanks for the reply. I have tried every single version of AFUDOS I could get hold of (most do not have the /M switch, I suspect the recent ones for EFI BIOS…) and also DMI236 which returns incomprehensible errors. I have given up!
I have tried many combinations with 2 MAC addresses then tried even with 1, does not work.

I got the FPT DOS 170 (no idea if good version or not, any help would be greatly appreciated!) and I am amazed to see this text in the HOW-TO-USE-FTP.txt

It can’t be the problem is so widespread ?!?! I had an Asrock Rack socket 1150 board that recently died (won’t power on - no BMC light) which had the Intel dual Gbe LAN chip and I had never had any problems flashing BIOS on it.



using FPT v. tried

fpt.exe -D <name>.bin
fpt.exe -D <name>.bin -BIOS
fpt.exe -D <name>.bin -GBE

which fails (screenshot attached).


I have nothing left to try. Please help!

Idea - if I was to find another same model motherboard, would doing AFUDOS /O (Save current ROM image to file) on it allow me to get a “working” rom to restore it on my motherboard and end up with non-zero LAN MAC ?? or would LAN MAC get zeroed during flashing??

Before I spend too much time trying to get a ROM of a “working” motherboard…

@dimadima - Don’t worry so much, we can fix, just be patient. Please give me your Intel ME version, if you are not sure check in device manager for Intel Management, or download HWInfo64 and in the large window once you run it, on the left near top there will be ME section, click that and find the ME version and post that here.
This will allow me to link you to the correct version of FPT to use, and give you the correct commands to use (above are wrong). Then we can dump your BIOS and or the GBE region if not locked, and I can help you put back in.

No, your last question about another board would not help either, you would be stuck with incorrect LAN ID then as well. However, if we cannot find LAN MAC Location due to all zero’s currently, then it could help.
Do you have ANY backup from before this happened, so I can look in and find the LAN MAC ID Locations? I know where the boot from LAN MAC Goes, but that is not same as these, and this BIOS does not contain usual GbE module where they’re stored on desktop versions.
I’m sure I can find eventually though, then edit in your correct ID’s then you flash BIOS again.

Updating BIOS using the method you did is how this happened and it probably did not ask if you wanted to use /K switch to keep current DMI Data.
BIOS should never be updated via web interfaces, DOS is suggested or within the BIOS itself when possible. Of course, flashing in the official BIOS for your board could have helped cause the issue too, if the OEM BIOS differed enough.

Here, from the official F6 package, is possibly correct FPT to use (If your ME was updated to this or similar version during the update you did).
If your ME was not updated, we may need to use older version still, we’ll know more once you get me your current ME version


Inside SPI_UPD folder is FPT to use (Only DOS or EFI Version), if using DOS version be sure fparts.txt is also on your DOS boot disk/drive etc (Possibly also needs to be there for booting to EFI as well)
Run this command, you may need to move a jumper to service mode, I am unsure which way allows you to dump Full BIOS, try both ways and send me the files it ouputs.
FPT -d BIOS.bin

@Lost_N_BIOS thank you! I was running AFUDOS from the SPI_UPD from the official F06 yesterday yet my eyes did not see that FPT is there

This one seems to work “better”.


no idea what it is asking me to do

I almost missed it too!

This means FD is locked, did you try also same with service jumper enabled (two-pin jumper, unsure of label I’d have to download your manual, may say FD, ME, FDO, Service)? If not, please do that now and try again.
ME is the issue, without jumper enabled ME is locked for read/write, so when trying to dump the entire BIOS as above, it will give error. All other regions are read/write = YES except ME, this requires the jumper enabled or disabled (Try other way now on jumper)

Also, since I did not see this region in your BIOS, but I see it now in the FD as unlocked, lets see if we can dump that or not and maybe it’s just in unusual location so I didn’t see it.
This is where I normally look for LAN MAC ID (GbE region, which I don’t think your board has, but left in FD from being lazy I bet)
FPT -gbe -d gbe_reg.bin

Thanks! This was a quick reply at 5am before running off to work, I’ll try with the ME jumper when back home.

And, as to the previous question - I have no backup. I probably have not flashed enough BIOS before to see things fail - it always “just worked” - so did not take any before updating.

Thanks, hopefully it should work once jumper enabled. I’ll see if I can find any dumps to look through, there’s far too many 00 00 00 00 00 00 's in stock BIOS (60K) to know which might be your current LAN MAC ID.
It’s usually easy error when this happens, often it’s 88 88 88 88 87 88 invalid ID, so easy to find and fix.

Dima, by any chance did you buy this mobo recently of ebay one of 2? :slight_smile: So I have fallen into exactly the same trap, and if it makes you feel any better I went with the windows flash option which does have the -K and it wiped out both my MAC addresses as well.
Was there any reason you specifically went with F6? Not to confuse matters but I’ve gone with F10.

Lost_N_BIOS, would you be please please be willing to help me out also?

If so…
Attached is my screwed F10 version of the BIOS output using the fpt -D, with the jumper off. (And man those jumpers disintegrate easily).

My previous mac addresses before they were wiped:

MEKW.zip (4.06 MB)

Hello and welcome to the club, lol. I wish there was a way to notify anyone else buying that board to not touch the damn BIOS!

I went for the F06 as I did not want and need any of the Spectre/Meltdown patches, which disable speculative execution and effectively reduce cpu performance. You only care about these patches if you have multiple parties using your server that do not trust each other and you want to safeguard them from accessing the areas of memory they does not belong to them, e.g. if you would make a VPS out of it to rent out to the world. Hardly my use case for a mini-ITX home server:-)

I bought this board as my Asrock Rack socket 1150 died recently and I could not find a decent used same socket board for sale, I can’t really afford new hardware prices:-)

Also I’m not convinced these are Gigabyte MB10-DS1, i think they are a derivative for Datto (who seem to make NAS’). I could not for the life of me get the supposed i210 drivers to work; which is the reason I flashed the bios in desperation.
If you look at the board layouts in the manuals the usb and the nic’s are in the opposite places, as well as being stacked.

On the plus side at least the horrible blue Datto screen has gone now, even if I have no NICs that actually work.

Oh, this is interesting. I noticed the board layout was a tiny bit different vs the manual in a couple of places as I was putting it together but I thought Gigabyte were just lazy and did not update the drawing from say Rev1.0 etc or the was a difference due to the lack of SFP vs. the more expensive cousin.

What is also curious I noticed now the F01 it came with is a couple months “newer” than the oldest available official Gigabyte BIOS (F06) which makes me think they could have modified the F06 and called it their F01. Now - how do we get that BIOS to compare? We all wish we’d taken backups.

I have never heard of Datto before and yes getting rid of the irritating blue Datto branded screen at boot was one of the motivators to flash BIOS lol.

I have already tried contacting Datto asking them to make their F01 available, without any liability or support implied - they could not care less to help.

I also have a ticket with Gigabyte support which is still “being processed” after 4 days or so.

There is a seller in the US which seems to have quite a few of these boards available. Maybe he could be persuaded to dump BIOS from one of them to help out?

With the LAN MAC all zeroes it is a hell of a job to figure out where it is set. I wish we could get the original BIOS somehow.

Did you also upgrade the BMC/IPMI? Or only the BIOS+ME?

@Lost_N_BIOS the jumper as expected did the trick and here’s my BIOS.

Original LAN MAC:

You were absolutely right there is no GBE region:-)


MY_F06.zip (4.01 MB)

@Lost_N_BIOS on the subject of jumpers, I noticed there is one named “BIOS RCVR”.
While all the rest are documented - these BIOS jumpers are not!



Do you think if I set it this will make the board magically recover BIOS to the “factory” F01 it had ???
I do not think this board has dual-BIOS like other Gigabyte boards. What might be the purpose of this jumper? Very tempting to try…:-)) worst case I just flash with the broken F06 again? lol

So @Mekw I gather you didn’t make a BIOS backup before flashing either? Yes, I will help, once I figure this out, too bad there is no GbE, we’d be done by now! Do either of you guys know anyone else that owns this model, even online friend you could contact?
If yes, please message them and show them how to get a dump created with FPT and ask them to include at least one of their MAC address if not both, this will help me be able to fix your MAC Addresses for you.
I may be able to figure it out anyway, but a dump with valid and known MAC Addresses in it would really speed up the process

You both should try to ask Datto if they have a tool to reprogram the MAC ID’s, or ask for their specific default location in the BIOS (What module is it stored in, or what hex address, either would be helpful).
If not, hopefully Gigabyte will reply eventually, if they do ask them these same things, maybe update your tickets to them too and tell them you can fix manually you just need to know where to put the address (Tell them you don’t need to know how, just where).

In the meantime I will take a long look through the BIOS and see if I can find the location. What is the LAN chip in these boards?
This usually holds one LAN MAC ID, but only for the PXE Booting from LAN thing, not really the two MAC ID’s we need to fix, but I’d like to check this module in case it possibly holds anything helpful

@dimadima - that may work, or it may work like a BIOS flash, and purposefully leave your current LAN ID In tact like a normal BIOS flash would do usually. It’s something you can try, there is a secondary BIOS chip on the board most likely.

Do either of you have CH341A or other flash programmers and SOIC8 test clip cables (If soldered on BIOS)? If yes, then whoever does have programmer could go ahead and try out the recovery jumper and see what happens, then if it’s bad outcome you can put back the FPT dump if needed.

If you do get back to that F01 BIOS, send a dump for comparison. I doubt it will fix the LAN, but you might get lucky.

That looks like Gigabyte board to me, but it’s hard to say exact model that it could be, if all same as what you guys though when you picked this BIOS to flash or not vs board revisions and updates etc.
I know the manuals are always old, often written using pre-production boards too, so that not matching up exact is expected even if you purchased official board from Gigabyte.

@Lost_N_BIOS i do NOT have any flash programmers. Are you saying in this case i should NOT try the "BIOS RCVR" jumper?

It’s up to you, may not be good outcome since you flashed in other BIOS. If this is your only system I would wait and not do it until you have programmer in hand, if you have another system you can use in mean time while you wait on a programmer to arrive then go ahead.
It would probably be OK and recover, to old BIOS with zero LAN still, but best to have programmer ready in your hand just in case, especially if this is critical use system. You can get programmer quicker than 3-5 weeks from china usually, but it costs more buying locally or from seller that offers faster shipping options.
You need CH341A ($2.50 on ebay) and if BIOS is soldered to board also need SOIC8 test clip cable ($3.50 on ebay), or a kit like EZP2010 or EZP2013

*Edit - did you guys see last post here yet? Maybe some of them are your posts?

Looks like by flashing a different BIOS, they were able to get correct LAN ID’s to show in BIOS. With this, you can dump via FPT again, I can find where those are stored, and then fix in original BIOS then you can reflash that one again.

Poor chap on the other thread. Unfortunately the DS4 is a no go for me as I don’t have the 10g NICs on my motherboard.

@Lost_N_BIOS - According the manual - 2 x GbE LAN ports (Intel® I210). Again I’m a little skeptical on this as it was getting these working with ESXi that prompted to me flash in the first place as they were being discovered as 10g X557 Nics, which the firmware apparently removes.

I’ll take the risk with recover and report back @dimadima if the damn jumper doesn’t disintegrate :slight_smile: