Patch Bios HP 800 SFF G1 in order to Support NVME SSD PCIe (Booting)

I’m trying to Patch Bios HP 800 SFF G1 in order to Support NVME SSD PCIe (Booting). BIOS is already patched but I can’t install it.
Bios Patched
Attached → L01_0278.part1.rar & L01_0278.part2.rar


So, i’m trying to patch bios using first “[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash” (i’m getting error 280 when i try to flash back dump bios)… and i’m stuck in here.

Dump Bios
Attached! → biosreg.rar


Can someone help me add NVME boot support to flash back bios dump modded to enable this?.

Thanks a lot!

Edit by Fernando: Thread title shortened and customized




biosreg.rar (3.42 MB)

L01_0278.part1.rar (4 MB)

L01_0278.part2.rar (2.38 MB)

@kyrios - Please run the following commands at grub prompt again, all of them, then after that redo the BIOS region dump with FPT and send to me
setup_var 0x96 0x00
setup_var 0x97 0x00
setup_var 0x98 0x00
setup_var 0x99 0x00
setup_var 0x9a 0x00

Additionally, after grub changes above, please run this command below with FPTw and send me the created file.
Put new BIOS region dump from after above grub changes + File below, into single max compressed zip. Upload to or
FPTw.exe -a 0x60000 -l 0x8B0000 -d vol1.bin

Here we go (dump+captures)…

Again, thanks a lot!

@kyrios - You’re welcome! Missing file >> vol1.bin Ohh! Sorry, I forgot to tell you jumper may be needed.
Now, after grub, please put on service jumper, then reboot to windows three times, on third boot to windows after jumper is on, then run command below and sent me file.

Also, sorry! I had incorrect offset to dump in above command, sorry! So maybe that was why (I assume so, that’s in ME region ), or jumper needed too, I am not 100% sure.
You can try this first without jumper, then we’ll know, if vol1.bin created then no need for jumper just yet
FPTw.exe -a 0x5E0000 -l 0x8B0000 -d vol1.bin

Don’t Worry. Yes, works with no jumper needed.


@kyrios - I am on limited internet, don’t want to download stuff I already have (ie BIOSreg dump from post #3 looks to be included there?) I also don’t need whatever “cap” is in there.
Please upload vol1.bin only

* Edit - @kyrios - OK, I didn’t want to wait, and have you waiting some more again too, so I grabbed above file anyway
Here is NVME mod volume 1, flash this back via following command >> FPTw.exe -a 0x5E0000 -l 0x8B0000 -f vol1NVMEMM45.bin…647697162779646

Then, to install to NVME, you need to make NVME RAW or Initialized as GPT, then follow all steps at #4 in the “This is what you should do section here”
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

To make NVME RAW - You can use diskpart in windows from OS (Direct from any CMD Prompt), or from installer ISO (press Shift + F10 on the first setup screen where you pick language)
Either way, remove all other drives, so only the NVME is there, and any other disk you will recognize by size/name etc - so you don’t accidentally wipe wrong things.

At CMD Prompt >>

>> Diskpart
>> List disk << Here, identify by size, and then note the number which disk you will be wiping to raw here (If in windows, this #'s will match what you see the drives shown as in Disk Management) - Be sure you do not select your USB or main OS drive if in OS
>> Select Disk # << here, replace # with NVME # you want to wipe to raw.
>> Clean
>> Exit

Everything is working ok!, i can boot via PCIe Adapter (NVME SSD) without any problem!..

I can install windows (EFI mode), boot and work!!

I made a few tests:
PCI Express x16 READ 2962 MB/s WRITE 2862 MB/s
PCI Express x16 slot downshifted to a x4 (White): READ 1595 MB/s WRITE 1521 MB/s

Can you give me your paypal account to give you a beer? (to make a donation)…

Thanks again!!


@kyrios - Thanks for quick test and report back, great to see everything went smoothly!
Is this PCIE 3.0 or 2.0 system? I ask because even at x4 PCIE slot, speeds should be same as a x1 slot, because NVME only uses x4 no matter if it’s in x4 or x16 slot.

Thanks for offering to send something my way, I’ll shoot you a PM now

@gloobox - A while back we discussed this kind of flashing while still FPT 25-28 error locked.
And we were not 100% sure how that worked, BIOS region only, or direct flash area you want to mod (such as ucodes like Deathbringer was doing when he showed us unlock on these) etc.
Yes, do direct area flash via offset + size, only last volume of these BIOS are protected by the lock, that’s why entire BIOS region fails.
See above, this is NVME Mod flash in, by dump of BIOS region + first volume only within BIOS region (For size OK confirmation post-edit).
Do the actual edit/mod in full BIOS region dump, then extract first volume of BIOS region only and flash it back in via FPT

Error 7 is still an obstacle for me.
I ever tried it on ASUS P9X79 which had no any bios lock,and I will got error 7 too when flashing the modded bios.
It seemed something preventing the FPT to flash.

@gloobox - You shouldn’t have to FPT on Asus P9X79 anyway, that model and all it’s variants have USB Flashback, correct?
If some of the variants do not have USB Flashback, then FPT works, because I’ve made mod BIOS for ALL the Asus X79’s for many users

Yeah,but actually I just want to show you where the error7 would happen.And try to solve this kind of problem.
I had tried to flash the modded bios with FPT on some chinese X79 mobos,and found some mobos would show error7 but some not.

Ohh, OK. Sorry, I don’t have any Asus P9X79 here anymore, so I can’t test myself to see about this issue for that model
What other mainstream (NON-OEM) models do you have this issue on, maybe I will have some board in your list and can test myself?

I will upload the TWO of chinese X79 mobos’s bios after days,and let’s analyse it.

That does not help at all with any of this error 7 discussion you wanted to get back into

I think same as you, according to HP 800 G1
(2) PCI Express x1 (v2.0)
(1) PCI Express x 16 (v2.0 - wired as x4)
(1) PCI Express x16 (v3.0)
(1) Optional PCI (v2.3)
there should be no major difference between one slot and the other.

@kyrios - PCIE x16 3.0 slot will be MUCH faster for NVME
But for x4 vs x16, PCIE 2/3 it would not matter, NVME only uses x4 so no matter the slot width 4/16 it will be same speed (only diff would be PEI 2.0 or 3.0)

And sorry, I meant x16 in the post you quoted above, not x1, left off the 6 Here’s what I meant to say there >> I ask because even at x4 PCIE slot, speeds should be same as a x16 slot, because NVME only uses x4 no matter if it’s in x4 or x16 slot.

Hello, can you please guide me to setup elitdesk 800 G1 with same bios 2.78 patching, so i can boot nvme drive

step by step please…

@elitepc - See post #2 in this thread, here is guide on how to use Grub/setup_var, you start at step #6, I’ve done 1-5 for you and info is on post #2
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

After you’ve done stuff in grub from post #2, then you need to run this command with FPTw.exe and send me the created file >> FPTw.exe -a 0x5E0000 -l 0x8B0000 -d vol1.bin

Here is my copy/paste on how to use FPT to dump BIOS region, but you wont be doing that here, just run command above, I’m dropping this so you can find correct ME System tools package

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

This is the error shown

FPT Error Message.png

here is the backup

biosreg.rar (3.4 MB)