[Problem Solved] NVMe Support for ASUS Z87-K

Hello everyone, this thread started from <<<here>>>

@Lost_N_BIOS help me do this :slight_smile:

EDIT1 by Fernando: Thread moved and thread title shortened
EDIT2 by Fernando: Added to the thread title, that the problem has been solved.

@galiber - Did you see there is newer BIOS?

First you need to follow this guide, you can start at step #6 as I’ve done the info gathering from #1-5 for you and details are below
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Rename .efi file to >> Shellx64.efi

SMI Lock variable to change >> 0x7D
BIOS Lock variable to change >> 0x7E

So, at grub prompt, you will type the following, one line at a time, enter between each (case sensitive)
setup_var 0x7D 0x00
setup_var 0x7E 0x00


Then, reboot and do the following (step #2, you can skip “testing” of, the above will make it possible, and that step is what you use to actually flash in the mod BIOS). Also no need to attach file, unless you want me to edit
So, do #1, and this is the file you now edit to do NVME mod to (toss out previous edit). Once you’ve done the NVME mod to this biosreg.bin file, then flash it back via step #2
The actual NVME insert on this BIOS can be done safely with UEFITool 25.0, 28.0, or MMTool 4.50.0.23 (Possibly others as well, but did not check)

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below


If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required
> CLICK HERE TO DOWNLOAD CMD PROMPT REGISTRY ENTRY <

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

@Lost_N_BIOS

Thanks a lot! After I finish work I’ll get on with it and give an update on how things went.
-----------------



I tried that one - 1402, it detected my keyboard, but wasn’t responsive to it. Good thing I had a friend over with his PC and I managed to boot/enter bios with his keyboard. I had removed all of the drives and the “Press F1 to setup” promt was showing.

@galiber - You’re welcome! Don’t skip any steps, or do something other than outlined, and be sure you DO NOT use any previously modified BIOS file you downloaded from Asus, you will loose your system specific info.
If you see any “size related” or RED error in FPT, stop, do not proceed and do not reboot, and show me image of the command you typed and the error on screen. PDR or GbE errors can be ignored, those are normal/expected.

On the 1402 and KB issue, probably you needed to get into BIOS and load optimized, and or change some legacy USB Setting then it would be OK. But yeah, not ideal to do that if you can’t use KB to do it

@galiber @Lost_N_BIOS
JFYI: To make it easier for other ASUS Z87-K users to find the solution for this specific problem, I have moved this thread into the the best matching Sub-Forum. Furthermore I have shortened the thread title.
I hope, that this is ok for you.

Hi @Lost_N_BIOS

I just started the procedure :slight_smile:

I flashed the original file for 1401 with ASUS EZ, now I’m trying to backup the factory firmware, but I can’t, I get this error:
Error 284: Fail to load driver (PCI access for Windows).
Tool needs to run with an administrator priviledge account.

I even loged in as administrator and did it from there but nothing… Any tips?

@galiber - That is explained in the spoiler
Admin account has nothing to do with running CMD as admin, you need to do that via registry fix is easiest way, then you can just right click anywhere and run CMD as Admin from here
I just updated link to registry fix to make it easier on you, sorry I forgot that was bad link before

@Lost_N_BIOS



I saw that, followed the previosly not working link and desided to find one myself, did that, the option appeared but I got the same error. With your new link, I got the RIGHT registry and it worked! Continuing, I guess I’ll be back here in a minute

@galiber - Yes, sorry about that link, I forgot when I copy/pasted
I have to run now, be back in about 8 hours.

@Lost_N_BIOS and @Fernando
What can I say guys… IT WORKED!!! I saw that little pata drive in my boot devices list

For anyone that wants to try this: be very carfull ( and have at least 2 keyboards as a backup the second one saved me 3 times - 2 times when I put the newest BIOS and the other time was when i had to write in grub <OPTIONAL> )
The steps I did that worked for me:
1. Flashed my bios with the !ORIGINAL! file from ASUS using the ASUS EZ tool from inside the bios.
It’s easy, just put the file on a flash drive in FAT32(that’s what I had, idk if it’s a must), go in bios → advanced mode → TOOLS and the version you have of ASUS EZ. Then just find the file, click it, and agree to use or/and upgrade the BIOS.
2. Used the instructions from that @Lost_N_BIOS gave me:
In general what I got from them was: download HWINFO64 from the Dump BIOS Region w/ FPT section of his post, saw that my ME FW version was 9.0, downloaded the correct ME System tools package it was 9.1 for me and unzip that. There I went to Flash Programming Tool → WIN32 (I ignored WIN64 as instructed!). I had an issue where I couldn’t shift+right click to open CMD(PowerShell is not an option, neither is opening CMD as administrator and navigating - I tried but failed miserably) and had to use a registry which is provided at the end of the same section. After I did that, I ran the “FPTw.exe -bios -d biosreg.bin” command from the in the CMD and it generated a biosreg.bin file. That is the file that will become the newly modded bios.
3. From @Fernando 's <original guide>, I got the UEFITool 28.0 → the “This is what you need:” section → spoiler → b) section. Also, in the same spoiler section - get the .ffs files (get both - if an error shows for the bigger one you’ll use the small one). Now follow that guide from “This is what you should do:” → 2.BIOS modification: → b). Note: you are edditing the biosreg.bin file from the previos section and the only thing you should do !!(as in changes - do all the the imprtant checks and verifications!!!)!! is to find the right place of the DXE driver, insert it, and save it again as .bin. You’ll get a prompt to check your changes - do it to be sure that it’s OK. Do that and stop before "3. Flashing of the modded BIOS:"
4. Again from Lost_N_BIOS’s instructions

did that, in grub - got the errors that were the same as the picture in the mentioned thread - as it’s said there - they shouldn’t be an issue. did ctrl+alt+del and that was that.
5. Now the only thing left was the step 2 from Lost_N_BIOS’s “Dump BIOS Region w/ FPT” section with the .bin file i got eddited in step 3 from this guide, rebooted and there the PATA drive was.



Sry for this, I wa realy excited and started typing, feel free to modify/remove this post. AND THANKS AGAIN FOR THE BLAZING FAST HELP!!!

@galiber - Great job, and thanks for dropping outlined method in your steps for others!

I think maybe you wrote out some things backwards, or did some things I told you backwards maybe?
Step #4 should be done before you get file in step #3 (ie unlock BIOS/SMI lock first, then dump BIOS region, then edit, then program it back)
Or, maybe it just looks confusing how you wrote it out?

You’re welcome though, and great to see you are now booting your new NVME