[Problem] Win7 x64 Install onto AMD Ryzen 5950X with X570 Pro4 System

Hi everyone,

I hope everyone’s well.

Like many of you I am still a Windows 7 user.

Just yesterday I decided to upgrade my PC build which now included the Ryzen 5950x and Asrock x570 Pro4 motherboard.

I have since experimented different methods, I’m using a spare 1TB hard drive and I thought to do a fresh install of Windows 7 x64, but after “Windows Loading Files” it then BSOD.

BUT…when I use a x86 disc, the setup boots and the installation completes!

I even boot straight into the freshly installed operating system!

This has me scratching and pulling my hair, I went through BIOS, tweaked settings and tried different combinations but the system just doesn’t seem to like anything 64bit, even thoigh the hardware is all under spec, the last thing it would want is 32bit anything but yet it gladly accept it!

Can anyone help me out here or explain what is going on? I would REALLY appreciate it!

Edit by Fernando: Thread title customized

Welcome to the Win-Raid Forum!
It would be helpful, if you give us the following information:

  1. Which specific BSOD error message did you get?
  2. Did you use an original (untouched) or an already customized Win7 x64 ISO file as source? If the latter, what did you integrate?
  3. Which sort of target disk drive did yizu use (manzfacturer/model)? Which data transfer protocol (AHCI or NVMe) does it use?
  4. Did you do the installation of the OS in LEGACY (MBR) or in UEFI (GPT) mode? Has CSM been enabled or disabled within the “BOOT” section of the BIOS?
1 Like

Hello Fernando, thanks very much for getting back to me!

  1. BSOD is 0x0000007e.

  2. I used both Untouched and Gen2’s Sep2023 ISOs.

  • When using original untouched iso/disc, it doesn’t get pass “Windows is loading files”. After completion bar fills, I get BSOD.
  • When using Gen2’s Sep2023 ISO from USB, I am able to go through setup process. Once completes the “Starting Windows” animation logo appears, after that it goes into endless bootloop.
    I don’t know if I had to “intergrate” anything? Isn’t that already part of the setup process?
  1. All drives used are mechanical, from Toshiba and Seagate. I’ve unplugged all uncessary hard drives and use only one 1TB Seagate 2.5" hard drive for (constant) Windows 7 installation.
    Correct me if i am wrong but because of my method, they’ll all be AHCI?

  2. OS installation has been largely MBR (I have tried GPT but no luck). CSM has been enabled in the Boot section, with two corresponding settings set to “Legacy”.

>Here< is a discussion within the Windows 7 Forums about a rather similar problem.
Maybe it will help.
If not, here is another option: Check the compatibilty of your rather new onboard USB 3.0/3.1 Controller with the old OS Win7 x64. Maybe you have to load or integrate a suitable USB driver, which supports the HardwareIDs of your USB Controller and Win7 x64 as well.

1 Like

@Fernando Thanks for getting back to me again!

I’ve checked out that forum link you’ve provided and the problem is similar, but unfortunately the link doesn’t work or at least contain a Windows 7 ISO, so I can’t try TechBench by WZT modified ISOs out :frowning:

How do I integrate the drivers during setup? Because I clicked on “Load Drivers” but it’s not picking up anything on the USB (Gen2’s ISO).

What’s even stranger is that the x86 disc runs perfectly fine, and it was an Untouched ISO too!
Surely with hardware this new anything 64bit would execute, but it seems to prefer 32bit OSes, how does even happen? :question:

It is better to integrate the related driver into the boot.wim and install.wim of the ISO by using a tool like NTLite.
P.S.: By the way - I have the same mainboard like you (ASRock X570 Pro4). Maybe I can test it myself…

1 Like

Sorry for my late reply!

But yes, I have been looking into doing that and have been watching tutorials on how to use it.
I plan to use it alongside the latest driver package that CanonKong released on his own thread…but I’m very paranoid and eagar to avoid disappointment, which is why I tried the other methods first that was recommended to me. :melting_face:

I just saw your update to the post and AMAZING!
I’m so pleased to hear that you have an identical board to me, you’re probably the best shot I got out of all the forums that I’ve posted threads on!
Please do give it a go…I would be extremely appreciative :pray:

@Fernando Sorry to bother you again!

I forgot to mention, if it’l make things easier, you don’t have to pull out your build and start replacing hard drivecs and etc.

It can merely be a simple test, in that you can (and recommend) use an untouched Windows 7 x64 ISO burned on disc or bootable USB and you should hopefully see that it fails to even load setup.

Hope you don’t mind this and please do let me know! :pray:

Although I don’t have actually the required free time to do such tests, I did it, because I found by chance within my archive an old Win7 SP1 Home Premium DE x64 ISO file dated July 2017, where I had integrated the MS NVMe Hotfixes.
Result: A few seconds after having started the Win7 SP1 x64 installation in UEFI mode I got a standstill (no progress anymore, after 15 minutes I stopped the procedure and turned off the PC). I don’t know the reason for the failure, the display showed permanently the words “Starting Windows”, but nothing else (no BSOD, no error message).
Important difference between our PCs: My system drive is an NVMe SSD, so I had to integrate the MS NVMe Hotfixes into the Win7 ISO file.
I am sorry about the fact, that you do not benefit from my test results.
Nevertheless I wish you good luck!
Please let us know, if you should succeed one day with the Win7 x64 installation, and don’t forget to reveal the trick or solution.

1 Like

@Fernando Thanks for getting back to me once again!

Yes I thought time might be an issue for you hence why I suggested the simple test, but I highly appreciate you giving it a go!

I do not think the main differnce is because of the NVMe, your issue is the same when done in UEFI, it’s known that Windows 7 doesn’t like UEFI, thus the main difference is that you booted in UEFI, whilst I did not.
This is why my build is (and always has been) non-UEFI, CSM and Legacy enabled.

Is it possible if you can give it a go again that’s non-UEFI compliant?
From there you should see either a BSOD or a system reboot.

I have an untouched ISO of Windows 7 x64 Ultimate, would you like me to link it to you?

I am HIGHLY appreciative you helping me out in this matter and giving it a go, I feel we can probably solve this matter together.

Thanks for the quick reply.

Since my system disk drive (with the OS and the EFI boot partition on it) is a Samsung 990 Pro, I cannot install with my current system any OS in LEGACY mode. Simple reason: Our ASRock mainboards do not contain an NVMe Option ROM, which is required for such purpose.
For an install of Win7 x64 in LEGACY mode there are only these 2 options:
a) usage of a SATA connected disk drive or
b) usage of an NVMe SSD model, which has an NVMe Option ROM in-the box or inserting a customized Option ROM into the mainboard BIOS.
I don’t think, that I will repeat my test under these conditions.
By the way - I don’t need a link to your Win7 ISO file. As a former Win7 Beta tester I got it together with a valid key from Microsoft.

1 Like

@Fernando Not a problem with the quick reply, I’m just really pleased to get a response and very concentrated to getting this work (it has been a week a two days without my main computer…and I use it for work)! :slightly_smiling_face:

I understand your situation…however I am not saying to go ahead with a full installation but rather if your x64 installation will even load up. That’s one of the hurdles I’m trying to get through.

The two optioins you;ve mentioned, i do want to further clarify that I am and only been using SATA hard drives, and that only an x86 installation will work.

Absolute respect for being a Windows 7 Beta tester! :pray:

Before I am going to try myself the installation of Win7 x64 in LEGACY mode, I would like to know the following:

  1. Which USB port of the ASRock mainboard did you use for the OS installation?
  2. Have you ever tried to circumvent the USB3.0/3.1 driver problem by using the on-board USB 2.0 Header (Nr. 20 of the Layout picture in the Manual)?
1 Like

@Fernando That would amazing if you could…thank you so much!

  1. I have tried all USB ports, but mainly the front panel which is USB 3.0.
    I would like to note that I did try installing x86 / 32 bit through USB flash on these ports and it still worked.

Once again to clarify, I did install x86 from an installation disc and that worked in itself.

  1. I’ve even added USB ports on an empty slot in my chasis and connected it on USB2.0 header but I don’t think it picked it up (will try this in a minute).

It’s important to note that in the last 24 hours I went throug the following:

  • Disconnected all USB headers; Window 7 still doesn’t boot.
  • Removed BOTH graphics cards to hopefully migitate a potential graphic driver issue, thus tried using HDMI output on motherboard; No Signal and was presented with 4/5 long beeps. Even without display, I can tell the computer rebooted (I’ve gotten used to the sound it makes).
  • I placed my ancient but trusty 7600GT graphics cards; it made absolutely no difference.
  • I’ve updated BIOS from 4.20 → 5.60. No difference.
  • Turned off WAN Radio and BT (Bluetooth) in BIOS. No difference.
  • Disabled AMD CPU fTPM. No difference.
  • At the final hour, I downloaded Windows 7 Build 7000 (first official Beta) to see if there is any changes to the code compared to the RTM release. Again BSOD after “Starting Windows” animated logo.

4:30am bed time.

I really did try to cover a lot of ground but something now really doesn’t seem right. Am I seriously missing something? :disappointed_relieved:

@Fernando Hello!

Hope you’re having a good weekend!

Sorry if I wrote too much previously… forgiveness please :pray:

I was wondering if there might be any updates on your side of things perhaps? :crossed_fingers:

Not only to do you a favour (I was curious myself) I have done your requested test.
This is what I did:

  1. As first step I created an NTFS formatted, in LEGACY mode bootable USB Flash drive with an original (untouched) Win7 SP1 x64 Ultimate Edition on it by using Rufus.
  2. Then I connected a 256 GB SATA SSD to one of the AMD SATA ports and to the PSU.
  3. I entered the BIOS, enabled CSM and stored this setting.
  4. After having re-started the PC and pressing F11 I was able to boot off the USB Flashdrive, which had been prepared as first step.
  5. The Win7 installation in LEGACY mode began , the “Starting Windows” message disappeared, but a few seconds later I got this BSOD, which seems to be absolutely identical with yours:

So I can confirm, that the impossibility to get Win7 x64 installed onto your ASRock X570 Pro4 mainboard system has definitely neither been caused by your Win7 source nor by a wrong BIOS setting.

This is what I recommend to do: Send a Feedback to the ASRock Technical Support and ask for a solution. You can use >this< contact form.

Good luck and Happy Easter!

1 Like

@Fernando Thank you ever so much for trying!

Indeed that is exactly the same BSOD that I’m receiving.

May I ask, what BIOS version are you currently running perhaps?

The BIOS of my mainboard is the latest (L5.61).

1 Like

@Fernando Sorry for the late reply and thnaks for letting me know!

I thought to use this opportunity to give an update, a lot of things happend once again in the pass 48 hours.
When I made my post asking if there were any updates on your side, I decided to try downgrading my BIOS (since I was starting to believe this could be the only cause), I went all the way down to version 1.00.
The computer no longer booted up, POST and ended up in a power cycle. The reason as I discovered that evening was because that version of the BIOS did not support Ryzen 5000 series. This costed me dearly.

The next day I ended up rushing to a computer exchange store and purchased a Ryzen 2600, which then thankfully work.
I thoguht I would give it a go, I tried doing another fresh install of Windows 7 x64.

From there I had to update the BIOS in the very old fashion way, because I discovered again that a Matisse cpu was required to ensure Ryzen 5000 compatibility.
The Ryzen 2600 was Pinnacle Ridge.
I went to BIOS version 3.90 and changed back to Ryzrn 5950x. Endless bootloop once again.

Swapped back to Ryzen 2600, downgrade BIOS to 3.20 which is the earliest version to support 5000 series.
Windows 7 64-bit still worked.
Swapped back to 5950x, again endless bootloop.

4:00am bed time.

1 Like

@Fernando This has now led me to come to somesort of an understanding to my problem.

It is very well evident and documented that 5950x CAN work with Windows 7, either my successful attempt with Windows 7 32-bit, or the many users on the internet who had 64-bit running with the said CPU.
I can even make the argument that I’ve had success on a Ryzen 2600.
CPUs matter very little in this regard.

I have boiled it down to the fact something has gone horribly wrong in the BIOS from version 3.20 that started support of 5000 series.

Anyone or myself could be happily running their system on any previous generation or series CPU with the latest BIOS update, and could decide one day to upgrade the processor that would still be compatible because it’s AM4.
As soon that’s physically installed and one presss the power button, the machine would fail!

What do you reackon can be done?
what do you think the next step(s) should be??
Since we all now have abetter understanding, can this be resolved?

Sorry for the long post(s) but I hope this helps and hope to hear from you again! :pray: