[Request] Acer Aspire A717-72G Bios Unlock

Hi I need so help to unlock the bios of my laptop (Acer Aspire A717-72G-752W).
I want to unlock the advance tab in the bios. (Like in this video https://www.youtube.com/watch?v=uJV3Rtmb7Jk)
But I don’t want to use a CH341 programmer for that. I found this on the forum but it’s not the same model nevertheless i think it’s possible (Acer E5 571G 51DS Bios Unlock).

I want to know what are the risks also :slight_smile: because i don’t want to mess it up

Bios Links:
https://global-download.acer.com/GDFiles…1915.1560273746
or
https://www.acer.com/ac/en/US/content/su…roduct/7601?b=1

Laptop page:
https://www.acer.com/ac/fr/FR/content/model/NH.GXEEF.004

Hope for a positive reply :wink:
And Thanks in advance for the help you will provide :smiley:

CpuZ_MainboardTab.png

CpuZ_CpuTab.png

I did what @Lost_N_BIOS said here in the #2 ([Request] SVF1421MSG BIOS MOD - ADVANCED MENU)

I have this:
-Intel ME Version: 12.0, Build 1069

So i used the “Intel CSME System Tools v12 r17.rar” and run this command: FPTw.exe -bios -d biosreg.bin (in the C:…\Intel CSME System Tools v12 r17\Flash Programming Tool\WIN32)

FPTw.zip (3.79 MB)

When i try to run the command FPTw.exe -bios -f biosreg.bin like in this thread: Acer E5 571G 51DS Bios Unlock (2) #22

I get this: error 167(Screenshot)

I don’t fully understand what to do next :man_facepalming: hope you will help me :blush:

screenshot bios write.png

What you do is wait for help Please edit your posts when you want to add more info and no one has replied yet - thanks

Some model of system that’s not yours is not related at all, and means nothing when it comes to unlocking or if it’s even possible. You may or may not need to use a flash programmer, some BIOS this is the only way it’s possible, others this is the only way it’s easy, some you cannot do even with programmer.

Thanks for posting all the necessary links and BIOS files etc. Please slow down now before you brick your system! FPT can brick in a hurry if used incorrectly, so wanted to warn you now, slow down and wait for help.

I will check your BIOS now and edit this post with more info shortly, specifically and initially on the 167 error since that is first obstacle.

"What you do is wait for help Please edit your posts when you want to add more info and no one has replied yet - thanks" - so sorry for that one

"FPT can brick in a hurry if used incorrectly, so wanted to warn you now, slow down and wait for help." - I was wondering about that, thanks

"I will check your BIOS now and edit this post with more info shortly, specifically and initially on the 167 error since that is first obstacle." - thanks for providing some of your time to help me

You’re welcome, I will try to help, but you may need programmer and SOIC8 test clip w/ cable.

See this guide for how to use grub and setp_var, you can start at step 6 since I’ve done 1-5 for you
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash
Alt boot to grub when no boot to EFI on exit page - [Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN (2) <<< This applies to you, you’ll need to use this method to get to grub

once at grub prompt you’ll disable these variables

BIOS Lock >> 0x17
Flash Protection Range Registers (FPRR >> 0x6D1

So at grub prompt type each of the following one line at a time (enter after each )
setup_var 0x17 0x0
setup_var 0x6D1 0x0

Both may fail, and you may need to use another tool instead - Please send me image output of any error messages from each command, in case it contains info I need.

This tool I’m sending you multiple versions, try each and if any give you the txt files rename them to filenameversion.txt so you know what they came from, so same can be used to write back once we’re ready/
If multiple give you the txt files, send me a copy of the ones from version that creates the largest files
http://s000.tinyupload.com/index.php?fil…932311127599521

From command prompt, at each versions folder location, run the following commands for each version
H2OUVE.exe -gv vars.txt
H2OUVE.exe -gs -all Setup.txt

Normally, this system does need to use programmer, as mentioned here, but maybe we can get around it (Possibly not, and in case you ever need it, order CH341A and SOIC8 test clip cable now, both are less than $7 total shipped on ebay)
https://www.bios-mods.com/forum/Thread-R…72G-BIOS-unlock

@Lost_N_BIOS But where do I get boot64.efi or Shell.efi?

Edit1: I made a freeDos bootable USB with rufus this could work?

Edit2: Nevermind I found the USB Bootable BIOS utility sry

Download the .efi file in the guide I linked, rename it as mentioned in the second link I said applied to you.
I do not prefer Rufus, or FreeDOS, sometimes it can cause issues. Here is my suggested method to make DOS Bootable USB - (Follow steps 1-4 to create bootable USB)
<Request> Flagship X470 Gaming 7 Wifi Motherboard BIOS Fix

@Lost_N_BIOS I think i am a little bit stupid because i can’t use that utility since i get the same error for multiple USBs (Annotation screenshot)

EDIT1: I did all the things by hand and I got this (GRUB screenshot) but I think that didn’t do it correctly I created a efi folder on the pen drive and i put the boot/boot64.efi inside from EFI-Setup-FPT-Universal-IFR-Extractor.zip and I also pasted the USB-Boot content to the USB root (DOS usb screenshot)

EDIT2: So i used the Tool http://s000.tinyupload.com/index.php?fil…932311127599521 and i got a big file from the H2OUVE_100.0.9.2 but not the others (archives include screenshots of cmd for all 3 of them)

EDIT3: I run the commands again setup_var 0x17 0x0 and setup_var 0x6D1 0x0 and the first one seemed to work (GRUB2 screenshot) but i have the same error when i try to write back my backup again

EDIT4: I found more versions of that tool here(https://gitgud.io/walkman8196/lnsider_Bl0S_TooIs/tree/master) could this help?

Annotation 2019-06-18 221045.png

DOS usb.png

GRUB.jpg

H20UVE_100.00.16.08.zip (23.9 KB)

H20UVE_x86_WIN_1.0.0.11-beta4.zip (49.4 KB)

H20VE_100.0.9.2.zip (67.5 KB)

GRUB2.jpg

I didn’t mention it but in bios I can’t change boot mode to anything else than UEFI is that a problem?

f16t4869p80962n2_qbgtWuUr.jpg

YOu have it all working properly! At least in your first “GRUB” image. Not sure what’s going on in your GRUB2 image, you are trying to set 0x17 again which you already changed previously?
So, you disabled BIOS lock, but can’t get FPRR disabled, nothing new here, I told you it’s a pain!

Not sure why your USB is write protected?? Maybe due to you are in UEFI Mode, not sure, I’ve never seen that exact in dead/dying USB/SSD when you can’t write to them.

Nothing new at the link you mentioned, all the same three versions I sent you to use. These are the only publically leaked versions that I’ve seen

So yes, 100.0.9.2 works for vars, hopefully that will be enough, or lead us to the correct GUID to edit the rest. Let’s confirm this is all, and maybe give you another way if UVE doesn’t work properly
Please do same thing for these apps as you did fir H20UVE, run each 32 and 64 command from each versions folder, keeping all files in same place. Once done, zip all back up in a single file for me.
None may work, it’s OK, just something to check in case it will work
http://s000.tinyupload.com/index.php?fil…603526132448404

I run all of them and only 2 gave me something :cry: but not much

EDIT1: In the GRUB2 screenshot i was checking if the values had change after a reboot :slight_smile:

EDIT2: So the H20EZE or H20SDE can’t run ? I have to only use H20UVE? (https://gitgud.io/walkman8196/lnsider_Bl0S_TooIs/tree/master)

EDIT3: I was supposed to run these commands:
H2OUVE.exe -gv vars.txt
H2OUVE.exe -gs -all Setup.txt
(With the H2OUVE.exe replaced by the filename)

OR the commands found in the “Command To Run.txt” ?

I have also done it with the following commands:
SCEWIN.exe -gv vars.txt
SCEWIN.exe -all Setup.txt
And
SCEWIN_64.exe -gv vars.txt
SCEWIN_64.exe -all Setup.txt

Because I wasn’t sure which one to use(the commands in txt file or these ones) :man_facepalming:

Here is the link:
http://s000.tinyupload.com/?file_id=07962245152342458225

SCEWIN-NoWr.zip (129 KB)

In grub, using setup_var, if you want to check a settings current value, only type the command and variable (no setting at end). Here’s an example to check value of variable for fake 0xQ2 setting >> setup_var 0xQ2
The other Intel Insyde programs are not for what you’re doing here, only UVE

For the last package I linked you too, SCE, the commands to run for 32 and 64 bit are inside in a text file.
This has nothing to do with UVE program, and this does not use anything like the commands you have written above, please check the text file included in the SCE package

I checked your SCEWIN attached package, and only two versions are in there, does that mean the other two didn’t produce output?
Ahh! Sorry, I remember these only work on AMI BIOS now anyway, sorry! Always trying to find all solutions before telling user programmer is the only way, but it may come to that.

Here is edited vars.txt. Please pay attention and do only and exactly as I mention here or you can brick your system
Take the varsM.txt file below and put it in your H20UVE 100.0.9.2 folder. Then run the following command from admin CMD Prompt to program back in

H2OUVE.exe -sv varsM.txt

http://s000.tinyupload.com/index.php?fil…365051492387080

Once done with that, do not reboot, dump the vars again using the following command and then compare varsm.txt and varsmcheck.text with hex editor, are they same or not (?)
If they are the same, fine, reboot. If you are not sure, or can’t check etc, do not reboot and send me that varsmcheck file and I will compare. This is to make sure what you wrote in was applied properly

H2OUVE.exe -gv varsmcheck.txt

If all looks correct and varsm.txt matches varsmcheck.txt exactly, then reboot and then come back to windows and try FPT flash of stock biosreg.bin back into BIOS again

so i have both
Edit1: I don’t think it worked but i am not sure

varsM.txt (195 KB)

varsmcheck.txt (195 KB)

@Kronos128 - please put those in a zip (Both in single zip), our forum software parses out text here and I don’t trust it to compare like we need to.

Ok here is it

EDIT: this line is different:
[021] Custom
GUID: 4570B7F1-ADE8-4943-8DC3-406472842384
Attributes: 0x7
DataSize: 0x6DA
Data:

And in fact many more as I see I could be wrong tho

H2OUVE.zip (64.1 KB)

Annotation 2019-06-19 210558.png

It’s rearranged now, but looks OK, the rearrange could be normal and expected since we edited.
The change I made is there in correct position too, so should be good to go and FPRR now disabled.

You are correct, change is at custom
GUID: 4570B7F1-ADE8-4943-8DC3-406472842384
Attributes: 0x7
DataSize: 0x6DA
Line - 000006D0: 00 01 01 00 00 00 00 00 01 00


Change to - 000006D0: 00 00 01 00 00 00 00 00 01 00

Should I do anything? … reboot? (Hope it will not brick)

Is it normal I see it blank in the varsmcheck?


RIP my internet modem crashed :joy:(using 4g now)

@Lost_N_BIOS there is something missing here

edit: sry for the second reply pc reconnected to the internet and send it :man_facepalming:

Annotation 2019-06-19 213227.png

Sorry, I don’t know what you mean >> blank in the varsmcheck

I checked your image, and don’t see what you are trying to compare there? I told you it was re-arranged. There is 8 x instances of “Custom” in each file

Please edit your posts when you want to add more info!


i know that but i could not delete it sry my phone and pc sent both a reply


So it’s fine i mean it works? can i reboot?

When you say re-arranged,what does it mean? They don’t need to be in the same place to work properly?


So now i do this? I need to flash the biosreg.bin from the beginning? It will not overwrite all the things we modify until now?


EDIT1: So the lines of varsM ([021] Custom) are at the end of varsMcheck ([068] Custom)? (Screenshot)

EDIT2: Thanks for merging my 2 replays from earlier :+1:

EDIT3:


Thanks for the tip

EDIT4: What is the text file vars? Is it the bios? If so what is the difference between this one and biosreg.bin?

Annotation 2019-06-19 214933.png