[REQUEST] Asus FX504GM Bios Unlock Hidden Options

I have tried unlocking options in bios to further investigate is there anything to be done with the 25W CPU powerlimit when both CPU and GPU are under load.
Underclocking the GPU with low VCore and low-ish Mhz seems to have some effect on this, going from hitting the power limit all the time to hitting the limit only 60% of the time played.
When the limit hits the CPU clocks start to vary anywhere from 2.3 base to 3.9 Boost and the FPS drops are terrible, plus the general decrease in FPS.

Thermals are not a problem, I have a big hole on the bottom of the laptop, a external fan setup with 2x 120mm fans and swapped liquid metal for both CPU and GPU.
Temps hover around high 50’s to mid 60’s when gaming, upper 70’s when hit with a synthetic load.

I tried to mod the bios myself using AMIBCP and AMIFlash using the /GAN variable. The changes wouldn’t take place.
Looking at other guides, I also tried the FTP method but got stuck at the start when trying to backup the bios, with error code 367: FPTW.exe cannot be run on the current platform.

I’m pretty familiar with computers in general but this is something I know nothing about so any help would be appreciated.

@Tubs - Well… if you tried unlocking already, then you have your answer about the power limits, as during unlock attempts you can see all the hidden settings.
Did you browse around settings and see if you could find what you are looking for? Yes, I see plenty at Advanced >> Thermal Config and all it’s submenus & at Power and Performance >> CPU Power management. And more at Advanced >> Platform Settings
So yes, once unlocked you should be able to get things set how you want them

What BIOS are you using, latest 308 - https://dlcdnets.asus.com/pub/ASUS/Gamin…X504GMAS308.zip ?

I’m pretty sure I can unlock it all for you What is your CPU?
Once you do below, and send me your dumped BIOS region, and I see what error you get when trying to write back the dump, then I can give you more info on what you need to do before you can FPT flash back your modified FPT dumped BIOS.
Don’t ever FPT Flash stock or modified stock BIOS! Just saying now, in case you jump ahead or someone reads later and jumps ahead

Please take images of your BIOS, you may be able to use F12 to screenshot to USB. I want to see one image of all main pages, like Main, Advanced, Boot, Save and Exit etc. Put those in a zip and upload for me

On FPT, you were possibly using wrong version? Here’s how to do that properly - Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error given >> FPTw.exe -bios -f biosreg.bin
^^ This is important step, don’t forget ^^

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required

@Lost_N_BIOS Yes I’m using the 308 bios. CPU model is i5-8300H and GPU is GTX 1060 3GB, if that matters. Here’s the stuff you wanted: https://we.tl/t-p0MePoliDC

@Tubs - Thanks, 167 error is a huge pain, it can be removed by editing a BIOS module, but you have to flash that module edited BIOS in with programmer (if it can be found). Or by AFU, which is not ideal if the only AFU method that works is old AFU that allows /GAN
Can you please try this method, with the BIOS below, as a quick test. Download the tools in this guide, just so you have this exact version of AFU. Basic idea here is flash stock BIOS first in windows, then without rebooting yet, flash the mod BIOS, then reboot.
If all goes well, then great, we use this method and then I’ll unlock your BIOS.

Here is method - https://linustechtips.com/main/topic/592…r-motherboards/
Here is mod BIOS test, changed one byte in BIOS region - http://s000.tinyupload.com/index.php?fil…564245132569222

If that method doesn’t work, it’s up to you, I can give you latest AFU that allows GAN and tell you best way to do that, or you can wait and get flash programmer, then dump and I edit and you program back (suggested, if above doesn’t work)

@Lost_N_BIOS Followed the guide, flashed stock bios first and after that the mod bios you provided. Both flashed without problems, after reboot nothing seems to have changed. How can I tell the difference from mod bios to stock? Bios version is unchanged in bios or CPU-Z. I may have a flash programmer on hand, ordered it to fix my friends old mobo with a socketed bios chip. Thought I doubt that a laptop would have a socketed chip, may have to shop on eBay. :slight_smile:

@Tubs - great, 167 hurdle bypassed! Yes, nothing should have changed in BIOS visibly, I changed a default setting of a hidden setting just as test to see if you could flash in mod BIOS or not.
No flash programmer needed here, unless something goes wrong But yes, if you were to use that on laptop you need SIOC8 test clip with cable too, since laptop BIOS would be soldered to board not in a socket.

Now that we know you can flash mod BIOS, I’ll proceed with the edits. I may have 1-2 test BIOS sets for you to test interim, then final unlock will come after that.
Will get first test set to you soon

@Lost_N_BIOS Amazing! I’ll be waiting :wink:

On next test, you will be able to see changes in BIOS so there wont be any question if it’s flashing or not.
Sorry, I should have edited something you could see, like microcode update or something, I didn’t think about that when I did the edit, but it’s OK we will confirm for sure on next set.
I assume it flashed OK, otherwise it would tell you no to edited BIOS (if you try that first, without flashing stock BIOS, then it will say no and wont let you flash)
Next test coming shortly, I will swap Exit menus and you’ll see new Save & Exit page

* Edit @Tubs - Please test both, let me know which of these BIOS you see new Save & Exit menu, or if you see it on both it’s OK too just let me know. Flash same way as before, stock BIOS first then without reboot flash one of these and check BIOS, then do same for next BIOS after done inspecting first
Also, if there is a bunch of submenus there now, don’t worry, this will not be final location or final way you will see/enter those, they’re just there by default (nested into exit by Asus, it’s a mess in there as you’ve seen in AMIBCP I’m sure )
If one shows the submenus inside exit as described above, and the other doesn’t, also let me know which that is too.

Man, that avatar gets me

@Lost_N_BIOS Tried both of 'em, neither showed me anything new. :frowning:

@Tubs - Certainly unexpected BIOS is setup wonky, hopefully I wont have to do it the hard way
Same files here, but instead of exits swapped at blocked locations, 0’d out so this may cause both Save & Exits to show up on both, but need to see outcome of this before deciding to not use this method and do it the hard way.
Well, one more possible way to do this, if these fail, before resorting to the hard way. Same as before, please test both, blah blah blah (as mentioned above

@Lost_N_BIOS Same as before, nothing new. :confused:

@Tubs - Hmmmmmmm!!! And Grrrrrrrrrrrrrrrrr OK, here is set of four, same stuff but with exit ID’s swapped at setup module too, test all let me know outcome. If these all same fail then I do it the hard way, that will take some time (few days probably)

I promise I know what I’m doing hahaha! No, usually it’s not hard to unlock BIOS, but sometimes you run into strange walls, odd BIOS construction by random engineers vs the usual methods used, gets tricky sometimes
The “Hard way” isn’t hard, it’s just far more tedious and involved, lots of info to gather in hex and breakdown into readable format of what’s what, then swap it around as needed.
It’s not hard to do that it just takes forever due to how it has to be done and that it’s not the usual way to do this, so due to that it takes even longer because it’s rare to have to do it.

As you can see here, and MANY other threads where I’ve unlocked BIOS, it’s usually just a simple test or two I need and then all unlock is next move / done.
I started helping on this thread below at same time as yours I think, and I’m done there already. Can’t win them all so easy I suppose
[REQUEST] [HELP] ASUS FX 503VM unlock both advanced tab in bios

@Lost_N_BIOS I’ll test them out. I’m sorry my machine is a tricky one :smiley: Fingers and toes crossed one of these works.

@Lost_N_BIOS Still nothing. Are we sure its flashing anything? https://i.imgur.com/b9nmEB3.png It sure looks like it, but since there is nothing changing its making me have a serious press x to doubt -moment. :confused:

@Tubs - yes, I was beginning to wonder if it was actually flashing, since no changes in so many different edits is very unexpected. Try adding /P before /GAN and try them all again (Sorry)
I didn’t notice that was missing in that guide, but it should be a given (/P = program main block), but I used to assume, and you would from the feedback it gives you, that all BIOS is programmed and it’s not because sometimes you have to add /N to update NVRAM or /B to update bootblock when microcodes are in certain regions and you update them.
So it doesn’t always update all as it appears to say it’s doing. If necessary, I can make you a BIOS with boot logo edited, or updated microcodes or something like that, then you can be sure it’s flashing it in.

Here, please test as you had been (Without other flags, just /GAN). After this, check with HWINFO current microcode version as shown in the image below, is it one of the updated versions shown on right of second image or still old as seen on left side?
This is no changes, your original biosreg.bin + updated microcodes only (dupe removed & FIT Fixed after done). If we find it does not change using command as given in the guide, then we know flags may be required
/B will put in microcodes and /P will program main BIOS region which should be default always so I can’t imagine this being required.




I will make you another with boot logo change, so you can test the BIOS region flash without /P and see if it changes logo or not, but I’ll have to do that later, will take me some time to find the logo since I have to locate it manually and it’s not defined or labelled.

Did you already order a flash programmer like CH341A + SOCI8 test clip with cable? If yes, maybe best we just stop and wait for it to arrive.

@Lost_N_BIOS CPU microcode changed from B4 to C6 with the ucode.bin test

Edit: When I try to flash for example AMITS.bin with /P /GAN it says error 18 after the flash as so https://i.imgur.com/6evZH9S.png

I can order the flash programmer stuff next week if necessary. :slight_smile:

Do you get same with /GAN /P instead? If microcode is changing, I assume rest of BIOS is flashing in too and it’s just all failed edits
Yes, I would order flash programmer anyway, in case you ever need, it’s too cheap and useful to not have this. However, it may not help, if I can’t find proper ways to edit this BIOS.

I’m almost positive the long hard way I mentioned will work, but you’ll have to give me some time to sort all that out here and start making some test BIOS for you again.
With that method I can’t make quick sets of BIOS for you to check, at least not at first, until I’ve got each section broken down into it’s elements and details.
I’ll start this tonight, maybe get at least one test to you with switched exits again so we can confirm that method works on this BIOS.

Trying to find where I edited similar style BIOS Mess I see I made same complaints here about this poorly constructed BIOS mess here when I was helping with a FX505DU

Seems there, I complained, but never got back to the user. I had to stop helping there, maybe around this time, unsure, but I couldn’t keep up with two places so I had to stop going there for a while until I have more time to help in both places
Still digging through all the BIOS I’ve modified, I know I’ve ran into this mess a few times and I’m sure I sorted it out before, I keep good notes while I edit too so I should have solution just have to find it. If not, long hard way it is

#Edit - looking at the modified BIOS above from Genius239, he edited that in same way I am here (the way I originally started going too), which should be working as I suspected.
So I think maybe BIOS region (at least the 2-3 modules inside there) are not being written in using AFU method, even in that thread they say you have to use programmer too.
I think it’s best here to wait until you have programmer so we can be sure it’s being fully written in, that way there is no doubt and time is not wasted doing multiple edits that may not even be necessary

@Lost_N_BIOS Yeah same result with /GAN /P. I ordered the flash programmer yesterday, should arrive before 18. of December. :smiley: Hope it gets here sooner. I’ll get in touch here when I have received everything. :slight_smile:

Guess we’ll wait and see then. I could do long way, but as I mentioned above, I think the way I started doing here is proper it’s just not flashing in, so programmer needed (per my last comments/findings above)

Yes, we’ll revisit once you get your programmer setup! Once you get that too, I can maybe do quick unlock for you, and you flash it in, then you’ll be able to to rest of mod flashing/testing etc from FPT and can put the system back together. If I can find and remove the FlockDN or FPRR/PRR lock @ error 167
We may need to save that until end, after menu done etc, because I think I looked before and saw a few possibilities but it’s not usual so may brick and you would need to test several BIOS for me to see if it bricks or removes the lock (ie I’m not sure on this one, since it’s not normal, but may be able to remove)

@Tubs @Lost_N_BIOS hey any news on the bios modding?
i have the exact same config repasted mine so good temps here.
can get my 8300h to run at 3.9ghz all time by undervolting the gpu to 700mhz.
currently trying to get my gpu to reasonable clocks instead of that miserable 1531mhz and seems like the only solution is modding the bios.
we can maybe co-operate to find a solution?
ps using 308 bios

@mohsen1essa Hello, still waiting for the flash chip programmer stuff to arrive. I’ve received 1 out of 2 packets so we’re getting close to be able to continue.

I would think that editing one bios here plus all the other threads this amazing human being is helping out is enough work already for our bios god @Lost_N_BIOS . Can’t speak for them though, maybe having 2 machines is helpful.

I’ve been running my GPU at 1296Mhz at 700mv for the best middleground CPU/GPU performance. Another profile I use in totally GPU bound games is 1680~Mhz at 825mv. But yeah no progress has been made since the last message.

In the future, this thread will hopefully have the key to solving our problems. Stay strong :slight_smile: