[REQUEST] Bios Flash for ROG ASUS Z390-I HPET mod

Hello,

I wish to unlock/modify BIOS/ PCH Configuration features for ASUS ROG Z390-I:
https://www.asus.com/Motherboards/ROG-ST…/HelpDesk_BIOS/

High Precision Timer
TCO Timer

I’m kind of new here and would greatly appreciate your help or either point me into the right direction.
Look forward to your feedback or reply’s.

Thanks

@jon0071337 - Can you already see >> Advanced >> PCH Config submenu?

Since this board does not have USB Flashback, we have to use FPT method, lets get started with below. Do not send me biosreg.bin yet, first we need to get past step #2, then you will make new biosreg.bin and send to me
Tell me what error you get at step #2

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required
> CLICK HERE TO DOWNLOAD CMD PROMPT REGISTRY ENTRY <

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

step #2

Error 167: Protected Range Registers are currently set by BIOS, preventing flash access.
Please contact the target system BIOS vendor for an option to disable
Protected Range Registers.

FPT Operation Failed.

I get same result when doing step #2 from DOS as well.
Thanks

@jon0071337 - Thanks, error is expected, DOS not needed Did you have secure boot disabled before you started? If not, redo again and disable it, also remove any BIOS password or TMP/Encyption etc.
167 can be a pain sometimes, but we can try to bypass. Are you using the latest BIOS now? If not, flash it in using EZ Flash, then follow guide below, start at step #6, I’ve done 1-5 for you
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Toss out, or set aside previous BIOSreg.bin file, so you don’t mix it up with new one you will make (or use new name, such as biosregnew.bin)
After you do this, you will redo step #1-2 with FPT, for this use a new BIOSreg name, once success at step #2, you send me that new bios region file.
I also need answer to my question at post #2 before I do any edits.

Rename .efi file to >> Shell.efi

Flash Protection Range Registers (FPRR) variable to ensure disabled >> 0x127B
BIOS Lock variable to disable >> 0xBBD
BIOS Guard variable to ensure disabled >> 0x7CD

So, at grub prompt, you will type the following, one line at a time, enter between each, case sensitive
setup_var 0x127B 0x00
setup_var 0xBBD 0x00
setup_var 0x7CD 0x00

Then reboot, and redo FPT step #1-2 using new BIOS region file name, if success at step #2, send me the new BIOS region file.



I did grub prompt: setup_var 0x127B 0x00 / setup_var 0xBBD 0x00 / setup_var 0x7CD 0x00 and then FPT step #1-2.

You have PM with biosregnew.bin and my email address.
Please reply back with PM/email if you need to send me back the modified file.

Referring to your question at post #2. Sorry but I do not see it, maybe typo mistake?

Thanks

@jon0071337 >> Question at post #2 >> Can you already see >> Advanced >> PCH Config submenu?




Yes. I have attached picture.
Thanks

IMG_20200621_161005.jpg

@jon0071337 - Here, I think I got it, but possibly not and TCO may still need another suppression edit.
Please test M1 first if HPET AND TCO does not show up, test M2, if then still no TCO let me know and I will make follow up edit.
* Link removed per request *

Flash via >> FPTw.exe -bios -f filename.bin

Both settings [HPET and TCO] show up in Advanced >> PCH Configuration and didn’t notice any real difference between these 2 new bins.

Now it shows all the hidden settings from Advanced >> PCH Configuration.
Can you make it only show only IOAPIC 24-119 Entries like original and add only HPET + TCO.
I also don’t care to much about TCO but HPET is the most i need so this will work for me as well.

Check attached pictures.
Thanks

IMG_20200621_193928.jpg

IMG_20200621_194536.jpg

IMG_20200621_194551.jpg

I got the files, can you please remove the link from tinyupload.
Don’t wanna get hardware ID banned from gaming services if someone out there were to use and exploit it.

Found this picture in another thread here. I want something like this or maybe only HPET.

ROG-HPET-TCO.png

@jon0071337 - So, what, unlocked more than requested is too much? You were only supposed to flash one BIOS there, unless first one didn’t work. So, did M1 work and show HPET and TCO, or only M2 showed both?
Yes, I can redo and make only TCO and HPET visible, once you answer above.

Also, you asked for TCO in your first post, now you don’t want it?? I can do both, no problem, just funny you said that after requesting this specifically
Please confirm HPET only, or HPET + TCO?

The pictures here shows bin2.

bin1 worked as well and showed up same exactly same stuff in Advanced >> PCH Configuration including HPET and TCO.

@jon0071337 Please see my edits above and answer TCO/HPET question.
Also, please confirm, in M1 BIOS I sent you, both TCO and HPET were visible? I did not look at images, far to large to download non-zipped just to look at BIOS settings



HPET + TCO

What I’ve meant if it’s to much hassle to do both I will be satisfied with only having HPET. xD

Thanks, but now missing confirmation of question at post #13 - Don’t worry, it’s no hassle to do both or only one, I just needed to know for sure what you wanted.

* Edit @jon0071337 - here you go, let me know if all OK now, and only HPET + TCO added, once you confirm you got the file I will remove the link
* Link removed per user request *

Thanks, I’ve got the file. :slight_smile:

Reimage and testing now.
----------------------

bin3 doesn’t work.

Problem is, when I try to go to PCH Configuration it gets stuck and CTRL + ALT + DEL is required to reboot.

@jon0071337 - Bummer! OK, I will redo other way instead Sorry about that!
* Edit @jon0071337 - here, if TCO does not show up in this one, I can’t make it visible without making all the rest visible like I did originally
DEAD LINK!

If neither show up, then your only option for either/both is first BIOS I made you (M1)

Sure, no problem.


I think the link provided is wrong/typo. >> File ID is not correct. File doesn’t exist.

@jon0071337 - Sorry about that, new link - *LINK removed per user request *

I got it and test it. Now I see TCO but not HPET.
I also see PCI Express Configuration >> PCIe Speed. I already have this option in System Agent Configuration>> PEG Port Configuration >> PCIEX16 Link Speed but its OK doesn’t really matter.

You can leave as it is but can HPET be added as well there?

[image attached]

IMG_20200621_220222.jpg