[REQUEST] BIOS version 1.90 for Qosmio X500/X505 (PQX34U) Unlock Advanced Settings

Exact name: Toshiba Qosmio X500/X505 (PQX34U)
Bios: InsydeH20 Rev 3.5
Link to Bios: Qosmio X500/X505 (2nd Generation i7 boards)

I’d like unlock the Advanced hidden menu and any other hidden menus and settings. However, there is an “Advanced” menu but does not
allow any real advanced settings. I upgraded the CPU to the i7 2960XM and the bios sees it fine. So it seems the Microcode is up to date. I would
like to unlock the bios too so I can upgrade the memory to post with 32GB 2x 16GB DDR3 1600 MHz PC3-12800 I purchased. The system will just power on,
stay a black screen and so it is crashing trying to post. I read on one forum thread setting the memory voltage and speed should get it to work with the memory
making it so the bios is not guessing the correct settings. Do this by putting your old memory in, set the memory settings, save settings, power off and switch to the new memory.
So, if possible unlock thermal settings for the Fans, unlock overclocking features for the CPU, Bus Clock, Memory and Graphics.

Also, remove any whitelists in the bios. This bios is non-UEFI and the SLIC is for Windows 7 not sure if it can be updated too.

As you can see there are no thermal controls for the fans or overclocking features in the “Advanced” menu in the attached images.

Thank you for any help!



@JoeCowboy System may not be compatible with the memory you mentioned, probably due to density, since if it was OK it would just downclock or run it at whatever speed/timings/voltages it allowed. Nothing anyone can do about that, this is common issue, especially with high density memory
We don’t do SLIC here, but I can check for whitelist if you give me the exact error you get when trying to use a device you think is whitelisted.

Need a proper link to your BIOS, above link does not work, even if I correct it to https://support.dynabook.com/support/vie…ntentId=3483125

Do you have flash programmer like CH341A and SOIC8 test clip w/ cable? If not, you need to order, not just for recovery but it may be the only way to flash in mod BIOS.

Finally, I hate Insyde BIOS, so may not be able to help unlock, but sometimes I can find proper location to edit

Thanks for getting back with me so quick. The link is for the bios update from Toshiba with Windows or DOS flasher but I extracted the bios from the update and attached it.
I do not have a programmer yet to dump the bios directly from the bios chip. I will try and order one today. I still would like advanced menu unlocked and any other features too
regardless of the memory not currently working if possible.

I know there is a great love hate relationship for InsydeH20 bios.

Thank you!

tz6_190.zip (1.46 MB)

@JoeCowboy - Please link me to the BIOS download from the manufacturer, or attach the full exe package, the link you posted in post one doesn’t work. This is required in case I need to modify something in the stock flashing tools so you can flash mod BIOS.
Some people can modify Insyde BIOS with their eyes shut, but that’s not me and I don’t think we have any modders like that here on this forum. Some Insyde I can figure out how to unlock though, but if not you may need to ask at BIOS-mods forum.

Hey! So now the link I posted in reply to you initially is working, the other day it wasn’t and would lead me to some homepage there. So no need to upload or link now, I’ve got the stock package!

Since this is Intel based system, lets see about doing this way first - Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error give >> FPTw.exe -bios -f biosreg.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)

* Edit - please attach me a zip of one image of each main section of your BIOS, so I can see which are currently visible to you - Never mind, I can see what I need from the images above and the BIOS itself.
You have all visible menus already, but one of the advanced is hidden. I can unlock this BIOS, but there is two possible edits to be made. Do you want to wait until you have programmer in hand, or do you have other systems you can use in case this one bricks due to wrong edit?
Go ahead with the FPT stuff above, because if we can flash that way it will be much easier than trying to flash using the Insydeflash tool because we’ll have to try mod with that, you’ll have to show me the error, then I try to mod around etc and it may not be possible in the end, especially if the board reboots to actually do the BIOS flash.

Thank you for the quick reply. I have other systems to use if the BIOS mod fails. I did order the programer. I look forward to testing your mods.

@JoeCowboy - OK, please send me your FPT BIOS region dump and I will edit for you. What error, if any, did you get when trying to flash it back?

Here is the flash back of biosreg.bin and I have attached a copy of the file.

Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007-2011, Intel Corporation. All rights reserved.

Platform: Intel(R) HM65 Express Chipset Revision: B2
Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
W25Q32FV ID:0xEF4016 Size: 4096KB (32768Kb)

PDR Region does not exist.
- Erasing Flash Block [0x400000] - 100% complete.
- Programming Flash [0x400000] 2560KB of 2560KB - 100% complete.
- Verifying Flash [0x400000] 2560KB of 2560KB - 100% complete.
RESULT: The data is identical.

FPT Operation Passed

biosreg.zip (1.01 MB)

@JoeCowboy - Great, thanks, so since it flashed back without error that means there’s nothing you need to unlock before you can flash in mod BIOS.
I’ll work on this tonight and get back to you soon. Almost forgot! What exact error (Exact wording) do you get when you use item that you need whitelist removed?

White list, nothing really I thought there might be a way to just remove all white lists if any for anybody else too that might need this mod.

Also, what other updates can we do far as chip sets in the bios to replace? Just wondering…

@JoeCowboy - Yes, I can bypass all, but I need to know exact wording of some error, so you have to have seen it on this model at least once/with something so I can find in BIOS.
I’ll see if I can find it, but looking for an error blind sometimes leads nowhere since I don’t know the terms used when a blocked device is connected
I looked for “remove” “Please remove” and Atheros since it’s commonly on the approved areas of whitelist (only found Atheros PXE boot agent), so no luck on that - I need to know exact error presented, so you’ll have to test something and see if it works or not.

What do you mean about chipsets? That’s nothing to do with BIOS. Do you mean like CPU microcodes, if yes I can update those too if you want (For CPUID 206A7 or 206A3 - 206A5/206A6 already up to date).

First goal though, is unlocking the full advanced menu, then I’ll need new images of all sections within it, so I can see if anything still hidden. Hopefully I can get it unlocked for you, then any hidden individual settings is no problem.
Here is three test files, one edit is first instance of menus bypassed, then second edit both, then third is last instance only. I’d say test “both.bin” first, then “last.bin”, then “first.bin” Stop and test no further once you see new contents in advanced (or a second advanced possibly)

Thank you for the quick reply. I just flashed the bios Both.bin like above using FPTw.exe -bios -f Both.bin

It passed when I flashed it.

The system does not boot you can hear the fans kick on. And the audio backlights just pulsate along with the hard drive light. It will stay on for a few minutes then shut off. No video too.

What now flash the BIOS chip when I get the programmer in the mail… I didn’t get to test the other two BIOS mods yet.

Or can I create an BIOS recovery USB thumb drive?

Just my luck for picking that one, I guess it should have been one of the singles No, once programmer arrives, you’ll dump BIOS contents and send to me and I’ll rebuild you a file to program back in to recover it.
Nothing you can do now but wait, don’t waste your time trying things, seriously, it will get you no where…

However, yes, you can try USB BIOS recovery I suppose, that may work if you can get it to invoke and there is a known BIOS recovery method for this system (use stock BIOS)

I played around with holding FN + ESC buttons plugged the power back in and pressed the power button. Then released the FN + ESC buttons everything light up normally and the power button light pulsated. So I will get me a thumb drive format it FAT32 and put the stock BIOS. One forum thread said use the use Phoenix tools to figure out filename to name the BIOS file to. One said extracted/dumped BIOS and searched for ".fd" in the extracted file. Case sensitive.

I can send you the stock .fd, sorry I assumed you already had this. (only mention of .FD or .fd in BIOS has this exact name too = BIOS.fd) Here - http://www.filedropper.com/bios_1
Some recovery methods work with brick BIOS, but from what I’ve seen, this is extremely slim chance (Due to cause of brick) even if you already know the exact recover method and had used it many times successfully on this system.

You were correct the file needed to be renamed to "BIOS.fd". You would probably laugh I created one small 1GB partition on a 125GB thumb drive formatted it FAT and put the file in the root. I did the FN + ESC buttons, ext… The power button sits there and flashes like I said before and then it rebooted after a couple of minutes. But the screen is still black like it is not fully posting. I will remove the CMOS battery and see if that might make a difference by wiping the settings.

I tried clearing the CMOS by removing the battery. It was a long shot but no go. Hopefully here in the next few days the programmer will arrive in the mail. I.will dump the contents of the BIOS.

Try small 128MB-2GB FAT32 formatted USB. There is probably some specific clear CMOS pads you can short, but you’d have to hunt that info down in google, if it’s even out there.

I looked in the platform.ini file like you said had BIOS.fd , AA, BB, intel.fv, ME.fd, 7.fd, 9.fd. but still no go. I am still waiting for the USB programmer to come in the mail.

Also, tried Andy’s tool. The pop up screen just give SLIC and key info. The log didn’t say anything either about what the recovery name is supposed to be. So I am at a loss on where to look in that tool for BIOS name.

That is the correct name already, but none of that matters if there is not a specific setup recovery method. Did you find some method outlined somewhere for this model or Toshiba in general?
Not all systems have a recover mode or method, and like I said the way BIOS bricked may not allow recovery anyway Best to not stress on this and just wait for programmer to arrive

Ok, finally got the programmer in the mail and dumped the contents of the Winbond 25Q32BVS. Which required me to disassemble the entire laptop because it’s on the bottom of the board. Oh well, fun, fun… Luckily I didn’t have to remove the heat pipes and fan to get to it. To test from here on out I will not be putting any screws back in but until it forced into submission. LOL

I have attached the BIOS dump.

DUMP_BIOS.zip (1.38 MB)