[REQUEST] BIOSMOD ASUS ROG STRIX H270F Gaming Support i3-8100 i3-9100F

Please help me to BIOS mod with ASUS ROG STRIX H270F Gaming MB for support i3-8100 i3-9100
Orginal BIOS:

p.s if modify is hardly, can only support i3 8100

@Jack07 - what originally included microcode do you not mind loosing (506E3, 506E8, 906E9)? Sorry, I can’t keep them all, and may need to loose two, so tell me your first pick OK to loose, and then a second in case I need to remove two

Notes to myself -
i3-8100 = B0 >> 906EB (SR3N5)
i3-9100 = B0/U0 >> 906EA (SRCZV)

I had i3-8100, but I had used 6E8ES CPU. Could you only remove 506E3 and add 906EB for i3 8100(B0).
Because i3 9100 need to cover-off the CPU pin which will be hardly to work.
Only replace the 506E3 to 906EB Thanks

P.S Also need to know flash bios will be use AUFDOS or FPTW program. Which is right way ?

@jACK07 - I will try to remove only 506E3. I could remove all and only add the new, but I assumed you’d want some older in there just in case too
I am adding 906EB and 906EA for the 9100 you mentioned. You can do the tape off on CPU pads, I did it on 9100F, with kapton tape, cut into tiny 1 pad wide strips, took me a while and sveral tried to get a few areas right, but it’s possible to do, keep at it, you will get it

What is your current ME FW version? This may be the hard part if you already have newer ME FW in there, or have you already used coffee on this board and just need different BIOS Now?

* EDIT - OK, I just tried without 506E3, still need more room Which of these can you also do without 506E8, 906E9?

Proper way to flash is via Flash Programmer, unless you already have ME FW or lower, otherwise you may not be able to get the proper ME FW in there.
FD ideally needs programmed in too, it may be required as well. This requires pinmod to unlock FD then dump with FPT, unlock it, program it back. Or program all with hardware flash programmer

You can flash by USB Flashback, but you wont get the ME/FD changes in there. FPT can be used for BIOS region, but only if you dump your current BIOS region and send to me first (otherwise you will loose all your board specific data)

AFU/AFUDOS should NEVER be used on this board, for any mod BIOS. Ideally I wouldn’t even flash stock BIOS with standard AFU either.
USB Flashback only, or EZ Flash (w/ stock BIOS), or FPT Dump then edit, the flash back (or hardware programmer, dump, edit, flash back)

I checked with my two H270F boards, there are ME with (MB2) and (MB3).
Both MB are first want to use i3-8100 or i3-9100F.
I am not sure this ME support or not, because they high than
If you need FPT dump BIOS or ME, Please let me know which I can dump and provide to you.

P.S Do you have i3-8100(U0) and i3-9100F picture with tape pin off for CPU pin which can also provide to me reference? Thanks
Could you provide me the BIOS file which can USB flashBack used, Because I have three MBs? if I have bios which can flash MB1 in the future.

You didn’t answer my question above >> Along with 506E3 removal, Which of these can you also do without 506E8, 906E9?

You need to check the actual in-BIOS ME FW, not what’s “In BIOS downloads” Did you check that?
If not, here’s how you check (sometimes shown on Main BIOS page), if not download HWINFO64
Then on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
If both are currently 11.8, then that’s an issue we’ll have to deal with

Yes, image is here for how to tape off your CPU’s, see section 3.2

USB Flashback will flash in the BIOS I send you, but it will not flash in the modified FD region or the downgraded ME FW.
For that you need to either do pinmod and unlock FD first, via E.1 from this thread and also covered at 5.3 in above link, or purchase a flash programmer like CH341A and SOIC8 test clip with cable

For B0 step CPU (i3-8100) you may only need to have correct ME FW version and do the “Connect 2 CPU pads” SKTOCC mod (no need to tape off CPU) + Mod BIOS region.
Reflash of modified FD region may not be required for B0, but I am not 100% certain
@chinobino Is all of the above correct for i3-8100 B0 CPU? ^^

Downgrade of ME FW is “sometimes” possible with other BIOS edit or grub/setup_Var edit, for this, we will look into this and see if we can get it done for you after you confirm your current in-board/BIOS ME FW in there now

Yes that is correct for B0.

@chinobino - thanks, I thought so. What about my comment on the FD region, is FD re-write required for B0 or not?

I found some program can downgrade ME to 11.7.xx and I plan use B0 step i3-8100 to this MB. So MCode will store 6E8, 6E9 and 6EB
(P.S reserved 6E8, Because I have 7th ES CPU will use it). I already done something which study from this forum. attached is the BIOS
for your help.
1. update ME 11.7x
2. update GOP to 1080
3. update MCode to 6E8, 6E9 and 6EB
P.S I didn’t know how to SKU

@Jack07 - Stop now before you mess up the ME FW, or flash in a broken FIT BIOS. What program are you talking about flashing ME FW with? I assume it will fail, or corrupt ME FW most likely.

So, I can remove 506E3 + 506E8? If yes, OK, thanks. If not, your request and latest post is confusing I already had full BIOS mod done for you, just waiting to sort the microcode space issue so I can do that and then fix FIT
1. 906E9, 906EA, 906EB is OK?
2. 506E8, 906EA, 906EB is OK?
Or, please confirm in full CPUID format which 3x microcode you want in BIOS.

If you have to do SKU mod, then you have to write to FD, which you cannot without pinmod or flash programmer.
This is why I am waiting on chinobino to confirm if FD write is required for B0 or not.

option 2 is better, Thanks
P.S I found Coffee_Lake_Mod_Tool in this forum

@Jack07 - You didn’t answer my question about ME FW

I am using CoffeeTime - [GUIDE] Coffee Lake CPUs on Skylake and Kaby Lake motherboards (66)
+ After that, MMTool 5.02.0025 to redo the microcodes
+ After that using UEFITool 55 and 25 + Hex editor to fix FIT table and unlock FD

Here is Option #2 BIOS in capsule (.CAP) for USB Flashback (ONLY) + extracted BIOS body in .bin format for programmer (As well as separate ME.bin and FD.BIN for FPT usage)
Don’t program full BIOS with FPT without editing in your info first or you will loose Serial, UUID, and LAN MAC ID in two locations (Not just what FD44Editor replaces, it only fixes one location)
Flashback usually will only flash the BIOS region, but with this you safely get BIOS region flashed and leave all your board specific info in place (Serial, UUID, LAN MAC ID etc)<br />Pinmod + FPT will be needed to do the ME FW & FD region (if it’s required). Or flash programmer.


However, I just remembered, you may be able to downgrade ME FW via FPT if you enable the ME Re-Flash option via grub with setup_var
Here is guide on how to use grub/setup_var, file attached at end of guide. You can start at step #6, I’ve gathered the info you need below
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Rename .efi file to >> Shell.efi
Me FW Image Re-Flash variable to edit >> 0x6C7

So, at grub prompt, you will type in the following (case sensitive)
setup_var 0x6C7 0x0

Then reboot to windows, and with the ME.bin file I included above, put that in folder with FPT and from Admin CMD Prompt run >> FPTw.exe -me -f me.bin

The download file include FD.BIN file. May I know I need use below command to flash to my BIOS, right?
When ME flashed completed.
FPT -pdr -f FD.bin

@Lost_N_BIOS All Coffee Lake CPU’s require ME 11.6.x/ on 100/200 series chipsets - so yeah need to unlock FD/ME regions to downgrade it.

I do follow steps for ME downgrade. But get a error. Do you have any idea on this
Error 329: Region does not exist.

1. format FAT32 with usb and copy bootx64.efi to /efi/boot dir in usb
2. enter to the BIOS, then Launch EFI SHELL
3. setup_var 0x6C7 0x0
4. CTRL-ALT-DEL restart PC, and enter to BIOS for ME Operation → Temp Disable
5. CTRL-ALT-DEL restart PC to Windows
6. use FPTW64 -me -f me.bin
PS C:\temp\fpt\win64> ./fptw64 -me -f me.bin

Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007 - 2016, Intel Corporation. All rights reserved.

Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
W25Q128FV ID:0xEF4018 Size: 16384KB (131072Kb)

PDR Region does not exist.

RESULT: The data is identical.

FPT Operation Successful.

7. fptw64 -pdr -f fd.bin
PS C:\temp\fpt\win64> .\fptw64 -pdr -f fd.bin (edited by 2020011, wrong command, right one should be ftpw64 -desc -f fd.bin)
Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007 - 2016, Intel Corporation. All rights reserved.

Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
W25Q128FV ID:0xEF4018 Size: 16384KB (131072Kb)

PDR Region does not exist.

Error 329: Region does not exist.

8. Restart PC, Enter to BIOS to see ME firmware version is

Try using command prompt instead of Powershell.

Also, can you post your ‘meinfowin64 -verbose’ output after changing the variable for ‘Me FW Image Re-Flash’?

@chinobino - Thanks, but I am asking if for B0 CPU, does he need to write to FD region (not to unlock, but to add in any possible SKU Change made during ME FW mod edits)?

@Jack07 - Yes!! ^^ always use CMD Prompt (AS ADMIN ONLY) for FPT, never powershell

If you are on Win10 - here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required

If you are on Win7, right click the folder which contains the EXE, hold shift and press right click, choose open CMD as here and it will be Admin CMD

As mentioned, you cannot write FD without either pinmod first or flash programmer. Correct command to write FD with FPT, after you’ve done Pinmod is as follows
FPTw.exe -desc -f fd.bin

Further FPT info, you cannot use ./ in command line strings and you cannot use PowerShell. Use Admin CMD directly from folder only, with file location just as I mentioned above (example below for ME)
FPTw.exe -me -f me.bin

Step #4 you mentioned is not used here, what do you even mean enter BIOS for ME Temp disable??
You are setting it hard disabled via grub, or it may only stick one reboot (I can’t remember), but either way you do not enter BIOS, reboot to OS or DOS and do FPT right after step #3

You have now corrupted your ME FW, so you must do pinmod and unlock FD, flash FPT from DOS may not be an option with corrupted ME FW (I can’t remember), or get flash programmer.
If you had followed my directions as outlined, this would not have happened Powershell was never mentioned, only Admin CMD (also, since users like to deviate from what I mention, I also didn’t mention FPTwx64 so don’t use it either - advanced mention )

Please boot back to grub and see if Me FW Image Re-Flash variable remains set to 0x0, if yes, then great! Check by doing >> setup_var 0x6C7 << and it will tell you current variable status
If it’s not 0x0 but is 0x1 again, then do it again, as mentioned above

step 4 # Because if ME Operation desn’t setup temp disable When you use FPTW -me -f me.bin will got error in Windows mode.

Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007 - 2016, Intel Corporation. All rights reserved.

Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
W25Q128FV ID:0xEF4018 Size: 16384KB (131072Kb)

PDR Region does not exist.
Unable to detect ME disabled.

P.S Currently My BIOS show up ME is, but MEinfoWin64 has a error
I am not sure is ok or not, My CPU is i5-7400ES CPU

C:\TEMP\FPT\MEInfo64>MeinfoWin64.exe -Verbose
Intel (R) MEInfo Version:
Copyright (C) 2005 - 2018, Intel Corporation. All rights reserved.

LPC Device Id: A2C4.
Platform: Intel(R) Kaby Lake Chipset

Error 63: Unknown or unsupported hardware platform. HW: Intel(R) Kaby Lake Chipset. Supported HW: Cannonlake Platform.

When use BIOS ez-flash 3 and try to flash H270PG.CAP file get the below error
Selected file is not a proper BIOS!

Could you tell me the detail of the step for flash the bios ? Thanks

@Lost_N_BIOS From overclockers.ru;

And in Coffeetime v0.85 it says;

According to this post from svarmod about the way the different versions of Coffeetime apply the SKU mod, Coffeetime v0.83 (and later) uses the hack method - which still requires writing to FD but again only for U0/P0.

So it seems you don’t need to do the SKU change for B0 only ME FW.

@Jack07 - Sorry, yes, I forgot, you need to FPT from DOS! Please redo, in DOS

EZ Flash is not used for anything here, ever

I told you best and easiest way to do this is with flash programmer, or you do pinmod and dump FD, edit it (which I’ve send you unlocked and Coffee edited already), then program it back.

Everything else will be difficult or impossible for you without doing one of those ways. Once you get ME FW downgraded your problems will be over, focus on that only for now.

Once you get ME FW downgraded, then you only need to USB Flashback the .CAP BIOS I sent you (Don’t do this first!)

@chinobino - yes, thanks, I’ve read that, and it was not very clear (Since I’m generally not concerned about FD for region unlocking purposes) but I think you clarified it for me now, thanks