[REQUEST] BIOSMOD ASUS ROG STRIX H270F Gaming Support i3-8100 i3-9100F

@chinobino Thanks for your advice
I try to find the Intel ME Tool v11 again which not from github.
run MeinfoWin64 -verbose again. The attached file is it.

@Lost_N_BIOS Thanks for your help. BIOS file is MCode is 906E9, 906EA, 906EB (Option1)
which is not Option2, but it is work for me with i3-8100(B0) of ASUS H270F MB.

P.S 1. by the way, If ME can unlock with efi shell(setup_var 0x6C7).
Is it possible, can use efi shell(setup_var something) for unlock FD?
Because pinmod is difficult to short the pin.
2. I used AMISetup_IFR.bat to check found 0x8E5 offset is BIOS Lock.
I am not sure is right or wrong.

ME11info.txt (11.7 KB)

@Jack07 - Sorry about that, I sent you wrong option package because I had the files labelled opposite than post #10
Here is proper Option #2 package w/ 506E8, 906EA, 906EB - http://s000.tinyupload.com/index.php?fil…410967107019646

You can get latest ME 11 tools from here in section C.2 - Intel Management Engine: Drivers, Firmware & System Tools

No, FD can only be unlocked by pinmod or flash programmer, but for B0 CPU, you do not need to write to FD region so you are OK on this unless you can’t get ME re-written, then you would need to unlock FD so you can do that.
BIOS lock not related to FD/ME stuff

From your MEINFO report >> Local FWUpdate = Enabled
So you should be able to flash in ME now, however, I think now after seeing this (Host Write Access to ME = Disabled), that option we changed only allows ME FW reflash via ME FW update tool, which wont downgrade ME FW in this instance
So you will need to do pinmod or get flash programmer, if flashing in the above CAP file via USB Flashback does not downgrade the ME FW


sorry for hijacking this topic, but I have the same motherboard as the topic author and kindly asking for a help with a way, how to run i3-9100F there (SRF7W - B0 stepping).

My ME version is, so I’m curious if there’s a way, how to get the modified BIOS to the board without using flash programmer (I have one, but SOIC8 clip won’t fit in there as there’s too little space around BIOS chip) and while FD is still locked (sound chip is shielded, so pinmod won’t be an easy one).

Can FPT help me to dump the original BIOS to backup board specific data (SN, UUID, etc.) or is even CoffeeTime tool able to grab that info from running system? (option 3 - Setup MAC-address and personal data) I’m quite worried, that as long as FD is locked, I’m won’t be able to dump original BIOS.

Lastly, I’m curious about the CoffeeTime vs ModTool difference (both tools can be used for modifying the BIOS, but I’m not getting the exact difference between them) and why are you using some extra tools mentioned in this topic (MMTool, UEFITool, HEX editor) - does this mean, that CoffeeTime or ModTool are missing something, which is needed to be fixed manually?

Thank you very much for your time in advance.


in the end, I was able to successfully run i3-9100F on mentioned motherboard and would like to share steps taken by me for future reference / other users.

As I wrote in my previous post, my ME (Intel Management Engine) version was, so no ME downgrade was necessary (this will help a lot).

* If the ME is newer than, downgrade is necessary. To do so, there are (AFAIK) only 2 possible options - flash via hardware programmer (eg. CH341A … the problem is, that SOIC8 clip probably won’t fit the BIOS chip as JSPI1 header is right next the BIOS and header pins are getting in the way of the clip … I’ve tried at least 50 times but was able only to bend JSPI1 pins) or through FTP, but FD (Flash Descriptor) needs to be unlocked first (good luck with that as sound chip is shielded) - [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing
* Not sure if the GRUB option will be working for ME downgrade as well … didn’t tried it, but it’s probably worth to check if you really need to downgrade ME.

As ME was fortunately no issue for me, I’ve focused on preserving board specific data (SN, UUID, MAC). To answer my previous question - CoffeTime tool is able to grab MAC address from running system, but I didn’t found option to grab SN and UUID. There’s an option to restore such data from BIOS backup, so I went in that way.

As the FD was still locked, I wasn’t able to perform complete dump of BIOS incl. ME and other regions (I’ve used FPTW64.exe from W10 64bit) with following command (command line runned as local administrator) : ftpw64.exe -d BIOS_Backup.bin
On the other hand I was interested in BIOS region only (due to board specific data), so this command did the trick : ftpw64.exe -bios -d BIOS_Backup.bin; my backup was 13 824kb big.

Don’t bother to try modify this backup via CofeeTime or Coffee_Lake_Mod_Tool, those tools are expecting to get the “full package” (BIOS incl. ME region, etc.). Anyway, I’ve used FD44Editor to open up my BIOS backup and was able to extract board specific data.

At this moment I needed to insert my board specific data to modified BIOS file and flash it back to board. I’ve used BIOS prepared by @Lost_N_BIOS in this thread, but as both BIOS files in this topic are “full package”, I needed to extract BIOS region only. To do so, I’ve used UEFITool, opened up the H270PG.CAP file (option2.bin file will work as well), found “BIOS region”, right click it, selected “Exctract as is” and saved to the disk.

Now it’s time to open up this exctracted BIOS by FD44Editor and fill up all board specific data obtained from original BIOS backup (you should see, that ME version and GbE version are stated as “not present”. Once done, save it.

Alright, so now we have prepared BIOS (without ME) with board specific date, so all we need to do is to flash it back to the board.
To do so, you need remove BIOS lock first - follow this guide : [GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash
Long story short - in the end, I’ve done this : Downloaded EFI-Setup-FPT-Universal-IFR-Extractor.zip (attached in first post in the guide), unpacked, went to \efi Setup\boot folder, copied bootx64.efi to flash drive and renamed to Shell.efi (it has to be in root of USB drive). Rebooted the computer, went to BIOS and launched EFI shell from USB drive. I’ve typed in “setup_var 0x8A6 0x00” (without quotes) and then “reboot” (again without quotes)…the command (VarOffset to be exact) can be different on newer BIOS builds (as mentioned in the guide), but this was working just fine for me (BIOS version 0308). So if you won’t be able to flash BIOS region back (in next step) due to active lock, you need figure out the correct VarOffset (0x8A6) by yourself.

As the BIOS lock was now removed (based on my experience it last only for one reboot), I went back to Windows 10 and finally flashed the BIOS to the board with following command : ftpw64.exe -bios -f BIOS_Backup.bin (it took approx. 1 minute). Once this was done, I’ve powered off the computer and changed the CPU.

I have i3-9100F B0 stepping (SRF7W), so absolutely no CPU modification was needed - just put the CPU to the socket and power up the computer. First boot will take a while, so don’t panic if your screen will be blank for longer time than usual … approx. after 15-20 seconds, the system started with message, that BIOS update is in progress and by 2 automatic reboots later it was done.

Proof of concept (BIOS screens) attached.

Basically all necessary information can be found in this forum, but it can be quite time consuming to get all the pieces together, that’s why I’ve described all my steps in one post.

Btw - it’s possible to import modified BIOS region back to “full package” BIOS (bin or cap file) file provided by @Lost_N_BIOS via UEFITool and such file can be adjusted by CofeeTime or Coffee_Lake_Mod_Tool again - I did it just to triplecheck, that I didn’t corrupted BIOS region during my editing.

Once again, thanks a lot @Lost_N_BIOS for the modified BIOS files, it helped me a lot (I’ve tried to modify CPU microcodes via MMTool as I was using Celeron G3900 - microcode 506E3, but I was getting ERROR 4001: FV size is too small the required FV image size exceeds the set FV image size; no matter how many microcodes I’ve updated / deleted…so I’ve used your files instead and just believed, it will work on the first try )