[REQUEST] [HELP] ASUS FX 503VM unlock both advanced tab in bios

Hi all,I have managed to mod and successfuly flash the modded bios through FTPW .However even after changing the access to user one of the advanced tab wont show up ,only the default advanced tab shows up.IT seems there is nothing I can do inside AMIBCP further.So someone please help to unlock both of the advanced tabs.

I have attached my bios dump which I took through FTPW.

stock.zip (4.3 MB)

Is the attached dump your original FPT dump BEFORE you attempted to modify anything? If yes, OK, thanks. If not, please attach your original FPT dump instead.

Thanks for the quick reply

Instead of uploading the stock bios ,I have uploaded the modded one .So now I have flashed the stock bios through asus ez method and then made a dump through FTPW.

PLease find the stock bios dump in the attachment

biosreg.zip (4.29 MB)

I want stock BIOS FPT dump. You’ve above post contradicts itself, please clarify
This, contradicts itself, and now I don’t know what BIOS is what >> Instead of uploading the stock bios ,I have uploaded the modded one .So now I have flashed the stock bios through asus ez method and then made a dump through FTPW.

I need you to flash stock BIOS via EZ Flash as mentioned, and then make new FPT Dump.
If you had to unlock BIOS or SMI lock last time before you could FPT Flash your mod BIOS, do that this time too, before you make the new FPT Dump, that way it will be already disabled in the base BIOS I use and you will be all set to flash new mod BIOS again.

TO avoid confusion ,Once again I am attaching the pure bios FPT dump ( without any mods) with this message .

biosreg.zip (4.29 MB)

@kiranfdo - Thanks! Once I am done, anything still missing you will be able to make visible by AMIBCP edit >> Access Level >> Supervisor
Please send me archived package of one image of each main BIOS page/section (like main, advanced, boot, exit etc) You can probably screenshot to USB via F12
Sorry, I should have asked for those earlier!

bios pages attachment

bios.zip (3.5 MB)

Quick test needed, which of these BIOS do you have new “Save & Exit”, only one or both? If only one BIOS has new, which one? If both = No Save & Exit now, it’s OK, valid test result. This BIOS is a little tricky


Both bios has the new save and exit tab and both do not have the old save and exit tab.

yes the bios seems to be tricky because previously during modding , I was searching for the so called"magic string",but I could not find inside the setup image.

Great, thanks for quick test and report back. I may not need you to test anything else, for now at least, maybe later if something else missing still once full unlock is done.
But I think if anything missing after I do that you can just change access level to super, unless something suppressed in setup, then you or I would have to unsuppress it, but that’s not used too much

Magic string mainly used in old BIOS, Aptio IV usually, rare to see it on Aptio V but sometimes it’s used. This mod done on AMITSE Module, is main target.
I thought it was tricky because usually there is a short list of two byte ID’s for all menus either block or allow, but no short list like that here so I thought maybe I missed it, that was why I wanted quick test before doing anything else.

I’ll show show you how to do and give you my notes once I’m done, so you can learn how to do it for this system and be ready for next BIOS update

Glad to hear that everything is going on track.Fingers crossed for the update ,and eagerly waiting for the mod guide .
Thanks man.

@kiranfdo - Next quick test, then I will do rest of unlock. Please check Advanced page, do you see new settings Power Off Energy Saving + ASUS USB Charger+ in battery mode
Let me know if you see that in only one of these, or both, and if only one which one.
1. SDO
2. SDSet

I can see both settings in both bios

@kiranfdo - Thanks for testing and being patient Here is full unlocked BIOS, let me know if anything still missing inside visible menus compared to what you see in AMIBCP (or you can further edit to enable, just change missing item access level to Super)
If any “Submenu” missing inside a menu you can see, all you need to do is change access level to super at the root folder where that sub is referenced, you don’t need to change all access levels within it for each setting. If you don’t get what I mean there, let me know, I will show you image example.

New menus should be >> Main x2, Advanced x2 , Boot x2 + Chipset + New Save & Exit only. Please confirm that is all correct after you flash, or send me an image for later reference, thanks

In this package I include my notes, and the before/after files, in order to understand how to use what’s in my notes, please see the “Advanced” section of this guide, at the bottom in spoiler, that gives general explanation on how to do these AMITSE menu edits.
That method outlined in the guide does not directly apply to your BIOS, as your BIOS it’s a little different (Less involved), but you will see the general how-to once you read that guide and see my notes before/after edit info.
OverPowered TONGFANG CyberPower Machrevo MACHENIKE - Unlocked BIOS Guide W/ Files

Thanks a lot the every tab is visible ,the only problem is lack of manual fan control.The active trip 0 and trip 1 setting inside the bios doesnt work and none of the fan control softwares detect my fan rpm .So do you is there anyway I can get manual fan control?The laptop cpu heats upto 95 degree only then the fans ramp upto full speed.

Great to hear it, thanks for quick report back! On the fans, you have to enable or disable one of those overall thermal control things before the trip points work (either DPTF or the other one, you can only use one type at a time). Probably one you are adjusting isn’t the one enabled, or you tried to enable both methods.
I checked, default one enabled is the ones at Thermal >> Platform Config. However, in DPTF >> Policy Config There is policy set for both active and passive, you may need to disable.
But all this is guesses based on looking at settings and the help comments/info, I’ve never used any of that, only helped others to adjust/use when asked - and yes, it’s often tricky, but you will figure it out.

Is your ME FW working, do you see ME FW version in Main BIOS page or with HWINFO64, or does it show N/A or If NA or then ME FW is messed up, and that needs fixed, this can cause fan detection errors. Did the fan speeds show before?

No, there is no type of fan control in these kind of BIOS, only those trip points. It should kick in way before 95C!! Something wrong with settings probably. Did it do that on stock BIOS settings too, or only after you tried adjusting stuff? Did you load optimal defaults first?
95C is the passive trip point, but all the others there should be kicking in before that. As simple test, you could enable Automatic Thermal Reporting, that would automatically adjust things (ignoring all those other settings).
If that works, then disable again, and adjust settings more until you figure it out, but always start by first loading optimal (restore defaults) from the save and exit page

I have disabled DPTF AND automatic thermal reporting then I tried changing the trip points and fan rpm ,it dint worked.Further I tried with automatic thermal reporting enabled and then the fan kicks in at 85,irrespective of the trip point settings.For the last method I disabled Automating thermal reporting and enabled DPTF.Inside the DPTF I have lowered the active trip point and no luck .

SO if both DPTF and automatic thermal reporting are disabled , the fan kicks at 95 (irrespective of trip points and fan speed settings)
If DPTF or automatic thermal reporting are enabled the fan kicks in around 85-90 (irrespective of active trip points)
The stock bios behaves the same ,because in stock bios both of this settings were disabled so the fan kicks in at 95. No issues with the ME version ,it shows up in the bios.The fan speed dint showed up in the applications but inside the bios it shows up(stock bios also had the same issue).

It may be controlled by EC FW, but I have my doubts on that since by default DPTF was disabled and the other method was enabled. I’d imagine both of those would be disabled if it was EC controlled only.
So, even at stock BIOS, before you use any mod BIOS, the fans weren’t working properly and only turn on at 95C? If yes, something is wrong, you maybe should ask Asus about that in a direct email, especially if you are under warranty.
Put new thermal paste on the CPU and GPU, this may be the real issue, maybe fans runs but aren’t loud enough for you to hear until it gets super hot and then they go 100%

The help you need setting and understanding these things is not something I know how to advise about.
Something like that you’d have best luck asking for help at notebookreview forum probably, I’d say ask in Asus forums too but they’d assume you have locked BIOS and it should all be working fine.

For your consideration ,both Automatic thermal reporting and DPTF were disabled in stock bios.So I think the fans are controlled by EC FW,If that is the case then is there anyway I could try to change those settings?

Ahh, yes, I see now, sorry I thought the one at CPU Thermal config was enabled, I checked and see as you mention both are disabled.
The CPU thermal config one (DTS SMM), the help files says this -
Disabled: ACPI thermal management uses EC reported temperature values.
Enabled: ACPI thermal management uses DTS SMM mechanism to obtain CPU temperature values. << Try setting enabled, EC may over-ride that, but worth trying.
Out of Spec: ACPI Thermal Management uses EC reported temperature values and DTS SMM is used to handle Out of Spec condition.

You may need to ask Asus why EC FW is only invoking fan at 95C no matter what you set in BIOS, could be a BIOS bug (it is to me), and maybe no one reported it yet. You said stock was same too, correct?
Was it always that way? If not, maybe you need EC re-flashed, it’s corrupt etc (only w/ Asus help, or flash programmer can you do that) I can probably get you an EC FW file if you have programmer (don’t have time to look back about this right now)

As far as changing EC, no, I don’t know of any tools that work with EC FW. It could be done via hex/assembly, but I wouldn’t even know where to begin looking at that since it’s not something we usually play with.