[Request] How to Access Locked/Hidden BIOS Menu Settings

For now, we can modify the 3.14 BIOS and you can reflash that, flashing BIOS only since EC would remain the same.
Can you please send some images of the current BIOS, what all menus (Main sections) do you see and what all sub-sections do you see in “Advanced” and “Chipset” if you can see chipset.

Inside the package you used to update ME FW, there should have been also a ME Info tools folder, if not please download from below
Go inside ME Info folder, hold shift and right click on Win32 folder, then choose open command window here and run this command and post image of entire output here >> Meinfowin.exe

Asking about this, not for ME concerns, but to check if Intel Boot Guard is enabled/in-use - if it is you can’t flash BIOS with modified BIOS
I don’t think it is based on the current included ME settings, but it’s something we have to check because this BIOS is a “Bootguard enabled” BIOS type

Ok, I can flash modded 03.14 for now.

I have attached the BIOS Menu screens and MEInfo dump here.

Thanks! Good news is no Intel BootGuard enabled!

I don’t see how you updated ME though due to below? Oh well, at least it’s working (I’ll put unlocked FD in case it gets programmed in to during flash, normally you can only put that in with programmer)
Host Read Access to ME: Disabled
Host Write Access to ME: Disabled

OK, for now, I have several different BIOS mods done for you, without any menu changes yet (Except settings I did change, as you asked).
All have unlocked FD + settings changes you asked for in post #5, but no menu adjustments yet due to you just sent me those images, and I’d like to see if any BIOS flash goes OK before doing further modifications.
For now, only #3 concerns me, not that it’s a bad mod, but that you can’t recover easily and there is some changes in this one due to one larger microcodes used in the updates (by 2kb, normal board this is no problem)

1. BIOS w/ only the changes you asked for (+ Unlocked FD)
2. BIOS w/ the changes you asked for + Microcode FIT Table corrected (This tells the BIOS where microcodes are located) (+ Unlocked FD)
3. BIOS with the changes you asked for + CPU Microcodes updated + FIT Table corrected again (+ Unlocked FD)

Do you want to test BIOS now, if yes, #2?

If flash goes OK, I will continue to work on BIOS, and get you more available settings in the BIOS to play with.

As I mentioned in Post #5, I updated the ME firmware through FWUpdate (using FWUpdLcl.exe -f NewME.bin from DOS). As I learnt from this thread, FWUpdate can be used to update ME Firmware even if Host Read/Write Access to ME is disabled.

Yes, I can test BIOS now. With the FIT table corrected in mod #2, will I have to reformat the Windows installation?

I always forget that, I guess it throws me off every time I see it, I mean why have a enable/disable setting if it’s ignored when disabled

No, new windows install is not necessary at all for BIOS updates. But, you will need to make sure you set SATA settings back to how the originally are now, after the BIOS flash and optimized defaults are loaded again.
Usually this means setting back to AHCI, if IDE is defaults and you are using AHCI now. Or if you are using RAID it’s even more important to set that back to RAID before trying to load windows again.

Here is BIOS #2, full change log and many images included, flash how you normally did for this 3.14 update. Make a copy of the original update folder with all contents, and replace those original files with the modified BIOS files.

I tried the modded BIOS. Apparently nothing has changed. HPET and Power Saving things are still present. Please see the attachment Folder here.

After the flash, it took some time for the display to come. And I got a message stating NVRAM Reset and something like that. I could not note the contents of that message. After that BIOS splash screen appeared. All this never happened when I previously flashed BIOS.

Throttlestop always shows that to me too with EIST/C1E, for years, even before it was techpowerup version (Same for the program before that, can’t remember what it was named then maybe I7 turbo).
As for the HPET in device manager you may have to disable HPET as linked here I posted for another user, especially since you already installed windows with it enabled it will always be like that I think unless you change one of these ways.
[HELP/REQUEST] Is it possible to disable HPET somehow? There is no BIOS option, yet AMIBCP shows a value for it in a hidden section

To verify the BIOS flashed, and the changes I made are used, you can check in the BIOS at the actual settings I changed as shown in the images included.
What do you see in the BIOS, after loading optimal defaults? At First C-State option (Should be disabled, which disabled all below), Speedstep, , EIST, and HPET setting, what’s the default applied setting?

Aside from those default setting changes, changing your splash screen logo, or flashing new BIOS version may be the only way you can check it really gets flashed (Sounds like it did though)

  1. There are no new options/setting exposed in the BIOS. The BIOS Menu looks exactly the same as previously. So, I cannot check or change anything from there.

    2. I have tested this in motherboards, which have HPET as an option in BIOS Menu, that even after Windows installation if HPET is disabled in BIOS, it stops appearing in Device Manager in Windows. As I continue to see HPET in Device Manager, I am confident that HPET is not disabled.

    3. I can’t say about the older versions of ThrottleStop, but in the recent versions, say if you disable Turbo Boost in BIOS, it would be either greyed out or not appear in ThrottleStop. You can check that with any desktop system. But still, I do not consider ThrottleStop as a reliable application. I will have to find a similar application to check the Power Saving settings from within Windows (which may be even more unreliable). In any case, the settings should have to be there in BIOS Menu first.

    4. During the flashing of BIOS, it did show message confirming successful flash. So, the new BIOS did get flashed.

    Can you make my requested settings appear in BIOS Menu? Maybe you can also check the modded BIOS of genius239 if he has done something differently.

One more point: as I described the condition right after BIOS flash where it took some time for the display to come and then a message appeared related to NVRAM reset. Could it be that some kind of system recovery triggered because of any problems with the modded BIOS and that recovery process restored the previous BIOS as it was previously?

I didn’t expose any new options, only adjusted the ones you asked me to for now. Please check them and let me know. Or, are you saying you couldn’t see those settings anyway?
If that is the case, then I understand, sorry I was confused there I thought maybe you could see them but couldn’t adjust, so I set default for what you asked.

If that HPET thing is true for your current system, then yes, BIOS was not flashed in.

What functions did you run to do the flash this time, so I can look at those batch files and see if it flashed all BIOS regions and didn’t skip any due to same version already there etc. If it skipped anything, it may not have showed you, and still looked like it updated BIOS when really didn’t update all sections.

Yes, as mentioned I can make stuff show up for you in menus, just hadn’t got that far yet because I wanted to test this first and make sure actual BIOS flash went OK without killing your system (remember safety first )

NVRAM reset is normal, sometimes, nothing to do with BIOS resetting itself like you are thinking.

I will work on enable menus for you now, please wait and new test file will be ready soon!

I found the problem possibly! In flash.bat, there is a missing switch /k in command below, this reflashes all non-critical blocks (Likely stuff we changed, since this normally doesn’t change thus non-critical)
AFUDOS.exe %BIOS.ROM% /p /b /n /r %1

Please edit flash.bat to add this switch in like you see below, on both lines and then reflash as you normally would.
AFUDOS.exe %BIOS.ROM% /p /b /n /k /r %1

*Edit - First do above test please, reflash and then check the same stuff in windows again and see if anything changes. If so, or not, after that here is another quick test, chipset menu enabled hopefully and 1-2 other settings maybe, look around and see if you note anything new.
And if chipset menu is present, please send images of all it contains. Also, flash this BIOS with the above changes still in batch file too, thanks!

Yes. As you can see in BIOS Menu Screens that I shared in Post #23, HPET and Power Saving settings are not even visible.

I agree with you.

Ok. Thanks for confirming.

Just tried that, it made no difference.

Tried this BIOS. Again no setting has changed. The only difference is that in the BIOS Menu, Chipset Page/Menu has been created. And it is completely blank: no settings available there.

Edit: I should also mention that with all these modded BIOS flashes, the NVRAM gets reset. I hope that is not a sign of any problem.

Yes, I checked images again after replying, I see all that’s there and not there now.

Great, chipset is there now, thank you. I only enabled the menu to see if it worked on your board or not, next will be involved process to enable stuff in there.
So, I also enabled one CPU function, I think CPU Configuration. Do you see that anywhere? It may need other menus enabled first, but I made that change to test another visibility method too.
Maybe in advanced section, I can’t remember. Do you see that one anywhere, or no?

So, from this we can gather, BIOS is updating, so all settings I changed from their previous defaults are now set as I changed them. Such as speedstep, EIST, C-States (HPET aside for now), you can confirm the others with CPU-z, does it downclock at idle now or stay at max freq?
If yes, do you have windows power plan set to high performance? If not, set that and min/max CPU set to max if option available.

Do you see proper microcode now, or still same one that we assumed was from windows?

I will work now on getting more settings visible to you, will take some time, but I can send you updates as I go so you can test. I’ll start with a few options in chipset, and make those initial settings I changed from default to be visible for you too so you can adjust yourself.

No, NVRAM reset is normal, like clearing CMOS, it’s a stored settings/info thing. If you want that to stop, you can remove the /n flag from the flash.bat file

Yes, it is visible in Advanced Menu. But the settings inside the CPU Configuration Menu do not work. Please see the attachment Folder here.

As per ThrottleStop, C1E is now disabled but SpeedStep is still enabled (if you delete the .ini file in ThrottleStop folder and restart the application after a system restart, it will tell you the correct state of the system).

Regarding the CPU clocks, I can see that they stay very close to the highest multiplier 44: oscillate between 43.xx to 44 continuously. But if I just talk about the clocks, I have been able to manage the clocks in this way even without having access to CPU Power Saving settings.

I can see settings exposed in CPU Configuration Menu in BIOS. But if I make any changes, like Disable Turbo Boost, it does not reflect in Windows. After disabling Turbo Boost in BIOS, CPU still hits 4.4GHz while it should only be hitting up to 4.0GHz without Turbo Boost.

It is the same as it was previously. The Microcode is 1Eh.


I have found that the BIOS splash screen, where you press F2 to enter the setup, has become somewhat unresponsive after the latest BIOS update. I need to click on F2 at very high frequency and continuously before I could access the BIOS Menu. Previously, a gentle press of F2, maybe one or two times, would land me in the Menu screen.

@akm Thanks for the new BIOS images! Yes, I didn’t intend for either of these new changes to be usable, I mean I didn’t go into enabling settings etc.
This was only meant as a test, one to see if this method to enable chipset worked (Make visible), and then CPU configuration was another method to make visible only.
For either to have functional entries takes 100’s of more edits I need to make, that is why it’s not done now, only meant as quick test for me to see which method or if both worked for enable visbility of items before enabling them.

Sorry, I see C1E is still enabled! I assumed disabling the “C-States” right above that, would disable all C-states below it, most boards function in this way, so I did not change the individual C1/C3 etc to disabled.

On the CPU config, further down into that page once your inside the menu, are all those enabled already or unselectable aside from C1E? Things like boot performance mode, turbo, EIST, C3 report etc?
Or are they effectively “greyed out” and not selectable?

Turbo I did not change at all, you said leave it as it was. F2 to enter BIOS, maybe reverse placebo effect . Press it once or twice and wait.
I always spam mine to enter BIOS too, even if I really only need to hit once, habit for me It may be slower now due to rebuilding NVRAM data, if this is the case once you stop updating and it gets many reboots under it’s belt then it should be back to normal.

I’ll work on BIOS menus for you now, please be patient it will take some time, but I will try to quickly do the few settings you initially asked about first and get a BIOS to you.

They are selectable.

That’s right. As the option to change it was available, I tried changing it but the change did not happen. No worries though as you have already told me that those settings are not functional yet.

Ok, got it.

Sure, thanks.

The Reseller has just provided me the missing EC2 file for 05.01 BIOS. Please see attached the EC2 update folder here.

So you can enable and disable all those in CPU Config?

Turbo mode is only usable if C1E is enabled, I think, some BIOS is different about that. That setting has not been touched by me, so enabled and useable by default from your BIOS correct?
Or, did this only just not become visible? If yes, only just now visible, it’s OK, you can play with it and see what happens. I think you’ll see if C-state and C1E disabled then you can’t enable turbo.
Since I disabled C-state itself and that did not have the desired effect of disabling them all, test by disable all of them, and then check turbo, then enable all and check turbo.
Check turbo means two things here, see if you can adjust in BIOS or not with all C-state enable/disabled, and see what happens in windows with CPU speeds.

Thanks for missing file. I will put in new version BIOS folder, and then later we can update you to all that latest version stuff if you want.

First, BIOS settings and menu options! Blank chipset

Yes. But looks like enabling/disabling doesn’t work properly (see below comment).

As per ThrottleStop, C1E is disabled but SpeedStep is enabled. SpeedStep does not seem to be available in CPU Configuration in BIOS Menu.

I tried disabling CPU C States, Enhanced C1 State, CPU C3 Report, CPU C6 Report etc. and then disabled Turbo Boost. When I checked in Windows, I found that the CPU multiplier was locked to 42 (with no oscillations at all). So, certainly CPU C states did get disabled. But Turbo Boost didn’t. Previously, the multiplier was oscillating near 44 when C states were not properly disabled. If I disable Turbo Boost using ThrottleStop, the multiplier does get locked to 40 (with no oscillations). So, for disabling Turbo Boost, I still have to use ThrottleStop. The BIOS option is either not working at all or not working properly.

Probably due to hidden EIST, but both should be disabled by default. Sometimes this is due to manufacturer issues though, I’ve had some boards/BIOS give me more CPU multi w. turbo than others, some less, some more than any with same CPU I’ve ever seen too.
Sometimes this is also due to ME or CPU microcode versions, it’s all very tough to nail down what’s what and how some of this power saving stuff should work by default for your board vs another vs what you expect from previous use on other boards vs other chipset/CPU series too.

On some chipset/CPU, for turbo to work C1E or C3 has to be enabled, others it does not. And sometimes with those enabled you can set higher than expected multi, or under load one core will hit higher than you expected or sometimes idle all will.
Anyway, your above test may be affected by hidden EIST, but it should be disabled (Both). Test with C1E enabled and turbo on/off and then C3 enabled and turbo on/off, then both C1E enabled/Disabled with turbo on./off.

Turbo is all manufacturer set, I have not touched that at all since you said leave as it was (enabled, and already visible, so I didn’t even have to change anything for that one). But like I mentioned, it is affected and or restricted by other settings.

Here is new quick test BIOS, let me know (send images) what all you see in chipset and at the bottom of advanced page, go into new menu and show me what’s all there too.
I think it will be at bottom of advanced page, but may be new entry at top you can go into. Flash like before, replace these files and run your two batch files

This one will have second EIST visible to you hopefully, it’s called Enhanced Intel Speedstep Technology (spelled out this time, instead of EIST). Should be located in advanced >> Performance Tuning >> CPU Configuration
And, for CPU configuration, you might have new settings on your original CPU Config page, the one not in performance tuning.

Could you please include the latest ME? This BIOS has older ME ( Did you start afresh this time with the stock BIOS?