[REQUEST] MSI Z370M BIOS problems with 128GB RAM

Hi guys, I am new here!

After a lookup for 128GB RAM support for Z370 I found this page:
Make 22nm PCH LGA1151 motherboard like Z370 compatible with 128GB RAM

And after that I went and ordered 128GB RAM to see if it will work with the latest MSI BIOS releases.

Motherboard: MSI Z370M GAMING PRO AC
RAM: Corsair Vengeance LPX 128 GB DDR4-2666 Quad-Kit CMK128GX4M4A2666C16
CPU: i7-8086K

I flashed the latest BIOS (7B44v18) from:
https://www.msi.com/Motherboard/support/…RO-AC#down-bios

And strange things started to happen afterwards:
1. Slow boot time, takes 0.5-1 minutes to show anything on the screen
2. First thing to appear is: "The ME FW of system was found abnormal it is recommend to re-flash system BIOS by M-Flash to ensure normal system operation."
3. When in BIOS, the selected language (top right) is English but text in most places is Chinese, when I select Chinese then most of the text is in English and some is in Chinese. Restarting sometimes fixes this but more often than not it is messed up like this.
4. Booting into Windows is slow, once booted, the 128GB RAM is visible and usable.
5. When Shutting down the computer, the screen goes off, although the PC still runs. This same inability to shut down or restart is happening when trying to use M-Flash to flash another BIOS. Restarting or going out of the BIOS only happens with a hard press of the power on-off button on the computer case.
6. Flashing back the older BIOS (7B44v11) does fix all the issues explained above, except that in BIOS 64GB RAM is seen as accessible, and in Windows it shows 128 GB (64.0 GB Usable)
7. BIOS 7B44v15 is the latest one I can use without the above issues but I still get 128 GB (64.0 GB Usable) in Windows.


I am not skilled at all to perform a BIOS Mod, as I fear bricking or damaging the system. It is over my head what you guys are doing here.


Is there anyone with an idea how this can be fixed? Will following the guide above, to Modify an earlier BIOS to support 128 GB work?

I am willing to and I will donate to the person who helps me get 128GB RAM working normally, if he does not want the donation I will donate to the forum.


Anyone with a clue please post something. Thanks in advance.



EDIT: When trying with BIOS 7B44v16 or 7B44v17 (not sure), right after the “The ME FW of system was found abnormal …” the screen shows the following message before booting to Windows: “Error sending End of Post message to ME: HECI disabled, proceeding with boot !”

Did you reflash that BIOS twice or not? Sometimes you need to flash it twice, or you need to be sure to select BIOS + ME when you update. Did you choose BIOS + ME? If not, do that now, just to be sure this isn’t the issue.
Sounds like the ME FW is messed up, or when you flashed to latest BIOS the ME FW didn’t get updated, or got corrupted.

Aside from ME FW corruption issue, I think BIOS already set/enabled for 128GB. But you need non-corrupted ME FW, and then we can set the HAP bit disabled to disable it properly.

Can you see ME FW version anywhere in BIOS info area? If not, check if you can see if ME FW / version is shown with HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Here is image example of how it should look, where to find in HWINFO64. If you see 0.0.0.0 or N/A anywhere, or in HWINFO64, you don’t see ME FW area, then ME FW is corrupted and we’ll have to fix that before we do rest of edits that may be needed.

HWINFOMEFW.png



Also, please do the following, so I can start seeing method we’ll have to use to fix your ME FW if BIOS reflash twice doesn’t do it (Use latest BIOS)

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Latest version BIOS has 11.8, so any older probably has 11.x too anyway, I assume whatever version is in there would be V11, so you probably need that package.
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -desc -d fd.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)
https://www.windowscentral.com/how-add-c…creators-update
https://www.windowscentral.com/add-open-…menu-windows-10
https://www.laptopmag.com/articles/open-…ator-privileges

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required
http://s000.tinyupload.com/index.php?fil…134606820377175

@Lost_N_BIOS Hello and thank you for joining in !

When I use the M-Flash tool, there is no mention of ME anywhere. It just says system will reboot to enter flash mode. Then when in this flash mode also there is nothing to select or choose, just point to the BIOS file and the update starts.

I did flash the latest BIOS (7B44v18) twice and the issue is still here.
I would agree with you that any of the BIOS versions 16, 17 and 18 support 128GB as I see all 128GB RAM in Windows with those versions. With v15 and earlier only 64GB is seen as Usable.

In BIOS (7B44v18) under Settings\System Status, under System Information, there is ME Version: N/A

In Windows, with HWiNFO64 v6.20 there are only two entries under Motherboard: ACPI Devices and SMBIOS DMI, there is no Intel ME.

Then, I downloaded:
Intel CSME System Tools v11 r28 - (2019-10-27): For 100/200/Z370/H310C/B365/X299/C400/C620-series systems which run CSME v11
And run the command as suggested.

The resulting fd.bin file is here:
http://s000.tinyupload.com/?file_id=78144150131904899219

Looking forward for further instructions.
Thank you !

@paul44 - Maybe it’s only shown if BIOS it set to update ME FW, which if same as current, or ME FW corrupted it may not show too, I’m not sure.

ME = N/A means your ME FW is corrupted, this is the cause of all the issues you mention, we need to fix that, and then all may be fine or we may stil need to disable ME FW via HAP Bit as outlined in the guide you linked.

FD is unlocked, very odd, but lucky for you!! Here is ME FW from the v18 BIOS, please be using that BIOS when you do this. Copy that file into the FPT/Win32 folder, and then run this command >> FPTw.exe -me -f me.bin
Then, before you reboot, close all apps, and run this command (it will auto-reboot, if not, it may be due to the messed up ME FW, see below in case it doesn’t) >> FPTw.exe -greset
http://s000.tinyupload.com/index.php?fil…950947349415829

If -greset doesn’t auto reboot, shut down, remove power cable from board (24 and 8 pin), then press and hold case power on button for 10-15 seconds.
Goal is to drain all power from board, then let sit for one full minute, then connect all power again and check ME FW in Windows again.

@Lost_N_BIOS

I did run the command >> FPTw.exe -me -f me.bin
And it appears it completed it. Please see attached image.
There is a yellow text: "Unable to Detect ME Disabled."

me.bin.png



Then I run the command >> FPTw.exe -greset and it did reboot on its own.

After that, when it booted to Windows, in HWiNFO64, under Motherboard there is still no Intel ME.
Going again to the BIOS and checking the System Status, ME Version still shows N/A.

Shall I do the command >> FPTw.exe -me -f me.bin again and then do the -greset as you suggested with unplugging the power cable etc… to drain all the power from the motherboard?

If not can we approach fixing the ME FW in another way?

Now, please dump ME FW and upload for me to check >> FPTw.exe -me -d me.bin

If -greset auto rebooted, no need to do the power drain stuff, that’s only necessary if -greset doesn’t auto-reboot it.

We want to disable ME in the end via HAP Bit, to enable 128GB memory, but I checked stock ME FW and this is not set by default (they’d never do that) Did you disable ME FW before, using any method like ME Cleaner or something similar?
Anyway, post flash of ME as you did above, it should be fixed now, since you flashed in stock ME FW, but it’s not so I’m not sure what’s going on here unless you have ME Re-Flash enabled in BIOS maybe? If you do, then set that back to default (disabled)

Actually, looking closer at that image again, only 16KB was written. Please try same thing in DOS instead, flash ME FW I sent you with DOS FPT (copy all DOS folder contents to root of DOS bootable USB),
then >> FPT.exe -me -f me.bin
then >> FPT.exe -greset

If still same after reboot, then do the following from DOS only and do not use this rewrite command at other times, only here and now
FPT.exe -rewrite -me -f me.bin
FPT.exe -greset

@Lost_N_BIOS Thanks for the update !

Here is the dump of the ME FW >> me.bin
http://s000.tinyupload.com/index.php?fil…977359502343663

I did not disable ME FW on my own or touch it in any way (except for following your instructions here), first time I hear about ME Cleaner.

The only thing I did was to update the BIOS from v11 to v18 and then remove the 64GB RAM I had and in its place put 128GB RAM. Then things got weird as I explained in the first post here.
After that I tested most of the BIOS versions, from v11 to v18, with v15 being the last one which works normally, but it will only let me see 64GB RAM out of the 128GB.

I searched the BIOS for ME Re-Flash, there is a search function and entering “flash” does not show any results, entering “ME” shows only results not relevant to ME. Searching manually I also can’t find anything relevant.

Of course having a working BIOS v18 would be perfect, although if it is easier to do, I could make do with a v15 with 128GB RAM enabled as per the Guide mentioned already.
What are your thoughts on this?
----------------

@Lost_N_BIOS Just saw you edited the response. Going out to buy a USB now and will test your instructions and report back. Thank you

@paul44 - Thanks for the info on what you’ve done or not done to ME FW. When I mentioned ME Re-Flash, I meant in your actual BIOS settings (as in when you are in the BIOS), not to search the BIOS itself with tools/hex etc, or via BIOS “Search”
To clarify here, I checked your BIOS and this setting is specifically named “Me FW Image Re-Flash” and may or may not be visible to you in BIOS anyway (if not, then you’d never have changed).
This is located in PCH-FW config page of BIOS, inside FW Update submenu, all this usually inside a hidden advanced menu you cannot see, so now that I’ve checked this, I assume you cannot see and have not changed it to enabled via BIOS (or via grub or other method due to your above comments)

ME FW you uploaded has been changed from what you flashed in, but I am not ME FW pro, so I cannot tell if those are normal expected post-flash post-run changes or not.
What we can do, is try ME FW w/ HAP bit set (ME FW disabled) and 18 BIOS you’re on now and see if that works with 128GB as desired, or if not, yes we can go back to v15 BIOS (not sure what you mean, where that’s mentioned in guide, I didn’t see it)
Here is same ME FW again, but with HAP bit set so ME FW is disabled as per the guide (any ME Flash after this, you may have to do from DOS)
http://s000.tinyupload.com/index.php?fil…904652283843607

Flash via >> FPTw.exe -me -f mehap.bin
Followed by >> FPTw.exe -greset


Thing here is, in the end, we want ME FW disabled, but only when we do it, and only the way we do it. How it is now, it seems disabled/corrupted, but it’s not corrupted so not sure what is going on.
Does the ME FW show as N/A if you are using 64GB or less? If yes, then maybe this only seen with 128GB installed and is just how it errors/bugs when that much is in there without the mod being applied.
If this is the case, then the above flash should fix that, well it should properly disable ME FW per the guide and allow 128Gb to function properly.

@Lost_N_BIOS

Yes, I don’t think there is ME Re-Flash visible anywhere in the BIOS. I was searching for ME settings and options when in the BIOS, not with tools HEX etc.

I prepared a DOS USB and flashed the ME FW you sent (v18, no HAP edit) with DOS FPT.
The results were the same as flashing from Windows (like on the screenshot in post #5), meaning that the ME FW error on boot is still there and boot is again slow like before, no ME visible in HWiNFO64.
Then I tried FPT.exe -rewrite -me -f me.bin, it erased the block and then did its work, no errors were shown. Still no changes and the ME FW error on boot was still there.

Then I flashed the edited, MEHAP.bin using DOS FPT. The displayed messages on the screen were exactly like on the screenshot in post #5 with the only difference being:
“Programming Flash Block [0x00BC000] 4KB of 4KB - 100 percent complete” was not there and instead in its place there was "Programming Flash Block [0x00BF000] 16KB of 16KB - 100 percent complete"
Still no changes and the ME FW error on boot was still there. No ME in HWiNFO64 and in BIOS it is still ME Version: N/A

After both flashes I used -greset and both times the PC rebooted.


By mentioning v15 of the BIOS, I meant that by my own testing, when the system has 128GB RAM installed, v15 was the latest BIOS version that was functioning without issues (PC quickly boots, restart from BIOS restarts the PC as it should, no ME FW error etc.). Of course v15 only allows 64GB of the RAM to be used.

Under description for v16 BIOS at MSI BIOS download page, it says "- Improve memory compatibility."
When using v16, v17, v18 the issues and ME FW errors appear.

My guess is that perhaps something was changed, so that the memory support for 128GB is not functioning as it should?

What if (the normally working version) v15 of the BIOS is taken as a base, and only minimal modifications are made to it, to test if 128GB would work, without the errors that it is giving now?

Can a modified ME be created for v15 that allows for 128GB?
Perhaps we can test two edits of the ME file, one with 128GB allowed and one with 128GB allowed + HAP bit to disable the ME.
Would that make sense, what do you think?

@paul44 - ME FW error will be there with MEHAP, that is ME FW with disabled HAP Bit (goal of your request), so that is expected. However, maybe there is some bug in the v18 BIOS ME FW I’ve been using.
You said V15 was OK. I will do same using ME FW from V15 BIOS instead, and update it to latest version as well, this way we know there should not be ME FW issues.

Ahh! So yes, maybe they’ve messed up V16-V18 and no one has complained enough for them to see it’s broken (Seems odd for that to happen across so many BIOS / such a time period though). Maybe your memory is not 100% compatible? We’ll find out

Yes, we can do V15 BIOS and ME FW if you want, but it would be more ideal to have working V18 BIOS for all it’s bug fixes, enhancements, and security fixes. That’s why I haven’t gave in and gone that route yet.
If that is what you want, you don’t care about v18 BIOS, let me know and we can just do V15. Otherwise I’d suggest we sort out V18 as described above.
Let me know which you’d prefer?

@Lost_N_BIOS Thanks for your response !

Okay, I did not know the ME FW error was still to be expected after flashing MEHAP.bin.
After flashing both me.bin and MEHAP.bin the computer still has all the issues I described in the beginning, so from an end user point of view, I see no change in my experience with any of the two ME flashes we attempted.

How would you recommend we continue with this so to find a way to overcome the issues? I have the time and patience to test as many things you send my way.

At the same time if it is not too much work to attempt a v15 fix, that would be nice to have a working version that I can use on the computer right away.

Please do as you see fit, I will follow your instructions.
So far, from what I can see I have tried everything you have suggested, if I had missed anything let me know and I do it


EDIT: Yes I think they might have messed it up with the 128GB RAM support, if I had to make a guess these ME FW errors are just the way it errors out when the BIOS can’t properly handle the 128GB of RAM. Then inside of Windows the RAM is seen and is Usable…

@paul44 - You’re welcome! Yes, once you set ME HAP Bit per the guide, this setting is actually for disabling ME FW. However, I’m not sure if that would stop any possible ME FW issue (bug) from still affecting the system, you’d think disabled means ME FW and bug not loaded, but you can’t always assume.
I suggest first, you stay on BIOS v18, let me grab V15 ME FW, and disable ME FW via HAP Bit, then you test 128GB. If that does not work, V15 BIOS and same ME FW would likely = same. Disable ME FW always has issues, some systems this is worse than others.
Yes, you’ve tried everything as I suggested, no problems there that I’ve seen

Here, lets test, stay on BIOS V18 first. This is V15 ME FW used as base, and Disabled via HAP Bit set. If you continue to have issues on V18 with this, then flash V15 BIOS and repeat
http://s000.tinyupload.com/index.php?fil…423667545578328

Flash via DOS >> FPT.exe -rewrite -me -f me15hap.bin
FPT.exe -greset (or do power drain dance if this does not auto-reboot, or you can try -greset from windows after this if doesn’t work in DOS, but it may not work in widows either due to we are disabling ME FW)

@Lost_N_BIOS

While still on v18 BIOS I flashed the v15 ME FW file you provided via DOS, system rebooted after -greset. There was no difference again, ME FW error was there and all the other issues too. Also again no ME visible in BIOS or in HWiNFO64.

Then I flashed v15 BIOS, there was no ME FW error on boot (just to confirm again that this BIOS version 15, does not give the ME FW error on boot).
Then via DOS I flashed the V15 ME FW you provided (HAP Bit set) (system rebooted after -greset) and there was again no error during flashing and after reboot, no errors anywhere. After that I boot into BIOS normally and under System Status I now see ME Version: 11.8.50.3470. In Windows, HWiNFO64 also shows the Intel ME entry under Motherboard.

The amount of RAM with this BIOS (v15) and the v15 ME FW you provided (HAP Bit set) is limited to 64GB. Both in BIOS and in Windows I see 64GB Usable.
Was this to be expected? Or was the v15 ME FW also edited to allow the system to see the 128GB RAM?

INFO: When BIOS was v15 and I booted into DOS to flash the v15 ME FW you provided, for the first time there was NO yellow text: “Unable to Detect ME Disabled.” like it was in post #5. I don’t know if this info helps but here it is.

@paul44 - By Design and you request, the ME FW in above post #12 is ME Disabled FW, so you should not see ME FW or version in windows apps or BIOS etc (only No ME shown, 0.0.0.0, or N/A depending on where you look/with what tools etc) At least I think HAP Bit Disable doesn’t let you see version/info, but maybe it does?
After you flash V15 BIOS you need to flash back in the ME Disable (HAP Bit set) ME FW again. Sorry I didn’t make that more clear above, I said flash V15 then repeat but didn’t specifically tell you that you needed to then reflash ME HAP FW again.

Yes, that info helps, it means stock ME FW of BIOS v15 was flashed in and it’s not broken like V18 is. Now, do FPT flash of ME FW using ME FW in post #12 and that command in DOS.

I did not check v15 BIOS to see if it has 128GB enabled in it, since you seemed to say that was already a given or tested “in the guide” you said. but I will check now.

* Edit @paul44 - V15 BIOS is not 128GB enabled, here, I’m modifying it now, please wait! This will have the ME FW w/ HAP bit set (ME FW disabled) + the BIOS itself modified per the guide to allow 128GB
*edit - BIOS >> http://s000.tinyupload.com/index.php?fil…374458464420879

V18 already had this edit in BIOS itself, but apparently they messed up the ME FW somehow, I guess by trying to make it 128GB possible but not disabled maybe?
I assume that is possible, and should be, you shouldn’t have to disable ME FW to use 128GB, especially manufacturer shouldn’t make it so you have to do that, it’s a security issue so obviously they wouldn’t put out BIOS with ME FW disabled.
So I’ve been waiting for us (dsanke) to find way to make this possible, based on manufacturer released BIOS, without having to disable ME FW.

Here is comparison in hex and assembly, so you can see where/what the edit looks like via hex if you decide to try on future BIOS

V18-V15-128GB.png

@Lost_N_BIOS Thanks for the response and the modified BIOS !

It turns out that we have made some progress…

After flashing the latest file you sent: BIOS v15 (ME FW w/ HAP bit set (ME FW disabled) + the BIOS itself modified per the guide to allow 128GB), the PC gives the same ME FW error and behaves exactly the same like v18 with 128GB RAM. The stock v15 BIOS (without the ME FW disabled and 128GB modification) did not behave like this. With v15 (128GB mod) The startup is slow and all the other issues also appeared.

BTW: The modified v15 version you sent, with 128GB installed, does give all of the issues I explained in post #1, except for the language issue. It is not messed up like when 128GB is used with v18.

Which must mean that, if the BIOS is capable of using 128GB RAM and as soon as 128GB RAM is put in the system (or specifically these exact RAM sticks, can’t know with no other 128GB kits at my disposal) it can’t handle it, is not 100% compatible or whatever we should say here. The end result being the ME FW error appears even though it seems unlikely there is any error with it, just the way it errors out. Does that make sense? In Windows all works well, 128GB is seen and usable, it is only that the BIOS and startup, shutdown is messed up.

What do you think @Lost_N_BIOS ?

Can anything further be done to solve this?

@paul44 - You’re welcome!

So, success, correct? 128GB seen and addressable? If yes = success. ME FW issues and startup.shutdown issues etc, all related to ME FW being disabled
This is normal and expected in some systems, some even cause fan to run at 100% or you can’t set memory speed/timings etc. As I mentioned before, ME FW disabled causes all these kind of issues, some systems much more affected than others.
I assume all working perfectly now, nothing wrong with your memory, and any other memory would give you same outcome. That is, if you can see and use 128GB of memory I mean.

I just noticed your post #1 point #4 about V18 experience!! >> 4. Booting into Windows is slow, once booted, the 128GB RAM is visible and usable
This means V18 BIOS, stock as-is is compatible with 128GB and it was always working! Sorry I didn’t notice that until now, I thought you said you could see 128GB, but could only address/use 64GB
This means no mod BIOS or anything was ever needed here, so sorry I didn’t catch that until now

You can now flash back in stock V18 BIOS, suggested for all the fixes, security enhancements etc in there. No reason to use old BIOS for same result as new BIOS

Please show me image of this ME FW error, so I can try to find in BIOS and bypass check

@dsanke - do you know anything to disable MSI ME FW error message, or resolve the power issues (Shutdown) when ME FW disabled on MSI?
I’ll see if any BIOS setting, or if I can disable check/warning via assembly edit.

Maybe this one?
End Of Post Message, VarStoreInfo (VarOffset/VarName): 0x789, VarStore: 0x1, QuestionId: 0x171, Size: 1, Min: 0x0, Max 0x2, Step: 0x0 {05 91 92 18 93 18 71 01 01 00 89 07 10 10 00 02 00}
One Of Option: Disabled, Value (8 bit): 0x0 {09 07 04 00 00 00 00}
One Of Option: Send in DXE, Value (8 bit): 0x2 (default) {09 07 94 18 10 00 02}

@Lost_N_BIOS


Yes, 128GB is seen and addressable with BIOS v16, v17, v18 and the special v15 you modified !


I thought we both knew that the system worked with 128GB RAM and that we were trying to fix the startup, restart, shutdown and language issues.
Thanks for clarifying that ! No worries at all, it happens that sometimes we miss something


I would still like to ask you, that we continue to work on the v15 of the BIOS and not the latest one (v18). Reason for this is the language.
Like I mentioned in Post #1, Point 3., there is an issue with the language (when 128GB RAM is installed) on all BIOS versions after v16.
Please see this image:

20191210_125609.jpg


Even with English selected, there is Chinese and if I select Chinese, most text is in English but in some places it is still Chinese.


At the same time, the modified BIOS you sent (v15) does work with the 128GB RAM and there is no Language issue !

So I would prefer that we try to fix the startup ME FW error and the power issues (reboot and shutdown does not work), if possible on BIOS v15 (the one you modified).

Here is the ME FW error on startup:
The ME FW of system was found abnormal
it is recommend to re-flash system BIOS by M-Flash to ensure normal system operation.

20191210_130230.jpg




@dsanke If you have any idea how to help the ME FW error or the power issues, please share. Thanks in advance !

Sorry, no, I didn’t notice until today when you mentioned it again I thought you could only use 64GB, but see 128GB with v18 and you wanted that fixed. Sorry, that’s my confusion the whole time I guess
Yes, I missed that one little thing, through the whole thread off for me

I’m not sure on the language thing, I’ve never seen ME FW cause that, does it happen now with V15 too, or only v18 (what about 16, 17?)
The rest, known possible issues with ME FW disabled

Yes, no problem, we can continue with V15 I made you, not a problem to me. Whatever else you want done I can do (like give you the hidden advanced menu with TONS of options, or update microcodes etc)
I guess as I read on, you answered me about the language Does this happen when you slam/slap or drop your keyboard, or anytime? I’ve had that happen when dropping keyboard often, at least language switch
Yes, great, at least with V15 I made you there is no language issues.

Reboot/shutdown cannot be fixed, unless dsanke tells me some maic trick I’ve never heard of before.
This is common problem with corrupted or disabled ME FW, if you search here with “shut down or slow and ME FW” you will see huge amount of threads.

Thanks for image, if I can find this exact module making that happen in the BIOS, I may be able to bypass the check that causes it at least. I will check for that later today or tonight when I have more time.

@Lost_N_BIOS I don’t know how to disable that "ME FW error message"
This BIOS should be very easy to modify , just set HAP bit , no other modification need.

@dsanke - thanks anyway, only hoped you knew some ancient MSI Secrets for the ME warning What about ME FW Disabled shutdown issue for this model, any remedy?
Yes, BIOS v18 was ready (except HAP Bit HAP bit not set, but also not needed - see #17 above), v15 needed SIInitPreMem BIOS mod + HAP Bit