[Request] NVMe SSD detection problem with a Clevo Notebook

Hello,

I have a chinese clevo clone notebook called monster abra a5 v8.1 and i have a bios version of n.1.03, i have a intel 600p 240 gb ssd and a 1 tb sata hdd installed, i just bought a new 970 evo 1 tb but i couldn’t make the pc recognize it, my bios is very limited and can’t find a setting to see it, my intel ssd is also nvme and works no prob. it’s nvme 1.2 though, so i thought maybe i should update my bios since it’s dated 2016 but nvme 1.3 released in 2018.

so i looked for a bios update but couldn’t find the bios download in my producers website but since it’s a clevo clone i thought maybe i can find help here. i have seen various topics for bios version n.1.03 but i don’t know if it’s fully compatible with my version. can you help me resolve the problem?

edit: i have contacted my producer, they said the bios version should be n.1.02 but ii forgot to ask if it’s newer, dou you have any idea?

Edit by Fernando: Thread title specified

@Berkto :
Welcome to the Win-RAID Forum!
Since I doubt, that your issue has anything to do with the NVMe module of your notebook’s BIOS, please answer the following questions:
1. Where and how (additionally or by replacing the Intel SSD) did you connect the Samsung 970 EVO SSD to your notebook?
2. Off which disk drive (HDD or SSD) are you booting? Where is your drive C: and where is the boot sector?
3. Which Controllers (I need the exact names) are listed within the “IDE ATA ATAPI Controllers” and “Storage Controllers” sections of the Device Manager?
4. Which OS are you running?
Merry Christmas and Happy New Year!
Dieter (alias Fernando)

Hello Dieter/Fernando

first of all thank you for your welcome,

here are the answers.

1. i have 2 m2sata ports and 1 sata hdd port, i had a 240 intel ssd on one of the m2sata ports (one empty) and a 1 tb hdd already installed on it’s dedicated port.
2. OS was installed to the intel ssd. (so does drive c:)
3. under IDE/ATAPI controllers only listed device is “Standart SATA AHCI Controller”
under Storage contrellers there are daemon tools, “Microsoft Storage Controller” and "Standart NVM express Controller"
4. I’m running Win 10 with latest updates.

Thanks again for your help!

edit: i just spoke with my manufacturer again and they said n.1.02 is the latest version for my pc which should be dated 2018. so if can find a guide for updating n.1.03 to n.1.02 that would also help a lot! thank you.

@Berkto :

This cannot be true, because your Intel SSD cannot use the SATA interface.

Replacing the currently in-use BIOS v1.03 by a BIOS v1.02 would be a downgrade and not an update. I am unsure, whether this is a good idea.

To find out the reason for your problem, I recommend to do the following:
1. Prepare a bootable Win10 USB Flash Drive by using the tool Rufus according to point 4 of the chapter “This is what you should do:”, which is part of >this< guide.
2. Make a backup of your personal data, which are currently on the Intel SSD and store them onto the HDD.
3. Replace the Intel NVMe SSD by the Samsung one (the second M.2 port should stay empty) and unplug the HDD.
4. Boot off the USB Flash Drive in UEFI mode and choose to install the OS.
5. When you are asked where the OS shall be installed, you should be able to choose the Samsung 970 EVO.
6. If the SSD is brandnew, let the OS Setup create a new partition for the OS installation. If the SSD was already in use, let the OS Setup delete all shown partitions of it and create a new one for the OS thereafter.
7. After having completed the OS installation you can turn off the notebook and reconnect the HDD.
Please report whether you succeeded or not and in the latter case tell us what happened.
Good luck!

i tried exactly what you sad but i had no luck. i removed all the drives, installed 970 evo, booted in uefi mode with the usb, windows setup starts but cannot detect any drive to install.

my intel ssd and 970 evo are both nvme, i don’t get it why one works but other doesnt. the only difference is that the intel is nvme 1.2 and evo is 1.3 but they should be backwards competible am i right? or do i really need to do the bios update?

i know n.1.02 should be a downgrade but i saw a friends pc had n.1.02 installed, it’s the same brand laptop but different model and the bios was dated 2018 so i’m confused actually.

@Berkto :
Thanks for your report. I don’t believe, that the different behaviour of the Intel and the Samsung SSD is caused by the different NVMe standard their NVMe Controllers are supporting.
To exclude a hardware issue of the Samsung SSD it would be a good idea to test your Samsung 970 EVO with another NVMe supporting system.
Additionally I would like to look into the BIOS of your notebook. Can you give me a link? Maybe a replacement of the NVMe module can solve the problem.

here are the pictures of my bios menus. the drive called HGST is the 1 tb hdd, the intel is not even shown here but sure it works since the OS is installed on it. and i can see it in windows with no issues too but no sign of it in BIOS for some reason.

BIOS Settings - Pic1.jpeg

BIOS Settings - Pic2.jpeg

BIOS Settings - Pic3.jpeg

BIOS Settings - Pic4.jpeg

@Berkto :
Thanks for the pictures about your BIOS settings, which may have now opened the door for a solution of your problem (to make it easier for the viewers of this thread I have directly attached the pictures).
The 3rd picture shows, that the BIOS setting regarding "Secure Boot" has been ENABLED, which is a big mistake, if the user wants to boot off an NVMe SSD.
As a consequence I recommend to do the following:
1. Set the "Secure Boot" option within the BIOS to "DISABLED" and store this changed BIOS setting.
2. Repeat the last test and try to get Win10 installed onto the Samsung 970 EVO (after having removed/unplugged the Intel SSD and the HDD).
3. Report here, what happened.
Good luck (fingers crossed)!

well, i just tried that and still no luck :slight_smile: i disabled secureboot and deleted the secureboot variables, removed my hardware and installed evo only but windows setup still cannot detect the ssd, so i installed my hardware back again and they still work while secureboot is disabled but my new ssd is still not showing any signs of life :frowning:
--------------------
by the way here’s a bios photo of a different laptop which is the same brand but different model, but the bios version is n.1.02 just like they told me this is the up to date version when i talked them on the phone. and you see it’s dated 2018, since mine is 2016 even though it’s n.1.03 maybe it is a legit upgrade, what do you say?

BIOS Setting.png



EDIT by Fernando: Picture resized and directly attached

If you update, be sure to update BOTH EC FW and BIOS at same time! Not sure which is first, but it should be in their flash update instructions, if not, ask them FIRST
Also, do not flash “Different Model” BIOS to your system unless you are 100% sure it’s compatible with your CPU AND graphics card model.

If you want to be 100% sure, show us image of YOUR main BIOS page and tell me what graphics card your system has + attach the BIOS update package they sent you.
Then we can tell you if it’s compatible and if it’s newer and it’s build date

well the problem is because this is a local brand, i can’t find proper customer support, they didn’t provide me with the up to date files, they just said it should be n.1.02 but they didn’t recommend a bios update, they wanted me to ship my laptop to their service to get the ssd installed somehow, update the bios only if it’s necessary but they don’t say if it’s absolutely necessary at the moment or not, but it should be fixed with an update i guess so if you have further recommendation i’d be glad to hear, and i can’t find the files either.

i’d like to post the proper info but can you elaborate a little bit? and they didn’t provided me with any tool or file. i have a gtx965m graphics card, it’s a rare model so i don’t know if there were many different boards and bios out there for it. main bios page is uploaded up in the previous post by the way.

Ohh, sorry, I thought you had files sent from them. Since you do not, you need to find BIOS update package for your exact model.
Keep pushing them in email, tell them it’s silly and expensive to send system for BIOS Update, tell them to get with the program/future, and send you a BIOS + EC FW update package like every other brand does. (ie Shame them into it )
I will see if I can find you BIOS update package. YeGTX965M is rare, older model, and probably not a lot of new tonfang based BIOS would have vBIOS for this card in there, so you have to be careful what BIOS update, if any, you try to flash in there.

None of this should be required though, BIOS from2016 should be 1000% NVME compatible.
I think you may have other issue, which I’m sure Fernando will sort out for you. Did you test this drive on another system, and it’s OK, not DOA?

This info in spoiler may help, if you’ve already done stuff to this NVME on another system, make it RAW and then try windows install again
Also, use this tool to make your windows install USB, I’ve seen issues with other tools and methods, but never with this (ignore sys requirements, works fine w/ Win10) - https://www.microsoft.com/en-us/download…s.aspx?id=56485

You can use diskpart in windows from OS (Direct from any CMD Prompt), or from installer ISO (press Shift + F10 on the first setup screen where you pick language)
Or from repair/troubleshoot options in the installer/setup. Remove all other drives, so you have only USB and target win10 drive. Then from CMD prompt do the following

1. Diskpart
2. List Disk << Here, identify what your target disk is by size/name etc, and make note of it’s #, you will use it’s # next - (If in windows, these #‘s will match what you see the drives shown as in Disk Management) - Be sure you do not select your USB or main OS drive if in OS
3. select disk # << Here, instead of #, put target disk #, example >> select disk 0
4. clean
5. Exit

Reboot and run the installer again, then point it at the raw/blank drive, do not load any drivers or create any partitions etc, just select drive and click next


** Edit - What is your system serial #, from the bottom of the laptop? So I can try to find BIOS based on this info/method
https://forum.donanimhaber.com/rehber-mo…leme–143666488

*** Edit 2 @Berkto - Please do the following too, and upload file from #1, let me know what error if any you get at #2
If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below


If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required
> CLICK HERE TO DOWNLOAD CMD PROMPT REGISTRY ENTRY <

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

so first of all thank you so much for your help.

i have found the same post from that turkish forum, he basically says what you say but he also says that he doesn’t know how else it is possible if there is no model number. because under my pc there is no model number is written, so i couldn’t follow his guide unfortunately.

and you are right my 2016 bios should handle nvme devices because my intel ssd is also nvme, only 1.2 version. something is disabled but cannot find what it is. i didn’t try my evo on another device, but my friend also bought a 970 evo plus, they were both raw and it didn’t detect either of them. maybe i should try to install my friends formatted 970 evo plus, what would you say?

so i upload my biosreg file and also the screenshot of the back up and write proceses, also the me info screenshot.

Thank you.

biosreg.rar (2.74 MB)

biosreg.PNG

me_info.PNG

@Berkto - If it’s not detecting your friends 970 EVO either, then I assume at least one of them is not DOA. And, if windows it not detecting either as suitable target disk when RAW, then pre-formatted wont make a difference either.
If you did try, make sure you initialize the NVME as GPT, then make your partition. But, best way is RAW. USB should also be GPT, but it may not have to be, best way to make USB is via the tool I linked you to, others can cause random issues sometimes, so be sure you make installer USB with that tool.

Did you ever test with CSM enabled? You are starting with Optimized defaults loaded, correct? If not, you should be! Otherwise, fail safe with set Legacy boot mode.

@Fernando >> Fast Boot is enabled by default, if/when Optimized defaults are loaded, is this an issue with native NVME compatibility?

Thanks for the BIOS, I will check it out and see if I can find any updates.
I will also make you a mod BIOS, doing NVME mod and removing stock NVME compatibility, so you can test that.
This will rule out stock NVME ability having some compatibility issue with the 970 NVME.
In that BIOS I will also do full menu unlock, so you can change many other settings, including “Boot Mode Select” from the boot page
Additionally, I will include an unlocked copy of your BIOS as it was, no “NVME” changes

Before I send you any mod BIOS, please run this command from MEInfo/Win32 folder and show me image of the bottom of the report >> MEINFOWin.exe -verbose

here is the bottom of the report. i gpt as much as i can. i hope this helps. i will wait for your bios unlock, i’m sure that’ll be a 100% solution if i don’t brick my system of course :slight_smile:

info.PNG

@Berkto - Thanks, Measured + Verified Boot not enabled at FPF/chipset side, so you’re safe from Boot Guard causing any issues here
BIOS I make you should not brick

I suggest testing the original unlocked BIOS first, and make Windows installer with the Microsoft USB/DVD tool, then test NVME on all slots on the board, in case one is not wired properly for NVME
Might just be Fast Boot causing the issue? Disable this for sure for the NVME mod BIOS I made here, if/when you test that. Then you can enable later and test w/ enabled if needed.
For the NVME mod BIOS, be sure to follow all steps @ #4 here in the “This is what you should do” section - [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Here are those BIOS to test, write them back via >> FPTw.exe -bios -f filename.bin
If all still not working, you can flash back your original biosreg.bin
1. biosregnvme.bin = stock NVME stuff removed, normal NVME mod inserted + menu unlock
2. biosregunlock = original biosreg.bin dump >> Menu unlock only.

After BIOS flash, always load optimized defaults, then save/apply and reboot back to BIOS to make other changes.

Thank you very much. the file i sent you contains the original bios then? sorry for my lack of knowledge. so the guide involves the tools to modify my original bios but you won’t send any modded file, i’ll modify using the guide, i get it right i guess :slight_smile:

@Berkto - Sorry, I’m not sure which file you are asking about here? If you mean at post #13, yes, that is your “BIOS Region” you sent me, this is part of your BIOS.
And sorry for any confusion caused by my post at #16, looks like I forgot to drop the link for you after I uploaded the files/BIOS I made you!!
You don’t have to modify anything, sorry, I just didn’t post link for uploaded files when I posted my reply
Here you go, BIOS as outlined at post #16 - http://s000.tinyupload.com/index.php?fil…620582749654332

Hello again,

so here’s what happened. i removed all my drives to try windows installer tool work but it didn’t so i installed my intel ssd as well to turn windows on and flash the bios, and i flashed the bios with the unlock one, restarted the pc, entered bios and voila! my 970, along with intel was there, no drama! so i was very happy, turned windows on, formatted the evo with disk management tool and it was a new working drive! (i attached the photo of happiness which lasted very short)

then i shut the pc down to install my hdd as well, which i did. then turned pc on and guess what i saw? the evo was gone, there was only my intel ssd and my hdd. than i removed the hdd, booted again but no it was gone, than i did everything, tried other nvme bios, flashed the unlock bios again without the hdd but i had no luck. i couldn’t make the pc see it again, in the meantime secureboot, csm and fastboot were all off.

any guesses? :slight_smile:

WhatsApp Image 2020-12-26 at 19.21.02.jpeg

If it was present before…why did u flashed another bios file?

Do not know if ur looking for a multiple system boot machine but we have to question the changes made automatically in EFI boot partitions

Go back to previously flashed bios and without Intel NVMe ssd and no HDD SATA, only the 970, install windows.
Even if 970 doesn’t show in the bios, try anyway to install windows.
Add HDD sata, NEVER boot from it, confirm in Disk Management.
Add Intel NVMe, NEVER boot from it, confirm in DM.
Confirm the 3 drives in OS from the Evo.