[REQUEST] Unlock Hidden Menu Options Dell/AMI Bios

Please help unlock all the hidden menu options and features for this Dell Latitude E5530 vPro. Here is a link to download the full bios installer from Dellhttps://www.dell.com/support/home/en-us/…=latitude-e5530. I’ve attached my current bios dump and the ACPI tables from RWEverything.

–Edit to original post–
I updated the files in the archive to reflect updates I have been able to do myself. I also uploaded some pics of the current menu screen

BIOS.rar (3.45 MB)



Anybody care to help a brother out?


@Lost_N_BIOS : think you could advise me on unlocking this bios?

Been trying to get the same for my Dell G5 SE 5505 (want to change iGPU RAM Allocation :frowning: )
Dells are notoriously impossible to unlock.

@Net7 : Oh, really? I’m still new to bios and firmware programming or moddifying. So, I’ve accomplished quite a bit that I originally thought was impossible. I have tried following any guides I could find online for unlocking menus in AMI Aptio 4. However, none of them seem to apply to this Dell version of Aptio 4. I ran into issues trying to update the OROM files because Dell inserted them somewhere without setting any vendor or devices ids. I don’t know if this is standard for Dell products now, but this BIOS even has Tianocore EDK2 components

Dell usually uses Insyde so interesting if this is AMI

Still learning myself but what I’ve found is that the setup prep module needs modified in the Dell ami bios. The code in there suppresses all the other menus. I found threads on here showing to swap the end if and suppress if statements but I think there is a cleaner way. I have a friend who is a software developer that I sent my ifr file to so that he can advise on changes. I should be hearing back from him today. I can tell you that amibcp can’t unlock anything for Dell.

@Net7 - not sure if its a good thing or not, but not on this one

@frankr2994 - this is the guide I used for unlocking the menus of previous Dell’s that aren’t as complicated https://forums.mydigitallife.net/threads…r-unlock.54523/

That’s the magic string. I could not find it in my hex code. More so I don’t need to unlock any of those menus. What I need is a separate form all together. Still part of the setup module but I need intelRCSetup. The only info ive come across about enabling that form is that it can’t be done.

Try checking this out towards the bottom of the first post. Click on "How-2-Rip-It-Open-Yourself. OverPowered TONGFANG CyberPower Machrevo MACHENIKE - Unlocked BIOS Guide W/ Files.

Following that method seems to be a little more applicable for me, but still can’t find the backwards form id’s in AMITSE. Here’s as far as I’ve gotten on it so far.

Menu Info.txt (5.96 KB)


That’s really interesting. I may have to read that a few times to grasp. I’ve been working on this hex alot lately and I’m still barely getting it. I really can’t understand why some of it seems straight forward like 0x34 being 0 00 34 or it can be 0 34 or 34 00 or 43 00. I’ve seen it all over the place. Anyways in my amitse I can’t locate anything any way so far. What I have been working on is going through my platform module in text form and I’m tossing a bunch of notes in there for changes. It won’t make anything visible but it should still apply my changes. Really wish I could find a leaked copy of amiveb. That seems to be my only piece of missing software so far.


Only one question to ask you. If you edit the bios dump then could you reflash it again?? and does it boot normal?

So far, yes. I make one mod at a time and create a new dump after I know everything is working. Then, I move on to the next mod. Here’s the only things I’ve done so far:
Intel RST EFI “RaidDriver” v11.6.0.1702 ----> Intel RST(e) EFI “RaidDriver” v13.1.0.2126
Intel RST RAID ROM v11.2.0.1527 ----> Intel RST(e) RAID ROM v13.1.0.2126
Intel LAN Boot Agent GE ROM v1.5.50 ----> Intel LAN Boot Agent GE ROM v1.5.62
Updated 5 of 7 MicroCodes


Ok~i see !
Here is mod i made ,try it and check if there are any changes in bios screen…

Can you elaborate? What did you do and how?

Edit setup module via hex editor is what i did.

The hosting site you used required I disable my ad blocker to finish the download. After disabling and trying to download again, the site requires 2 hours between download attempts. Can you just upload it here instead?


I just realized that I hadn’t updated my start post to reflect the changes and updates I had already made before you downloaded it. So, what you modified is about a week old and is really the current BIOS. Do you think I should just flash what you uploaded or go back first? Do I need back to the original BIOS that you modified before flashing your bios_1.bin?