[Request] Unlocking zbox En1060 bios RAM Timing Setting

Hi. I am asking for help in unlocking bios for zotac zbox En1060
The stock bios have No memory Configuration setting, but I hope I can adjust the memory timing setting
In the UEFITOOLS software I search and find lot of memory or timing settings to unlock, i have got no experience in bios setting unlocking.
Can anyone help me unlock the memory settings? Allows me to adjust memory timing settings

I attached bios files also the bios pictures.
Bios download link https://www.zotac.com/download/mediadriv…EN1060KUEFI.zip

bios platform is AMI Aptio V

Thanks in advance for your help!

BIOS.zip (4.09 MB)

bios pic.zip (586 KB)

Hi Lost_N_BIOS, I saw that you helped many people in the forum.
Can you help me? Thank you very much.

@carking - You have ME 11.0 or 11.8 Firmware version (your images show 11.0, this BIOS you linked contains 11.8). Whichever it is I think uses same, all use V11 package. Go to this thread and in the section “C” download the matching ME System Tools Package (ie V11)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Do you have flash programmer (Like CH341A)?

* Edit - almost forgot, please also add images of BIOS “Boot” and "Exit or “Save & Exit” page too
*Side note - this BIOS is terribly constructed, they tried to hide everything by removing names, jumbled stuff into random locations, pretty rubbish and slacking/lazy engineer move, could have be done pretty much same but with much less of a mess if he/she knew what they were doing.

Hi, @Lost_N_BIOS
yes I have the flash programmer(CH341A and XTW100) but I think I can flash the mod bios with official bios updater, it use USB drive to flash.
Here is the new pics and biosreg.bin file, Thank you for your help.

biosreg.zip (2.96 MB)

PICS.zip (840 KB)

You’re welcome, and thanks for the pics, and FPT dump. Good to know you have programmer, I was more concerned with having to recover from broken BIOS, due to how it’s all constructed.
Also, the main reason I asked for FPT dump to modify, was if I modify stock BIOS and the stock updater uses FPT instead of AFU (Depends on how you choose to flash with the stock package) then you might loose your serial, UUID and possibly LAN MAC ID too.
To avoid those worries I planned to have you flash my way with FPT, but see my thoughts below, seems nothing to worry about anyway.

In the stock package, flash.nsh (UEFI boot method) uses AFU, and now that I looked again AFU is used in all for the BIOS flash, FPT only used for ME Update via the stock package if you use flashME.nsh, so I think you’ve got nothing to worry about updating BIOS using stock method and full BIOS I mod (instead of FPT Dump)
Will post a BIOS for you to try soon, I’ll jump back in there here shortly.

Great, thank you man! Can’t wait for your update.

@carking - For now, lets only go after “Advanced” section, so we can see how the BIOS reacts (looks), unsure if those tabs will resize, or are locked in place and sized as is etc. And since within this section is the memory controls you wanted to be able to adjust.
So, with each of these BIOS, in case you do not see advanced section, scroll/tab through all pages right to left and past right and left, to make sure there is not additional unseen tabs on either side, sometimes this happens if GUI is locked in place.
Please test these in order, and you can stop at first one you see Advanced show up (even if empty) then let me know. This is only test to see what happens when enabled at root level only, and to see how/which method enables.
This may have empty advance section, or limited settings etc, you’ll have to let me know, but the main goal here is only to find which method enables and I only made changes meant to enable it at the root level (I didn’t edit anything within it right now)

Please be careful while swapping out files for testing, so you don’t mix up the files, or mix up which file worked and what folder it was in, since all have same stock name.
Or, if you want, you can rename the files, but leave folders as they are so you know, then edit flash.nsh each time for the new BIOS name.

Hi, i try the first one bios in the amit folder, i can see the performance menu setting, enable it and then find most of memory setting can not adjust, the only adjustable setting is DLLBWEN(0,1,2,), you can see detail in the pics. then i try enable xtu interface setting, it makes me can’t start the pc, i need reset the bios setting to recovery my pc.
Now i am going to try the 2ND mod bios.

just try the Amit-Setup folder bios, the bios setting Looks the same as the first one bios, and enable the xtu interface still can not start the pc, in the memory setting the only adjustable setting still the DLLBWEN.
now try the last one.

Already try all of it, see my latest reply

amit pics.zip (322 KB)

@carking -Do you mean inside advanced? I’ll check images. Do not flash anymore BIOS, it’s not needed, wait until I send you new one now
From that set I sent before you only needed to flash AMIT >> AMIT-Setup >> AMIT-Setup-BCP in that order, until you found one that enabled Advanced and then stop there, sorry for not specifying that, I originally had them numbered but then changed to names instead.

Lucky for you the first one you picked was first I wanted you to test, and now the only one you needed to test. Nothing more to do until I look at your images and unlock the rest. Please wait patiently

*Edit @carking - see I told you this BIOS was a mess! I see “Advanced” replaced “PC Health” and I didn’t even touch PC Health, it should have been left in place. Do you still have it and just GUI is locked, so you have to scroll over now to get PC heatlh in random named menu?
Sorry, but from your images I can’t tell what is “Grayed Out” for you and what is editable? Not sure how we can fix this?? Maybe you draw on images of screen with paint, to show what you can and can’t edit?

XTU interface may not work with your system/CPU/Chipset etc, I have no clue about this, but obviously it’s not working, stop trying

Sorry, English is not my first language, so it’s a bit hard to express, but I uploaded new pictures and videos. You can easily understand what I mean.
And i try all the bios you provide, looks all the same for me.
The BIOS GUI has some problems, the options and names are misplaced, But it is not a problem, it can be used normally.

NEW PICS.zip (3.42 MB)

@carking - OK, I will check images and video later if needed, but I think I understood what was grayed out and what wasn’t after I re-read your comments again. For now, I was only focused on your main request about memory section, so for now that was only edit this time.
See my edit above, all BIOS supposed to look same, you only need to use one then stop once you could see advanced menu (Other BIOS after that are waste of your time to flash, not needed, no further changes are made in these BIOS anyway except on top of unlock you already found with first flash)

Please test this one, only changes are to >> Memory Overclocking Menu - you will need to rename the BIOS if you use stock flash.nsh or edit it to reflect new BIOS name

And yes, thanks for comment about the GUI, I mentioned this from the beginning, I think GUI would be locked in place and this would happen, it’s due to very poor BIOS engineer work. Nothing I can do about that, unless you want to remove one menu?

Thank you for your patience. I don’t need to delete one menu.

I tried the latest one bios.
The options name and value in the memory setting are all gone. After entering the memory option, the BIOS becomes very lag, check the pics



Hi @Lost_N_BIOS
I found an another zotac b150 motherboard product, and i upload the bios for you, hope it can help you understand zotac Bad structured bios.

pa350B150ATX-A.zip (5.12 MB)

@carking - Too funny - It’s OK, this BIOS is made very badly, and always (even in properly made BIOS) there is many ways you can make changes, this one just failed method, no big deal
Also, if this one fails too, there is still more ways to make not grayed out, so do not worry! Here, try again this way, sorry for the scare No need for other BIOS from different models.

About deleting BIOS menu, maybe I can locate the main GUI image and edit it to make one more tab for advanced, I’ll have to look and see what all images are used.

Unfortunately, most of memory setting still grayed out. Only DLLBwEn can be adjust.


@carking - Thanks for new pic, I see you also can’t see the “live values” above Memory Reference clock either (there should be entire list, just to show current values)
For now, see if this changes things, if not I see why it’s grayed by default >> A setting on the OC page, that’s hidden from you right now, I’m making visible now too please confirm >> (memory profile setting) if = 0x1 then all = grayed out at memory timings, but default is 0x0 so I don’t see why it’s grayed
We will get it though! - http://s000.tinyupload.com/index.php?fil…870278561515884

THX, i can always see the values in bios, just did not catch it in my pics.

I can finally access the value now. see the pics
But after my attempts, no matter how I change and save, it can’t be applied into Windows, so setting not work. Sometimes memory value setting will return to the default value after I save bios setting and reboot .
Maybe in the OC setting the mem profile is set to “default profile”? but there is no other section can be select in the men profile setting, you can check in the pics below.




Yes, I meant in OC, the memory profile setting is what’s tied to why it’s grayed out or not initially. Nothing to worry about for that now though, leave on default, or you can try XMP if your memory has XMP.
What settings are you changing and they aren’t sticking? What are you checking with in windows, show me an image what you set in BIOS then what you see in windows.

Hi @Lost_N_BIOS
Changing the timing setting not work (CL/ RCD/RP/RAS )
use CPU-Z to check how it work.






Thanks, I wanted to confirm how you were checking in windows, some confuse stock timings/SPD/XMP for actual current, plus I wanted to make sure you weren’t maybe setting impossible settings so it was failing to use them.
All you set is reasonable and should be working, I think the issue is “Default Profile” where you can choose default or XMP, there should also be a “Custom” which isn’t in this BIOS.
I will see if I can get “Default” changed to custom instead. If I can’t then this isn’t going to work

Here is test, I changed memory profile from 0 to 1, but it remained “Default Profile” where I expected it to change to “Custom” So this may not help, and this may also again gray it all out?
I’ll keep digging - http://s000.tinyupload.com/index.php?fil…152157952421555

Also, please link me to this exact product at Zotac’s site, I can’t find it, I only find “EN1060K PLUS” or “MAGNUS EN1060 PLUS i3” and "MAGNUS EN1060K"
I wanted to see what exact chipset it’s using. And, since you have this system in hand, can you look at the motherboard, then compare with all other regular desktop same chipset boards at Zotac’s site and link me to any that look to be exactly the same or nearly the same visually
With that, if you can find exact same board, we can put in it’s setup/AMITSE/AMITSE-SetupData and see if you get a better BIOS or not. This has some risk though, so before we do this make sure you get a complete and valid BIOS dump with your programmer or with FPT if you’ve already unlocked the FD