[Request] Updated Modified Bios for Strix Z270h

Hello, I am asking on behalf of a friend. That is getting issues with his PC, and I think he is having issues, with gaming and stuff happening not sure if it is because his BIOS has not been updated with newer modules or microcodes.

I am asking is it possible for someone to update the latest one (1301) with all the latest modules and microcodes. Up-to-date, stable, to try to see if it fixes the issues he is experiencing. This is last resort as we have tried nuking, different drivers, and asking PC world to fix it. With no luck.

He is using a i5 7500 processor, but might upgrade at a later date, if he can get this sorted out.

He is also using a Samsung m.2 970 250GB and a m.2 970 500GB.

Graphics card is a Asus rog strix RX 580 AMD.

The motherboard is the ASUS ROG Strix Z270h. With the BIOS version 1301.

Thank you for your time, stay safe.

If you need more information just ask.

STRIX-Z270H-GAMING-ASUS-1301.zip (7.73 MB)

@DrewBear - What is the issue he’s having?

Mod BIOS would not be flashed in usual easy manner, he would need to dump BIOS with FPT, send to me, and I edit, then flash it back with FPT.
For that, he would need to follow a few different guides to first unlock some things, then dump the BIOS with FPT and then flash it back after I edit. So this may not be ideal or easy for them if they’re not tech-savy


To add to the specs list, he has 16GB of ram that is the Max speed of what the processor can handle, all four slots are filled with ramd sticks, of the same make and serial.

Well the problems he is having are, games crashing, and stalling in the background processes, even trying to end the process it wont end at all, just makes the drive not respond and crashes the task manager and eventually just gets stuck, still can movw the mouse. but it only happens when he uses his game drive. Boot Destiny 2 or guild wars 2 etc…

He has tried changing drives like bought another m.2 drive to see if the problem goes away.

I have however guided him through the windows reinstallation, via phone. And have after installation, remotely installed drivers and software the usual stuff for gaming like c++ vs, directx and trying a few drivers from win-raid, mainly the Samsung ones here.

Main reason why I think if it were possible to update the modules and such in a BIOS file, the problem might go away, he has tried fully updating his OS and it seems to be worser on the newer windows 10 build 2004, so going back to 1909 seems better, but the problem is still persistent, the whole system seems to be working fine entill he starts a game on the other drive.

I am unsure if the BIOS file would be up to par for the spectre and meltdown, as well, I really am baffled on what to suggest to him.

Question, I don’t know about FPT at all, would it be possible to do that dump remotely, or would I need to be in front of his PC to do it, and is it simple enough to do?

Which guides will I need?

Thank you for your reply.

Games, as in any, or certain ones? Test a clean windows install, Ohh, I see yo did but then no comment on performance after that?
None of what you mention would be helped by a mod BIOS. It may all be Win10 crap/issue! Help him to test a clean Win7 install and see if all same or not.

Can his graphics card handle the games he’s trying to play? I don’t game, so that is up to you to know for sure or not.
Yes, latest BIOS would block spectre/meltdown, this is also unrelated.

Have you had him run Memtest86+ overnight, or at least 8-12 hours? If not, you should do that first, to be sure the memory is stable and there is not some faulty or unstable/dying stick.
That processor, and this board, can handle much more than 16GB FYI >> 64GB max of board is the limit there, unless you modify it, but yes, looks like that CPU may be limited to 64GB
What speed/timings is he running the memory at?

You mention a secondary game drive, is this SSD or HDD etc, M2 I see you mentioned, this may be bottlenecked if he’s using a M2 slot, best to try SSD on SATA Port or NVME on PCIE Port (Or if NVME M2, then may be OK on M2 slot)
For SSD or NVME, is critical that he also aligns the partition before he starts using the drive. This may be the main issue!!
To check this, have him download this benchmark tool, he does not have to run the benchmark, just select the “Game Drive” in the drop out menu on left side, and show me an image
Download is tiny box at the very bottom of the page - https://www.alex-is.de/PHP/fusion/downlo…p?download_id=9

FPT is easy to use, if you can follow the guided info I will give you. You can do it remotely from your PC to his, if you wanted.
BUT, the unlock stuff to flash back in mod BIOS is done via grub (Like Shell) or RU program (like DOS) and neither of those can be done by you unless you are there, he would have to follow one of two guides to do this part and either may be very intimidating to him if he’s not too tech-savvy.

First, a BIOS region dump is created by FPT, then you send it to me, and I then give you info on how to unlock mod BIOS flashing and that is done via grub or RU, then a new BIOS region dump is created with FPT again and you send that to me, I modify it, then you flash it back.
Actually, you can skip the first FPT dump stuff, I can gather info from stock BIOS. But as mentioned, updating all this is not going to help the issues described.

Here is guide to unlock BIOS Lock via Grub, you can skip steps #1-5, I’ve done those for you
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Rename .efi file to >>

BIOS Lock offset to change >> 0x90C

So, at grub prompt you will type the following then enter and reboot (case sensitive)
setup_var 0x90C 0x00

Or, here is how to do the same with RU instead (use info/offset from above for BIOS Lock)
Go to section 2.2 and make bootable USB with RU program, then read 2.3-2.5

Once that is done, here is how to make FPT Dump and test flashing it back (step #2 should succeed once above is done, it will fail before that)
You should need V11 ME System Tools package, to save you some steps on the start of this

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )


Thank you for your reply

Well, his PC was working well before, but he moved to a new place, and it has been about 2 months since he was able to go online and such his PC has gone heywire.

His specs he was able to play all his games without hiccups, and now it is just crashing, without error codes. Seems to be stuck in background, but at the same time it seems to make the drive unusable, till he has powered his PC off, but no issues in Samsung magician, says it is healthy, the benchmarking on the same software is also normal.

I have not tried telling him to do memtest, even though, it could well be that, I have tried to get him to try a game on his main os drive, (he has two m.2 nvme 970 evos 1 is 250GB which has his Windows on, with steam and what not on it, and the other 500GB has his steam games and origin games, epic games and loose games on, we trier destiny 2 and guild wars 2, and a offline game to see if it would be internet related, which comes with the same results, the game runs, but slowly, then after a few minutes it slows even further, then gets stuck, only way out is through CTR ALT DEL to get task manager up, to end task, it ends it on the task bar, but we have to close steam also, and it makes the process of the game come off the steam tree and then puts it on its own on the task manager.

It is taking 2.4 2.5GB of ram and is stuck.
Trying to go into the drive from the (This PC) in windows, the drive shows with the C drive but, is inaccessible, doesn’t show a error, when clicking on it, it makes the window go into not responding.

And if you look in disk management it doesn’t load the window, says it is loading but never does, and gets stuck.

When we reboot the PC the problem goes away and everything is accessible.

Only thing that looks weird from what I can see in the device manager, before his disks, the Samsung 970 is showing with the SCIS at the end of each disk.

And the windows disk management. Shows the recovery the first partition then the EFI then the windows partition.

To me it does sound like a memory problem, rereading this, but I am fully unsure, the PC is at default settings, not touched the BIOS at all.

I would presume the timings are at the default rate, as they are all the same memory, brand and serial.

For the dump and such. I think it would be best for me to actually go to his next week to see, about the dump and such.

Don’t think he will be able to follow all the instructions.

@DrewBear - Then it’s probably all due to new windows updates, or the drive/alignment as mentioned since in that time he’s been trying other drives (so check that as I noted, show me image of AS SSD open with “Game drive” selected, and another with C selected too)
May be best for you to get him back on older version of Win10, one that he was using back when it worked properly. This is common issue with Win10 updates, or new “Windows” versions as they roll out.

Unresponsive C drive, that may be a faulty/dying drive, hard to say without swapping in another (and not the other “game one”). Sometimes NVME/SSD die in odd ways, that aren’t detected by health scans, and freezing-I/O errors is one of the common signs of this.
Memory speed/timings could be anything, especially if leaving all that to auto, best to check with CPU-z and see what is being set.

Yes, I suspected from what you mentioned that he may not be able to do all the BIOS dump stuff needed for a mod BIOS here, it’s OK and no rush if you have to wait to do it. This isn’t going to help the issue anyway.