[Request] Z390 AORUS PRO Disable VMX / HPET

Hi sorry for the delay… i had a long night
i tested the bios but it seems HPET is still enabled

@Kujira - This is not possible in the BIOS I sent you. Whatever the issue was that made you want it disabled should now be solved, and or lesser than before.
On modern boards and or Win10, you will always see High Precision Timer in Device manager because it’s used by other timers by windows only under that same umbrella name.

Please see my comments, info, and testing image here under change log area
There you will see how to test this, and how you should have BCDEdit useplatformclock set, in case you messed with that before/already.

you were right!
using that command line game me the lowest timers 3.580mhz

@Kujira - Nice to see Probably some time previously, you maybe disabled useplatformclock via BCDEdit trying to disable HPET or lower timers etc.
With how windows/timers work now, with BIOS disabled HPET and useplatformclock Enabled (Yes/TRUE) it’s best results that way.

sadly i have a new issue.
i tried to revert back to an older bios version just to test if it openes some hidden settings. just for test purpose

now when im trying to update to your bios that you linked me it says "check id error" or something like that and i cant update the bios

i tried to update to a clean f10 version and it worked…
what could be the issue that now i can use your bios anymore?

edit:wanted to add that im using the aorus pro wifi and not the regular aorus pro <

@Kujira - Sorry, it looks like I sent you BIOS for non-Wifi, which you should not have been able to flash in initially anyway, unless you were already using the non-wifi model BIOS
That can happen sometimes if you use @BIOS to download file from online, or use @BIOS with wrong file you downloaded (Sometimes it will not check BIOS ID).

So, I will have to make you a new BIOS for the WIFI model! Sorry, and not sure how you flashed in that first file I sent you via Qflash You should have got the error then, that you are getting now
To answer your original thought, no, if you flash back in other non-mod BIOS, anything that was hidden and revealed or changed in the mod BIOS, will be gone once you flash back in stock BIOS

So, you need BIOS from this page, with VMX and HPET Hard disabled, correct - https://www.gigabyte.com/Motherboard/Z39…support-dl-bios
What version?

Sorry for the long delay. had some real life issues ;0
anyway. yes it is what i need. F11 would be fine.
Thank you :slight_smile:

@Kujira - No worries about delayed reply, I’m always lost and behind anyway
Due to your current BIOS/board mismatch situation, Please flash using the included modified EFIFlash 0.80
Use this command line >> Efiflash80mod.exe Z390AOPW.F11 /C /DB

*** For anyone else using this BIOS later on >> Simply flash via Qflash ***

so it’s not with Q flash? how exactly i do it?

@Kujira - No, you can’t Qfash it, because right now you have incorrect BIOS flashed into your board, so QFlash would tell you no
You need to make DOS Bootable USB, and flash with EFIFlash using the command I mentioned.
Here in this post #10 is my suggested way to make a bootable DOS USB stick, you can use step #1-2 ONLY (USB may look empty to you, depending on your file/folder view settings, it’s not empty)
Use F12 boot menu to choose USB (not UEFI-USB), then at CMD prompt run command I gave above


Hi, I flashed the bios and it worked!
but sadly. my gpu RGB suddenly stopped working after the bios update :frowning:

no idea what to do. cant get it to work
edit:gpu rgb work after using OpenRGB

But i do have few questions regarding HPET if i may

1.with HPET disabled in BIOS. would it be better to reinstall windows?
2.I feel like the FPS is better and the Windows is snappier but it feels like windows takes abit more time to restart/shutdown - is it related?
3.what about other commands like disabledynamictick\tscyncpolicy? should i mess with them?

WinTimerTest- shows 3.5mhz for me


Im unable to find a setting to disable it , i went through every setting and have not found it , theres just vt-d but does not disable intel virtualisation for me

im on Version f11k

@Pasjidadi - I can put old microcode into latest BIOS, if that is what you want? Sorry, I don’t know what microcode offers best performance/stability etc, you’ll have to google around about that.
Latest beta or latest final is my suggestion always, I use latest beta always unless there is some known issue.
If you want Virtualization disabled, see links below for already modified BIOS. If you need some other BIOS version edited you’ll have to let me know.

@whitehurricanez - Do you need virtualization disabled? If yes, see below, if F11 BIOS would be OK for you?

F11 VMX ONLY Disabled - Non-WIFI Version [Request] Z390 AORUS PRO Disable VMX / HPET (Post #10)
F11 VMX + HPET Disabled - Non-WIFI Version [Request] Z390 AORUS PRO Disable VMX / HPET (2) (Post #20)

F11 VMX + HPET Disabled - WIFI Version >> [Request] Z390 AORUS PRO Disable VMX / HPET (2) (post #28)

If you want me to do new edit to F11k, I can, but before I do, are you sure you don’t want to use latest final BIOS or latest beta?

@Lost_N_BIOS I Dont mind as long as it works , *F12k is my current bios sorry for typo , f11 would be fine too as i was on it previously .As long as vt-x is disabled .thank you

your a legend for doing this free of charge .
if you have a paypal ill happily donate <3

@whitehurricanez - I can do F12k mod if you want too? I’ve already done mod to this BIOS to enable RGB edit changes via BIOS using mod BIOS + secret backdoor access.
I can add VMX Disable on top of that if you want, and show you how to access the RGB stuff in BIOS?
Glad to see F11 edit is OK for you! Yes, I disabled VMX, which disabled all virtualization

Let me know if you want F12k mod too?
If yes, I will make edit on top of this mod BIOS if you don’t mind, see post #6 (or post #16 I would use, if you also want HPET disabled)
How to hard disable HPET on Aorus Z390 Pro?
Or, if you don’t care about RGB access via BIOS, I can just edit stock F12k and disable VMX?

Thank you, I really appreciate it!! I can’t do paypal, however, I will send you some info about gift card and one of the ways you can use paypal

@Pasjidadi - What is your CPU model and SSPEC or stepping, are you sure your CPU is using 906EC?
If you are looking for a pre-spectre/metldown microcode, there is none for 906EC as the fixes are baked into CPU
Would you mind edit on top of the above linked BIOS too, would that be OK? I mean the #6 one + VMX disabled and microcode you wanted?
Or, if you don’t care about RGB access via BIOS, I can just edit stock F12k and disable V + microcode you want?

@Pasjidadi - OK, I will make from stock F12k, just how you mentioned New install of windows is not required/does not matter.
Windows will react like it always does, it will replace/use it’s own microcode whenever it sees fit to do so, unless you stop that from happening via this method -post #272
** Edit >>

@Pasjidadi @whitehurricanez @yaysonbourne @Kujira

F12j - WIFI Version - VMX Disabled + Additional BIOS with VXM+HPET Disabled

F12k - NON-WIFI Version - VMX Disabled + Additional BIOS with VXM+HPET Disabled
F12k - NON-WIFI Version 906EC Rev 84 - VMX Disabled + Additional BIOS with VXM+HPET Disabled


Flash via Qflash, once done, shut down, clear CMOS, boot into BIOS, load optimized, save/apply, reboot back to BIOS to make any changes you need.

@Pasjidadi - Sorry you ran into some issues! Did you flash it how I mentioned, and do everything I mentioned in order as outlined?
Anyway, sounds like you got it sorted out eventually now, glad it’s working good for you now that all is done

It may have been due to old microcode you wanted, and memory having to retrain with that microcode and how CPU was functioning with your preferred settings now vs how they worked with the CPU before.

@Pasjidadi - Remove CMOS may not clear all stored CMOS values always, best to use the clear CMOS Pins or button if there is one (hold button or short pins for few seconds while powered off)
That may be the issue, or could be memory training had not kicked in yet, then all OK after second restart after you loaded optimized and reboot. Or yes, could have been some random USB issue too, but I assume that was may coincidence that it seemed that was part of the issue.
Yes, great all is good to go now!! You’re welcome!

@Lost_N_BIOS Hi again , would you be able to add a disable secure boot to the f11 , and what currency amazoon gifts carrds do you accept?

@whitehurricanez - Hey! What do you mean, you can’t see “Secure Boot” option to disable it?? Surely that is visible to you!?!?
It should be at “Boot” Section, at end of the page If you cannot see it, then you have “CSM” enabled above it, it’s only visible / possible to use with CSM disabled.
And both may be hidden from you until you select Win8-10 on the Windows 8/10 Features option. If you cannot see any of this, show me your “Boot” page from top to bottom, use F12 to screenshot to USB then put in zip
About the GC, thanks for asking, I really appreciate it. I will send you a PM