[Solution] Win7/8.1 Drivers for USB 3.0/3.1 Controllers of new AMD Chipset Systems

A post was merged into an existing topic: [Problem] Win7 install with x570 Chipset+Ryzen 5000 Ser. CPU

Recently upgraded from W7 to W10 with a new Rig but do miss the w7 interface.
Have attempted to install W7 to a spare SSD which I prepared with the eufi partitions
and efi.
Installed directly to system partition using Dism the canonkong w7 amd prepared install esd
(from start of this thread) It boots into updating registry and reboots to the windows starting
logo and hangs there. Safe mode stops on loading drivers.
Have turned off secure boot, wifi, sound, resize bar in bios all other settings are default.
The Mobo is MSI b650 mag morta (same spec as canonkong CPUZ at start of this thread
but bios is newer AC0 and cpu is ryzen 5-7600x) 16gb ddr5 memory. Amd Igu.

Any suggestions as to the cause and or remedy would be very appreciated.
thanks

@socket Recently experienced the exact same thing with my Asrock X570 Pro4 motherboard, the most likely reason could be the microcode embedded in the BIOS.

I would suggest downgrading with the release version when the motherboard launched. It’ll be a pain but that’s the only way to determine if it’ll work or not.

If it doesn’t work, the very last option would be (which is currently what I’m going to try and do for my rig) is to inject a Windows 7 compatible microcode into the BIOS.

1 Like

I have MSI B650 Tomahawk and for me disabling HD Audio Controller (in BIOS) fixed it. Though it kept throwing BSODs for me. Also I was at earlier BIOS version. To be precise: 7D75v172(Beta version) 2023-06-30.
BTW don’t forget to change boot from UEFI to CSM and also 4G decoding must also be disabled.

2 Likes

Thanks Mango Juice ,
Have the HD audio disabled but the bios does not accept CSM, always reverts to EUFI upon booting.
Windows7-Fan,
downgraded the bios to A10 but no improvement.
Have also tried the FlashbootPro to install W7 but that fails to even boot the usb stick.
Its been done so any sudgestions welcome.

Maybe boot mode is set to UEFI only. Go to BIOS → Advanced → Boot → Boot Mode Select → [LEGACY+UEFI] → F10 to save and exit.
Then go to main BIOS page, set to EZ mode → activate CSM there. → F10 again to save.
CSM must be enabled for Win 7…

1 Like

Success
After many attempts have finally managed to install Win 7 on Msi B650m / Ryzen system.
using canonking patched Win7 Pro for AMD Platforms.esd.
Installed patched boot files to the Efi partition to defeat the int10 hanging logo at startup and it
fired up with just three device probs Vga, Sound and network controller. Happy days :slight_smile:
For details of the patched Efi files read this thread-

Tools that I used to install Win7 to M.2 SSD drive were -

DiskGenius create partitions and assign Efi and system drive letters
Dism install W7 esd to system partition
Bcdboot create efi boot files
Bootice edit BCD
Hirens Pe 64 install patched Efi boot files

Hirens PE x64 is a usb bootable utility that contains all the above programs
download from https://www.hirensbootcd.org/files/HBCD_PE_x64.iso
You also will need Flashboot-Pro for patched Efi files

The installed resolution matched my display at 1920 x 1080 but need to get a graphics
card and driver that is compatible win7 / Amd B650, any suggestions ?

1 Like

need to get a graphics card and driver that is compatible win7 / Amd B650, any suggestions ?

You need AMD 6000/Nvidia 3000 series cards for Win 7 as newer generations no longer have any Win 7 drivers. I’d go for top of the line of these cards. I personally got a used-for-mining cheap 6900 XT from a miner. It has been working for almost 2 years now. Though for modern DX12 games I use Linux (Nobara/ Linux Mint both are really easy and amazing to use).

did u fix Vga, Sound and network controller drivers for win7?

Any way to fix this “Windows cannot initialize the driver (Code 37)” for all processors of a 2950X running on X399? (Driver is amdppm.sys)

2024-05-09 (05_07_36)-Device Manager-fs8

canonkong which is the best processor that will run on Windows 7?
Will 7950x3d work good on windows 7 or will it have problems because of 3D cache?
I need it to work without problems and as fast as possible. Which is the best processor for this?

I think this is a bios bug, not the driver problem. Testing on X399/TRX40/WRX80 both are working.

I think R7-7700/7700X/7800X3D is the best chioce, if you need higher performance, 7950X it the best chioce. I am not recomand 7950X3D, it is too expencive.

Thank you canonkong. I will not overclock the processor and I do not plan to buy new processor in the next 3 years so I need the best possible performance. At the moment I can get 7950X3D with very small difference from 7950X so price is almost the same. What I am afraid is that Windows 7 may not work proper with 3d cache of 7950X3D.

I have 7900X3D and it works fine. Of course it does not have “Core Parking” feature of Win10/11 (they use Xbox app there to detect user is started a game, when they detect it, they disable CCD1 so only 3d v-cache cores are available)… yet it works with no problem. If you must use 3d-cache to increase gaming performance you can disable CCD1 in BIOS (CCD0 is 3d v-cache cores, CCD1 is normal cores). When you do this it is as if you had a 7800X3D now.
BTW if you don’t want to disable CCD1, there is an option in BIOS to Prefer Higher Cache Cores (as opposed to Prefer Higher Frequency Cores or else AUTO) without the need to disable anything. I haven’t tried it myself to see what happens or if it works on Win 7. I can test it if you want.
(Because I mainly game on Linux and older DX11 games on Win 7 run fast already so I don’t even need extra 3d cache performance in old games TBH)

MangoJuice I will appreciate if you can test that. Also can you mention what brand is your motherboard so that I can have idea what to look for in BIOS in case I buy different brand motherboard?

I just tested 3 games that I have on Win 7 (I reduced their resolution to make them CPU bound):

[Game - FPS]

Last Epoch - 351
Outer Wilds - 137
Metal Hellsinger - 235

CPPC → Cache
Last Epoch - 352
Outer Wilds - 135
Metal Hellsinger - 230

CCD1 → disabled
Last Epoch - 351
Outer Wilds - 132
Metal Hellsinger - 280

Of my games, only Metal Hellsinger (First-Person Shooter genre) benefited from 3d v-cahce and CCD1 had to be disabled for it to take effect. Setting CPPC to prefer cache did not work at all… except I have tested Outer Wilds on Linux and 3d cache can result in 50 to 100 FPS more there (without disabling CCD1 and without cppc → cache) but on Win 7 game was hard locked to monitor refresh rate (165) so I could not really test that… I used a GPU bound scene for it because when CPU bound it always reached 165…

I have MSI MAG B650 Tomahawk.

MangoJuice thank you for the testing you have done. I am probably going to buy MSI as well following canonkong recomendations.

Both MSI and Gigabyte can work fine on win7 now, Gigabyte latest BIOS fix the A5 BSOD problem now, not need mod acpi.sys flie.

2 Likes

Thank you canonkong for this information.