[SOLVED] Bricked MSI-Z68A-GD55 G3 BIOS after flashing NVMe modded BIOS

Good Morning,
I have bricked my motherboard when attempting to use method described in >this< tutorial. Currently waiting for SPI Programmer to fix it. I am planning to reattempt when mobo is fixed.
Mobo is MSI-Z68A-GD55 G3
Original bios: http://www.mediafire.com/file/qu0tudhn94…681IMS.p80/file
Modded bios with NVMEv4: http://www.mediafire.com/file/6zryjwltkk…_4.P80.rom/file

Please let me know if I did something wrong, perhaps I should use older version of NVMe driver, v3?

EDIT1 by Fernando:
Since I thought, that this discussion has not much to do with the topic “How to get full NVMe support”, I have moved it into a separate thread and gave it a more specific title.
Furthermore I have added the link to the tutorial within this start post.
EDIT2 by Fernando:
Meanwhile the problem has been solved and the reason has been detected as well. That is why I have customized the thread title again.

@drewstew656 - When sharing files online, please use archive (7zip, zip, rar etc) EDIT by Fernando: 7-zip archives cannot be attached within this Forum!
Sorry to hear you bricked the board! No, this nothing to do with NVME V3/V4 version, always use V4 until V5 comes around. How did you flash the mod BIOS? And what tool did you use to do the modification with?
I checked your mod BIOS, all looks good. So, could have been a randomly bad flash, that happens sometimes even with stock BIOS. Or, could possibly be something in the way you flashed it.
Proper method to flash mod BIOS would be rename to stock name.extension and flash with M-Flash. Since your mod BIOS is not named that way, I assumed you didn’t flash this way, correct?

@Lost_N_BIOS :
I actually used UEFI Tool to add nvme driver as per the instruction. Then renamed the bios from E7681IMS.p80 to E7681IMS.p81, as I did not know better. Put it on a flash drive and used MSI’s MFLASH utility from UEFI.
Sorry for not using zip, will remember in the future.

EDIT by Fernando: Unneeded fully quoted post replaced by directly addressing to the author (to save space)


Oh well, I hope I will be able to fix it with the programmer I bought this morning on Ali Express. MSI boards have JSPI1 port to do the flashing, so no desoldering needed. I just need to wait the time for it to arrive, haha. Besides it’s a 10 year old board, I am surprised how much value these hold on eBay.
I was also thinking, would it be worth putting Ivy Bridge Xeon E3-12xx v2 instead of current i7 2700k, to bump amount of PCI slots. I actually had NVMe drive Samsung Evo 970 recognised by the system, but I was only getting something like 1.5MB/s read/write speeds. Thinking this might be because it wasn’t running at PCIe x4, probably x2 but could not really check it.

@drewstew656 - that should have been fine as well, changing the name like you mentioned, as long as it’s a normal MSI name.extension format it should be seen and flash, some MSI will flash any name, but others has to be similar/same as stock.
What version UEFITool did you use, maybe that caused some issue I didn’t see? I checked a few of the usual issues I see with mod BIOS, and your mod looked OK, so it must have been random bad flash, or possibly some issue with certain version of UEFITool edit and I didn’t notice it.
Yes, you will be able to fix with programmer. JSPI1 port is tricky sometimes, it’s really made to be used with a BIOS on PCB/cable etc to boot directly from them remove and flash main BIOS, but you can program through it sometimes.
Hope you got SOI8 test clip with cable too, in case you cannot program through JSP1. Here is some JSPI1 discussions for your reference
Flashing BIOS chip (MX25L3205D) with CH341A progammer - can’t detect chip
[Guide] Recover from failed BIOS flash using Raspberry PI (11)
Xeon E3-1240 v5 working with MSI Z170-A PC MATE but with bios reset on boot (3)

@Lost_N_BIOS Unfortunately I cannot check what was the version of UEFI Tool because it is on the machine with broken bios. I only managed to backup bioses and that’s how I was able to share them.
I got JSPI and SOI8 clip as well. I actually got these items:

and a proper programmer too in case above USB cannot crank enough power (read some comments that it might happen):


I have not programmed bios before and you have to wait for these items to come from China sometimes 2-3 weeks, so I doubled up.
With all the equipment I will try programming using flashrom from a MACBook and first get machine back up and running. I will surely reattempt flashing NVMe driver. Please let me know if there is any specific UEFI Tool version is should use or avoid.

@drewstew656 - that JSPI1 cable/adapter may work, if your board is one that can program through JSPI1. If it keeps failing you may need to solder programmed BIOS chip onto that PCB, this is the designed intended usage of JSPI1
I’m not sure what will work from MAC, if anything, and I can’t help you with flashrom, so hopefully you can figure it out yourself. Or, if you have some other windows system, then I can help.
If you redo your mod, use UEFITool version 25. If you have doubts, let me know and I can make you new BIOS

1. I have reflashed original bios with EZP2019+ and oh boy that clip is annoying, but overall it works more often than not. Clip sometimes cannot properly attach to the chip and programmer is getting dumb. flashrom is unfortunately not compatible with the programmer, so I had to use Win box.
anyway - board unbricked, problem solved just for 10 minutes because I wouldn’t be myself if I did not try it once more.
2. since i got myself a programmer i have felt empowered to try modded bios once again. it is unfortunately broken. it was done with uefitool-0.26
3. my another attempt with uefitool-0.25: https://www.mediafire.com/file/9rlhmss02…DXE_4…zip/file. Archive also contains previous broken mod. I have not tested new mod because uefitool-0.25 was reporting checksum error after adding driver. it would be good if you can confirm it is good to go. both files differ when comparing binaries which i guess is a positive thing.
4. last problem I have is that after reflash to stock bios, my old UEFI drives are not visible as bootable. I cannot select Mac OS X or UEFI OS anymore and I cannot boot from these. I have Clover on one of the drives that actually helped me to select NVMe. Not sure how to fix that one. I took a pic prior to all the modding, showing how it looked when it worked. see attachment.


TLDR - my previously modded bios with uefitool-0.26 is definitely broken, please confirm if mod with uefitool-0.25 looks good. i have also issues with drives visibility and selection for booting in UEFI.

@drewstew656 @Lost_N_BIOS
Since your recent discussion has much more to do with the topic "How to get a modded BIOS properly flashed" than with the topic "How to get full NVMe support?", I have moved your posts into this already existing thread and hope, that this is ok for you.

@drewstew656 - about your drive issues, be sure you first load optimal BIOS settings, then save and reboot back to BIOS. Then you need to set everything how you had it before, such as Secure Boot mode or not, Windows OS or Other at OS Type all that kind of stuff needs to be same.
Especially if you are now having these issues with stock BIOS too.

You should not use Clover, now I am not sure how you can fix any of this, other than a clean install to your NVME, due to I’m sure clover maybe messed with the BCD, but not sure.

Please send me your original dumped BIOS from chip after you got the programmer and before you did anything to the chip.
Sorry, I can’t check your BIOS files above, mediafire is terrible to me, I tried for about 20 minutes and got 200KB of that file and that was after the 4th or 5th starting download attempt .
Please upload here - http://tinyupload.com/

@Fernando - no, our discussion is only about NVME BIOS modifications, as per the original thread it was located in
Neither of us are discussing “how to flash a mod BIOS”

@Lost_N_BIOS :
As you have stated within >this< post, drewstew656’s mainboard didn’t brick because of having inserted a wrong NVMe module or done a mistake while modifying the BIOS.
Since the repair of a bricked mainboard has nothing to do with the Sub-Forum “NVMe support for old systems”, I had moved the related discussion into the “BIOS Modding” Sub-Forum.

@drewstew656 @Lost_N_BIOS
Due to Lost_N_BIOS’s recent comment I have moved all topic related posts into a separate thread and tried to give it a meaningful title.
I hope, that this is ok for you both.

This topic is still about getting NVMe driver installed into BIOS so the drive is recognised for boot.

I have uploaded original Bios and 2 other mods I made in the meantime. One has been done with UEFITool and the other with MMTool following instructions from NVMe thread on this forum. I haven’t tested any of the new mods yet. Please have a look and let me know: http://s000.tinyupload.com/index.php?fil…047864242283809
It took me good few hours to bring my setup back to where it was before I bricked the board. I can boot into NVMe drive indirectly using Clover installed on EFI partition on a secondary SATA drive. I had to also manually create UEFI boot options using EasyUEFI tool so they are visible in BIOS. However no reinstall of the OS was required. Turns out original entries were stored in NVRAM that got cleared when I was resurrecting the board.

TLDR: I am on the stock rom, back where I started and ready for another flash. Please kindly inspect my mods.

@drewstew656 :
Until now this discussion is about how to get your bricked mainboard working again. This has nothing to do with the topic “How to get full NVMe support for old systems”.
Please consider, that >this< thread contains already ca. 5.200 posts. Its visitors (more than 1.6 millions) expect a quick access to the required information and are not interested in discussions about how to get your specific mainboard working again after a failed BIOS flashing procedure.

As soon as you got the NVMe modded BIOS properly flashed, you should return to the source thread.

@Fernando i dont need help with unbricking the board. It has been done, it is alive and kicking and i haven’t asked any technical question regarding how to reprogram it. Also My last message contains 2 mods with nvme drivers for @Lost_N_BIOS to check. How is that unrelated to nvme?
Me being verbose describing what can go wrong and how to fix it when you insert nvme driver into bios should be useful for other people attempting the same.
I cannot see how the argument about quick access to information holds considering that thread already contains 347 pages. To find anything useful you have to use search or google.
But you know what, it doesnt matter your forum, your rules. At least i can talk about my own stuff in a separate thread. So thank you, it actually works to my favour.

What works?
Are you able to boot off your NVMe SSD?
What was the reason for your bricked mainboard and what was the key to solve the problem?

@Fernando - I am LOST as-is, moving threads mid-discussion because someone mentioned bricked once (not the main thing here) makes me even more LOST
The brick mention was brief “hey, I bricked” then directly into how to insert NVME properly and what was wrong with previous insertion (and still on that as of last comments too)

You asked if it was OK/needed, I’m answering No, to me this discussion was always, and still is, about NVME BIOS modification/insert, and should be where it was all along.
This is just my opinion, but splitting up discussions and moving topics around like that all the time because someone talks briefly off-topic for a second about the same hardware device, makes for a much bigger mess, and more confusion within any thread and to all involved, at least to me anyway.
Taking a handful of comments outside of a 5K post thread doesn’t help anyone find anything any easier later, search here is already terrible, and no one is digging through the thread page by page, so 5K or 10K on/off topic really doesn’t matter
However, as mentioned, my entire goal in that discussion was about fixing BIOS with NVME for him properly and or how he maybe did it wrong so he could do it differently in the future.

You moving my topic works in my favour. I can get answer easier and dont need to skim through unrelated posts :wink:
Reason " why " is unknown but i can tell that uefitool 0.26 produced bad bios after insertion of nvme, i tried flashing it with the programmer and it bricks the board. I am on stock now so still no boot from nvme. waiting for someone to review other two nvme mod attempts done with uefitool 0.25 and with mmtool.

So, two to one, I guess I loose (edited in more thoughts above)

I’ll have to move the rest of you guys discussion back into the NVME thread, because it now has nothing to do with bricked BIOS which is the topic of this thread
I guess that would be all but post 1-6, since those are the only ones about bricked BIOS (recovery was done, not discussed, etc)

Although i agree with your point of view on the conversation @Lost_N_BIOS and the fact original posts were nvme related please also notice that current discussion about where the posts belong is totally offtopic, guess we might be better off leaving it as it now is. Besides who wants to argue with the boss :wink: not me. I just want my nvme flashed :wink: shall we continue the topic ? Thank you for reading another lengthy unrelated comment from myself.

Yes, that always happens too when threads are split, it’s always undesired to me unless someone goes way off-topic for hours/days etc, but that is why I said "This is just my opinion"
I’m not trying to argue with anyone, only stating my own opinion/thoughts, since I was directly asked.

I think Fernando is helping you on the BIOS per post #15 which you never replied to, I am now lost and don’t know what is going on here.
If you need help with NVME mod BIOS, you should ask in the NVME mod BIOS thread, do you want me to move this discussion/request to the proper thread (see what I meant all along)
As to your request to continue, my reply still stands at post #9 now, however I was able to download the BIOS zip you posted at post #7 today. Please wait, let me check
* Edit - both BIOS edits 25/26 look OK to me