[SOLVED] How do I get hidden menus shown within IFS "Form Sets"

After help from some excellent people here and at MDL, I now got a BIOS with all available updates integrated. Only the final touch remains; getting the hidden menus to show. What I have tried without much success so far:
-Edited the Setup PE32-image (GUID: 899407D7-99FE-43D8-9A21-79EC328CAC21) and changed all “Suppress If” to false. This gave me a few extra options, like the ability to turn USB completely off.
-Changed just about all menus to USER using AmiBCP v5.02.031. This had no effect.
-Looked for the magic-number; there is only one entry in “Form Sets” in the IFS from Setup, so I concluded it would not work.
-Looked at the IFS from AMITSE (GUID: B1DA0ADF-4F77-4070-A88E-BFFE1C60529A); it only contains A language-list in “String Packages”, nothing in “Form Sets” so I have no clue what to do there. Neither can I find any hint about what it is supposed to contain.

Relevant files are attached(These are the results of what I’ve tried so far). These are the menus in question, those circled i red are the ones I got, the ones circled in blue are the ones I want:


Please someone enlighten me.

Edit: Found a solution, posted it here.

EDIT by Fernando: Thread title shortened (was too long), but can be changed at any time by h_celine by using the “Edit” button under the start post.

E7890IMS.zip (3.96 MB)

Section_PE32_image_AMITSE IFR.zip (427 Bytes)

Section_PE32_image_AMITSE.zip (215 KB)

Section_PE32_image_Setup_Setup IFR.zip (68.6 KB)

Section_PE32_image_Setup_Setup.zip (117 KB)

@h_celine - Please attach your final mod BIOS that has all your updates to BIOS modules in it, like RAID module, microcodes, etc whatever you updated module-wise, but does not have your edits to "Suppress" in setup (not needed).
Please also zip up a set of images of your BIOS, showing at least one of each main BIOS page you can see currently
And what is this model, so I can put your BIOS into a proper folder for my storage for others in the future if we get unlocked properly.

@Lost_N_BIOS :
OK, I took the BIOS I got running now and replaced Setup (GUID: 899407D7-99FE-43D8-9A21-79EC328CAC21) with one extracted from version before I tried editing it. Attaching the the file I inserted and the IFS.txt for completeness.
The motherboard model is MSI N3050I ECO (MS-7890).

bios.zip (3.96 MB)

Bios_Screens.zip (2.34 MB)

Section_PE32_image_Setup_Setup.zip (117 KB)

Section_PE32_image_Setup_Setup IFR.zip (68.6 KB)

Thanks @h_celine - I don’t need the modules or IFR etc, I will gather all that myself, and I will use stock BIOS as base, unless you will still upload BIOS as I asked for (updated modules such as RAID, vBIOS, microcodes etc, whatever you updated like that normally, but before any unlocking attempts)
Replacing setup helps, but that will not put it back to how it was before you made edits (Due to AMIBCP changes are not in setup). So if you have a clean copy with just your regular BIOS updates, nothing on attempts to unlock, please upload that.
I can unlock without any of that, and prefer to work on a clean BIOS that does not have unlock attempt changes already done, anything I miss you can unlock yourself at the end with AMIBCP. My unlock will largely not be using that, which is why I need clean updated BIOS without unlock attempts to anything

@Lost_N_BIOS : Sorry, I forgot about the AmiBCP edits. Here is the BIOS with all updates I’ve done and no attempts at unlocking.
Though I realized when packing it that I have not updated Intel-SATA driver yet.
Edit: Abut the SATA, I probably forgot it because UBU can not find any SATA driver to update…

bios.zip (3.96 MB)

Due to the GUI design of this BIOS, many menus you want may not show up visibly, you may need to scroll past exit and they magically will be there without a tab/title on top.
This is a maybe/likely, due to it’s probably a locked in place GUI with images in there for only the titles currently visible (I’ve seen this on a few Asus BIOS I unlocked)
Additionally, many of those you circled may be useless to try and unlock how you did, such as “MFlash” for example, it’s already there in another way, and OC Profiels 7-8 useless, overclocking submenu also useless since it’s just informational

Thanks, I will use this BIOS as my source then, and you can update SATA driver later (unless you want to do it now, I can wait)

That’s funny, this is “ECO” model, but they hide the “ECO” menu from you!? What gives MSI!!

@Lost_N_BIOS : Yes I expected there will be graphical breakage in BIOS screens when forcing menus into a "GUI-BIOS".
And MSI is definitively not my favorite these days first the latest bios form 2017 contained microcode from 2015 and they refuse to release new bios, then I discover that in-BIOS M-FLASH refuse to flash microcode part of bios. So hiding the ECO menus on ECO motherboard does not surprise me at all.
Edit: And yes, please use that last bios.

@h_celine - You can get to MFlash via hotkey or something, correct, asking since I don’t see it in BIOS images you showed but you mentioned using? Never mind, I see it as a main menu item in BIOS images now (Sorry, was blind! ) Do you have flash programmer for recovery in case needed?
So MFlash does not update microcodes? How about we work from FPT BIOS region backup then instead? Then I can update the microcodes for you too while I’m in there. If you want to do this, please flash the BIOS above you gave me in post #5.
Ohh, I see they’re already updated, OK well this method will allow you to reflash in updated microcodes too while you put in the mod BIOS if you’d rather go this way and haven’t been able to get them flashed in otherwise.
I will put back in the updated ones, since MFlash wont put them in there for you in this backup we’ll create

After you’re using that BIOS from post #5, download ME System Tools V2 package from section “C2” in this page (Bottom of first post)
Intel Trusted Execution Engine: Drivers, Firmware & System Tools

Inside you will find Flash Programming Tool folder, and inside that a Windows folder. Select that Windows folder, hold shift and press right click, choose open command window here (not power shell)
Then run the following command from the CMD Prompt and zip the created file for me >> FPTw.exe -bios -d biosreg.bin

@h_celine - I see this in the IFR, do you have a page before this “Textual/advanced” BIOS that shows you images summary of the BIOS and you have to hit some hotkey to get into the general BIOS like in your images?
This should have became visible for you when you made all your changes to suppress if’s, since this is a suppressed setting, but maybe not since it’s also a “Menu” section in general

Settings, FormId: 0x2718 {01 86 18 27 7C 00}
One Of: BIOS Mode, VarStoreInfo (VarOffset/VarName): 0x395, VarStore: 0x1, QuestionId: 0xE, Size: 1, Min: 0x0, Max 0x2, Step: 0x0 {05 91 67 0C 68 0C 0E 00 01 00 95 03 10 10 00 02 00}
One Of Option: Standard Mode, Value (8 bit): 0x0 (default) {09 07 69 0C 10 00 00} << Default
One Of Option: ECO Mode, Value (8 bit): 0x1 {09 07 6A 0C 00 00 01}
One Of Option: OC Genie Mode, Value (8 bit): 0x2 {09 07 6B 0C 00 00 02}

This may be worth testing, changing above via grub using setup_var
setup_var 0x395 0x1 for ECO
setup_var 0x395 0x2 for OC Genie mode
setup_var 0x395 0x0 to put back to default

Here’s how to make these changes via grub with setup_var, guide was made for other purpose, but you can use and start at step #6 but use above variables to see what happens. If failed BIOS and no screen, clear CMOS to undue
Your .efi file from the guide needs to be renamed to >> Shell.efi
[GUIDE] Grub Fix Intel FPT Error 368 - BIOS Lock Asus/Other Mod BIOS Flash

Same change can be made by AMIBCP, in Setup >> Settings, Change BIOS mode to one of the above (even when not visible these changes would apply)
This would be way to unlock BIOS in general for many options, OC Genie Mode or ECO mode would have a lot more than default one. Then many changes made in AMIBCP would likely apply/become visible, and for MSI this is better way to try first over other unlock methods, since those break BIOS easier on MSI BIOS.
Can you please test both of these mods and let me know outcome without other changes, how does BIOS look in general, what settings visible. You can do either way, via grub or via AMIBCP setting change edit then reflash in saved BIOS.

@Lost_N_BIOS : The microcode problem is solved, I used afuwin /GAN.

The first page in my bios is the one in “MSI_SnapShot_00.bmp” no screens before that one.
The Standard Mode / ECO Mode / OC Genie Mode did not show up when I changed the suppress if’s, only USB-master on/off, some wake on kb/lan/usb settings and some serial port settings, nothing interesting.

I will try setting OC Genie mode, but the settings I am most interested in is the Chipset menu and the Advanced menu(especially the ACPI sub-menu, but secondly the whole “regular” advanced menu as opposed to MSI’s excuse for an advanced menu.).

Edit: No, there is no special hotkey, this is what I get when I press del to enter setup.
And by the way, the bios screenshots is from with my suppress if mod attempt enabled, it made so little difference that I did not bother to flash another time, but sorry, I should have said so at once.

@Lost_N_BIOS : Tried setting “OC Genie Mode” as default. Loaded Optimized defaults. Turned off and on. No change in available menus or sub-menus in BIOS. I’ve learned for the microcode issue, so I dumped the BIOS with afuwin and checked that the change was actually flashed. Here are screenshots from the dump:



Regarding eprom burner, I got a Dangerous Prototypes Bus Blaster v3 that I’ve not had the chance to try, I believe that should cover it.
And by the way; if it by any chance would be easier to remove the “Click Bios” and let it fall back to text mode BIOS-setup-screens, that is also an quite acceptable solution.

@h_celine - Thanks for testing OC Genie mode, can you please also check ECO mode, since this is ECO board that should work at least, should be the default! Main reason I wanted to try this before anything else is MSI BIOS break much easier than other BIOS
The BIOS mode setting above wouldn’t show when unsuppressing a setting blindly because it’s in a menu you can’t see anyway, so you wouldn’t see it no matter what even if unsuppressing that option did make it visible.
“Settings” menu would need to be visible before you could see it, it’s also under a gray out suppression too.

You should try out your Bus Blaster, so you get used to how it works, know your backup made from it is good, and that you can recovery with it properly. That way you’ve got no worries

You did know that any hidden setting you see in AMIBCP, you can change that value and it will be applied even though you can’t see it?
This way, even if you can’t ever get something visible you can still change it, then if it’s still not applied then you know that setting is controlled by setup instead, so you’d edit there via hex/IFR or via grub/setup_var

And yes, I did assume you were already most interested in the other advanced, and chipset, that’s the usual things people want/need unlocked so I knew that from the beginning

Do you use the “Security” page at all? If not, I’d like to test switching that with other ADV or chipset, whichever you’d be more interested in having.
Because of the way this BIOS is made, the menus are not hidden/suppressed in the way it seems, they are simply left out of the actual code that displays them (AMITSE/PE32), and you can’t easily just add them in without other assembly work which I’m not skilled enough to do. But, I can switch what’s there
In most BIOS, in AMITSE/PE32 there is a few lists, one with all the menus, one that’s blocked, one that’s visible and sometimes a short list of block/vis too. But in this BIOS there is only a single short list of the few sections that are visible. It’s hard to explain if you don’t already know what I mean

Is this board a budget model based of another higher priced model nearly similar? If yes, what model so I can check it’s BIOS, if it has a more complete/proper AMITSE we may be able to swap that and the setup out instead of yours.

@Lost_N_BIOS : Tested with ECO Mode, still no menus or sub-menus appeared.

I was getting tired and sloppy yesterday, attached are a complete set of bios screenshots without suppress if mod attempt.

Yes, I know I can change values in AMIBCP and flash, just did that with OC/ECO mode test.

I do see security page. If you can switch in the Advanced menu there that would be a great step forward.

The motherboard is the smallest in a series where N3700I ECO is the biggest.
Other MSI Bay Trail-D cards i found are J1800I, J1800TI and J1900I.
And thanks for asking about that, gave me an idea. I’m going to try to look at the BIOS of Broadwell cards, as this is Braswell it might be possible to learn something about setup menu from them.

I will test the Bus Blaster when I need it. Understanding new things seems much easier when I have an incentive…

Edit: After thinking about it if swapping in menus is a easy solution, what would solve all problems was if you are able to swap the current Advanced menu with the other full Advanced menu, and swap the Security menu with the Chipset menu.

Bios_Screens_complete-NOT_supress_mod.zip (3.19 MB)

@Lost_N_BIOS : Checked a lot of MSI BIOS’es and I was wrong, it is not Broadwell boards but Z170 boards that has the matching bios version.
Edit: This next part is wrong, I just did not see the amputated menus before looking closer, they are not on top of list in AMIBCP as in my BIOS, but they are there:
They all seem to have only one item in the Form Sets, but most seem to have real advanced menus; as in they do not have the setup sub-menu with the amputated Advanced-sub-menu. One example you could look at is the bios for Z170-A Pro.

@Lost_N_BIOS : I got it working.
Thanks to your suggestions, I got the idea to try to replace the sub-menus in the Advanced menu I got with the menus I wanted. And that worked, with a single glitch, I can not use escape key to go back to Advanced menu after entering my modded-in menus, i have to go left to system info of right to M-Flash and then back again to get back to root Advanced-menu. Attaching the final bios and relevant files so other people can use as example for modding similar problem. This is how it looks now:






bios_newMenu.zip (3.96 MB)

Section_PE32_image_Setup_Setup_and_IFR_org.zip (185 KB)

Section_PE32_image_Setup_Setup_And_IFR_new.zip (185 KB)

@h_celine - Thanks for all the similar board links, I will check them out. It’s not so much the setup I’m after, it’s AMITSE/PE32. What I need is similar model, same CPU type compatibility, same chipset (But maybe Z170 is OK, what chipset is this one)
As for the flash programmer, that’s wrong way to think about it, you need to test it and get a backup made that’s verified and validated (Checked by you, to confirm not all 00 or FF and looks similar to stock BIOS in BIOS tools).
You want to do that before you need it, because you may not be able to do it after you need it, then you will loose locations and copies of serial, UUID, LAN MAC etc. It’s much easier to get all that back in correct location/format if you have a programmer backup before things go wrong.

I didn’t think about swapping adv for adv, usually there is some settings missing between them, some in the stock that isn’t in the hidden. But yes, that is a great idea if my swap thing will work.

Did you do all that within setup? I’ll download and look at it later, but great work! Maybe my method would not break the BIOS moving around? Do you want to try what I was going to do and see?

For your reference, here was my menu note info collection from AMITSE and setup, maybe it will help with clarifying some things, since the IFR/Setup does have some invalid and unused menu ID’s

Main Form Set ID - 4A 10 59 7B 0D C0 58 41 87 FF F0 4D 63 96 A9 15

Setup ---------- 0x2710 {01 86 10 27 07 00} = never visible
Main ----------- 0x271F {0F 0F 09 00 02 00 01 00 00 00 FF FF 00 1F 27} >> Not Visible
Advanced ------- 0x2720 {0F 0F 1E 00 02 00 02 00 00 00 FF FF 00 20 27} << Hidden one (Most complete)
Chipset -------- 0x2723 {0F 0F 20 00 02 00 03 00 00 00 FF FF 00 23 27} >> Not visible
Security ------- 0x2724 {0F 0F 3B 00 02 00 04 00 00 00 FF FF 00 24 27} << Not visible one
Boot ----------- 0x2725 {0F 0F 21 00 02 00 05 00 00 00 FF FF 00 25 27} >> More complete, not used >> Also 0x271D (Empty in IFR) + 0x2726 + 0x2839 (May be IS actual)
Save & Exit ---- 0x2727 {0F 0F 4E 00 02 00 06 00 00 00 FF FF 00 27 27} >> Also 0x3b28 (Actual)
Settings ------- 0x2718 {0F 0F 7C 00 7D 00 07 00 00 00 FF FF 00 18 27} >> Not Visible
Advanced ------- 0x2719 {0F 0F 76 00 02 00 08 00 00 00 FF FF 00 19 27} << Empty in IFR
Overclocking — 0x271A {0F 0F 7E 00 7F 00 09 00 00 00 FF FF 00 1A 27} >> Not Visible
M-Flash -------- 0x271B {0F 0F 80 00 81 00 0A 00 00 00 FF FF 00 1B 27} >> Visible
OC Profiles ---- 0x271C {0F 0F 82 00 84 00 0B 00 00 00 FF FF 00 1C 27} >> Not Vivible
Security ------- 0x271D {0F 0F 7A 00 02 00 0C 00 00 00 FF FF 00 1D 27} << Incorrect ID assigned (this = Form: Boot ID)
ECO ------------ 0x271E {0F 0F 85 00 86 00 0D 00 00 00 FF FF 00 1E 27} >> Not Visible

@00002094 - Menu’s blocked or Vis… seems maybe all visible/possible (Depending on BIOS Mode setting, when that works (ie other BIOS))
4a 10 59 7b 0d c0 58 41 87 ff f0 4d 63 96 a9 15 18 27 00 00 00 00 00 00 00 00 00 00 00 00 00 00 >> Settings
4a 10 59 7b 0d c0 58 41 87 ff f0 4d 63 96 a9 15 19 27 00 00 00 00 00 00 00 00 00 00 00 00 00 00 >> Advanced / Empty in IFR
4a 10 59 7b 0d c0 58 41 87 ff f0 4d 63 96 a9 15 1a 27 00 00 00 00 00 00 00 00 00 00 00 00 00 00 >> Overclocking (Not visible)
4a 10 59 7b 0d c0 58 41 87 ff f0 4d 63 96 a9 15 1d 27 00 00 00 00 00 00 00 00 00 00 00 00 00 00 >> Boot
4a 10 59 7b 0d c0 58 41 87 ff f0 4d 63 96 a9 15 1c 27 00 00 00 00 00 00 00 00 00 00 00 00 00 00 << OC Profiles
4a 10 59 7b 0d c0 58 41 87 ff f0 4d 63 96 a9 15 1e 27 00 00 00 00 00 00 00 00 00 00 00 00 00 00 >> ECO
4a 10 59 7b 0d c0 58 41 87 ff f0 4d 63 96 a9 15 37 28 00 00 00 00 00 00 00 00 00 00 00 00 00 00 >> System Status (Visible)
4a 10 59 7b 0d c0 58 41 87 ff f0 4d 63 96 a9 15 38 28 00 00 00 00 00 00 00 00 00 00 00 00 00 00 >> Advanced (Visible one)
4a 10 59 7b 0d c0 58 41 87 ff f0 4d 63 96 a9 15 3a 28 00 00 00 00 00 00 00 00 00 00 00 00 00 00 >> Security (May also be IS visible one)
4a 10 59 7b 0d c0 58 41 87 ff f0 4d 63 96 a9 15 39 28 00 00 00 00 00 00 00 00 00 00 00 00 00 00 >> Boot (actual)
4a 10 59 7b 0d c0 58 41 87 ff f0 4d 63 96 a9 15 1b 27 00 00 00 00 00 00 00 00 00 00 00 00 00 00 >> M_Flash
4a 10 59 7b 0d c0 58 41 87 ff f0 4d 63 96 a9 15 3b 28 00 00 00 00 00 00 00 00 00 00 00 00 00 00 >> Save & Exit

44 0f b7 1d 0d 4e 02 00 49 8b d4 41 be 37 28 00 00 >> System Status

8b c5 eb 5b 4a 8b 04 0a 0f b7 48 2a b8 38 28 00 00 << Advanced
66 3b c8 75 07 b8 02 00 00 00 eb 42 b8 1b 27 00 00 << M-Flash
66 3b c8 75 07 b8 03 00 00 00 eb 31 b8 3a 28 00 00 << Security
66 3b c8 75 07 b8 04 00 00 00 eb 20 b8 39 28 00 00 << Boot
66 3b c8 75 07 b8 05 00 00 00 eb 0f b8 3b 28 00 00 << Save & Exit

@Lost_N_BIOS : If you are looking for AMITSE I’m afraid you will be wasting your time with my links. All MSI BIOS I’ve looked at so far has only language-list and nothing else in AMITSE.

Yes, all changes were made in setup. There are still some settings hidden in CPU menu but I found solution just before getting to tired to execute it yesterday.
Correction form earlier; some(not all) of the inserted sub-menus behave as if they are root-menus, in that they evaluate Escape-key as quit-setup-without-saving.
There is also some other glitches, like:
-Entering Legacy Console Redirection Settings hangs and reboots computer.
-All readouts on ECO page says n/a
-Settings in ECO menu looks changeable in BIOS but they stay on setting from AMIBCP no-matter what you choose.
-Missing fan 2 and glitch in printout on F71808 HW Monitor page.
But I guess this is to be expected with menus not tuned for the hardware.

You are right about the original advanced menu though, one would loose some functionality by replacing it entirely. I did not think of that before, but are avoiding replacing those sub-menus in my current edit.

Thanks, but after finally understanding most of the setup IFR.txt, I believe(as long as we can not find info on AMITSE) that my current method is best solution for this board. If we replace root-menus per you suggestion, we will as you say, loose original functionality. I will upload relevant files again when I’ve unlocked and verified the still locked menu-items.

@h_celine - I am not “looking for” AMITSE, it IS in your BIOS (PE32 module and SetupData module, where AMIBCP changes to settings are saved), unsure what you mean?
I did not use your links for anything related to that, well your BIOS dump I used as a source to pull AMITSE module and setup module from, but I’m not sure what you’re talking about so unsure what you mean regarding language only lists etc?

If you mean AMITSE and IFR output only giving you some language list in a 1KB file, that’s a given/normal, you never get IFR output from AMITSE.
AMITSE is modified via hex or assembly. It controls what’s actually in the BIOS interface, or not there/hidden, Setup module only controls stock settings and their names etc (When NVRAM or AMITSE/Setupdata is not used to control the settings).
All that info I gave you in the spoiler on my previous reply with the @Addresses is from your AMITSE PE32 module, except the list at the very top, which I use from Setup IFR to compare/locate with stuff in AMITSE and edit.

If you want a “In general” idea of what kind of modding I’m talking about here, see this guide I made recently, look in the spoiler at the bottom and you’ll see how AMITSE modifications are done (Normally)
OverPowered TONGFANG CyberPower Machrevo MACHENIKE - Unlocked BIOS Guide W/ Files

@h_celine - *Edit - Here is an example of your BIOS stock AMITSE menu layout/calling function, this is where I would switch using my method. Most other BIOS have additional lists yours does not, that have hidden lists you can add/remove from to enable stuff, yours they never added so can’t "“reveal”


The errors you mentioned (About esc, can’t navigate properly) are why I asked if you want to try my method to see if it works or not, because if it does you wont have those issues at all.

I didn’t compare, what is in your stock ADV that isn’t in the hidden one? If you don’t use security page, and my method works, then you could swap security for either second ADV or Chipset and then not have the esc/navigation issues

If you’re BIOS was normal BIOS, I could enable both advanced, both boot menus, two mains if you wanted and chipset etc. but MSI have either extremely limited the BIOS on purpose, or build all their BIOS on generic limited BIOS and only add in as-needed instead of hiding unneeded stuff like everyone else does.

@Lost_N_BIOS : OK, I misunderstand AMITSE obviously. I believed one was looking for an AMITSE that gave IFR with more than language list in a 1KB file.

Thanks for info, I will look at it.

The things that are in small Advanced menu but not big one are: Fan speed for SYS Fan1, speed readout for SYS Fan1, some settings for com1 and com2, selector between single-/dual-led power-led(this one is gone in my mod as it was the only option in the original ACPI menu that I replaced with big advanced menu). That are those I can remember at-least.

I can try you method to see if it works, but since it will only give one of Advanced/Chipset-menus I see no reason using it as opposed to my solution. The navigation issues are not that big a problem, and one day I might discover how to fix them…

Have unlocked all relevant options in CPU menu, attaching result and relevant files.

bios_newmenu4.zip (3.96 MB)

Section_PE32_image_Setup_Setup_Unlocked_With_Adv-CPU IFR.zip (200 KB)

@h_celine - with my method, if it works, you would not have the esc/navigation issue, but yes there’s only that one menu suitable to swap with, probably best for the new advanced. Is there much you’d use in Chipset, or mainly the other ADV?
I was thinking if my method works, you could put the more used item there in place of security, and then have the least used item replaced using your method, so there’d be less issues getting around the BIOS that way when using the other menu instead of having it all inside main ADV.

Also, I can possibly fix your esc/nav issue if you want, send me your current BIOS as a FPT backup and I will check that out in assembly and see if I can change that from esc=exit to esc=return/back.
For me to figure that out, you need to tell me at least a few places you can use esc and it backs out, vs a few places that you use esc and it doesn’t but tries to exit on you instead.

@Lost_N_BIOS : That sounds like a good idea, the best menus to swap in for Security would be the real Advanced menu. Then I could put the Chipset menu in place of a sub-menu I do not need in one of the two advanced menus.

I will make a FPT backup when I get the chance; that PC is on a stability test that have to run at-least until tomorrow, can not use it while test is running.