Sony Vaio Pro 13 - SVP1321C5E bios issues


Try all the steps again or just step 2?

See edit above. Only try step #2 again, you already have biosreg.bin so no need to re-create. If you do the DOS way, copy your BIOSreg.bin to root of USB too, so you don’t have to do step #1 again.


Tried step 2 again after reboot and got this error ive attached.

Should i try the DOS bootable usb method?


Now, that’s more like it! Thanks, this is normal error, please wait for edit here

* edit - I made a guide for this, you can start at step #6 because I’ve done 1-5 for you
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Since BIOS page with launch to shell is hidden from you, you will need to use this method to get to grub - [Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN (2)
Follow that link, and then at that post, follow the other link and do ONLY steps 1-2, then come back and do everything shown at the link above, just like the image shows.

SMI Lock variable to disable >> 0x91
BIOS Lock variable to disable >> 0x92

So, at grub prompt you will type the following, one at a time, enter between each, case sensitive.
setup_var 0x91 0x0
setup_var 0x92 0x0

Once that is done, reboot to windows and try FPT step #2 again, it should succeed

If all this is too much hassle for you, we can carry on with programmer if you want.
OR!! I can make you new mod BIOS to program in once more, with all this already disabled, then you can program that in and test to confirm step #2 no error, then we can carry on with FPT and you can put programmer away
Let me know what you want to do.


Im gonna give the method youve outlined a go and see if it works


My usb drive seems to be write protected for some reason, i dont know what to do next.

Edit: ive tried a few other usb drives and they all say the same.


This is due to Win10, and or USB3 (or both). I recently noticed the same on my new setup. Use older system, something with Xp-Win7 and you’ll have no issues


Having a hard time getting the grub to work :frowning:

@muteen - Why, what’s the issue etc?

Wipe USB, start over. Go to this post, do 1-2 ONLY <Request> Flagship X470 Gaming 7 Wifi Motherboard BIOS Fix
Then go here, and do everything mentioned after “Edit” and make sure your USB matches what’s shown in the image - [Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN (2)

Then from BIOS choose to boot directly to USB if you can, if not, move your USB to first in list at Boot Device Priority, or at startup hit whatever hotkey is your “Boot Menu” key and then choose USB
As mentioned, we can carry on with programmer if this keeps giving you hassles, it’s not ideal but if we have to - we have to.

I can make this easier for you on next edit, swapping exit page for Save & Exit page, then you will be able to just follow the main guide method from post #24 directly from and wont have to do all the above work around stuff for when you don’t have exit to shell on BIOS exit page.


when i try flashing the usb with the hp tool, i dont see any files in the usb afterwards. ( is that normal? )

i carry on with making the files just like the image and i boot into bios, change my boot options to boot from the usb and reboot.

im then greeted with a blank black screen. :frowning:

Yes, this is normal, if you do not have “Show hidden files and folders” checked in folder options, once you enable that you will see 2-3 files.
Sounds like you may need to set BIOS to UEFI Mode still, or disabled that mode if already set, I can’t remember which way is required for that or if it matters.

If you want, send me new dump from programmer and I will do as mentioned, then you can do this in a much easier fashion following the main guide directly.


No luck, tried it a few times and nothing, even checked if there were files on the usb with hidden files showing and nothing on there. :frowning:

At this point id rather just use my programmer and try the easier method, so ive attached the latest dump of the bios chip:

latest (3.66 MB)

holy cow! i just found the bookmarks for that forum we were talking about and you wouldnt believe but its this website!

(Other Link 1) (Other link 2)


Sounds like you did not make USB properly then, so that would be why. In folder options/View, you need to “Show hidden files and folders” and you need to uncheck “Hide protected system files” below that, this is the one that will make them appear.
If you do that, and still don’t see them, then yes, USB was not made correctly for some reason.

Thanks for dump, we’ll just go this route. Program this BIOS in, and then test to see if you can now dump BIOS region with FPTw and flash it right back (be sure to use new biosreg name so you don’t accidentally flash older one)
If still error with FPT BIOS region flash, I can (and have already) made other test BIOS for you to try and bypass the locks, if you want to try them as well? Not included in this package, in case you just don’t want to waste time on trying stuff >> As noted in next sentence
Or, if you just want to carry on and do mods/flash via programmer and forget about this, let me know and we can do that.

* Edit - Didn’t see your other post until I posted the above, checking links/info now. you already posted first link in this thread previously.
Wait for edit, while I check other links, not sure what you are posting these about anyway?

* Edit 2 - OK, I assume you linked those about the HDD/SSD size limit? If yes, please be more specific, what post #? I don’t see anyone discussing size limits, only trying to get NVME Mod BIOS, or NVME Mod BIOS flashed in etc

Awesome, will try the first method out and get back to you asap!

Edit: sorry its just i realised when i mentioned in a previous post about a thread i read about bios locking ssd it turns out to be this forum xD

and they were talking about hdd to ssd which is a problem i dont have in the first place thankfully as i already have an NVME SSD installed

See my edits above, some not *Marked too I think

see my edits too above xD @Lost_N_BIOS

Here is others I mad earlier, in case you don’t mind trying. Sorry, I guess I should have added previously, but I assumed maybe you wouldn’t want to hassle with it.
For these, be ready for recovery with a good dump selected in advance in case any = brick, these have BIOS modules edited to bypass internal locks
Try in the following order, and after programming each, boot to windows and try to dump then reflash BIOS region (new FPT bios region dump/reflash each time, in case it’s working - and stop testing if one works, let me know which)

I have to run for now, will be back tomorrow night. So I guess you have plenty of time to test these now if you want.
If you don’t want to, it’s OK no worries, we’ll just carry on with edits and use programmer and forget about trying to make FPT flash possible (it’s OK with me, don’t feel forced to test!)


No worries dude will give them all a try and get back to you as soon as.

Doesnt hurt to try i suppose! I always love to learn something new anyways (any suggestions on where to start learning about all this, in general, ill be happy to hear from you about any resources)

Thanks again!


Flashed each of the bios files and ran FPTw after each time and i got the same error (See attached file)

So no luck possibly? im not sure what to do next.

FPTw (486 KB)

@muteen - Yes, thanks for testing, but this one proves to be yet another I can’t bypass these locks in assembly with. It’s not surprising, I’m terrible in assembly
We’ll just have to give up trying to allow FPT use and carry on with mods/edits and programmer.

Sadly, Sony is a major pain for BIOS menu manipulation due to what they do to the BIOS outside of AMI standard method, so we may not be able to get much flipped around either, but we can try!
First, lets test these two odd BIOS settings entries I see! Program in this BIOS, then in “Boot” there should be two new settings both named “Main” Before you look in boot, any new sections across the top?

Change top one to BIOS and reboot, do you see any new main menu sections? Or, do you see only a different “Main” section? Any other changes?
Then also change bottom one to whichever is not default selected, may be tough since both have same name (main)

So, this needs tested in four ways - With Main >> EC/BIOS version one way, then the other Main below this one set to one way then the other, with this one one way then the other
Hope you get what I mean, hard to describe and I thought this was is easier than having you program in 4 BIOS to test

If no changes with any of that, and no new BIOS sections right away with this BIOS, then I may only be able to add whatever is missing for you in the currently visible Sony menus


just to clarify, you want me to flash this bios and then test the bios settings to see whats new?

basically testing out the menu options and reboot after each time?