Stuck Trying to Activate AMT on Dell Opti 7040 (factory-disabled)

Hi Guys,
I have been able to activate AMT on a few Dell Optiplex 7040’s and 9020’s in the past using the method at this imgur post.
I was trying the same method on another Opti 7040 today but ran into an issue.
After dumping the ME flash contents to a file using the Flash Programming Tool (fptw64 -d me.bin -me), I tried opening the resulting “me.bin” file in FIT but I get the following error:
Unable to open file: D:\Temp\Intel CSME System Tools v11 r14\Flash Image Tool\WIN32\me.bin. Reverting to default configuration.

I spent some time reading other posts on the forum and came to the conclusion that this machine has a corrupt ME file system.
I am trying to follow the steps as outlined in section “D4. CSME 11 - 12 & CSTXE 3 - 4” of the cleanup guide
I am at the step where I need to identify what firmware/SKU the dumped image file has inside using ME Analyzer.
However, when I run the me.bin file through ME Analyzer (v1.84.0 r160), i receive A LOT of CRC-16 errors.


If anyone could offer any suggestion on what I can try next, I would really appreciate the help.

I will include the results from ME Info for this me.bin file here, in case that’s relevant (see attached)
and I will also include the me.bin file (see attached) as that seems prudent too.

meinfo_7040.txt (4.23 KB) (3.51 MB)

@markollides - Use another 7040 BIOS or ME that you’ve already successfully unlocked in the past.
Use this file as source for the ME cleanup guide, then clean/update as you want using the guide, save and then once you are done extract that ME region from the BIOS file using UEFITool, then replace into the current system BIOS using UEFITool, problem solved
Actually, if you already have a 7040 that you recently fixed, you can just dump/extract that ME, or if you have the file, extract ME region as mentioned above, then insert into this systems BIOS dump, or flash in however you originally planned to redo the ME region

Hi @Lost_N_BIOS ,
So, the issue with that is that I dont have physical access to any of the previous 7040’s that I have successfully re-flashed.
I also didnt keep the firmware dumps from those previous systems - although I REALLY wish I had now.

I do have remote access to one 7040 but I would need to physically set the system maintenance jumper on the mobo in order to dump the ME firmware to a file again so I don’t believe remote access can help me here.

I was under the impression that, if I was able to determine the version/SKU of my bad firmware, that I could use one of the dumps from the firmware repository to achieve a cleanup in lieu of a firmware dump from one of my previous 7040 converts.
Am I mistaken in this or would you say I am on the right track?

Ohh Ok, then yes, that is an issue! I will redo for you now then, if I have a 7040 dump, I assumed you probably had some of those files.
Yes, you’d have to be there to dump the ME. I have a dump from 7040MT, but I’m sure that systems ME probably has different settings. I extracted 7040 BIOS and extracted the HDR, but the ME file is unconfigured/stock in there, so that’s no help either.

We’ll have to wait until you or I can find a 7040 BIOS dump or maybe plutomaniac knows the solution. He may be able to fix all those checksums, and then give you corrected file to use.

No, you need a ME dump from Dell 7040 to transfer in the specific settings for that system, then you can use stock clean ME FW files in the repo or from the HDR. Let me look around here, maybe someone has posted a 7040 dump we can use.

Maybe @Karson can send us a ME or complete BIOS Dump, I see he said he has access to several

As Lost said, you would need to find another healthy 7040 dump in order to take its CSME configuration by cleaning it via [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization. Then, extract its cleaned CSME region via UEFITool and flash that on your own system via “fptw -me -f me_fix.bin” followed by “fptw -greset”. Ideally you need a 7040 dump but as far as I can tell, 5040 basically the same (Q170 PCH, same OEM Public Key Hash as seen by your MEInfo report) etc. For the 5040, you can find healthy dumps here or here for example.

Hi Guys,
Makes perfect sense.
You can bet I am going to start saving all my firmware dumps from now on, hehe.

Well I don’t foresee that I will have a chance to get my hands on another 7040 in the immediate future.
I’ll do some hunting around the forum this evening to see if I can track down a 7040 fw dump, otherwise, I will go for it with the 5040 links that @plutomaniac left.
I should have some time this evening to perform the cleanup, etc. as well.
I’ll let you know how it goes.

Hi Again,
I am happy to report that I was able to successfully clean and modify the firmware dump for the 5040 using the first of the 2 links provided by @plutomaniac
I actually used the original ME dump (pre-cleaning) provided by snakeman, the OP of that thread.
I was able to perform the cleanup following the guide then modified it to enable the AMT features.
I then re-imaged the Opti 7040 ME firmware and everything worked out. AMT features including remote power control and KVM are now active.

I expected I didn’t need to use the UEFITool to extract the CSME region since this was an ME-only dump I was working with in the first place.
Ostensibly I was correct in that assessment.

Now that I’ve taken a deeper dive into this stuff, I’m curious to learn more (the more you learn, the more you realize how much you don’t know.)
I wanted to ask if you guys could, perhaps, suggest a more comprehensive guide that covers the same area or similar to the Imgur post I linked in the OP (which simply explains how to dump the ME fw, modify it to enable AMT, and write it back).

I also want to thank you both, @Lost_N_BIOS and @plutomaniac for the guidance.
I really do appreciate you taking the time to offer your perspective.

@markollides - glad you were able to get this sorted out, AMT enabled and system up and running!

Sorry, I don’t know of any specific ME settings adjustment guides, but using the cleanup guide, you can pause while in the middle of doing that and look through all the ME FW settings and adjust some things to whatever you want.

@markollides do you have any info on how to do this on the 9020, i have a SFF one that came with it disabled and need to get it working to run hackintosh on it with graphics acceleration