[Tool] EFIFlash v0.80/v0.85/v0.87 for Gigabyte Mainboards

Thanks so much. It fixed my problem on the “bios id mismatch”. It seems that I downloaded the wrong bios to flash I didn’t know it was the Chinese one. I flashed it and it works in updating my bios but now my motherboard is constantly having a orange indicator that is static. Is there something wrong with it?

@Harokki Do you mean a light that sections off the audio chip like this?

Your BIOS was likely reset to defaults with the BIOS flash and the LED has now been reset to default, which is ‘on’.

I see, so there isn’t anything to worry about. I appreciate your help in solving my problems I think I have understood how it works now. Thanks again.

1 Like

@Harokki You’re welcome :smiley:

Hey everyone, i noticed you guys got efiflash to work on your motherboards, ive tried the 470 versions however they were unsuccessful for me. When i load it in, its telling me that my file is the wrong size, i installed the wrong revision of bios on it without realizing and cant go back now, very frustrating. I’m having so many issues with things like ram and networking and im sure this is the problem as i have the wrong rev bios installed, much appreciated to whoever can take a crack at it.

My motherboard is X570S UD (rev. 1.0), is anyone able to write me a modded EFIFlash for the F4A bios? Thank you.

@Gritz Hi and welcome to Win-raid,

If you have flashed a Gigabyte capsule BIOS to your motherboard then unfortunately you can’t downgrade (or cross-flash) your motherboard to an older BIOS using Efiflash.

Intel chipsets have a workaround using FPT (Flash Programming Tool) but I am unaware of an equivalent software tool for AMD chipsets.

You may need to buy a EEPROM programmer to flash the motherboard BIOS chip with the correct revision BIOS.

If you are not sure what I am talking about then you may want to read these threads:

[GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher

[Guide] Using CH341A-based programmer to flash SPI EEPROM

Thanks for getting back to me, this forum is actually very cool, didnt know it existed until now. The bios i actually have installed on it is F33g from the rev 1.1, so it is an older bios so im not trying to go backwards, its just the size limit that is stopping me from upgrading, im trying to go to a newer version. Does that matter or am i still out of luck?

@Gritz If you have tried the modified version of Efiflash v0.87 and it does not work on the X570 chipset then it is possible that you may need a later version.

@dsanke If you have a spare moment could you please provide a link to the modified EFI version of Efiflash v0.99? Unfortunately I can’t access it on smxdiy.com

Thanks in advance.

Efiflash_v0.99_mod.efi.zip (58.3 KB)


@dsanke Thank you so much for the fast response and upload!

Thanks for this, although it was unsucessful, still have the bios size mismatch, looks like ill be buying a new motherboard for chirstmas, thanks for the help.

Try this [Tool] Flashrom v1.2 [DOS] [AMD]

1 Like

Hi guys,
I have Gigabyte Z690 Gaming X DDR4 (v.1.1) mobo and I can’t flash modded bios even with modded efiflash 0.99 :confused:
Bios was changed with UBU tool - standard update of cpu microcodes, vga module etc.
To original bios from gigabyte site new efiflash v1.0.1 was attached. Maybe someone could modded this version?
Efiflash_1.0.1_not_modded.zip (57.4 KB)

Doesnt that board have USB Q-Flash Plus feature… not accepted? Asus still does…
Intel FPT tool can also be used if possible… and internal EFI Q-Flash fails verification of the file?

EDIT: I didnt suggested to use the presented EFIFLASH mod files on this thread as they were for previous motherboard models, i asked if you tried the other options…

When I use modded efiflash with bios file which was changed in UBU system read file then reset into the q-flash and after that error appears:
Invalid bios image

Those with Intel chipsets that want to flash a recent Gigabyte BIOS that has a capsule and has been modified will likely need to use the relevant version of Intel’s Flash Programming Tool (FPT) for their chipset.

WARNING: You can erase/overwrite the MAC address of all Intel ethernet adapters on the motherboard with FPT so make sure you have made a full BIOS backup and record your Intel MAC addresses somewhere!

NOTE: The “-savemac” command should be used to retain the MAC address(es) for Intel ethernet adapters when flashing anyt BIOS with FPT.

1 Like

It is clear for me that I need to use FPT but which version is suitable for Z690 chipset?

P.S. I was able to update modded bios using USB Q-Flash Plus method - thanks to @MeatWar. But the quiestion is still open: which version of FPT should I use and where can I download it?

The Intel FPT tool is related to the ME FW version from the chipset.
Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15) - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (16+) - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

Theres no tools for ME16 at least to my knowledge.

Agree. I do not have any luck finding ME16 package tool. There is only FWUpdLcl64.exe and FWUpdLcl.exe on ASUS webpage here - inside MEUpdateTool.

how to download this amazing tool?