[Tool] EFIFlash v0.80/v0.85/v0.87 for Gigabyte Mainboards

@dom191984 Glad to hear everything worked out thanks for reporting back.

I’m writing here just to say THANK YOU!

i have a GA-970A-UDP3 motherboard rev 2.0 that crashed in a power outage, when i turned on the rig the legend “Main BIOS corrupted, recovering from BACKUP BIOS” appeared. Soon after the flash ended, the motherboard wouldn’t turn on anymore. I tried different PSUs with no results. Soon i discovered that the motherboard would turn on, only with the cmos battery removed and a fresh psu restart, but will no longer work if you shut it down or reset. I tried downloading the latest BIOS on the gigabyte website, and for my revision 2.0 the files were FA, FB, and FC, this last one being the latest version. When i tried to flash it ID VERSION MISMATCH came up, the BIOS recovered from backup flash displaying in the cmos setup was version F1, which is for revision 1… i double checked the revision number just to be sure and i was downloading the correct BIOS but i was unable to flash it. The motherboard came with an incorrect BIOS revision in the BACKUP BIOS from the factory, and the only way i was able to flash the BIOS for revision 2.0 was using this software. As soon as i flashed the correct bios revision using the /x (force) option, everything started working fine after.

Thank you so much, i was able to fix my motherboard from a faulty factory backup bios!

@SonicDcer That’s quite a story, it’s good to hear that you managed to get the motherboard running normally again!

Not tried it yet, but it looks like all Gigabyte maintained boards are switching to capsule BIOS.

It might be a good idea to use UBU to remove the capsule and flash this way from now on?

Just thinking for QFLASH users, if you were to stay on the official track surely QFLASH will be updated to only accept .CAP?

When I try to downgrade from f12 to f9 on a z390 aorus pro, I get a message about error because secureflash is on, and that in 5 seconds there will be a reboot … Then a countdown of 5 seconds passes and nothing happens, the command line restarts. Only mod 0.87 works for me, other versions give a file error. But still no results.

@zoomcool7 Yes this is a deliberate decision by Gigabyte to stop you from downgrading to previous BIOS due to “major vulnerabilities concerns”.

The F12 update for the Z390 AORUS PRO says:

Introduce capsule BIOS support starting this version.

Customers will NOT be able to reverse to previous BIOS version due to major vulnerabilities concerns.

I have posted a guide on how to get around this limitation here.

Please read the entire guide carefully as you can overwrite/erase your Intel ethernet MAC address!


Thank you so much!
However, this did not solve my micro freeze problem =(

Hey, i have 2 computers runing a motherboard from PCWARE (Gigabyte based mobo), their model are APM-A320G, i needed the F55 bios to run Ryzen 5 4500 in them, but PCWARE couldn’t provide them the day i was building those 2 machines, so i downloaded the F55 bios from gigabyte for the mobo A320M-S2H and forced flash using the modded efiflash 0.87 i found in this forum, modded by Dsanke’s, that made the two machines works properly with the new ryzen, everything was okay, but the VGA vídeo out isn’t working, so PCWARE sent me their new F55 bios for this particular mobo APM-A320G, i tried to flash them, using the same efiflash 0.87 modded, but i got this error message: “BIOS is protected by SecureFlash” “System must restart to complete BIOS update process”, i restart the machine, tried to flash many more times and always got the same error. i’ve read something about capsule bios but i haven’t uderstand it, i have an SPI programmer that i will use as last resort, but i wanted to flash them in DOS as i did before, have any clues in how to resolve this? tried to turn secure boot off, CSM off, TPM off, etc but haven’t worked… Pleaaaaaase help :slight_smile: @chinobino

@Natalinus007 [Edit] FPT will not work with an AMD chipset - my apologies.

Is there a chance this will work with an Asus board?

I’m trying to flash an Asus pre-built desktop that comes with a Prime B550m-K motherboard. The pre-built hasn’t had a bios release since January. The Prime has several newer releases but can’t crossflash using any tool I’ve tried thus far.

@D2theZ28 No. Most Asus boards have locks that prevent you from flashing the BIOS EEPROM using software. You will likely need a BIOS programmer (such as the very cheap ch134a).

I can’t seem to download any of the zip files when I click them a new tab opens and closes by itself and which version should I use I have Z390 Aorus Elite

@4TECHGAMERYT Hi, it sounds like your browser or anti-virus may be blocking the download. Perhaps try a different browser first. You could also try right-clicking the links and selecting ‘save-as’.

If you are flashing an official BIOS that has not been modified then use the latest release (currently v0.98 for DOS and v1.00 for EFI shell).

turned off windows smart screen and it still won’t let me download it. any other ideas?

Besides a “Healthy” OS
ISP/Country restrictions…
TOR browser or Opera with VPN enable

1 Like

this worked. thanks man!

1 Like

Hello. I want to update my BIOS which is GA-B150M-D2VX-S1 and is modded by revlaay’s AIO Tool. Is there any download links or a way to update my BIOS?

@Haroki Hi, yes you can update your BIOS using Efiflash - there are download links for Efiflash in the first post.

If you want to flash a modified BIOS that sometimes can’t be flashed by official EFIflash versions then try the modified versions made by Dsanke.

@chinobino Thanks for the reply. So if I replaced the original Efiflash that I installed on the Gigabyte website to update the bios system with Dsanke’s modified Efiflash I would be able to update it right? Because, I tried updating the bios using the original bios that I installed from gigabyte website and it showed me “bios id mismatch”. I am trying to update my bios to the latest version. Sorry I am kinda new towards all this stuff. Pardon me for asking too much questions.

@Harokki Yes, Dsanke’s modified version has BIOS checks disabled - which means you can flash your motherboard with a modified BIOS or cross flash another motherboard’s BIOS.

Are you attempting to flash the GA-B150M-D2VX-SI to the latest official BIOS? You shouldn’t be getting the “bios id mismatch” message with either Q-flash or Efiflash.

On the Chinese Gigabyte page for the GA-B150M-D2VX-SI the F23d BIOS from 9th March 2018 is the latest BIOS and should not require the modified Efiflash - is this the official BIOS you are attempting to flash?

If you are attempting to flash any modified BIOS you will need to use Dsanke’s modified Efiflash.

If you are attempting to cross flash to a BIOS for the GA-B150M-D2V I would strongly recommend you to make a backup of the original BIOS before you attempt to flash anything.

Make sure you know how to recover from a bad flash in case the motherboard won’t boot and also note you will need to use the modified Efiflash to cross flash to a GA-B150M-D2V BIOS, if that is your intention.