[Tool] EFIFlash v0.80/v0.85/v0.87 for Gigabyte Mainboards

@acseyang Hi and welcome to Win-Raid forums.

As you have not tagged anyone or mentioned any names I am not sure who your comment to directed at.

The EFIflash links are in the first post and I have now uploaded all EFIflash versions to this MEGA folder.

Currently there are no tools for ME 16 (if that is what you are asking).

The problem I encountered was as follows.
After getting a completed BIOS update screen after launching efiflash with the needed version, the BIOS version didnt change at all after checking after the first reboot. There too were no reboot time that took more than one reboot to return to a boot from my normal drive.

What were the differences between the firmwares?

If you mean the BIOS Version then i tried to Update from F23 with EOMID to a F24 comercial. Because my retailer i bought the PC from may have used custom Gigabyte Mainboards but thats Not so likely, i Just wanna Test Out ever Software option i got.

This is an older thread with rather low activity about a tool that doesn’t seem to work for very new boards according to chinobinos post from february.

So to get a constructive answer it might have been useful to provide some more details like tool- version used, system used, commandline used, type of board, type of ‘custom’ gb board, maybe even a screenshot of the process, maybe add link(s) to actual firmware and firmware that’s to be flashed?


Otherwise maybe:

Good luck


I have a b660m motherboard. I tried to flash the bios uding the modded one, but it gets stuck after the transfer success line. It does not touch the flash itself.

Try the fpt method from your SKU ME engine. ME FW 16 if not mistaken

Hello. I have very strange problem with flashing my motherboard Gigabyte AX370M-DS3H which is branded with TERRA logo. There is F23 BIOS. And now: Q-flash giving Oemid Mismatch error. So I tried 4 versions of moded efiflash, I tried flash F23 (this have older date than installed on motherbord), F24, F31 and finally the newest F51m. The flashing seems to be successful. Always reads the Bios file, writes, verifies, restarts, but i have still F23 bios with TERRA logo. Any sugestions?

@erni123321 Hi and welcome to Win-Raid forums.

For your OEM AMD chipset you may need to use a different tool such as Flashrom.

As I do not own any AMD motherboards I can’t test this - if you can’t recover from a bad BIOS flash it might not be worth the risk.

I have a Gigabyte B550M DS3H AC and I am using the Efiflash_v0.87_DOS_Mod but for some reason it wont complete the “Transferring Bios Data” and it does not reboot automatically. When I reboot manually the bios has not changed.
If I use the original Efiflash with an original bios file it works fine but I cant use my modified bios. I have tried all of the different modified versions of Efiflash.
Any idea why it is not working or what I can do instead?

@SteveW Gigabyte has implemented new security for the B550M DS3H AC BIOS as of F14.

Once you have flashed any capsule BIOS you cannot downgrade or flash a modified BIOS using Q-Flash or EFIFlash.

As I mentioned in the post above, you could try Flashrom - other than that you will likely need a hardware programmer.

1 Like

Hey all,

My goal is to flash a retail BIOS onto a GIGABYTE MODEL X 11TH (intel) prebuilt that seems to have an AORUS Z590 XTREME motherboard, but Q-Flash and EFI shell methods have not worked. Q-Flash tells me that the BIOS I’m trying to install is incompatible, and when I tried via the EFI shell… nothing seemed to happen. Perhaps I did it wrong in the EFI shell.

I bought this thing secondhand for an absolute steal of a price, not aware that the thing comes pre-loaded with a dummy-proof BIOS that disables overclocking. Lesson learned, I guess. Nevertheless, I’ve spent a little over a month searching for some guidance on how to go about this. Surely it must be possible, right? I’d like to know if any of these EFIFlash tools posted here could help me out. If not, surely an SPI programmer could get the job done, no? I’m not a layman when it comes to technology by any means, but I’m definitely not up to speed on BIOS hacking/modding. If any of you brilliant folk have any insights on how to go about this, or any guides to SPI programming (given that it is possible in my case. By the way, is it?) I would greatly appreciate it.

@jxding Hi and welcome to Win-RAID forums,

You can possibly flash an official Gigabyte BIOS to your motherboard using Intel’s Flash Programming Tool (FPT).

You will need to download the CSME Tools for your specific chipset (either CSME System Tools v15.40 or CSME System Tools v15.0) depending on which version of ME firmware is currently on the board.

You should read this thread and also download the CSME tools :

Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15)

Before you attempt to flash the motherboard please do a complete backup of your current BIOS using the Windows version of FPT from a command prompt:

fptw64 -d bios.bin

WARNING: Unlike Qflash or Efiflash, FPT will not check if you are flashing the correct BIOS to a matching motherboard so you can brick your motherboard if you cross-flash the wrong BIOS or file! Be very careful!

2ND WARNING: As your motherboard has an Intel (2.5GbE) Gigabit Ethernet Adapter you can potentially overwrite (erase) the MAC address(es) with FPT causing it to no longer function! Although the MAC address may be recoverable it is a big hassle that you will want to avoid. You will know if you have erased it if it displays 888888888788 as the MAC address.

To check if your motherboard has any Intel ethernet adapters and at the sametime backup the MAC address(es) type the following commands;

fptw64 -gbe -d gbe.bin

If you don’t have an Intel NIC (or there is no GbE region in the BIOS) you will see the following;

“GbE region does not exist!”

DISCLAIMER There is always a risk when flashing the firmware of any motherboard. You must decide if you think the risk is worth it - if you don’t know how to recover your motherboard from a bad flash then I don’t recommend that you attempt a BIOS flash. I am not responsible for any problems that arise from your actions. It is recommended to have access to a hardware programmer to recover in the case of a brick.

After copying the BIOS file you want to flash into your FPT folder use the following command to flash the entire EEPROM (all BIOS regions are overwritten i.e. Descriptor, GbE, ME and BIOS);

fptw64 -SAVEMAC -f BIOSName.bin

The command -SAVEMAC will retain your Intel MAC address so don’t leave it out.

If you have any questions please ask.

Thanks chinobino,

I do have a few questions. I made the grave mistake of using EasyTune to enable XMP (I was desperate), which my computer did not seem to like very much at times. Sometimes the computer would just randomly blackscreen, no BSOD, and everything would seem to stop working. The only way I know to fix it is by holding the power button. This issue has persisted even after all overclocking was disabled and Easytune was uninstalled/memory integrity restored. Ran windows memory diagnostic (haven’t got around to memtest86) but nothing turned up. Reset the CMOS and now my PC doesn’t shutdown properly when I click shutdown (it says “Shutting down…” and then after the screen goes black it immediately brings me to the login page). My best guess is that this is due to BIOS corruption of some kind, so my first question is, should I try to reflash the current BIOS to the chip before using the FPT tool to back it up? Would that corruption matter in this process?

Also, this motherboard has a dualBIOS system, does the FPT tool only affect the current BIOS? Not sure how the BIOS_SW works, my most basic guess is it controls a bunch of tri-state buffers that switch the EEPROM currently in use, but I would also think that the motherboard could be able switch it automatically without moving the physical switch, so I’m not sure.

I’m finishing up finals week here, so I’ll be ready to try all of this out some time next week. I’m not too worried about bricking the motherboard since (hopefully) with the help of this forum, I can probably figure out how to use an SPI programmer to reflash it with my laptop, or just use the backup BIOS in the event that nothing works out (and it’s still functional, that is).


As you likely know, your motherboard has a switch labelled ‘BIOS_SW’ to manually swap to a 2nd BIOS chip if the first get corrupted and the system can’t POST.

The manual says Main BIOS is switched to the right and Backup BIOS is switched to the left.

Don’t try to boot from the Backup BIOS until you have verified your RAM is error free or you may corrupt it also.

You should use FPT to make a backup of both your Main and Backup BIOS before you attempt to write anything.

FPT will only see the currently active BIOS, so you will need to use the BIOS switch to dump both chips.

If you upload your BIOS dumps here they can be inspected to see if any regions have been corrupted and check if they are even the same version.

Do you also have a copy of your OEM BIOS and a link to it?

It sounds like you may also have some Windows corruption or your profile could be corrupt. You could try creating a new Windows user profile and see if the PC will shutdown.

Have you tried running Windows System File Check (SFC) from a command prompt to see if Windows is ok? e.g.

sfc /scannow

Running memtest86 is a good idea, you will want to make sure your system is 100% stable before you attempt to flash any BIOS.

To ensure that CMOS is cleared completely you could also try unplugging all power from the motherboard (including the 24-pin ATX main power connector and CMOS battery) then leaving it for at least 15 minutes to allow any residual power to drain and then boot into the BIOS and load optimized defaults - then check if Windows will shut down.

Please don’t write anything to your BIOS chip until your RAM is proven to be ok and you have a backup of both BIOS chips.

I have indeed run “sfc /scannow” multiple times since my shit started to stink. It did find corruption the first time, and I just ran it again to find nothing.

Here is the support page for the godforsaken thing:

BIOS hasn’t been updated in years.

I’ll run memtest86 next week when I finally get the chance, and if all goes well, I’ll dump the backed-up BIOS’s here and we can hopefully get to the bottom of the corruption.

1 Like

@jxding Yep, sounds good.

I don’t understand how to use this. It doesn’t seem to work like the .exe files. Should I change the extension?

@DiscoStu Hi and welcome to Win-RAID forums, Efiflash is a command line utility that should be run from either an MS-DOS bootable USB stick or from a UEFI shell.

I got that, but all versions of Efiflash up to 0.87 were .exe, and 0.99 is .efi. How do I use a .efi file?