Transfer lost serial UUID into fresh bios file.. Please help..


Think I blanked my bios rom accidentally using incompatible version of flashing program and only software that works is ASProgrammer 1.40.
Assuming that all of the serial and UUID MAC info is lost how do I make new ones if I did not have a backup bios to work with??

Thank you.

Please first add a link to stock BIOS. Then add a zip of all stickers on your board, and the box too if you have it.
On the board, be sure to look on top/bottom of PCI/PCIE slots, on and on sides of LAN metal box, on the plastic I/O cover if there is such a thing on that board, side of 24pin connector, and back of board too if any stickers.
Check your router logs and see if you can find your MAC ID, in case it’s not on a board sticker, I bet it’s there but if you can check router logs and confirm against sticker that would be great.

I’ll get you a BIOS made tonight. Worse part is NVRAM volumes will be lost, maybe I can find a similar dump to use for those.
If you can find a random dump, or know someone that will give you a BIOS dump (even Region if that’s all they can do, unless universal BIOS backup toolkit works, that will be OK), along with their serial, UUID and mac, so we can find all the proper locations it should be.
If not, I’m sure we’ll find the way. Check your other post about this, I replied about the erasing and maybe how it happened, or maybe that it’s not erased and something else making it look that way now.

Well I will not be able to do so until after work tonight however as a student of the modding arts I would like to learn how to this procedure myself. In anycase I’m not even using this Z270-WS motherboard anyhow as I got a replacement APEX IX board on sale last week. So the processor is now in a new motherboard but wanted to try a coffeelake mod on the old spare board. My first step was to try to backup the bios. I should have done that when it was in a running system but did not think ahead. Anyhow the problem is that the stupid flash programmer version 1.18 - 1.30 must have messed up the rom chip when it was trying to read. I didn’t even select erase or program anything at all but ASProgrammer 1.40 is giving me all 'F’s in the rom reads so I assume the rom is erased.

Anyhow thank you for offering to assemble a new rom for me. I’ll look for the MAC address tonight and send you a link later tonight but if you would please detail the procedure I would appreciate it,

Thank you

No rush here, and yes I will tell you where it all goes and how to put it in there once we sort it all out

On ASProgrammer, are you selecting the correct ID? And are you sure you have the ID 100% correct W25Q128FV or BV, not something else directly after 128 (Some chips are 1.8V and would give you these results is why I ask)
You can try unprotect then read and see if that changes anything. Be sure you are connecting it all correctly too, and try with/without CMOS battery, power connected etc.
Also be sure to read what all I mentioned here [Guide] Using CH341A-based programmer to flash SPI EEPROM (20)

What OS are you using? I believe ASProgrammer is OK on Win10, but I’m not 100% sure, so if you can you may want to try Win7 real quick.
Also, you did install the CH341A PAR (parallel) driver correct? If not, it’s in this package, you only need to install it once -…257455007472602

Are you certain the connection is good, something to consider too, if you know it’s all connected properly, due to this testing done here by @lfb6 - [GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher (With Pictures!) (4)

Well my bios chip is actually W25Q128FVSQ not W25Q128FV so I don’t know if that will cause a compatibility issue. Tonight I will try to install the drivers on another machine and try again. I believe I have followed the guides instructions correctly placing pin 1 to the red wire on the adapter and on matching the dot on the bios chip to the red wire on the soic clip. I posted photos of my setup in the CH341A guide you referenced. I also tested the adapter and clip on a cheap obsolete netbox system board first to verify I had it all connected correctly which worked. Didn’t try ASProgrammer with battery however. Thought I wasn’t suppose to but will try. Also using Windows 10 on my notebook which because its a high resolution 3200x1600 screen the icons on ASProgrammer look really small.

Heres my bios chip pic:


Was able to pull a proper dump of the bios this time using my ‘FlashcatUSb’ programmer device. Guess its always good to own two devices. I used the information from this thread:…p-PCIe-x16-slot

and wired up the connections from the SPI header of the Asus Z270-WS to my FlashcatUSB programmer:

Now that I have a backup I would imagine my serial numbers and mac addresses should be in there. Will check the file and report back!


Your chip is W25Q128FV, that’s all we needed to know for this. I just posted a reply for you on the other thread, lets keep this all on here, so we don’t have replies in two places about the same thing.

But, please be sure to read my reply there, I answered you about the SPI pinout, and asked if you have already tried USB Flashback yet or not (This I’m very curious about)

Please use smaller images, or attach with forum software, thanks. Maybe just loose or not consistent solid connection with the SOIC8 test clip cable, this is common until you get used to using it often.

No need to remove CMOS battery, or power, sometimes one or both required to be there in laptops or certain desktops, but only there on laptops have I seen sometimes you need to remove one or both.

Sounds like you were able to dump finally over SPI, you can do that with CH341A too, but you need to use the serial drivers instead of parallel and you need to move the jumper on the side to 2-3 instead of 1-2

You should be able to fix BIOS, if corrupted, via USB Flashback, even without CPU as that’s it’s designed purpose. I’m curious to know if you’ve already tried that, and then tried to use the board with CPU again?

Yes, serial and MAC will be in your dumped BIOS, UUID too, all possibly in several places. If you need help locating everything send me a copy of your dump and I will show you where it’s all at (no need for the info at first, I can find without knowing, only need to send me that if I can’t find which I doubt )

Why would I need the serial driver on the PC side? It’s the way the CH341A is seen from USB(PC-)- side- why would I want to change this?
Jumper 2-3 means TTL- mode and 1-2 SPI mode? It’s still the same chip, just another way to connect to it?
(No critics, just trying to understand)

If he was using SPI mode, but yes, now that you mentioned, I guess cables would still go into same place on this programmer (in the socket), unless he used the side pins and DuPont cables.
Yes, the jumper is for SPI mode, those pins on side, and you are correct, no need to use those drivers I mentioned unless using those pins. I’ve never used this, so not 100% sure, only going by what I read previously.
If cables still in main socket, then yes, as you mentioned, no need to move the jumper or use the other drivers, thanks for pointing out!

Well I had tried 10X over to connect the soic-8 clip to the chip and couldn’t get a good read. Reason being I am guessing that the wiring of the soic-8 cable might not have been correct. I thought it was because the very same cable hookup worked on a cheap netbox motherboard bios chip without issues.
Anyhow using the motherboard SPI header worked perfectly and the Flashcat software instantly identified the chip and was able to save a copy of the rom image which had all my serial numbers verified via FD44Editor.

About have I tried recently to reflash a bios via flashback I have not as of yet. The motherboard hasn’t been assembled yet with other components like psu or anything to get it going yet. I will soon in the coming few days.
Last night I experimented with Coffetime and the other Easy mod tool for coffelake mods. Turns out Coffeetime chocked on my bios file, that I had modded its microcodes prior, trying to update the microcodes though had no issues working on the stock bios. The easy-tool had no issues either way.

Anyhow will post in the coffeetime thread from now on as my issue trying to read the bios rom has been solved.

But wondering now that I can flash via a programmer I no longer need to short any pins or pads?

Thank you

Yes, wiring must be correct in the cable since you dumped the other board. Some chips are harder to keep a good solid connection on than others.

Shorting pins/pads is only for using Coffee CPU in Sky/Kaby board, if you mean that, if yes it would always need done. If you mean the pin by “BIOS” chip (not actual BIOS rom), to enable super flashback they were discussing in the other thread, then no, you don’t need to do that if you’re doing to use SPI header and your programmer.

However, to make life easier on yourself, take any BIOS, current one, and dump it with programmer, then modify the FD to unlock all regions per this guide second spoiler (probably image two), and then program it back to the board.
Then FD is unlocked and you can write any BIOS region, or entire BIOS at once with FPT if you want, never have to use programmer again. If you do that, don’t flash in entire BIOS with locked FD though or it will be locked again, just flash BIOS region (FTPw -bios -d (Dump) or -f (Flash) file.bin)
And also do not FPT flash in stock BIOS region, always dump then edit, then FPT reflash. If you need to update BIOS and modify, then flash in the stock BIOS using stock method, then dump BIOS region via FPT, edit/mod, then reflash via FPT
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing

I was reading and studying that guide since this morning and have learned to unlock the FD descriptor tables but wonder how wise that might be to do so on a security perspective. I mean all I really care about having access to is the bios and ME regions. Everything else I don’t care but for simplicity sake I guess I will unlock them all. Not sure. Anyhow the guides description on v2/v3 variable locations isn’t 100% accurate I’m finding out experimenting setting them to FF and noticing which fields are enabled in UEFITool. All thats left is to turn off the Asus bios lock thats enabled by default. Want that turned off permanently but confused where to make the change. In the past I have always modded the byte code in the setup program but I am learning its also possible to that in the efinvramvariables file. The problem here is that searching for a string of default values corresponding to a range of setup variables gives me like a dozen locations in that efi nvramvariable file. Do I change them all??

Anyhow you’ll never guess what I discovered about my MAC address using FD44Editor. For one the MAC address was set to a non unique value like 88:88:88:88:87:88. I’m guessing since I bought this motherboard as an open box refurbished board the supplier probably didn’t care to put in the proper MAC address which I believe I found on a sticker stuck to the power connector. Though got to say I’m not sure what went wrong with using that SOIC clip with the CH341A. I mean it worked on another motherboard. Perhaps it just did not have good contact like you stated before.


Only someone with physical access to your machine would benefit from an unlocked FD, so unless hackers are sneaking into your building and trying to use your system, then nothing to worry about
But yes, you could choose to only unlock the ME/BIOS regions if you want, but then you have to worry about ME hacking then J/K

Do the BIOS lock at Setup module, or the submodule that contains BIOS lock (Sometimes it’s a submodule that ends in a bunch of 00000’s, instead of the PE32 of setup)

MAC address you can fix in GbE region of BIOS (usually at 0h, sometimes copied at 1000h), this can be flashed back in via FPTw.exe -gbe -f gbe.bin

Yes, it’s hard to say what happened with the programmer initially, but at long as it’s sorted out now nothing to worry about… Until next time (Get a good full BIOS backup made - FPT complete BIOS dump after FD unlocked, will be same as full programmer dump)

Just got that joke just now! Oh! ME hacking!