Unlock N970TF InsydeH20 Hidden options

Just upgraded to a Clevo based laptop, from an HP. Seems the bios utilized on these models allows for easier editing. I just glanced around, and seen quite a bit a options I would love to be able to tweak.

I have a CH341A to get the bios with. But unsure how to know what chip to look for? HWInfo?

Here is what I was able to pull via H20FFT bios.bin

Any help, or pointing to guides relevant would be greatly appreciated.


The clip for my CH341A doesn’t want to connect to the chip. So awaiting a new one.

@rlkd82 - Try with and without power/Main battery installed, some systems need this there, while others removed, and it will seem like no connection is being made if condition not met that your system requires.
Are you sure it’s the cable/clip and not the above? Can you dump BIOS from other systems with the cable, or not? If not, then yes, maybe the cable is bad or clip/cable connections etc.

Many Clevo BIOS is easy to mod, especially if AMI BIOS, and even more-so if it’s Intel CPU because you can just dump BIOS with FPT and reflash mod BIOS same way (once locks disabled, if in place)

Please re-upload your BIOS to another site, that site has virus on it. TinyUpload or Sendspace would be OK

To find BIOS chip, if you are not sure, upload an image or two of the board, if large images please put in a zip or 7zip.

Also, please link me to stock BIOS download if you can, I couldn’t find it on there site - I see this is common practice, since most are rebranded with some other brand name, so what brand is yours rebranded to be?

It was defiantly a bad clip. It would show connected, but never read anything. The one time it did, it wasn’t a good read. Amazon has a decent one with 1 day shipping so Ill be able to get back to it tomorrow.

This is a Clevo Insyde H20 bios. Even has a sticker underneath the ram slot. It is a rebranded by Eluktronics. For the price, its great. I have a delidded i9-9900 in it and its quite the powerhouse for a crazy price. Spoke with their support, and they didn’t want to message Clevo for an unlocked bios. Gave me some excuses why.

Im able to dump the bios no problems, but gives me an error regarding a locked ME when I try to flash it back.

Here’s the bios again. Sorry hadn’t realized that site was shady :frowning:

Also here’s two bios files I found for it. Bios

Heres a picture of the chip Heres the manufactures page, data sheet can be downloaded from there as well.

Connected, but not reading could be due to software version, or you need power added/removed as mentioned above. But yes, could be bad too, you’ll find out soon enough.

Thanks for the BIOS files. ONce you get new clip, dump the BIOS and send to me

Having a hard time dumping via programmer. battery removed, power removed doesn’t seem to make a difference. Any suggestions?

Keep trying, sometimes I have to clip a BIOS 10 times before it’s perfect. Make sure all is connected properly, if you are not sure take some images of your cable connected to the chip, chip without cable connected, and show me how you’ve got cable going into programmer too.

Programmer may not be needed since this is Intel CPU system.

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error given >> FPTw.exe -bios -f biosreg.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)

I currently have my laptop together, so went thru the steps requested. Here is the biosreg.bin.

All went well, and it flashed back as you can see here.

Also may be of use, here is the bios it flashes via windows. Snagged it outta the temp folder. Unpacked bios

See, no programmer needed then! At least not for modifications within the BIOS region anyway
Link me to the stock BIOS package from manufacturer, thanks. I don’t need extracted, and I want this to keep in folder for these BIOS, I don’t need it for mod BIOS though so not a huge deal if you can’t find a link again.

Please zip up a package of all your currently visible BIOS pages, all settings on all pages.

Your such a cool dude, thanks for putting the time and effort into this ;).

Heres most current bios I can find. 1.07.06 iirc.

If theres anyway to base it off this bios dump, that would be fantastic. I had downgraded to ver 6 and this is the latest I can find which is 7.

Give me a little bit and I’ll have those ss for you.

Thanks again!

This is probably easier. Heres the manual. Starting on page 127-149 is all the bios windows/settings ;).

Anything I modify for you will be made from your FPT BIOS dump, or at least that would be ideal. Why are you now linking some other dump?
If you are now currently on V6 BIOS, but you want to be on V7, then update to that BIOS and send me new FPT BIOS region dump, simple.

I cannot use manual for this, must be actual and current BIOS images, and if you are wanting to upgrade to V7 BIOS do that first too.

There is no release of ver 7.

Ill get those pictures, shortly.

Here ya go.

That ver 7 was dumped via fpt, just full bios no region. I might have a region dump around here, but you seem to be annoyed by the request so no worries :wink:

What do you mean no release of V7? how did you get it on there then? No, not annoyed at all, sorry if anything sounded that way.
Your posts are a little confusing, that is all. Linking a bunch of dumps, random stuff etc, I don’t need any of that so it makes it messy here.
Plus, yes, I do dislike Insyde BIOS, but only because I can’t always get it figured out

Is the above V7 FPT dump, from your system? What do you mean no BIOS region only full? You can’t dump full BIOS unless you unlock the FD, what command did you use? If you used just FPT -d filename.bin that would dump FD, maybe ME, GbE and BIOS region.
But no matter what, as long as BIOS region is there it’s OK.

All I need, is you to be on V7 BIOS since you wanted to be on that, and have already used it in the past, then dump that BIOS region
Then send me images of BIOS. That’s all we need here

Sorry for confusion. I downgraded from the ver 7 that came shipped with my laptop to ver 6. I had just wanted to get back to 7 if possible. Clevo made that for the reseller and they will not give to me.

I did indeed get it via Fpt -d

bios.reg file above is my current region dump

So found someone to mod the bios for me. All was great until adjusting ram timings. Bios locked up and refused to reset. I spent good few days trying to reset it.

Then tried to flash a copy of the bios, but durning the flash the ch341a unit I had burned up. Main chip started heating up, and I immediately pulled it out of the usb slot.

Bought a bus pirate, so via flashrom im able to see a generic chip. But it wont go any furture due to that. I managed to use another version of flashrom from somewhere else in my quest, and it read a bit of the chip unlike other versions and seems the chip is full of 0’s. So pretty sure I have one messed up chip.

I currently have a unprogrammed chip on the way, and was curious if theres a way to force flash this chip before I get the replacement? I cant find anyway besides utilizing a script in bus pirate terminal to force flash. Which to be honest is way over my head.

That’s probably an invalid read, not a 0’d chip, that’s rare, especially from simply changing a setting to one that fails to load.

I’ve never used buspirate so I can’t help, I only know CH341A and windows software. Install windows, use that, and yes, you can then program in any BIOS you want.

In the process of flashing the ch341a burned up on erase. Hence the 0’s, no manufacturer name/model.

The part that worries me the most is ec. From what I gather, when the board will not respond to ac input/charging of battery/power button you have ec problems.

Looking at the system block in the service manual, shows the bios spi as an individual chip, and thermal sensor, batt/ac, fan, and ec residing on the ITE chip.

My question, would a blanked out bios chip disallow the ec from functioning? Or should I also be ordering a replacement chip for ec as well?

Buspirate can be interfaced via windows/linux as it has its own command prompt, or utilize flashrom. Tbh though, the steep learning curve involved in writing a script is both annoying, or in my case very welcome. Ch341a’s for simple jobs I see the value. In my case I wish I never touched my system with one. Im one of the extremely unlucky ones it seems. Just my luck.

So the CH341A shorted out, may also shorted the board/BIOS too? Did it spark or smoke, or just get hot?
I still doubt chip is blank or 0’d If it just got hot, you could probably still use it and it’s fine, unless there was sparks or smoke, usually if you connect a cable backwards the chip or BIOS can get hot but it doesn’t short/smoke/spark, unless it’s a hard short or some internal short on the programmer itself.

Usually, EC FW is not on same chip as BIOS, as you mentioned. Since you didn’t write there, EC should be untouched, if BIOS is correct when replaced or programmed back in and board is not shorted all will be OK.

Blanked out BIOS, shorted BIOS, FF’d or 00’d BIOS would not allow anything to happen, thus nothing reacts almost always

How are you connecting the buspirate? As I mentioned I have no clue what this is, but your final comments make me wonder why you are less worried about this than a CH341A, both can short the board if you move the cable while in use or connect something wrong
This assumes buspirate is something you connect to the board in some similar way, other than a USB Port?

Everything may be fine, and your chip just needs programmed again, with a new CH341A << Seems like the easier way to me, since you are fighting a loosing battle with current items and can’t even tell what is error or what is actual.
CH341A connected properly, with known working software version per your chip, your read and dump would not be in question as to if it’s a valid dump of zero’s or not and you could write in a working BIOS in less than 2 minutes without wondering if it wrote it in properly or not before you rebooted.

I suggest you get another CH341A, they only cost $2, maybe you didn’t even short anything last time, maybe the $2 CH341A just happened to be a bad sample and you were unlucky. Hopefully everything is OK on the board itself

I had tried the clip, but the legs on the chip are extremely small so never got a good steady hold. Used these clips instead ensuring no clip leads were touching nearby legs or other clips.

Followed chip spec sheets connecting cs/clk/si/so utilizing board ac/ground for power. VCC being opposite side of CS Im 100% It nor VSS were touched. I believe it was 1.29 ver iirc that would see the chip.

Everything was looking great, until I started smelling the frying smell of electrical component. Instantly pulled programmer, and burned myself in the process. Heres a pic of the programmer.

Bus Pirate is a usb/serial programmer for multiple devices. Spi flashing is normally handled via flashrom, but offers a terminal as well that you can really manipulate with.

Im sure any fool can also destroy things with the bus pirate or ch341a alike. I personally, will never touch a ch341a again. I never cared about cost savings, just everyone used it. So to keep it simple and not have to learn all about deep level bios editing I cheaped out and grabbed one.

This situation sucks, but in the last week I’ve learned quite a bit about spi nor chips. How to send individual commands to change chip status, what order to do said commands in, to actually sending the bytes over. Not just running said software having no idea how it does it.

Thanks for answering my questions, its appreciated.

Those look MUCH easier to cause a short than the standard clips, so I suspect that’s what happened if those were used during the time this happened. But yes, clip can cause it too, or it may just have been a faulty CH341A
Your smell of ozone (magic smoke) and burned programmer is sure sign something shorted. Do you see blown trace or resistor near the BIOS chip?

Hope you can sort this out with bus pirate, if you end up never getting anywhere and are not sure the board is damaged, I’d get another CH341A and try again before tossing it all out to the bin

Inspection of the board, front back reveals no damage whatsoever. Actually the clips, if attention is paid, are leaps and bounds more secure then any test clip.

I have been using Pc’s since before 386 days. I’m no stranger to damaged hardware. Especially when overclocking with liquid nitrogen. If you are not savy, it’s gonna be quite the expensive venture considering the amount of sources of damage that presents to a system. I don’t know how many times my reflow station has saved the day during a bench session.

Have since, flashed and replaced the chip. Am writing from it as we speak ;). Thanks for following along on the adventure.