Unlocking Asus X450JF Bios

@Lost_N_BIOS
Hi there I’ve finally got my own flash programmer, as we’ve discussed here in this thread [ARCHIVE] Outdated UBU Tool related Questions, Reports and Suggestions (317)
I’ve followed this thread [GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher (With Pictures!) on how to use the programmer but it doesn’t tell which orientation should I follow when clipping the SOIC8 clip to the bios chip because I’m afraid that I may fried if I clip it on wrong direction.

Another question is that do I need to turn off my laptop and flash it on other computer or I just clip it and insert programmer to the USB port. Which one is the safest?

Here’s the latest bios for my laptop https://dlcdnets.asus.com/pub/ASUS/nb/X450JF/X450JFAS219.zip hope you can unlock it thanks!

@gjalleri - Here is a guide with plenty of images
https://www.bios-mods.com/forum/Thread-G…341A-programmer << Same as one directly below, but with all images expanded/visible at once
[GUIDE] Flash BIOS with CH341A programmer

And here is general CH341A driver and software package - http://s000.tinyupload.com/index.php?fil…257455007472602

Yes, you will need a second computer to connect the programmer to, for the USB and programming software end, other side/cable goes to BIOS chip on different system that’s not running.

Please dump your BIOS and zip then send to me. Make sure you take note of which software you use so we use same one to write back, not all may work properly, depending on your BIOS chip ID (Please also tell me what this is, so I can advise if needed)
Please also take some images of your BIOS, resize them once you are done to 1MB or less each (just resize to 1000px wide or so should do it, save as jpg or png). You may be able to F12 screenshot to USB, if not use camera. I need to see one image of each main BIOS page, like Main, Advanced, Boot, Exit etc)
Put all that in rar or 7zip archive with max compression, thank you.

Also, I found your original post on the UBU thread, asking about TSX. Are you sure that rev 12 is the microcode you need to allow that function to work? What CPU are you using?
I just fixed this for someone else recently, with same CPUID (306C3) and they wanted rev 12 removed, and 19 inserted instead, and then confirmed it was working, so I think you need 19 not 12
[Request] Gigabyte H97N-Wifi With a custom microcode.

Hi @Lost_N_BIOS I’ve uploaded everything on mega here’s the link https://mega.nz/#!554jUQ7T!ENYl_Mbup-IAg…Y8P93NP6UuaJAMA
There are 2 Bios inside their are both read and verified but they have different SHA256 is it because of the timestamp? dunno why.
All photos are already inside including BIOS UI Photos, BIOS ID, and BIOS Chip Photo. Not sure if I’m using correct chip type W25Q64FV or BV.



Honestly I’m not sure because SoNiX told me that this revision already have TSX enabled he told that I need to unlock the motherboard features to enable TSX not sure about this though.
But anyway if you can please upload rev19 and rev12 with disabled intel gpu and enabled intel gpu so that I could that I could test all of them thanks.

Wow, why is that package 40MB??? I guess you didn’t resize images I know nothing about TSX, and have never seen a TSX Setting in a BIOS, unless it has some other name?

Yes, your BIOS is W25Q64FV, you may need to choose W25Q64BV in the software. Looks OK though. Did you modify this BIOS at all ever? Especially at CPU microcodes, but possibly any other edit could cause the issue I see too (broken FIT Table)

I’ve not checked your BIOS for this yet, but I assume you cannot disable Intel GPU, unless your BIOS has muxed setting which is rare, otherwise Intel GPU enabled is required because even if other card is used the images all go through Intel before being sent out to the outputs
I’ll unlock all this for you to play with, but be warned now, changing graphics relating settings in laptops almost always = bricked, well not really, black screen and blind recovery is only way to fix due to no graphics output.
Not an issue for you since you have a programmer, but you need to be ready with known good backup to recover since this is almost always the outcome

I’ll start working on unlocking BIOS for you tonight.

Sonix said


I guess it’s fine then.


Nope, but I did update the bios before.

Thanks man really appreciate what your doing can’t wait :slight_smile:

Additional info.
SoNiX wrote


[ARCHIVE] Outdated UBU Tool related Questions, Reports and Suggestions (315)

and [ARCHIVE] Outdated UBU Tool related Questions, Reports and Suggestions (316)



so probably TSX was disabled was set disabled by the manufacturer or disabled by the bios.

If you continue reading it you’ve discussed about the FIT and PEI files

Manufacturer broken FIT table then, I will fix it too, it happens but not often, usually only on very old BIOS. It’s 100% broken, incorrect entry for every entry not just one or a few
Actually, this is some BIOS mod issue and you forgot you used BIOS mod, or maybe only the older v218 BIOS your currently using was broken (I didn’t check), but latest V219 BIOS FIT table is proper in stock BIOS.
I went ahead and checked, V218 does not have broken FIT Table so I think maybe you flashed Mod BIOS sometime in the past and forgot, or if you are not original owner of the system then someone did before you.
Or, it’s also possible that sometime in the past Asus had 218 BIOS online with broken FIT, but has fixed the file online now and made it keep same build time/date.

If rev 12 ucode has TSX, then this broken FIT may be why it’s not working, usually when FIT is broken microcode is not loaded/used. Check Win HWINFO64 or AIDA54 and see if current ucode version shows as Rev 12 or not.

SoniX meant that his/UBU’s “Fixing of FIT Table” is not currently programmed to fix FIT on your BIOS size at that current time, I guess he didn’t realize then you have an 8MB BIOS.
It may not be critical for Aptio 4 BIOS though, but it’s there so should be setup correctly… fixing

Only thing I know about TSX is what I linked above, and that user had rev 12 and needed it updated to 19 before it would work. I checked your BIOS, no setting with TSX in the name.
Nothing new or helpful discusses on that UBU page you linked, just random stuff we talked about in general about some BIOS and a little on this one.
Does it have any other name? Maybe @Conki knows, or he knows quick way to confirm which ucode is working if I make you BIOS with 12 and 19 ucode.

noTSX-x2-Modules.png



Few confirmations this is not a BIOS setting thing, just controlled/enabled by certain microcodes
https://www.supermicro.com/support/faqs/faq.cfm?faq=23889
https://www.reddit.com/r/rpcs3/comments/…e_haswell_cpus/
https://forums.anandtech.com/threads/wha…2496647/page-41

Here is initial test BIOS, program either one of these in with programmer, this is only required for one BIOS. Please let me know if you see the new settings in your old menu sections, and also if you see entirely new menu sections (duplicate’s but different) for Advanced, Chipset, Boot, Save & Exit
This is only test, new menus might be empty or sparsely populated etc, and yes once we’re done I’ll remove unnecessary dupes
After this BIOS is programmed in, all locks are removed so you wont have to use programmer anymore from here on out, and never again unless you have a bad BIOS flash or you accidentally flash in a locked FD or BIOS locked stock BIOS region.
So, after programming in one, next one and all you do in the future can be programmer in with FPT via this command >> FPTw.exe -bios -f filename.bin
http://s000.tinyupload.com/index.php?fil…240944523260459

Thanks will try this as soon i got home from work and yes I’ve checked it before TSX was disabled. What’s the FPTw BTW where can I get those? upon checking on google there’s a lot of version but dunno which one I should use.

Sorry, I assumed you’d already being using FPT before you picked up the programmer… What you need is in this thread in the section “C” you want the 9.1 package
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. And then here is how you dump BIOS and flash BIOS etc

BIOS Region only dump >> FPTw.exe -bios -d biosreg.bin
BIOS region only flash >> FPTw.exe -bios -d filename.bin (can be BIOS region only, or complete BIOS, that’s not encapsulated)

Flash entire BIOS >> FPTw.exe -f bios.bin (DO NOT Flash .CAP BIOS, or any renamed “encapsulated” BIOS, if you are unsure, drop BIOS in UEFITool and it you see Aptio Capsule at top of middle section you cannot flash that with FPT)
Dump entire BIOS >> FPTw.exe -d spi.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)
https://www.windowscentral.com/how-add-c…creators-update
https://www.windowscentral.com/add-open-…menu-windows-10
https://www.laptopmag.com/articles/open-…ator-privileges

How did you “Check it before” for TSX Disabled?


Honestly I bought this laptop back in 2013 as a slightly used laptop since then I’ve updated the BIOS from time to time if new version comes up.


This is more highly likely to happen cause I would never risk my laptop getting brick and back then I don’t know any bios mod available, like now I accepted the risk because there’s a way for us for recover brick bios using flash programmer

@Lost_N_BIOS
I’ve now successfully flashed the BIOS
So here’s the changes on the Bios Menu Main Tab there’s a new information GOV Version value is INT10 and on Advanced there’s a new feature called ASUS USB Charger+ in battery mode and it’s enabled and that’s basically it.

This is just first bios test see the screenshot below of HWINFO64 there’s still no TSX, I haven’t tried the 2nd Bios when I try to flash it on FPTW FirstTestBCPS-19.bin I get an error message below.

hwinfo.png

fptw.png

@gjalleri - Makes sense then, original owner must have had someone update ucodes in a BIOS, or he did, and it’s messed up… That or the Asus switcheroo I mentioned (less likely)

First, on the TSX stuff, as you can see in your screenshot ucode in use is 1C, not Rev 12 (First BIOS, and or original BIOS) or 19 (second BIOS I sent).
This is due to Win10, uninstall the windows update that’s providing the microcodes and or spectre/meltdown protection, or use Win7 instead, no other way around this now due to how Windows are doing protections for security issues these days.
So, until you figure that out, no need to even worry about flashing in the second BIOS I sent, you will still be on same 1C ucode instead of the Rev 19 contained within that BIOS.

I was not aware that lock was in place, causing the 280 error, I can remove it I think, but you’ll need to program in a BIOS once more (and then always replace this module I edit in any future BIOS mods you flash in too, once we confirm it worked I will send to you so you have a copy)

As for BIOS menu’s, we’ll have to try more changes and figure that out still. Here is same mod BIOS (rev 12 ucode still), different edit on the menus to see if that works, and this has attempt to remove the 280 error.
After you flash this, check menus, then try writing in same BIOS file via FPT (use -bios region switch) again and see if you get FPT error
http://s000.tinyupload.com/index.php?fil…317387556496636

@Lost_N_BIOS
I’ve flashed the new bios file you gave me, it’s same bios menu as the previous one and I’m also getting the same error code on FPTW64.exe -bios -f BCPU280.bin the same as the screenshot above.

@gjalleri How did you flash it, programmer or flash, maybe it didn’t flash in? If you flashed it same way as before, that let you see Asus USB Charger show up in Advanced, then I need to try again on the menus
Bummer on the 280 error too Will look again << On these tests, always expect you may need to recover via programmer, sorry but this kind of edits are risky if they fail - I have two more coming your way shortly, and I think I found reason menus weren’t showing too

* Edit - Here, program in BCPSStringPMM280.rom - http://s000.tinyupload.com/index.php?fil…263923527140702
After you program this, check menus, then try writing in same BIOS file via FPT (use -bios region switch) again and see if you get FPT error
Additionally included is BCPSString.rom, this is same menu edit test as above, but without the 280 bypass attempt, in case that bricks the board, this way you can still test this menu edit.

@Lost_N_BIOS
I flash it using flash programmer of course and the ASUS USB Charger+ is there as well, it’s just that other than that nothing was added.
Anyway I need to reformat my computer now because I update the microcode before using cpumcupdate from VMWare (I updated it long ago and for unknown reason even I already deleted the file it was still using the updated microcode).



How can I flash the rom files? is this file format acceptable for the flash programmer? and for the FPT am I using the correct syntax FPTW64.exe -bios -f filename.rom

Thanks for confirming you used programmer first, then that set is a fail

Format due to microcodes??? Sounds like you’re doing something wrong there. If you want updated microcodes in BIOS I can do that too

If software for programmer does not accept .rom rename to .bin same/same, sorry I forgot to rename to .bin (FPT may need that too, unsure)

For FPT, I never use FPTW64, but yes that is correct format to flash BIOS region only.

@Lost_N_Bios
I’ve already reformatted my PC and the microcode revision is showing 1A I don’t know why but I’ll reformat my PC again, I don’t know which update that updates the microcode and upon checking with KB I don’t have such update installed at all. So as for the BIOS I’ve flash the 1st BIOS BCPSStringPMM280.bin there’s ASUS USB Charger+ aside from that no changes, flashing from FPTW I’m still getting 280 error. I’ll try flashing the BCPSString.bin later.

Ohh, your formatting due to microcodes? That’s not going to help on Win10, as soon as it connects to the internet it’s going to download updates which contain whatever microcode it wants to use.
It may also contain some implemented during it’s install as-is, without having to connect to the internet, I’m not certain as I refuse to use Win10. You’d have to google how to disable that, if it’s even possible (again, unsure)

If you want to confirm BIOS microcode drop BIOS I send you on MC Extractor, or look in BIOS main page, or during POST Screen if you hit TAB during logo, or disable full screen logo

I can try more on the 280 error, but sounds like the menu edits are still failing (The other file is same, minus the 280 attempt to bypass, so you wont get menus there either)
Back to the drawing board, let me look at the BIOS some more, please wait, no need to flash or continue messing with anything else here yet.

* Edit - the use of dual setups in this BIOS is what’s messing me up, I need to figure out how to disable the AsusSetup and make it use Setup only. Since you have a programmer we can test simply removing AsusSetup, but you need to be sure you’re ready to recover

I see @lordkag knows how to deal with all this, but I don’t see him reply too often. I’ve found and edited the Boolean string to show all, if you see this lordkag, didn’t make any difference, and all tabs at each seem to be enabled in hex/IDA

@Lost_N_BIOS
sadly @lordkag hasn’t been online for Last online: 12.17.2018

Anyway I’ve reformatted my computer again without windows updates just to make sure that I won’t get updates I disconnect my internet while formatting.

So here’s my findings when I formatted my computer and installed Windows 10 the microcode update shows as “1C” tested with Windows 10 1507 LTSB which release is 2015, but when I formatted it with windows 8.1 it shows “1A” Both Windows 8.1 en_windows_embedded_8.1_industry_pro_with_update_x64_dvd_6052086 which was release in 2014 and Windows 8.1 Ultimate

So the microcode doesn’t match could you please send me a bios with rev19 or with reinserted rev12. Dunno what was the issue and I’m sure that my PC is not patch with spectre.

@gjalleri - Windows 8/8.1 may also be inserting microcodes too now, from being connected to the internet or from installer source files, I’m not sure I only use Win7 and know it doesn’t. 306C3 Rev 1A not in any BIOS I’ve sent you, or that you’ve sent me, so that has to be from windows.
Your stock BIOS contains rev 12 already, the last BIOS I sent you (BCPSString) contains only Rev 12 too, drop it in MC Extractor and you will see.
As mentioned though, I think you need rev. 19 - so here is BIOS with rev 19, this one should also allow FPT BIOS region reflash too once you’ve got it programmed in there (so no more error 280 as long as we build on this BIOS from now on)
https://www.sendspace.com/file/zwcmi2

@Lost_N_BIOS I’ve revisited this because I’ve installed Windows 10 LTSC 2019 which has microcode revision 24 which from the previous post that I had a rev1 on Windows 8.1. Anyway I don’t know which microcode is flashed on my bios laptop and I would like to try this again.
Sonix said that from this processor that I had already unlock TSX bios which is rev12 ([ARCHIVE] Outdated UBU Tool related Questions, Reports and Suggestions (315)).

Also I don’t know if I installed the last bios that you’ve sent to me and I would like to ask you again if it’s okay to you if you can send me a another bios with rev12 and rev19 so that I could try in again on my laptop.

Thank you very much and I really appreciate your help.

@Lost_N_BIOS

Good news I’ve finally found a way to disable the microcode that was installed though Windows Update. All you have to do is to delete or rename %WINDIR%\system32\mcupdate_GenuineIntel.dll.
Now is shows Rev19, before it shows 1C from the previous screenshot. Though Rev19 doesn’t have TSX. I’ll keep you update and I’ll try to reflash rev12 see if it will re-enable TSX again.


Also note that I’m still getting 280 error when flash through FPTw.


Just another question though why UBUTool is now recommending me to use MMTool 5.0.7 instead of MMTool 4.