Update Intel Raid ROM in Gigabyte GA-P35-DS3R for >2TB disks - Advice on mod please!

Hello! First let me say what a great forum and give my thanks! I’ve just spent the better half of two evenings reading through Fernando’s very thorough guides and attempting to patch my bios. It’s been fun and informative.

I have an old Gigabyte GA-P35-DS3R mainboard that I very very much want to add support for >2TB disks for use by the Intel Raid controller.

The last official firmware by Gigabyte for the GA-P35-DS3R is F13 with Intel Raid controller v7.5.0.1017. (note: Gigabyte also seem to have made an F14c beta but I can’t find it as the download link here appears broken).

I have read a few places that the Intel Raid controller needs to be >10.5 for >2TB support, and that Intel RST RAID ROM v11.2.0.1527 is in fact the best according to the page here

Thus what I have been trying is simply F13 BIOS upgraded with RST RAID ROM v11.2.0.1527…

So, I have followed Fernando’s Award/Phoenix BIOS Replacement of a PCI ROM module guide to replace the Intel RST RAID ROM in the F13 BIOS with Intel RST RAID ROM v11.2.0.1527 (using CBROM_198). This resulted in a BIOS file that I was able to flash using Q-Flash (Q-Flash confirming the checksum and allowing me to proceed) but after flashing the PC boots but there is no option to press CTRL-I to enter the Raid controller setup (while with the official firmware there is the option to press CTRL-I). Note: I think the CTRL-I option does not appear unless there are at least 2 disks connected to the Intel SATA ports, but I have this.

The ICH9RAID.BIN module is above the MINIT module however per the guide I have used a hex editor to confirm that “MEMINITENTRYPOINT” is at the same offset in the modded bios as the original. I have also tried completely recreating the previous BIOS structure by extracting everything and reinserting step-by-step, as suggested in the guide, also confirming “MEMINITENTRYPOINT” offset. In all cases, it’s like the Intel Raid controller option isn’t there - there is no option to access it. I have also wiped CMOS and reset the RAID option in the bios menu under “Integrated peripherals > SATA Mode > RAID” but same result so far.

So, is this expected? what can I try next? Should I be updating another PCI module in addition to the RAID? Is what I’m trying to do impossible? I haven’t fully understood the advice of SummoneR, maybe there’s some pointer you can give me in relation to that?

With many thanks for any advice on next steps. I’d really love to get this working if it is possible.

note: There seems to have been an inconclusive prior attempt at this same mainboard on this forum, documented here, and those BIOS provided there also don’t give the CTRL-I option for me.

love and mungbeans,


EDIT by Fernando: I have added the word “ROM” to the title to make clear, that it is a BIOS modding and not a driver modding request.

@Eld - For this BIOS, to mod yourself, I would use Cbrom155 or 219, possibly 115, especially since RAID Rom is above Meminit. 195 may be OK too, unsure, but 198 handles things a little differently than 195/196
It’s been a long time since P35 and I don’t have a board here to confirm which works properly. I do know if RAID insertion fails (ie wrong size, wrong method etc) then you don’t get the Ctrl+I due to rom fails to load

I found already modified and confirmed working - https://forums.tweaktown.com/gigabyte/48…s-80-print.html
But, not clear there if the mods are using TRIM enabled RAID roms, you’ll have to check this once you get it running.

Updated with…


Jmicron 1.07.28
Realtek 2.52




Also here with 10.5
P35-DS3R - F13/F14c

Updated with…



Both above seem to be confirmed working, however it doesn’t appear the user specifically said RAID or Control+I was working, so hard to know for sure.
If neither of these work for you, or it’s incorrect RAID Rom and TRIM is not enabled, let me know and I will do the mod myself, original BIOS is included in the 11.6 Mod package

@Eld - edit to add -
Seems per this post, that 11.6 is OK, but may cause issues with the Marvell ports, which most shouldn’t be using anyway
TRIM in RAID0 possible for all Intel chipsets from P965/ICH8R up!

@Eld - Edit 3 - Here, I did TRIM Mod for you with 155, MEMINITENTRYPOINT x2 stays same location for both entries 000e6839 + 000f17ad

Amazing! I’m very grateful to you @Lost_N_BIOS Hours of searching/reading and I never uncovered the 14c firmware, nor realized the mods you linked to are almost exactly what I was after, until you pointed the way.

I now have more confidence in all this and I was able to use 155 to add in the TRIM Mod myself and confirm I arrived at the same exact file you have provided. Also, glad to say this version based on F14c does appear to work (At least, I can CTRL-I into the raid setup menu). You’ve helped me resurrect an old board back into usefulness - it’s got 8 sata ports so I can make a nice experimental storage server out of it.

I have a few bios-modding newb questions, please answer what you feel like :slight_smile:

1. If I’m not planning on using SSD should I use the non-TRIM version of RST instead, or is the TRIM modified version known to be just as robust?
2. I have also used Cbrom155 to upgrade the GIGABYTE branded JMicron ROM v1.06.59 to JMicron v1.0.8.01 directly after adding the TRIM Mod - do you know of any problem with me doing that?
3. I’m planning to use the mainboard as a storage server. Do you suggest I mod any other aspect of the bios?
4. I think F14c was a beta never officially released by Gigabyte. Do you know how it differs from F13, or whether I should think about starting wih F13 as the base for the mod instead of F14c?

Once again, thank you!

@Eld - glad I could help you save the old board and give it some refreshed life again! Also, good you were able to mod with 155 too and confirm out files matched up, and it’s working that way, thanks for confirming maybe that will help others in the future too

1. TRIM mod just enabled TRIM, byte or two change I think, it should function the same with or without that done on a non-SSD, so no reason to not use the TRIM one (Might as well so it’s done and ready in case you stick SSD in sometime in the future)
2. That should be fine, just check the Meminit stayed in same place x2 again.
3. Maybe update CPU microcodes, if you have not already.
4. I do not know, but since that was final release for this board and it’s so many years old, this would be considered final in my book and would be the BIOS I would use too. Adding, no, I would not use F13, but that’s me (Unless you run into issues with F14c you didn’t have with F13, but I doubt that)

You’re welcome, and thank you again too for reporting back about the 11.2 and 155 BIOS edits.

hello, i have this mobo p35-ds3r rev1 and bought one xeon x5460 SLANP (i think this one is 10676h) ,that is not supported without new cpu ucode . tried F14c from above but is not supporting the new cpu. tried to upgrade ucode but failed . any help wil be appreciated . thank you

anyone? i am willing to appreciate any effort by donating some gift card. i really want to revive this mainboard. i followed this guide [Guide] How to update the CPU microcodes on a non-UEFI Award/Phoenix BIOS but after i compare the final result it doesn’t seems to add the new ucode
thank you

i have successfully added the ucode for my cpu x5460 SLANP(10676h) also the bios contains the mods added by Lost_N_BIOS from above. if anyone needs the bios http://www.mediafire.com/file/4uy9v3w7bd…2%2529.14c/file

Thank you very much, I am using GIGABYTE P35-DS3R with very old 14c bios with SLIC enabled BIOS.
I will try your modded BIOS and get for a genuine Win10 license.

Is it possible to update the JMicron JMB36x bios as well? Cause I have many HDD and don’t want to plug a SATA Card.
I have read the forum several time but still don’t know how to keep MEMINIT.BIN and PPMINIT.ROM at origin.

Just check your uploaded BIOS. I just wonder why used such long file name for the CUP code and old raid rom ?
Also the offset of MEMINIT.BIN is in varied position in different modded BIOS.
That makes me so confused. Cause I tried modding the ROM and failed. It can inject any rom easily but can’t keep the MEMINIT.BIN at same offset.
It caused my PC can boot up but can’t wake up after suspend or sleep.