Wanted: TRIM in RAID0 for Gigabyte GA-X58A-UD7 Rev. 1

Hello Fernando!

First of all, I definitely signed up here to this forum primarily to congratulate you for a VERY great job done with all your research, information gathering, hard work and also wanted to give you a massive gratitude for offering all this information in such categorized and fairly easy to read/understand manner for all of us otherwise confused not so techy Windows users…for free :slight_smile: Thank you very much! I have gone back and forth through various threads/stickies and discussion conversations, and even though I kinda feel that for the moment I’m having, just like another member so perfectly put it, kinda “analysis paralysis” (LOL!)…but I have definitely a much better understanding of the whole situation when it comes to AHCI/RAID BIOS ROM, how to approach them, the version numbers, the difference between classical IMSM/IRST and the new IRTS(e) software and also what to make of all that information, which was to be honest quite a confusing jungle inside Intel’s own information site. I am forever thankful to you for making this information available to us :slight_smile:

Having said that, I am still a proud owner of a Gigabyte GA-X58A-UD7 motherboard which I happen to love and the combination of this mobo + my i7-980X processor gives me the satisfaction which I need for the moment, so I have not seen any reason to abandon this combo yet!
To my despair after reading through your information, I realized that my mobo with the latest BIOS version (F9d) still was stuck with the original Intel MSM RAID BIOS-ROM v8.9.1.1002!

After searching a lot I managed to find a modded F9d Gigabyte version for my GA-X58A-UD7 mobo Rev1.0 at the Tweaktown site which already had the modded IRST(e) BIOS-OROM v11.6.0.1702 implemented into it (specifically mentioned that it was the CPL0’s modded version to allow TRIM in RAID-0). I believe it is the exact same OROM you’re offering in your download page… The reason I became interested was that I just recently got myself 2xSamsung 1TB 850 PRO SSDs and wanted to join them into a RAID-0 configuration.

So I now have successfully flashed my BIOS ROM and confirmed that it indeed indicates the correct OROM v11.6.0.1702 when looking at the RAID config BIOS set up page.


Now, before flashing the BIOS, I had just made a fresh Windows 7 Ultimate x64 installation, by setting up a RAID-0 connected to the two Marvell 9128 controller ports of my motherboard, with no additional Marvell drivers installed, basically letting Win7 MS/AHCI own drivers to pass through. I’m aware of the fact that I was not having TRIM at that point. I basically got about 360 Mb/s seq read then.

After flasing the BIOS with the BIOS with the OROM v11.6.0.1702, everything else remaining the same, and with my RAID-0 array still intact and operational with the Marvell 9128 ports, now I get only 270 Mb/s seq read!

So my conclusion is, that the Marvell controller, although not becoming disabled, still definitely gets crippled somehow after the BIOS flash has been done. Now you did mention in one of your information pages that for old Intel chipsets (mine is ICH10R) IRST(e) might result in a downgrade pace for the whole computer function when compared to its IMSM/IRST counterpart…but from what I understood, you meant when using the Intel AHCI SATA-II 3Gb/s ports. Here I see a hit on the Marvell port function too, and all I did was flash the BIOS. I have not even installed the corresponding suitable IRST(e) software or drivers!
I should mention that the Marvell firmware on the modded BIOS I used was the exact same as the one I had before so that is not changed in any way.

Well, all things considered…kinda strange IMHO!

But I’m not so concerned about the Marvell 9128 issue though, as I now will be moving my 1TB SSDs to Intel’s SATA-II 3Gb/s ports instead anyway. Every single piece of info I found on internet is saying that Marvell 912x controllers despite flashing with a uber 6Gb/s SATA-III ports, still would cap at 400 Mb/s maximum no matter what, due to bad drivers and using only a PCI-E x 1 lane, compared with the Intel’s own onboard SATA-II 3Gb/s ports which are direcly connected to the southbridge ICH… so those 6Gb/s Marvell SATA-III connctors were never meant to be used with high-end quality SSDs anyways…also there was no way to get TRIM work with them either when doing a RAID-0 array.

So I’m hoping to be able to get at least 500-600 Mb/s seq read with my SSDs when making a new RAID-0 array with my newly OROM v. and hopefully also a better 4K read as well :slight_smile:
It’s amazing how much new information one can learn during a couple of days just by finding the right stuff, thx to you guys!
So, a couple of questions if I may:

1. Should I simply use Intel’s RST(e) v. software now downloaded from your page, which corresponds exactly to my OROM BIOS version? No need to still consider an earlier version or a classical one, due to my older ICH10R chipset?
And I was going to follow your advice, installing the whole package, making the necessary cache settings and then remove the software itself and just keep the drivers…and hopefully being able to take advantage of the TRIM function now!

2. Do I just move my SSDs to Intel 3Gb/s ports, go into RAID BIOS set up, create my new RAID-0 array, and then reboot and move on to installing a fresh Windows 7 all the way, and then install the IRST(e) software/drivers afterwards, i.e. after Win 7 has been installed?

3. Do I have to put the AHCI/RAID drivers on a USB-flash and load those drivers before Windows start installing in order to be able to make a fresh Win 7 installation on a newly created RAID-0 array as boot up disk?? This is something that is mentioned in my Gigabyte GA-X58A-UD7 handbook, but I don’t know if this is valid even for the newer OROM chipset I have in my BIOS now and if this is necessary when using a newer IRST(e) version after Win7 has been installed…

4.Also, would I still need the Marvell’s own drivers as well, or can I use those SATA ports as normal SATA-HDD ports for data storage only?
Anything else to consider here?

I’d also like to add that I only used Q-Flash, as the @BIOS method has strongly been advised to be avoided at all costs because of the huge risk of bricking the whole motherboard!
Q-Flash worked just like a charm :slight_smile:

Thank you again m8!

Best Regards,

@ Bittornado:
Welcome at Win-RAID Forum!

Since I am not sure about the sort of TRIM in RAID0 modification, which has been done with the BIOS you have found at TweakTown, I would rather like to check it. Please give me the link to the modded BIOS or attach it as .zip or .rar file.

Provided, that the BIOS modification had been done according to CPL0s latest method, I doubt, that this performance drop has anything to do with the recently flashed BIOS containing the TRIM in RAID0 modded Intel RAID ROM v10.6.0.1702. I suspect, that you either didn’t restore all your previous BIOS settings or that you are now using another RAID driver for your Marvell SATA ports.

The first step is to break the Marvell RAID array by using the Marvell RAID Utility.
Then you will be able to create the Intel RAID0 array (after having set the Intel SATA Controller to "RAID" mode.

After having set the Marvell SATA Controller to "AHCI" or "IDE" mode, you can use the Marvell SATA ports for data storage.

You should wait until I have checked the modded Intel RAID ROM module of your just flashed BIOS.

Dieter (alias Fernando)

Thank you very much for the quick reply sir :slight_smile:

Looking closer to the one I found and the OROM on your site, they seem to be exactly the same thing actually, but here’s the link:

Just make a CTRL-F search for “GA-X58A-UD7 Rev1.0 BIOS F9d Mod”.

The actual download link itself:

I did not see this earlier but there’s a link actually back to your site there :slight_smile:

The info accompanied with the file is:
Modified with :
Intel SATA RAID to (modified by CPL0 for TRIM support with SSD RAID0)
Intel SATA AHCI 1.20E
Realtek LAN 2.45 to 2.58
JMicron ROM 1.07.28
Marvell BIOS Version / Firmware

Also, I noticed that there was actually no exact IRST(e) software version match for this OROM version I’ve got now, but you recommended “64bit Intel RST(e) AHCI/RAID Drivers v11.7.4.1001 WHQL” which seems to best matching for Intel RAID ROM v11.6.0.1702, so I guess I’ll be grabbing that one then instead!

But the only thing I’m still curious about…when I break the Marvell array and set up my new Intel RAID-0 array, do I still have to copy the AHCI/RAID drivers from my mobo CD-disc on a USB-flash stick to load them before Win 7 can be installed on a RAID-0 array as boot disc? I’m not sure whether that step is still necessary…the reason I did not have to do this when I set up my Marvell RAID-0 array was that it was not needed, according to the handbook. But apparently both Intel and JMicron controllers require this step…does that mean that if I need to do this, then those drivers are updated to the new version when installing IRST(e) software after Win7 has been installed?

Again, thank you!
Best Regards,
Sebastian (A.K.A Bittornado!)

@ Bittornado:

As I already have estimated, this is my analysis of your BIOS: The inserted Intel RAID ROM v11.6.0.1702 has been modded according to CPL0, but this was his first TRIM modding model, where he changed a lot of Bytes. It worked, that means TRIM in RAID0 was active, but the functionality of the on-board Marvell Controller was affected by this sort of the OROM modification. By the way: It were our Forum members sinders and SkOrPn, who did the first tests with this sort of Intel RAID ROM modification.

So there are at least 2 options for you:

  • a) You let everything as it is, but disabe the Marvell SATA Controller within the BIOS (after having disabled the RAID array).
  • b) You flash a BIOS, which contains an Intel RAID ROM module, which has been “TRIM in RAID0 modded”, but the latest and best way (without affecting any other on-board Controller). If you want, I will help you to get the related Intel RAID ROM module inserted into your mainboard BIOS (by the way: the TRIM modded Intel RST RAID ROM v11.2.0.1006 would be the better choice than the TRIM modded Intel RST(e) RAID ROM v11.6.0.1702).

What do you want to do?

Oh, I see…thank you so much for looking into it. Damn, I never realized the one I downloaded from tweaktown was different from the one here.
I saw your section with OROMs actually first AFTER I had downloaded and flashed my BIOS, or else I definitely would have grabbed the OROM from your site to begin with.

Anyways, I’m really keen to use the Marvell ports on my board for normal data storage with other HDDs, so I’d rather not disable the Marvell or any other controller at all, if possible. So basically the immaturity of these early OROMs was probably what affected my Marvell ports when I noticed my seq reads dropping like that after flashing my BIOS…that makes sense. I realized now after even more reading here that some others with ASUS boards but with the same Marvell controller on their boards also were affected when testing the earlier OROM versions, where some had to disable their Marvell controller completely in order not to get BSODs…

So anyway, if you are soooo kind to help me out, I choose the optin b) in your suggestion. I’d very much like to be able to receive a BIOS flash, which contains an Intel RAID ROM module, which has been “TRIM in RAID0 modded”, but the latest and best way (without affecting any other on-board Controller), please. I’d appreciate that very very much.

And then I’ll be using the TRIM modded Intel RST RAID ROM v11.2.0.1006 as suggested by you :slight_smile:

The BIOS version is F9d.
The Intel ROM version before I flashed my mobo was IMSM ROM v8.9.1.1002.
But IF possible, I’d rather not go back to such old and antique version as IMSM offers again! But I leave that in your capable hands to decide what’s best, will follow instructions accordingly to make things right again :slight_smile:

Again, thank you so much for all the help!
I’ll wait then for your further instructions.

Best Regards,

Although I usually do not modify BIOSes upon request, I have attached the BIOS X58AUD7.F9D, which I just have modified (EDIT: It has been deleted, because it didn’t work).
This is, what I did:
1. Removal of the Intel RAID ROM v11.6.0.1702, which had been modified according the outdated method and
2. Insertion of the actual TRIM in RAID modded Intel RST RAID ROM v11.2.0.1527.
You may flash it at own risk.

Good luck!

Thank you a million times m8!
I’ll test it out and let you know how it goes :slight_smile:

My mobo does come with double BIOS feature and I noticed that the back-up version is an early F2.
So if things for some reason would go REALLY wrong, I do have the option to roll back to F2 and then upgrade again to the normal F9d, so hopefully I won’t brick my board no matter what!

Just one other thing which I mentioned earlier…do you recon that it’s necessary to “load” AHCI/RAID drivers from my original mobo disc before installing windows 7, when I make a new Intel RAID-0 array? Or else I won’t be able to install Win 7 on an Intel RAID-0 array? This issue has had me confused…

Thank you!

No, Win7 has an on-board Intel MSM RAID driver v8.x.x.xxxx, which should be able to detect your RAID array and to install the OS onto it.
Nevertheless I recommend to prepare an USB Flash drive containing the 64bit Intel RST driver v11.2.0.1006 WHQL. So you can load this driver before the installation begins.

No, Win7 has an on-board Intel MSM RAID driver v8.x.x.xxxx, which should be able to detect your RAID array and to install the OS onto it.
Nevertheless I recommend to prepare an USB Flash drive containing the 64bit Intel RST driver v11.2.0.1006 WHQL. So you can load this driver before the installation begins.

I’ll get right on it :slight_smile:
Thank you my friend, I know that a lot of people have misconceptions about IRST out there, many don’t understand even the basics, like I didn’t 6 months ago either! I’ll make sure to send everyone I know to read through your site, it is one of the best information sites on the subjects out there! Really great job done!

Many thx!

Although I usually do not modify BIOSes upon request, I have attached the BIOS X58AUD7.F9D, which I just have modified.
This is, what I did:
1. Removal of the Intel RAID ROM v11.6.0.1702, which had been modified according the outdated method and
2. Insertion of the actual TRIM in RAID modded Intel RST RAID ROM v11.2.0.1527.
You may flash it at own risk.

Good luck!

Hey there again Dieter,
M8 I have now tried and tried flashing my BIOS with the new BIOS with the actual TRIM in RAID modded Intel RST RAID ROM v11.2.0.1527 you previously provided.

Unfortunately, when trying to load this file I downloaded from the link your kindly provided earlier via the Q-Flash (stored on my FAT-formatted USB-flash, exactly the same way I managed to successfully flash it last time with v11.6.0.1702), Q-Flash simply gives me an error message saying (sorry don’t remember the exact error phrase here) but something like “file not compatible” or “not a valid rom” or something similar :frowning:

Intel RAID BIOS is still stuck at v11.6.0.1702.

I tried to roll back to the F2 BIOS version which I previously noticed was already saved on mobo’s reserve BIOS (using the “BIOS Recover Method Via Manually Invoking BACKUP BIOS Auto-Recovery Using Power Supply - On/Off Switch” method provided here: http://forums.tweaktown.com/gigabyte/275…lash-guide.html), still no luck.
I also tried to clear CMOS both via the button at the back of my mobo and lastly by removing the CMOS battery for an hour or so, still no luck.

I’m not saying my mobo is bricked or anything…I just reinstalled Win7 on it again and using it here right now…but I’m clueless to how successfully flash it to the original BIOS + the actual TRIM in RAID modded Intel RST RAID ROM v11.2.0.1527 (incl. the new TRIM enabled modded method))…

1. Could it be that some detail in the modded BIOS ROM you specifically made for me, was not correctly implemented and maybe needs to be altered/corrected for it to work properly? Any way you could kindly have another look at that modded BIOS again please to make sure the changes were made correctly?

2. Or do you suggest some other route to take here?

3. Would flashing my BIOS first with a non-modded original vanilla F9d verion, and then downloading and applying the actual TRIM in RAID modded Intel RST RAID ROM v11.2.0.1527 provided on your site afterwards, ultimately also provide me with the same desired end result?

In that case, would you happen to have a copy of the original non-modded GA-X58A-UD7 Fd9 BIOS version to offer to me, please? I dunno know where to find a reliable non modded Fd9 copy on the internet by myself…

4. Also, on the same subject…is it mandatory to choose the “RAID” option for Intel ACH controller in BIOS, before attempting to flashing it with Modded RAID ROM with Q-Flash? Even if I don’t have any SSD/HDD connected to any of my Intel ICH ports?

Any further help here would be greatly appreciated :slight_smile:
I don’t seem to be getting anywhere without being able to solve the BIOS flashing issue first…

Best Regards,

I have done a look into the BIOS and couldn’t find a mistake regarding my work. A problem may be, that the Intel RAID ROM v11.2.0.1527 has an uncompressed size of 119 KB, whereas the Intel RAID ROM v11.6.0.1702 has a size of 117 KB (that means 2 KB smaller). BIOSes of X58 chipset mainboards usually have only very limited space for the Option ROM modules.

Yes, to be on the safe side regarding the Option ROM space problem with X58 chipset BIOSes you may try to flash a BIOS, which contains the TRIM modded Intel RAID ROM v10.1.0.1008, which has just an uncompressed size of 85 KB.

This will probably not help to avoid a flash failure.
By the way: You should always rename the modded BIOS to the "original" BIOS name, before you are trying to flash it.

I couldn’t find the “original” F9D BIOS either. The fact, that we are trying to modify an already modified BIOS, may cause some problems as well, since we do not know, where the source BIOS comes from and what has initially been done with the BIOS.

The usual BIOS flashing procedure is to choose the DEFAULT BIOS settings, before you flash any other BIOS.

Provided that you own the mainboard GA-X58A-UD7 Rev. 1.0, the last (BETA) BIOS delivered by Gigabyte was the version F9A (look >here<).
I just have replaced the Intel RAID ROM v8.9.1.1002 of the original F9A BIOS by the TRIM in RAID0 modded Intel RAID ROM v10.1.0.1008. If you want, you can test this modded BIOS, which I have attached (EDIT: The attachment has been deleted, because it didn’t work).
By the way: Gigabyte strongly recommends to use the latest @BIOS or FLASHSP1.EXE version, if you want to reflash a BETA BIOS version (look >here<).

@ Bittornado:

Since your problem is very specific, I have moved our complete discussion into a separate thread and gave it a more meaningful title.
This way you may get help from other users with a Gigabyte X58 mainboard and maybe even assistance from sinders or SkOrPn, who have done the first tests with the TRIM in RAID0 modded Intel RAID ROM modules.

Thank you Dieter!

Well I did try the latest option you so kindly provided as well, but no go :frowning:
I followed all of the necessary steps, also renamed the BIOS file to to its original F9d name.
But the BIOS simply won’t recognize this as a valid BIOS :frowning:

It is kinda strange though that the first modded GA-X58A-UD7 Intel RST BIOS-RAID ROM v11.6.0.1702 I got from tweaktown, with CPL0’s former tweak, did install with no problems when it was flashed using Q-flash.
While the other ones you took time to make for me with CPL0’s new modification, which are from what I understand, supposed to be much more “universal” and with much less modification being simpler modded, leaving most of the original BIOS intact…does not even want to be flashed to my BIOS.

I’m not entirely convinced that this issue could ONLY be a matter of file size, since I suspect that the outdated modded Intel RST BIOS-RAID ROM v11.6.0.1702 I flashed without any problems, should have had even more modifications in it so that file size should have been even bigger than those I received from you. So I really am puzzled here.

Anyways, I did manage to find a vanilla F9d, which was what I had to start with, and that one was also named in the exact same manner as the modded ones (X58AUD7.F9D) and I could successfully flash the BIOS back to that original non-modded F9d, so now the ACH ROM version is back to what it was originally, v8.9.1.1002.


May I ask which standard AMI BIOS tool you used for the purpose of implementing the modded RAID ROM into my specific F9d/F9a BIOS for my motherboard?
Did you use MMTool v3.26? Or one of the CBROM versions?

The original name of my BIOS file is X58AUD7.F9D.
So I tried to add the suffix “.ROM” but MMTool gives me “Error loading ROM image 10000h3”.
Without the .rom suffix MMTool can’t even find the file.

I tried to play around with both CBROM_198 and 155, but I don’t know whether a CMD command box is able to handle these software?
No commands are ever implemented…

So I was curious what tool you used for my specific BIOS ROM to make the changes you made earlier when you provided me with those 2 BIOS options??
I assure you I’m not gonna screw up my BIOS by cooking something I don’t understand and brick my mobo!
Just would like to know what software to use to experiment with.

I suspect that my BIOS is one of those odd ones which can’t be handled with the standard MMTool?

Oh, I’m using Windows 7 x64 version…could the 64-bit flavor cause the incompatibility issues with MMTool or other AMI BIOS tools I try to use here??

Also I should add that the reason why I don’t want to risk using @BIOS is because of several horrible stories I’ve heard from other Gigabyte owners…this method has apparently bricked several mobos in the past :frowning:
I’ve seen a lot of red flags about that…everybody I’ve talked to recommend using Q-flash instead.

FLASHSP1.EXE I have no idea how to use…does that one have to be used in conjunction with a floppy disk? I guess I need a real DOS environment to utilize FLASHSP1.EXE…
Still, I’m fairly confident that if the modded F9d BIOS with Intel RST BIOS-RAID ROM v11.6.0.1702 and the original F9d BIOS both were flashed with no issues using Q-flash, then the issue with the alternatives you were so kind to try and provide me with, must simply lie at some other level… I’d very much like to explore that further!

Thank you!

Your mainboard BIOS is an Award/Phoenix one and the suitable BIOS modding tool is CBROM.
You can find the related BIOS mdding guides within the start posts of >this< and >this< thread.

Oh yes thank you sir!
Just managed to find those very nicely written and comprehensive pages :slight_smile:
Well I guess since I now am back at my original RAID ROM version, I might take time and give the newer modded RAID ROM a go, I’ll most certainly learn a thing or two even if the BIOS itself still might not be flashable!

I’ll report back to this thread about my findings and results :slight_smile:
Thank you again for all the help m8!

In the mean time, if anyone else happens to have a functional TRIM-0 enabled modded RAID ROM BIOS for the F9d Gigabyte GA-X58A-UD7, please let me know!

Best Regards,

Can you give us the link to that original BIOS? Alternatively you can attach it.

By the way: After having done another deep look into the BIOSes for your mainboard I realized, that the module named PPMINIT.ROM seems to be a sensitive one (like the MEMINIT.BIN of other BIOSes). Since it is listed by CBROM below the Option ROM modules, the replacement of the Intel RAID ROM cannot be done the usual way. So you obviously have to use the DUMMY method, which has been layed down by SummoneR within >this< part of his guide.

Hi m8, thx for the above reference.
I tried to read through the posts in that thread, however, not sure if I completely understood the most complicated sections there…it was too techy for my limited knowledge I’m afraid…although I understand that after modifying the RAID ROM module, I need to create a dummy ROM module to fill the empty place there and to keep the module orders above those sensitive modules.

I’d like to ask you a couple of further questions please whether:

1. First off, am I correct to assume that with the CPL0’s latest newer RAID ROM modification, PCI ROM[B] / ICHARAID.BIN was the ONLY file which was modded for the purpose of enabling TRIM-0 functionality? No other files on that list was altered in any way?

2. How about the very first modded F9D modded BIOS with the TRIM-0 modded Intel RST(e) RAID ROM v11.6.0.1702 which I referred to you at tweakdown.com (GA-X58A-UD7 (rev1) BIOS F9d mod at http://forums.tweaktown.com/gigabyte/480…ified-bios.html) shich you explained it was CPL0’s former/older modification…even though that one fot successfully flashed to my BIOS? Do you happen to know whether any other files than PCI ROM[B] / ICHARAID.BIN had been altered or modified in that older modded RAID ROM v11.6.0.1702 by CPL0?

3. Also, since the the older F9D modded BIOS with the TRIM-0 modded Intel RST(e) RAID ROM v11.6.0.1702 version was the ONLY modded RAID ROM which Q-flash successfully would flash to my BIOS, are you under the impression that this older CPL0 TRIM-mod version is supposed to be quite inferior and/or instable/problematic to the overall system’s functionality compare to his newer TRIM-0 moddings, therefore the old modded version should not be used in any case??

4. Should the original PCI ROM[B] / ICHARAID.BIN file in the either F9A or F9D be first released off the BIOS table list completely, and then be replaced with the new modded RAID ROM downloaded from your site and after having be renamed to the new ICHARAID.BIN module by inserting it into the BIOS table list with cbrom?
OR…the above is not the proper way to go and it is not necessary at all to first release the original ICHARAID.BIN module completely from the F9A/F9D original BIOS table list, and one should just rename the new RAID ROM file from your site to ICHARAID.BIN and insert it into the BIOS table with cbrom while the original ICHARAID.ROM is still there on the list? Does it matter which approach of the above is used to replace the RAID ROM module?

I’m not sure I able to understand how to create a dummy ROM module by reading that post. I realize that what he’s trying to do is to insert the new module first which then will reside at the bottom of the list, then he creates the dummy module somehow (have no idea how that is being done there though), insert it into an original BIOS image by cbrom first to have it compressed in size, extract the compressed size, and then add it manually into his modded BIOS image by HxD.

But how he actually creates the dummy file and how he determines the correct needed file size and also how he actually finds the exact correct place in the BIOS image to paste in the compressed file…I don’t comprehend :frowning:
But it does explain why just inserting the the new RAID ROM module replacing the old one, does not create a valid BIOS file…

Is CPL0 still around somewhere to ask for help from?!


Yes, only the Intel RAID ROM module itself has been modified to get the TRIM in RAID0 feature.
The reported negative impact on the Marvell SATA Controller was an unexpected and unwanted side effect of CPL0’s first “TRIM in RAID0” modification for ICH8R/9R/10R RAID systems.

According to my knowledge CPL0 has never modified any other BIOS module than the Intel RAID ROM one.

According to the reports we got from sinders and SkOrPn it is safe to flash the BIOS, which contains the old variant of a TRIM in RAID0 modded Intel RAID ROM v11.6.0.1702, as long as the Marvell SATA Controller has been disabled within the BIOS.

The exact procedure about how to replace any Option ROM module, which is listed above any of the sensitive modules, has been layed down by SummoneR within >this< post. If you want to know more details, you should ask SummoneR or any other Award BIOS modding expert.
The main thing is, that the “Entrypoint” of the sensitive modules has to stay untouched by the BIOS modification. That is why you have to use CBROM_155 instead of the newer and usually better tool CBROM32_198.
As first step the not wanted Option ROM module has to be replaced by a similar sized compressed dummy file. This obviously has to be done by using an Hex Editor.
After having done that, the desired Option ROM module can be inserted the usual way. It will be added next to the bottom of the listed modules, but this doesn’t matter regarding its functionality.

You may send him a PM, but I am not sure, if you will get help from him. His last visit of this Forum was in April 2014.

Many thx for the detailed reply again.

So if by “Entrypoint of the sensitive modules” you simply mean the order of the modules within the BIOS image file in regards to all the sensitive files (e.g. if a particular module in the original BIOS happens to be beneath one sensitive module like MINIT/csimemrc.bin + above another sensitive module like GV3/ppminit.rom)… then in all honesty I see absolutely no difference in the consideration between the original F9A BIOS, F9D BIOS, CPL0’s earlier TRIM modded F9D BIOS with the RAID ROM v11.6.0.1702 or the modded F9D BIOS variant you so kindly provided me with which came with the RAID ROM v11.2.0.1527, or the other one which also you made out of F9A BIOS with the RAID ROM v10.1.0.1008!!! The order of regular modules vs the sensitive ones looks just the same in every single one of the above BIOS versions :slight_smile:

So just by looking at the module order list with either CBROM32_198 or CBROM_155 the all-around module order integrity of all the above mentioned BIOSes seems to be the same…at least when it comes to where the sensitive modules are being placed when being listed with the /D command. No difference whatsoever!

And none of them seems to contain any extra “additional filling” sized compressed dummy file in them.
Yet, the original modded F9D flashes just fine, so does CPL0’s older/earlier TRIM modded F9D BIOS with the RAID ROM v11.6.0.1702, while the other two modded F9D (RAID ROM v11.2.0.1527) or F9A (RAID ROM v10.1.0.1008) ever worked at all :slight_smile:

Well I’m sure it has something to do with the actual modification of the hex code in the resp. RAID ROM module. Maybe the required file size filling has been done within the module code somehow instead of having a separate visible dummy file module that can be shown with CBROM…but other than that, I really can not observe any module order misfit between the important sensitive files in ANY of the above BIOSes, as far as CBROM is able to indicate!

Anyways, pretty peculiar nifty issue this one indeed!
I might send a nice PM to SummoneR and ask him weather he might be so kind to just take a quick look and see if he could possibly help out with making a quick dummy file for me to test it out… would be a great victory if I could overcome this big mystery, lol!

I apologize for taking up your time again with this issue my friend :slight_smile:

Best Regards,

EDIT Seems as if just like CPL0, SummoneR has not been online here since April 2014 either :frowning: Damn.

No, I didn’t mean the order of the modules, but the exact location of the sensitive modules “Entrypoint” within the BIOS.
Can you please upload the original BIOS X58AUD.F9D? Then I would be able to compare the different BIOS files by using an Hex Editor.