Which are the "best" Intel AHCI/RAID drivers?

Thats a RSTe RAID driver not AHCI

AHCI to choose: 11.2 - 12.9 - 13.1

EDIT: Always check your AHCI device ID against the device IDs on the inf’s from package drivers.

Blockquote Thats a RAID driver not AHCI

yes but it does have an AHCI driver in it too that I tried on its own.

Blockquote AHCI to choose: 11.2 - 12.9 - 13.1
Ok I have tried out the first of them, perhaps the later ones will work. Thanks for clarifying this.

Blockquote 12.9 - 13.1

I am perhaps a bit confused here but under this I read:

Recommended for all Intel 5-Series, 6-Series and Mobile 7-Series Chipset systems, usable with all Windows Operating Systems from Win7 (32/64bit) up.


Recommended for Intel 7-Series Chipset Desktop systems and for X79/X99 Chipset systems, usable with all Windows Operating Systems from Win7 (32/64bit) up.

As I read it windows 7 is later than windows XP (32bit), so both 12.9 and 13.1 should NOT work. Only " v11.2.0.1006 WHQL" should have a chance. And it is a very confusing package filled with many strange labels that makes very little sense. So perhaps I should select some only a few of these drivers, but which one should I then choose?

Hey my friend, dont care or have time for details, i just pointed you the drivers for X79, OS details and user preferences its your job, so those are the packages offered from our forum founder Fernando and this is not a thread dedicated to XP OS, even so certain modern drivers can sometimes work in older OSes, good luck.

Ok, maybe I should create another thread. But this thread actually does mentions windows XP in the first post:

  • best chances for a successful integration into Windows XP, if the user doesn’t know the exact Intel SATA AHCI/RAID Controller specification of his system

even so certain modern drivers can sometimes work in older OSes

Yes, but the problem really is that the AHCI drivers totally wreck the OS if installed incorrectly, so it takes a lot of time to everything again. Still I have in the distant past been able to install WinXP 32bit correctly on the motherboard. But I can’t remember how or what driver that I used!

The error message indicates, that the related driver (here: Intel RSTe v3.8.0.1108) hasn’t been correctly integrated into the ISO file.
By the way:

  1. The files named iaStor.sys (for Intel RST drivers) and iaStorA.sys (for Intel RSTe drivers) are the real driver files and required for AHCI and RAID configurations.
  2. >Here< is the Guide about how to integrate Intel’s AHCI/RAID drivers into a Windows XP ISO file.

Okay, I think I understand what the problem is now, and the possible solution. And it seems to be a very fundamental problem, stemming from the way that X79 chips seemingly incorrectly “connect/bind” various storage controllers while installing older versions of Windows. First when installing Windows XP 32bit, the installer seemingly attempts to also use the Intel driver on the ASMedia 106x controller and it is this that gives the strange error. Note that this behavior is NOT changeable via BIOS, so the ASMedia can’t just be disabled to stop this fault. So the solution is to make the ISO image with both the Intel AND the ASMedia driver. And then the Windows XP installer it works as it should, giving the AHCI drivers:

I remember that when I installed Windows XP many years ago I actually wanted to check if I could use both controllers, so without thinking about it I made the “correct” driver set up when I made the ISO. This “hidden” and definitely uncontrollable (at least from the ASUS BIOS) connection of the X79 is not completely unknown. From trying to install NVMe with windows 7 64bit, I have heard from others that this is known to a hit and miss depending on the MB. And it is known that the NVMe controller cannot be accessed by the installer unless the motherboard can (not all MB can) shout down all the other AHCI controllers.
This seemingly “hidden” connection of storage controller of the X79 could explain why Intel choose to not support Windows XP 32bit, while still supporting the 64bit version. These version was released with some 4 years of time in between: 2001 vs 2005. So apparently Windows XP 64bit and later have some difference in the way that the windows installer cause the X79 to access the storage controllers. And the error message is hard to understand as it imply a faulty ISO driver. So this is probably the reason why Intel decided
to cut the support for it.
Anyway thanks to Fernando for the drivers, these really are necessary for gaining Trim-like garbage collection for SSDs. And finally thanks to anyone for help using the drivers.

hi I am confused, which driver is best for intel chipset 300 series for AHCI (for m2 ssd)?

The choice of the “best” AHCI driver depends
a) on the HardwareIDs of the related AHCI Controller (shown within the Device Manager) and
b) on the in-use OS.
By the way - I have moved your post into this better matching thread.

1 Like


using windows 11

For your system I recommend either to stick to the generic Win11 in-box MS AHCI driver (it is by far the newest) or - if you want to use an Intel AHCI driver - to look into the table at the bottom of the start post.


I’ve been using the mod for over 10 months on my 8-series B85 motherboard WIN-10 and WIN-7, no issues at all. just recently moved to windows 11. the only driver that’s showing in device manager is MS-ahci driver (10.0.22000.258)-2006. i need some recommendations on which AHCI driver to install?

The same…the hw device is the same, there is no recent Intel drivers to your HW device ID on new OS, so stay with the in box MS driver or the old Intel.

EDIT: What part you dont understood? There were no more recent INTEL drivers released for WIN11 for 8 Series chipset motherboards.

1 Like

there’s no intel ahci drivers for windows 11 on our motherboard yet?
the ms ahci drivers for windows 11 are quite decent actually :o

i have MSI H310M gaming plus and core i3 8100 and one sata SSD + one WD blue HDD.


OS: Windows 10 64bit 20h2

1.do you recommend intel sata AHCI driver over default MS driver? im a gamer and latency is important for me, so how can test drivers latency? can Latencymon show me difference?

2.also you said that

Latest Intel RST drivers v17.9.x.xxxx WHQL
Recommended for modern Intel Chipset systems from 300…

but i cant find any 17.9 versions in download page (only 17.11 and 17.7).

3.i installed intel driver through SDIO, also i noticed a service
created after reboot:

Service name: RstMwService 
Display name: Intel(R) Storage Middleware Service
Description: RPC endpoint service which allows communication between driver and Windows Store Application

can i disable this service?

thanks :heart:

Welcome to the Win-RAID Forum!

I only recommend it for users, who are not satisfied with the performance/stabilty of the generic MS AHCI driver.
By the way: The Win10/11 in-box AHCI driver is very good and brandnew (despite its shown wrong date).

The latest and best v17 platform Intel RST drivers are v17.11.1.1001 WHQL.
I forgot to replace “17.9” by “17.11” within the start post (it is fixed now).

You may be able to disable/delete the service, but I don’t recommend to do it.
Dieter (alias Fernando)

1 Like

hi, I am currently on an Asus RIVE x79 motherboard, I am trying to install windows 10 and i remember having to f6 my RAID drivers- but cant seem to find the appropriate flpy64zip that intel would always have. any help is appreciated.

Welcome to the Win-RAID Forum!
You don’t need to load any F6 driver at the beginning of the Win10/11 installation, because both Operating Systems have a compatible Intel RAID driver in-the-box. Once the OS is up and running, you can try to replace it by a better Intel RAID driver version according to the start post of this thread (depending on the HardwareIDs of your on-board Intel RAID Controller).
Good luck and enjoy the Forum!
Dieter (alias Fernando)

i ran into a platform not supported error when i tried installing the intelRST drivers, so i figured id just start from the beginning. thanks for replying :slight_smile:

Hello, @Fernando and all members of this forum!

For the 14th “generation” of AHCI/RAID drivers I found a “” version on “Station-Drivers”. Someone please explain to me why the “” version is considered the latest if that version (“”) has a greater number.

The 14th generation has “0”, “5”, “6”, “7”, “8” and “10” branches or something. So I think it’s reasonable enough to assume that the “10” branch is superior to the “8”.