X79 Turbo Rev 6.0 (PLEXHD) -- Cheap Chinese X79 board that can freely change Vcore after simple BIOS modifications

A lot of people have been buying cheap Chinese X79 boards for some years now. They offer decent performance for a small amount of money, and the ability to use registered ECC DDR3 RAM means that memory cost is actually very, very low. There is a large Russian community offering great advice on these boards (site1, site2, site3). A new revision of a well known motherboard has now appeared, and with some BIOS modifications it can perform even better:

The already really good:
Vcore and primary plane current (PP0) can be adjusted freely after a simple BIOS mod. I have not seen any mention of this anywhere else, and this enables decent overclocking. My dirt cheap 6c/12t Xeon 1650 can do 4.3 GHz all core/thread Prime95 AVX stable (not just “gaming OC”). I will post the original BIOS, and maybe this functionality can be “transplanted” to other cheap X79 motherboards as well. The power draw is however in the 220W region, so I have added fans over the VRM heatsink.

The potentially really good:
-In the BIOS the CPU strap ratio is seemingly adjustable (1.00, 1.25 and 1.67). Potentially this can bring on great FSB overclocking. This is one of the things that I intend to research further, and my efforts will be documented in this thread.

The normal:
-Package power limits can be adjusted freely after a small BIOS modification
-The DeathBringer ram patch still works (i.e. the board can force the RAM to 1866 MHz)

The not so good:
-Memory timings does not work like in previous revisions of the board. There is a “Performance Tuning” menu, however it does not have anything underneath it. Here it might be possible to “transplant” this from a BIOS from an earlier motherboard revision, or maybe unlock it some other way. I will document my findings in this thread.

The bad:
-Quad Channel does not work (same as with Rev 4.1 and 5.0). This new revision 6.0 seems to be based on the B85 chipset.

The really bad:
-A wrong BIOS setting can soft brick the board (I tested to change memory mode from “Independent” to “Sparing”). No amount of clear CMOS will work, only flashback with external programmer works (I used a normal CH341A). To make things worse, it is really hard to flash the soldered SPI chip. To even initiate communication with the chip, some steps were needed: 1. Power on the motherboard ; 2. Plug in the CH341A to a USB port; 3. Power off the motherboard ; 4. Start the flashing software

Here is a link to the original BIOS.

Here is a link to an overclocking BIOS, with the following changelog:
-Hex edited in the DeathBringer ram patch, so that memory can be forced to 1866 MHz (available under “Chipset ; North Bridge ; DDR Speed”)
-Changed all settings in “Advanced ; CPU Configuration ; CPU Configuration” to “USER” access
-Changed “Advanced ; Performance Tuning” to “USER” access (seems there is nothing underneath here, so way to set RAM timings from BIOS yet
-Changed default value of “Advanced ; CPU Configuration ; CPU Configuration ; Host clock Override” from 0 to 10000 for “Failsafe” settings (optimal already uses 10000)

To overclock the CPU, do the following:
-Change “Advanced ; CPU Power Management ; Power Technology” to “Energy Efficient”
-Change multipliers and voltages in “Advanced ; CPU Configuration ; CPU Configuration” as needed. The controllable Vcore for turbo mode is given in steps of 1/256 V, i.e. each extra bin increases the voltage with roughly 4 mV. Also make sure to increase “IA Core Current Max” (in 1/8 Ampere) and the two power limits (in 1/8 Watts) to something high. I increased these all to a value of 2600, corresponding to 325 A/W.

I received a new BIOS with ME enabled from the manufacturer.

However, I had no real luck with this, it just takes a lot longer to boot the computer. So no real practical use.

@Lost_N_BIOS , [mention]Lost_N_BIOS[/mention],



Overall goal with what I am trying to do: Access the ICC overclocking in BIOS, but I am getting the same error message as in this thread.

What I have done initially
-Unlocked menus through AMIBCP 4.53 by setting them to “USER” (Advanced/Intel ICC which then re-directs to Advanced/Enabled)
-Added a second ICC profile (using the Overclocking template) in Intel FIT. This guide helped a lot

But still I cannot change anything in BIOS (same error message when going into “Intel ICC”, freezing when I select a profile), or using Intel XTU. As I understand it, this is because ME is disabled in this BIOS. What I have done further to enable ME:
-Tried updating to the latest 9.0.x and 9.1.x 1.5Mb ME update. The system can run with either one, but still no access to ICC
-Dumped the IFR to text and searched for relevant strings
-Manually checked in AMIBCP if there is anything I have missed
-Ran me_cleaner on a complete SPI dump to verify that the AltMeDisable bit is not set

Am I on the right track? Is there some advice you can give me? If you need it, BIOS can be found in this post. It seems that ME is disabled in most/all of these Chinese boards


(Basic test to see how notification works: @ForeignerInBeijing , [mention]ForeignerInBeijing[/mention]

)

@ForeignerInBeijing - Don’t use AMIBCP 4.53, use 4.55, just because

Many Chinese board makers break ME FW compatibility in the BIOS, not just disable it, because they don’t want to deal with fixing/addressing user concerns/questions about ME FW.
This is common with many of these kinds of boards, nothing you can do to fix or enable ME FW here, other than pester the booard manufacturer/seller, to create a BIOS for you where the ME FW functionality is not intentionally broken and disabled (Good luck!)
There is NOTHING you can do until you get a fixed, non-ME-Broken BIOS from the manufacturer.


Thanks for your reply, I was afraid that would be the case. I have tried to use whatever little power I have (threaten to return the board to the seller unless they provide a new BIOS with ME enabled), but I honestly my hopes are not high at all.

@ForeignerInBeijing - Yes, sorry, but this is well known issue, as you mentioned too.
Did you also ask DeathBringer about fixing the ME in BIOS, if not, ask, he may know how to fix (I assume some removed or manually broken module, not a BIOS setting)

Are you 100% sure ME is broken on this model? Can you see ME FW version in windows with HWINFO64 as shown below, you will need to install ME Drivers first
What is the need for ICC type changes anyway? You can OC CPU via Advanced >> CPU area, so I see no need to be wasting time trying to get this working??

HWINFOnew.png



I do see that ME FW SKU is set incorrectly to Q87 chipset! Did you test changing that during one of your clean/update/add-profiles ME FW trials with Intel FITc program?
There is no X79 option though, what is your actual chipset, look under the heatsink and check with your eyes
If X79 or C61x, then SKU should be changed to C610 + something else (X, G, A or No Emulation)

@Lost_N_BIOS

Update: The seller did indeed respond and sent me a BIOS. However, it was for version 1.03, i.e. no use for me on 6.0. Interestingly it included a basic change log in text format. The only difference between what they sent me (X79QA004) and the latest version (X79QA005) is indeed that ME is disabled by default in the BIOS config. So no real progress.

I am not 100% that ME does not work, but I cannot see anything ME related in HWinfo after installing the related drivers.

I have not asked Deathbringer yet, but I will do that.

The reason why I want to change this:
-For my current system (1650 stepping C2), then I can overclock the way I want, nothing more to be gained (maybe I can get RAM to run faster if I get the 125 or 167 strap working)
-When looking at building bang-for-buck gaming systems, then I beleive that an original 1620 paired with DDR3 ECC memory would be a fantastic deal (more than “good enough” with a decent GPU). I do not have first hand experience, but the multiplier seems partially locked but the FSB is not limited. So by getting the CPU strap unlocked, I could potentially make an incredibly cheap “2600k” equivalent system.

Regarding chipset: The original BIOS states B85, thats what I used when experimenting with FITC, and most importantly it also matched what I found under the heatsink (G31426 01 PG7, SR178) which should be B85 (ref1, ref2). See below picture for my chipset.

Chipset.jpg

@DeathBringer

See post #4 in this thread. What is your experience when it comes to enabling ME on Chinese X79 motherboards? Please note that this one uses B85 chipset, and therefore comes with 9.0.x


I’m not interested in that.

@ForeignerInBeijing - This is not X79 board then, this is B85 chipset motherboard? How is it even possible to run 1366 CPU with B85 chipset??
Reply back, tell them they sent you old BIOS, ask for new + ME ENABLED and see if you can get properly reply/BIOS. I doubt, and this ^^ is probably more than half the issue here.

@Lost_N_BIOS

It is well documented that they do indeed use a large variety of non-X79 chipsets on these boards. The initial versions of this motherboard used at least B75, Q75, Q77. For Chinese X99 boards, it seems that they are sticking to X99/C612 chipsets.


Just as I saw your reply here, I also received a new BIOS from the manufacturer with ME enabled! I have not tried it yet, but I will post here as soon as I have, but Sunday night now and I have some other things that needs to be done as well. Probably next weekend.

On a sidenote, I was looking for what can be done for a Lenovo T440 that I just got. When examining the different patches, I found that it patches “PlatformHiiAdvancedDxe” to enable XMP/Memory Timings. It might be applicable for my Hybrid X79 board as well, I will test.

@ForeignerInBeijing - Thanks for the info, I didn’t ever notice this about these cheap X79 boards, very strange this is even possible!
Hopefully the BIOS they sent you works!

Lenovo BIOS and or edits related to it, has nothing to do with BIOS here

Hello there!
First of all, thank you for all the effort you put into modding a bios for these new revision boards there @ForeignerInBeijing
I had a bit of bad luck with Chinese x79 motherboards in general. First one I got off eBay was the “Deluxe” orange variety which died on me a couple months down the line. Then I got an earlier revision of these “Turbo” motherboards, but before I could even flash a new bios onto it, I ruined it by trying the dreaded soldering mod (youtu.be/B0JyWfsyLKU?t=270).
Now I’m running a used-up X79Z mining board which has a genuine S602 chipset but for which I couldn’t get a bios that’ll unlock the CPU multiplier (but I did successfully mod it with the best version of bios I could get off of this now (in)famous Russian site (xeon-e5450.ru/socket-2011/motherboards/x79z-v161-bitcoin-motherboard).
However, being a used-up board that ran in a server farm, the caps on it can’t even sustain 4 Ram sticks anymore, the front-panel on-off switch never worked right meaning I have to shut off power and wait for my 1200W PSU’s caps to drain for it to start back up. All that and now it would randomly shut off during the heatwaves we got this summer.

So I decided to fork over the cash to buy this board again, but now the manufacturers changed the Chipset yet again!
Because of that I probably came really close to bricking this board by flashing the wrong bios version! >.<)
Sooo, yea… thank you for starting this thread. It has been a Blessing :slight_smile:

All this effort is towards the goal of overclocking my Xeon E5-2687w v2 CPU which I researched far and wide to be the best-in-class for x79 platform single-thread overclocking.
The extra power-pin will hopefully also add a bit more stability to my 1080ti GPU, tho I didn’t manage to get my old spare GPU to fire off of it, probably because it can only run off PCIe 2.0

I will attempt to flash the version you uploaded to MEGA later tonight using AFUDOS and I’ll post the results here.

All the best and good health to you Champ! &^^)

UPDATE:
I wish i would have kept my word and tried your version only, but I found that one Russian forum with all of the moded bios versions for x79 mobos and it promised so many features unlocked… It has a bios for the 4.0/5.1 version of the board (drive.google.com/file/d/1EpEZKePeKUwUAjIB2xx4Jl8fNGrHWjdM/view) which i swear looks IDENTICAL to the 6.0… but of course it’s NOT.
Long story short, it bricked my new motherboard which now stalls on startup and doesn’t post.
I’m glad I at least had the common sense to back-up the bios with both AFUDOS and the Intel Flash Tool as a ROM and a BIN file respectively.
Come next paycheck I’ll try to hit up my neighboring PC shop about reflashing the bios chip directly.
First with your version then with my backups.
Our chipset serial numbers look to be the same version so I’m still hopeful yours will work :slight_smile:

UPDATE 2 Electric Bugaloo:
Eff it, i’ll just buy a TZT CH341A USB adaptor with a clip-cable attachment and do it myself. It’s damn cheap off AliExpress and looks insanely useful for unbricking anything with a BIOS chip on it. I’ll post updates here if i remember in the few months it’ll take to arrive from China.

Hi, @ForeignerInBeijing the oc bios work on x79 turbo 1.3 q77???

Sorry for the late replies, a lot of real world things going on this year

@Lost_N_BIOS
I got a BIOS from the manufacturer that enabled ME. However, nothing really works, and it just takes a lot longer to start the computer. So I have given up on this project. Being able to change multiplier on unlocked CPUs is "good enough" for me.

I will add a link to the BIOS above, just in case someone else is interested/has more knowledge in trying more things.

@nonarchistNoble
Right, you absolutely want a way to externally flash BIOS chips before trying any of this, and a cheap CH341A is what I use. While you are at it get a 1.8V adapter as well, then you can flash all the common computer things (including GPU VBIOS). When there is a major number change, (1.x, 4.x, 5.x, 6x), then I would be very surprised if the BIOS is interchangeable.

Where did you get the information that a 2687w v2 would be a good match on a Chinese X79? There are some high BCLK clocks on branded motherboards, but you are not going to get that here. A 1680V2 is IMO by far the best performance choice here. For reference, I run a dirt cheap 1650V1 on mine.

@joaquincasado
"Out of the box" I would be very surprised if it worked. Different ME, since there is a different chipset generation. But maybe it would be possible to simply transplant your current ME into the 6.x BIOS.
—Q1: Can you send me your complete BIOS dump, including ME?
—Q2: Do you have a way to externally flash BIOS in case something goes wrong, like for instance a CH341A?

Hi, I tried to Flash this Bios with v1.03 Quad Channel Memory and it seems does not work, motherboard was unbootable now.
It seems Quad Channel version and Dual Channel Memory version BIOS was not interchangeable. Most of BIOS of Quad Channel version can be used by different revision. But I really like the idea of modify Vcore so I can put my 1620 pass 4.2 ghz.
Do you have the Bios for Quad Channel Memory version ?



I realized this is an old post, but this saved me recently. Thank You for sharing this!