Z77 Extreme 4 + 3570k stuck multipliers

Hey all. Recently I’ve been overclocking my system to try and get the most out of it before I do an eventual upgrade sometime down the line. The issue I’m having currently is with my ASRock z77 extreme4 motherboard. In the BIOS I cannot alter the ratio multiplier from 38x to anything above that. The + sign does not go over 38 and if I manually enter a value above 38 such as 42 for example, it automatically resets back down to 38. I believe my ram profiles are also a little funky but that’s besides the point, I am more worried about being able to overclock my processor currently.

This user here seems to have the exact same issue as I have and he had to buy a CH341A Programmer which is what I assume I will have to do as well. z77 + 3570k can’t overclock over x38

I have taken out the battery from my Motherboard for about an hour with the PSU cable unplugged. I have flashed to an older (2.70) and then to a newer (3.00) BIOS version from my previous (2.90). I have moved the jumper over from pins 1-2 to 2-3 to try and clear the CMOS, and still nothing works. I would appreciate any help on this issue, thank you.

@sosaa - you may not need programmer, you have to try and see if you can fix without first. Please try what I mentioned in post #8 z77 + 3570k can’t overclock over x38
Please download Intel ME System Tools V8.1 package from this thread in section “C” - Intel Management Engine: Drivers, Firmware & System Tools

Use the FPTw.exe from that package, put your files into it’s same folder (@ Flash Programming Tool\Windows) and start your command prompt from that location by selecting Windows folder, hold shift and press right click, choose open command window here (Not power shell)

There was no System Tools V8.1 package in that thread so I downloaded V8. This is what I got after entering command: fptw.exe -rewrite -me -f Z77EXT43.00

Error 284: Fail to load driver (PCI access for Windows).
Tool needs to run with an administrator priviledge account.

And doing second command of: fwupdlcl -f me.rgn

Communication Mode: MEI
Checking firmware parameters…

Error 8714: Firmware update not initiated due to file open or read failure

In that thread, Ray is having same problem as me when he says this: “Ok that’s the weird thing. On the cpu ratio option i can find only 2 options: auto or all core. No per core option like most overclocking video.

If i set turbo 30 enabled the multiplier change on x47 just on display. If i try to change it will move instantly to 38. If i don’t change that value to 47 still remain x38 on bios and Windows.”

@sosaa - Sorry, yes I meant v8 not v8.1 You need to run as admin, simple. Right click the folder location where FPT is inside, hold shift and press right click, choose open command prompt here (not power shell)
Yes, I know it’s same problem as yours, that’s why I said use those files and those fixes there, since it fixed it for him (except he had to use programmer). But that’s not always the case, thus I said for you to try this way first.

For the ME update you tried second, rename the me.rgn file to me.bin, but try the FPT method first, followed by this command after first one is done >> FPTw.exe -greset
Then test BIOS multiplier changes, if no luck still, then try the FW update one next >> fwupdlcl -f me.bin

Hello. I did both things as you asked. First the update, then reset. Then when it booted back up I went into bios and still ratio locked and no ‘Per Core’ option. After boot I did fwupdlcl -f me.rgn on FWUpdate/Local-Win folder. Intel Firmware pop-up appeared, I clicked yes, and then nothing happened. Should I do reset after that too?

The file you linked here is also dead: https://nofile.io/f/0JpZ1XYUOqa/me.zip

@sosaa - Here is both of those files uploaded again, and I’ll edit link in the thread too.

Use this command >> fwupdlcl -f me.bin

I don’t know what you meant about Intel Firmware pop-up? All of this is done in a command prompt windows, so I don’t know about any pop-ups that you should be seeing.

greset is not needed once properly used fwupdlcl, which you couldn’t have done yet since you said the link was dead… So how did you run this command already without the ME file?

So, you ran these two commands already, and it automatically rebooted, then you checked and no multipliers still?
fptw.exe -rewrite -me -f Z77EXT43.00
fptw.exe -greset

Thanks for the reply. I downloaded the bin file and entered in the fwupdlcl -f me.bin command. This is what has shown up:

It got to 94% very quickly but then it was stuck there and I went to go eat. 30 Minutes later it it is still like this, is there a estimated time this takes?

And yes, I already ran both of these commands and multipliers were still locked along with no ‘Per Core’ option.
fptw.exe -rewrite -me -f Z77EXT43.00
fptw.exe -greset

It normally takes 30 seconds or so, maybe a minute. Your ME is too corrupt to update this way it seems. You will need to purchase CH341A flash programmer and if BIOS is soldered to board also purchase SOIC8 test clip cable. These are on ebay for around $2.50 each, if you need links let me know.

"Per Core" options may need a BIOS mod, did you see these before, or know they should be there on this exact board? This is unrelated to your issue, just making a general statement there, you will still need to fix this just like the other thread via flash programmer.

Can you dump entire BIOS with FPT (ie is your FD Unlocked, or do you know)? FPTw.exe -d bios.bin << Upload that file for me to look at

I have closed the FWupd that was stuck at 94%. Also, I do not believe my BIOS Chip is soldered. It is raised quite high and it looks like there is a latch to remove it, would this Programmer be suitable?


I am not sure if the FD is unlocked. I entered in this command on the FlashProgrammingTool/Windows folder
FPTw.exe -d bios.bin

And a windows User Account Control pop-up appears asking: Do you want to allow this app to make changes to this device? And the App is the Intel Flash Programming Tool, then I pressed yes. After pressing yes on this a command prompt popped up with red text, maybe errors, and it closed immediately.

@sosaa - Show me an image of your BIOS if you want to be 100% sure. I checked stock images at Asrock and it is socketed BIOS shown (there is no latch for this type of BIOS), but they may be old or not same as you have on your board, best to be sure in case you need a cable.
If you do not need cable, BIOS is in a socket, you should also order one of these so you don’t break the BIOS legs they are very fragile and bend super easy (even with these if you are not careful_

Thanks about the pop-up, that’s all windows, as for errors etc I can’t say since we don’t have an image. To see if you have locked FD or not run this command from the folder that contains FPT >> FPTw.exe -desc -d fd.bin
upload that file for me to check.

Intel flash programming tool is not an app that has any pop-up or window. This is all ran from command prompt as administrator. Select the windows or win/win32 folder that contains FPTw.exe and hold shift, then press right click, choose open command window here (Not power shell)
If you are greeted with a UAC popup asking if you want to allow say yes. Then you will have a admin command prompt open. That is how where you enter the FPT commands, this window will not close on it’s own

Yes, that’s same type I just linked for someone else too, maybe cheaper here (Didn’t check the price on your link) - https://www.ebay.com/itm/142685058952

Hello again. I tried to took some pictures of the chip and this is what it looks like. To me it is not soldered I think. Hopefully the pictures in the album are clear enough for you.


If so I will purchase
https://www.ebay.com/itm/382759287349 (this one a bit more expensive but its from USA so it will arrive here faster)
And then I will use a pair of tweezers to help dislodge it.

As for command you told me to enter of FPTw.exe -desc -d fd.bin, this is what I receive when I input that command

I am not sure if I should overwrite. I do not want to do anything wrong.

@sosaa - Yes, thanks, that is removable socketed BIOS. Make sure seller is really in USA, not in China using USA location to fake people out, check reviews for long wait on delivery in negatives etc and fast delivery mentioned in positives.
Oh, I checked the listing, looks like real USA seller, you can never tell sometimes these days, but that looks good!

Never mind check the negatives + Neutrals too (all say same)! Lots of people saying “It’s been over two weeks” “Doesn’t take two weeks to ship from Goergia to xx state” “This item not in USA” etc.

You need to find chip extractor from USA seller too then, like I linked above, otherwise you might break the legs getting it out of there.
Seriously, you can wiggle it side to side with slight upward pressure using something plastic or wooden and then just when you think you’ve got it out good enough to grab it shifts and you smash all the legs sideways.
If you do attempt, only get it about halfway out, where you have enough room to slide a ribbon underneath it or something like that, then fold both sides up so you have hold of it directly above and then pull straight up and out.
Very easy to break or badly bend, I do suggest getting an IC chip extractor. Tweezers, be careful, you can crack and scratch the chip up badly too (it’s like brittle/soft porcelain so don’t use too much pressure squeezing or prodding etc)

For your error mage from FPT, that means you’ve already ran this command before and there’s a fd.bin file in the folder. If you didn’t do that, or don’t remember, it might not be yours (maybe came with FPT download someone packaged for you?) delete the file and then run the command again.

I deleted the bin file and ran the command and same thing happened. How do I upload the fd.bin file for you to see?

That’s weird, are you running it twice? Upload to any file host and give me the URL, or attach to your post in full reply (hit reply on this post, don’t use box underneath) the attach is on right under text area
I’m sure it’s locked for ME, and FD. You can simply dump the entire BIOS and see too as I mentioned >> FPTw.exe -d bios.bin

I’m sure it’s locked for ME and FD, which means unless you pinmod the board we can’t rewrite FD to allow full FPT write without a programmer. We can try one thing if you want?
I can gather your board details from you, or you keep a safe BIOS region backup, then you test flashing a pure stock BIOS region in instead of your current, if that works, then I can rebuild a new BIOS for you from stock putting your board details back in.
Since you already reprogrammed ME via FPT, doing this will be almost same as programming with a programmer (except we wont write FD region, but that has nothing to do with the issue here)

Yes I tried that command as well:
FPTw.exe -d bios.bin

And the same thing occurs. A UAC windows permission pops up, I click yes, then another command prompt pops up for a split second with some red text in it from what I can see and closes. The original command prompt I wrote FPTw.exe -d bios.bin is still there but if enter that command again, the same thing happens.

How exactly do I upload the fd.bin file? I assume the fd.bin file is the one you want? The upload field gives me this error
Fehler: fd.bin Dateityp nicht erlaubt! (Error: fd.bin file type not allowed!)

Also I am ready to try whatever. I tried doing the pinmod before I made this thread but I believe I did it wrong and pins that I must short are incredibly tiny, so much so that the paper clip is thicker than them, so I’m not too sure how to pinmod correctly.

So, when you run this FPTw.exe -d bios.bin is bios.bin created too? If yes, upload that and fd.bin Put both in a zip file then you can upload here.
Yes, pinmod is tough sometimes, you do not have to touch the pins, you can touch the traces on the board where you can see sliver on sides (pins are actually dots underneath the chip). You can use needles, with wire soldered between them

The command:
FPTw.exe -d bios.bin
Simply gives me a notepad file in the folder saying this: Error 26: The host CPU does not have read access to the target flash area. To enable read access for this operation you must modify the descriptor settings to give host access to this region.

It is when I do:
FPTw.exe -desc -d fd.bin
That I get a fd.bin file in the folder.

I compressed the fd.bin file for you using winrar, hopefully this works.

fd.zip (268 Bytes)

Yes, I assume that will give error, you can’t dump the entire BIOS due to FD is locked. Sorry, I only suggested that as an attempt, since it seemed you thought maybe FD was unlocked.
I already know it’s locked, but I can check your FD to verify. Here is what’s locked and what’s not


You can pinmod or wait on programmer

I purchased the programmer but because many sellers lie about location and it may come from China, it may take a week or two to get here.

Maybe we could try pinmod and see if I can get it to work? I cut a piece of paperclip and held it with pliers. Do you think that it is possible to bridge it with this or do I need something thinner? Also, how does process go. Do I unplug power and turn off PSU and bridge them? Or keep power on but computer off? Or do the bridge while computer boots? Thanks.

Added some pictures for you to see if it is adequate or something smaller is needed.


@sosaa - Yes, hopefully it arrives in a few weeks for you Yes, you may be able to use tiny paper clip, you only need to touch the silver traces on the board at the points. You can also solder wire to two needles if you solder.
Shut off computer, short the pins and start the board, so yes it’s while booting the short is applied. Be sure you have correct pins. What you are using in your images wont work, too fat/thick and too much plastic on the ends to even have the metal exposed to touch to the traces on the board.
That general idea is good, but you need to expose the ends and grind to find point, or use much smaller clip