[Discussion] UBU Tool related Questions, Reports and Suggestions

As I already have written, your system will not use any Intel RAID BIOS module, because the SATA Controller is running in AHCI mode. If you want to update the Intel EFI RAID module nevertheless, you can find the latest/best ones within the start post of >this< thread.

1 Like

HI all,
I Just got from ASRock tech support a new version of bios, with new microcodes, but it doesnt resolves the problem with CSME detection tool, it is still “This system is vulnerable” situation.
Anyway, i opened it with the UBU tool and it shows that the microcodes are not in the database. Provided MEGA link in the tool itself, doesnt work. So how do i send the microcodes to be uploaded in the database?
And my MB is ASRock Z370 Pro4.


Can you share the BIOS file?

Z370P4_4.zip (8.9 MB)
There you go!

Did you implemented the update for the ME CSME 11.8 CON H DA v11.8.93.4323
The CSM tool will inquiry the board ME fw revision.

All tools and MEGA links for the Intel Management 2-15 thread are working correctly.

EDIT: This has nothing to do with UBU, the guide is here: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15)

1 Like

I dont know how to do that. There is a problem with UBUTool and ASRock boards with newer APTIO V BIOSes. I allways get the “parseFile: non-empty pad-file contents will be destroyed after volume modifications” , and I don’t know what that means and how to overcome it. Also, when I try to update BIOS with that modified BIOS file I get some error. So i asked the ASRock tech support and supprise, they replied with the updated microcode in BIOS but without updated CSME. So that’s it…

It worked flawlessly!

1 Like

UEFI BIOS Updater v1.79.17 did not updated till 3-Jul-2021.

Did the project ended?

This is a user tool project, the user has not provided any further updates since then.

The tool itself doesn’t need an update. UBU users, who want to get the latest available modules inserted, can put them into the related sub-folders of the “Files” directory.

did i insert the wrong file?
my device is Asus X455LD notebook with haswell cpu

You obviously did not follow the advices of the _Readme.txt file, which is within the Files\intel\RST subfolder of the UBU tool:
You have to make sure, that within the related RST subfolder the desired (latest) Intel RST Option ROM RAID module has been named “RaidOrom.bin” and the desired (latest) Intel RST EFI RAID module has been named “RaidDriver.efi” before starting the UBU.bat command file.
Only in this case the UBU tool will find the matching updated Intel RAID module.

my bad, i downloaded the file from this topic AHCI & RAID ROM Modules and it has .bin extension

Can anyone help? Why is Ubu not replacing the microcode for my AMD laptop bios?
[REQUEST] Vivobook Pro 14 (M3401, AMD Ryzen 5000 Serie) - Bios SMU/Microcode upgrade - BIOS/UEFI Modding / BIOS Modding Requests - Win-Raid Forum (level1techs.com)

My attempt:

  • Get the MMTools and rename as described
  • Updated MCU to latest version
  • Get MCU microcode repositry and paste all AMD microcode into Ubu/Files/AMD/mCode/AM4
  • Run Ubu and try to update microcode but failed…

Hello I updated my Z97 Marks S with a modified bios file from UBU.
I did this already around 3 - 5 times in the past successfully.

Unfortunately I’m having currently this issue:

  • XMP / Ram Settings aren’t changeable.
  • Normally my RAM is capable of 1600 MHz through it’s XMP profile and normally I’m using the RAM with a frequency with 2200 MHz.
  • Now matter what I’m changing Frequency or Timings, the settings won’t change and the RAM uses it’s stock settings (1333 MHZ).
  • I’ve already tried to rollback to stock BIOS, removed CMOS battery, using only one RAM module instead of 4, etc… without any success… RAM settings still locked smh.

Has here maybe someone a clue how I can fix the issue?

You have here, a recent user, with a similar situation, he solved by getting a new SPI chip, now is performing tests but are not yet concluded regarding the old SPI/NVram or old Intel ME FW image on old SPI.

Read the whole thread to understand the possible causes.

EDIT: Glad you made it, presumably the EZ2 should be the one that doesn’t override the whole SPI… strange things happens…lol

1 Like

Thankyou for linking this to me.
I think I will buy a new BIOS chip then (which isn’t much a problem).

Or is here a guide on how to flash a .CAP Bios directly to a SPI chip with a CHA341 programmer? Because I have luckily one in hand.

Only thing that quite annoys me is that my motherboard has a plastic shell over the BIOS chip (Z97 Mark S) which will be quite annoying to remove as I have to unscrew the mainboard first in order to unscrew the plastic shell. Wish they would have placed the BIOS chip in a more accessable location or leave a small hole in the plastic shell to access the BIOS chip directly… :frowning:

I was able to fix this issue by just flashing latest stock BIOS via Asus EZ Flash Utility 2.
Now I’m able to use XMP again.

I tried exactly this before but instead with the BIOS Flashback USB function and this didn’t fixed my issue. I don’t know what BIOS Flashback via USB does different than EZ Flash Utility 2, but maybe someone else can profit from my finding/solution/fix.

1 Like

maybe if you want to mod, mod 1 bios from stock with UBU

then use MMTOOL to extract the dxe driver (remember the GUID shown when abt to change), mostly if OROM was changed its all on CSMCORE or CsmDxe, extract that, and the rest

For MCode, you might want to find the Guid 170- below MemoryPei, the one that’s not on DXE Driver. extract, then replace it to the guid 170 (size should be small) on very top, replace mcode as you want, save, and extract the verytop mcode, now with another clean stock copy, replace all the DXE you extracted to the same exact location

This way sometimes works on avoiding pad files getting destroyed.

Hi, the Intel_RST(e) updates in the original post seems down. Could I be possible to have a mirror to the Intel_RST(e) update archives?