[Guide] NVMe-boot for systems with legacy BIOS and UEFI board (DUET-REFIND)

hi there, i had the same proble… did you sole that?

i would like to thank all the enfforts that people do to help, but i tryied a dozen tutorials and none with success… Clover, duet, duet/refind, aioboot (pizuski)… nothing works… i think that have to be some twiks/configuration on the bios that are missing in the tutorials… does anyone knows a complete tutorial that works with: Asus P6X58E-D
more specs: intel i-7 960; Crucial P5 Plus nvme M.2; Pcie adaptor Conceptronic EMRICK05BS Emrick… thanks in advance

Nope. Will not work for me. Can’t figure out why. Thinking its a bios setting but what one? I have the pc in question exactingly over clocked and don’
t want to ruin that. But eventually I will restore it and try.

i made progress…
some bios config:

  • disable usb 3.0
  • change sata to AHCI
  • USB boot with aioboot (pizuski)… includes Clover… there is a tuto in the forum

my problem now is when i connet my nvme via pcie, my win10 in HDD dont boot… and when try to intall win10 via usb with clover, it freezes too

hope this can help you

I don’t have USB 3 on this system

Already set to ACHI.

I will try that boot drive program. If you could link that tutorial that would be sweet.


yes… but i think that the problem is some tweaks at bios that are missing in the tutorial, because i already tested the same prog it no success, and after made the change in the bios, the proram runs… now is missim something more, as i cant boot with the nvme via pcie card adapter connected

try to disconect all HDDs too… i did it and it runs

this guy says, at 1:10 min, that if is not a UEFI Bios, dont even try because it wont work, its a waste of time

i still dont know if its possible… i cant do it

here two videos that shows how far i went… one boots from Clover and the other one from my native multiboot… this one stays almost 2 min at the symbol windows screen

by the way, i tested with win10 Lite [Spectre], in both cases


That aio program booted for me and seems to work. I changed nothing in the bios except to boot from usb. I’ll have to pull some hardware but in a few days I’ll try to get Windows installed. I will detail how it goes.

I can’t get that windows logo to show. After I select clover bootloader, i select the USB drive with win 10 on it. system reboots and nothing happens.

Really, I am sick of all these guide that do not tell you in detail how this has to work. Even the guy who wrote the guide for aio has mistakes in his guide. #3 does not get you clover boot loader…its #6.

What I think the issue is for both of us is either the usb sticks or the OS.

it happens with me too… so i read about, and you must do, in your windows usb install this:

  • *After the image has been burned to the USB, copy bootx64.efi from the /efi/boot folder of the Windows ISO/DVD into /efi/microsoft/boot. Rename the file to “bootmgfw.efi” and also rename cdboot.efi to cdboot.bak.

then you will see at glover menu a EFI install option… start it and wait (instalation stays at win logo for 2 or 3 minutes. just wait)

i download win10.iso from wintool… and Rufus settings must be GPT//
unffortenlly i cant get it to work with the nvem connected via pcie… it frezzes… but without the nvme, it goes well

then let me know

Thanks for the help.

Followed what you said but it didn’t change anything for me.

When I boot the aio I see a menu 0-9, then, a, d, f, g for options. Clover boot loader is 6. When I select 6 I am presented with: boot grub2 ufei from aioboot, boot winpe from aioboot, boot windows from legacy hd1. Under neath are: start uefi shell 64, options, about clover, restart computer, exit clover.

It seems logical that I would want to pick “0” which says: “install windows from iso” but I have not a clue which options I should choose once in that menu.

well… it seems that your usb win install is not reconized by Clover… see the files below, and see if you done like that… it works for me… windows instalation takes 2 or 3 minutes to go, but will do… i did it without nvme installed, cause with nvme, windows instalation crashes

I don’t know if this might be of help for you, but, in my case, for some reason, DUET only manages to boot when I set my controller setting to IDE. When I set it to AHCI, it hangs before showing anything. Blinking cursor on black screen.

My motherboard is MSI 870-G45, running a Phenom II x6.

It’s annoying though, I’d have liked to run native ACHI instead of IDE emulation.

Interesting. I never thought to try that. Nvme doesn’t use ahci as i understand but other drives still will, though I do not understand all of that. Can’t you change it back to ahci after getting everything installed? I guess not or DUET will go back to not working.

Thank you.

Edit: the aio boot loader does work for me but I simply lack the expertise to navigate it as I am not seeing the options laid out in this guide.

Yeah, I know, the IDE/AHCI/RAID mode is for connected SATA devices, but for some reason, anything else than IDE and DUET doesn’t do anything. Black screen with blinking cursor.

Funnily enough, I noticed I can type stuff on that black screen and the cursor moves down, as if it’s showing me an error message, but nothing appears.

Also, I tried booting with Clover (the other solution), and it does the same thing the moment I set AHCI or RAID instead of IDE. Anyone has any clue why that is?!?!

@noInk Hi, do you have a Github? Gitlab? notabug? etc…?

i write to report:

1.0.5 “2020” Works,
USB cannot be created in Windows8.1x64 “latest build with EDGE”,
Only W10.

#2. does Not work with SATA 6Gbps to PCIe with Aspeed controller.
like: Sonnet Tempo Dual Sata, with latest Firmware installed.
only works with x58 board Intel ICH10R

i know NVMe is faster but,…
ssd is cheaper and many equipment has a sata port.

#3. Reboot does Not work, Only Power Off.
Reboot detects USB as Damaged.

#4. USB creator is very picky about USB drive type, brand, size, model,…
tested different brands of USB drives, microUSB to USB adapter, CF, etc…
all are created but some work, not all support DUET…

Boots UEFI Linux 22.04.1 LTS ok
Boots UEFI Win8.1x64 ok.

Win 8.1x64 by default has Bios boot loader,
but with the USB or DVD Restore Comand prompt method,
list volume
x:> bcdboot f:\windows /s c: /f ALL
or UEFI, or Bios.
ALL does Not work with Old MacPro5,1 2009/2010/2012
“single cpu tray has x58, dual cpu has 5520”
Mac Only supports Windows8.1 /f Bios boot mode.
UEFI Linux works Ok.
but i want to test VirtualBox & other

Thanks a whole bunch. I was really really struggling getting Clover working (Been to several sites & tutorials, changed boot files and hell knows what else I’ve tried!) and it didn’t work with the NVMe driver at all, so I was ready to call the quits with that.

Then I found this article and it really saved my bacon. I have yet to try this on my SuperMicro server which has some +30 disks, so it might be somewhat of an challenge to get it detecting the right disk and set it to boot with the NVMe as the default one.
But, I got this far and it managed to boot in UEFI-mode, and that motherboard has some UEFI-support, so I don’t expect there to be any problems, or at least not that many, in that department.

At the very least, I’m now able to run that on my other PC which also lacks native M.2 support. Best case scenario, I get both computers running with it, worst case only one, until I get the other one working as this looks promising AF.

Thanks for making a simple tutorial which actually works right off the bat, apart from me not having set up the UEFI-boot in BIOS, which was fixed within a couple of seconds.

I was unable to use that bootloader, so I was incredibly lucky with the “regular” Clover, but I will still use this on my other computer. Just waiting to finish backing up all data so that I can erase the other SSD and install Windows on it and there will be no more slow SATA SSDs for the OS.
Two things that I noticed with regular Clover; One was that the boot6 (Which seem to be started or is(?) the file “boot”) had to be removed/backed up and replaced with a copy of boot7 (renamed to boot), and secondly, as I was pulling all cards, including the GPU and thought that the internal crappy Matrox-something-16 MB VRAM would suffice, I was very mistaken.
I got a strange thing when first trying to boot it up, since SuperMicro have their own way of making BIOSes; Normally, there’s a lot of beeps when things like USB devices are activated (Typically a lot of them when using hubs, one beep/device), and as I saw “6” then a seemingly frozen blank screen, I heard the same beeping noises, only a few more, but then nothing happened.
When I then suspected, after a revelation that it juuust might be the internal GPU, it turned out to be just that. I was ecstatic. I just got it to work.
I was able to finally boot up Windows from the SSD (I used the one I previously installed on from the other machine).

Then I spent maybe half an hour trying to get the machine to play ball with the ASMedia 1166 SATA-controller that just wouldn’t allow me to disable it.
Normally, the BIOS reads the addon-ROMs then present found drives in the BIOS settings, which it surely did, but it totally ignored all other drives being disabled.
Luckily I found out that I could disable the PCIe slots, which solved the problem.

I also had to cycle between using the NVMe SSD/USB-stick with the regular SATA SSD, which almost drove me nuts since the @#½&% BIOS was reset at one point, and I missed that the SATA-modes had been changed, so I kept getting “boot device inaccessible”, and a few very very careful inspection of all the settings later I was able to boot it up so that I could copy necessary data between the drives in different configurations.
I had to switch between these a few times, but now I think it’s doing just fine.

What an absolute nightmare this has been, thankfully there’s a solution to most problems. You just need to sort them out, one cluster-hump at a time.

Again, thanks.


I installed DUET (2015 and 2020) on my DL580G5 server.
I don’t have an m2 SSD for now …

On startup I got an error
“Boot Failed - EFI Misc Device”

The disks are installed on “LSI card, SAS2 2008 Falcon”
the discs are visible and I can launch the install of Windows 10, 11 … but on restarting the disc is not bootable…

I have another Intel Standard SATA 2 controller which boots normally … “PCI Dual Channel Standard IDE Controller”"

Is there a solution for my “LSI Card, SAS2 2008 Falcon” controller ?

1 Like