X58/LEGACY BOOTING FROM NVME DRIVES (PIZUSKI METHOD) (MOST QUICK&SIMPLE WAY)

So you may be wanting to boot a efi system from a bootloader to boot nvme drive and having trouble like i did.
dont give up til you try this


0. run Cmd, diskpart>list disk> select your nvme disk >clean>select disk n>format gpt> if CMD says successfully created GPT partition than you may proceed young warrior…
1. download AIOBOOT https://www.aioboot.com/en/download/
ITS GOT CLOVER BUILT IN (so if your clover or duet USB didnt work or if you had my problem, and the dbr wouldnt write the dos OS file to USB for boot, then you dont have to worry because this version is already set up/working etc!
MUAH*

2. extract the application to desktop [[File:2020-06-26 (2).png|none|auto]]

3.Run as Administrator

$$$$$$$$$$$$$$$$$$$$$$$$

4. choose your USB stick, and select auto install Bootloader. and hit OK!
(make sure you select format fat 32 as well )(if it gets stuck at 77% just be patient and watch your USB stick, if the light is still flashing on it then data is being write or its communicating with your PC [[File:2020-06-26 (3).png|none|auto]]

5. check the USB for files in windows explorer, and if you have the nvmedxe.efi (or best efi driver file for your nvme) file copy into the clover driver off driver 64 directory for safety, i dont know what works or doesn’t i was just trying everything at one time HAHA![[File:2020-06-26 (7).png|none|auto]] [[File:2020-06-26 (9).png|none|auto]] [[File:2020-06-26 (10).png|none|auto]] [[File:2020-06-26 (11).png|none|auto]]






6.If you did correctly follow it should look like this [[File:2020-06-26 (5).png|none|auto]] [[File:2020-06-26 (6).png|none|auto]] [[File:2020-06-26 (7).png|none|auto]]

7. Attach your USB with Windows ISO from media creation tool or Rufus and Boot from clover USB ( it will take you into AIOBOOT bootloader first but clover is option 3, then go into refind, you should see your windows USB in refind and then you can boot it.
once you get to the hard drive selection of windows 10 install if your disk successfully partitioned to GPT As stated in step 0.

8. i ignored a message that came up in the windows installer saying the GPT wasn’t correct for windows install, but i ignored and proceeded and everything installed correctly and im running fantastic, its business as usual
Thank you all for the help along the way its been a fun challenege bringing 2010 into 2020 but it was worth it,

2020-06-26.png

2020-06-26 (2).jpg

2020-06-26 (3).png

2020-06-26 (5).png

2020-06-26 (6).png

2020-06-26 (7).png

2020-06-26 (9).png

2020-06-26 (10).png

2020-06-26 (11).png

2020-06-26 (12).png

Clover keeps crashing for me both on live and in qemu.

Hi @Pizuski ,

I followed your instructions until here

"Attach your USB with Windows ISO from media creation tool or Rufus and Boot from clover USB ( it will take you into AIOBOOT bootloader first but clover is option 3, then go into refind, you should see your windows USB in refind and then you can boot it."


I don’t see Refind. Did I miss out anything?

me also…didnt find refind nowhere…

MOBO: M5A78L-M PLUS
CPU: FX-6300 Black Edition
VLW2560/PM961 NVME M.2 used with PCIE X 16 Adapter
System: Windows 10

Windows on native system (HDD) is able to recognize the NVME drive but not able to boot when using Windows Installation Media/USB

Steps taken over the past 2 weeks and reading many forums (failed):

Duet was being weird on my PC

1. Installed Clover on host system using the link for Clover and was able to create a separate 200 mb BDU partition, created directories for drivers 64 appropriately.
2. When booting after disabling IDE and setting SATA configuration to AHCI got the following argument: the drive p.list argument at line line 1194, product name not defined

How can product name be defined without Clover Configurator as I am working on Windows 10 ?

3. To try to solve this I installed a seperate p.list (HACKINTOSH) ASUS-PRIME-Z390-A-config.plist_
4. Continued to receive error: Expect a bolean, and int8 or a string starting with ‘n’ or ‘-’ for '/boot/XMPDetection:175’

Result -> Loaded into clover but could not detect my Windows 10 Installation media thumb drive

5. I ended up using AIO boot which was then recognizing my Windows 10 flash drive after selecting option into Clover using "Pizuski method"
6. In the Windows installation, I was receiving the same error when booting installation media: Check your BIOS/boot to use this drive as your system may not be able to boot
7. I also tried to install separate signed drivers for PM961 M.2 on a separate USB from @Fernando fix this issue but to no avail.

Please help as I am starting to pull my hair out.

@Randomaccessmonkey : Welcome to the Win-RAID Forum!
Since it neither makes sense nor it is welcome here to post similar posts into different threads, I have deleted one of them

Why didn’t you do the change of the SATA mode as first step?
Regards
Dieter (alias Fernando)

Hi @Fernando the guide stated that I would need to install the Clover client on the same machine since the p.list automatically configures to the machine which Clover is installed.

There is no way for me to load into Windows 10 and then install Clover from the desktop from the SATA after switching from IDE to ACHI as the OS runs into issues (Windows Stop Code: Inaccessible boot device)
—————————————————————
Despite these issues I was still able to follow @Pizuski guide using AIO boot software (Pre loaded with Clover) to recognize the Win-X USB Stick which was installed using Windows Media Creation tool.

The issue I run into is that the Win-X USB Drive is unable to install onto the NVME, despite being recognized by the installer, due to a boot error: “Windows cannot be installed to this disk; the computers hardware may not support booting to this disk. Ensure the field controller is enabled in the computers bios menu.”

This issue is non-unique to clover, as it occurs during normal installation process when booting directly from the USB. I have already confirmed the existence of NVME drivers using clover shell command drivers.

image.jpg

@Randomaccessmonkey :

That should have been no surprise for you, because the boot sector cannot find the SATA connected HDD/SSD anymore after the switch of the SATA Controller from "IDE" to "AHCI" mode.
You should choose the desired SATA mode before you start with the OS installation. You can enter the BIOS and change the SATA mode at any time, that means without having installed any Operating System.

Yes I followed the protocol as you described: however Clover is unable too recognize Win X Installer USB. I’ve had luck with AIO boot, however there is boot error as shown in figure/img in my previous post for the NVME drive.

And my apologies, I thought you were implying to install Clover after “IDE” to “ACHI” switch in regards to my first message.