[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing

FPT and phoenix-uefi-winflash-1.5.66

The Phoenix is backuped by programming device,how can I flash it use FPT or phoenix-uefi-winflash? My laptop is made by the elitegroup computer system.

BenQG41SUS45INE1MB8L.rar (3.26 MB)

Download.

I changed the hidden bios setting named Me FW Reflash(…)
And it worked. (only for ME region)
But how does it give the permission needed for flashing?
It’s locked by intel descriptor too, isn’t it?
Can bios override descriptor’s read/write permissions?

The pinmode method worked for me. Thanks!!!

Hello!
Please, i need help. I have Dell Latitude E6410 laptop and i need unlock bios write access permission.
I backuped bios (i’m new user and can’t attach, but will add link), i can open it in UEFITool 0.28 or UEFITool_NE_A59, it’s Ok. I found GUID - 899407D7-99FE-43D8-9A21-79EC328CAC21 (Setup), exported it as is and as body.
But then with Universal IFR Extractor v0.5 i can’t extract it, in one case Extractor tell: “Protocol: Unknown”, in another case it extract blank txt without significant data, only headers…
Maybe i need another IFR Extractor or what?
link to bios: Dell Latitude E6410 Compal NCL01 LA-5472P nvidia Bios + EC.rar - Google Drive

Hello, I’ve tried to unlock my DELL Precision M4800 to flash a modded BIOS (enabled SPD write, tried to also unlock hidden settings), I have unlocked ME Reflash (setup_var 0x2BC 0x1, HWINFO64 shows that ME section is completely missing after that though), but FPTW64.exe outputs Error 25.

No miracles here and what you want is a very risky operation on this OEM machines, even worst on a laptop workstation, they do usually contain various security, TPM/EC spare chips etc…
The error is due to bios region is locked and all the info regarding this operations on certain motherboards/systems is in the forum. Also HWinfo not showing ME information is not sign of a good “unlocked ME” work…

Radical users, that can spare a machine, have SPI programmer and has advance user skills, have been seen to do manual edits to the FW with the Intel FIT tool/HEX edit to the SPI/FW FD…but very few and very few cases of success.

And nothing more i can add, wait for another user opinion, good luck.

I feel like previous owners were doing something with it, before I received it. I have original BIOS dumps though, and I also have a CH341A (3.3V mod). Why I am trying to do it in a “software” way? Because this machine is tough to disassemble completely (Well, it is not, actually, it is all because of a place where I live, but that’s for another conversation). So that’s the reason why I am doing it this way. It also has a little “ME DISABLED” sticker under a battery.