[help needed] unlock show avx512 menu on asus h610m-a d4

I am using Intel i5 12400 with avx512 still available but disabled by microcode
, i am succes reenable that feature again with helping from mm tool

but problem is avx512 it activate at default bios in auto mode, because avx512 menu is disabled by asus, but i try with AMI IFR extract my bios, menu avx512 is still there but hidden by Suppress

but i still confusing how to unlock/reshow that all avx512 feature related in my avx configuration in bios menu with hex, i try open my bios with AMI BCP but not succes because max string error so config not showing off

any help is appreciated, here my bios and IFR log

(。・∀・)ノ゙Hi, what menus are currently visible in your BIOS? You can attach some photos. Get help faster.

1 Like

here currently show in my menus brother, only avx2, and avx2 voltage ratio + avx512 all menu is hidden

avx2 only

here screenshot from asus z690 with menu avx512 toggle and voltage controll showing up and that feature is related to IFRextracted but hidden in my bios

sory i upload image persection because limit

it’s here

1 Like

Thanks brother i see it 2 file, where that file get modded, is 2 bin? i see AMI Capsule still in there

i try compare IFR in two file original and 2.BIN files

i see now AVX512 Structur is different now, Suppress is removed now, nice brother :fireworks:

because it still inside Capsule like i can flash it with EZ Asus flasher and intel FPT not needed here

You can see them now. yes?

1 Like

i am not tested it yet because still outside home brother

Oh, no. You can’t modify it like that.
First, the syntax was broken. Don’t you see that the lines have moved to the right? At least, you had to keep “end” codes for each of "one of prompt"s. It works so that “suppress if” should be followed by the “end” and also the extended conditions are followed by the “end”. Second, for AMI BIOSes any changes in the IFR module associated with a decrease/increase in the total number of elements must be synced with another table by making corresponding changes in the AMITSE setup data module. After all, it is AMITSE that is responsible for the structure of the final BIOS Setup Utility.


Wow, welcome back, this change was made because there was success before this (single option move). Multiple options are also a first try. thanks for your clarification :kissing_heart: :innocent:

no i dont mod it bro , it generated by IFR extractor,
suppress missing is from bios edited by 553349149

can you help unlocking that menu

Good Morning.

Le’ts Overall Simply Clarify this:

That means;



is like for a Fully Command written Row end. so it says you can go ahead with the next coding row, you had to type for

and that so on, until at least to be need for.

iama right @Sweet_Kitten ?

1 Like

Sadly, but no. Im online, but still not back. I can access the network from my smartphone, but there is no access to the computer.

Six more month and I’ll be at home.

here ORIGINAL & MODIFIED ifr TXT FILE anyone can have look

Everything will be fine, looking forward to your return

Also, have you tried 1.bin? It changes AMITSESetupData. Sometimes this is enough to make the options visible.

If not, I’m going to re-edit 2.bin.

1 Like

thanks for your help brother, i extracted 1.bin from capsule to INTEL IMAGE with uefi tool ne 62 and flash with intel FPT csm 16, you awesome, now all hidden avx512 menu showing up and toggle avx512 for enable and disable is worked

hope you share some little tutorial to unlock that menu, i need to unlock other menu like BIOS Lock and flash protection range registers (FPRR) in PCH security menu
so i dont need to disable FPRR or bios lock with setupvar if it enable again sometime with their failsafe setting is set to on

The approach doesn’t always work, sometimes you just need to change the suppression condition like kitty mentioned, sometimes you need to change multiple modules at the same time. Take AVX512 as an example, find the QuestionId A7 00 (offset 112A4) of AVX512 in the AMITSESetupData module, change the next 15 bytes to default 09→user 0D