Help! with z390 aorus ultra bios f9 HPET SETTINGS


Can someone help me with the bios settings. I want to disable Hpet settings, but can’t find it in bios menu.




Can someone modificate the bios :?


I’m trying to change by myself but getting this error:

( F8 bios opens normally, but cant save after changes)

Please don’t make multiple posts in a row, if you need to add more thoughts or questions please use the edit button, thanks

I will make you BIOS with HPET and a few other settings visible, please wait. I can’t do it until tonight, sorry but I only have a few minutes right now before I have to run.

Ok i changed the hpet settings. ( edited bios: ).
Now i can’t flash mod. bios using q-flash :D.
Any help:?

@jonasdanys - Please wait, before you brick the board, I will give you a full menu edit so you can access that entire section (PCH-IO Configuration)
If you can’t wait, and want to try your mod BIOS, here is how you remove the Qflash block - [OFFER] Gigabyte GA-Z370-Aorus Gaming 7 BIOS mod (6)

ok, i will wait. Thanks :slight_smile:

@jonasdanys - Sorry for the delay here!! Can you please show me image of your “misc” BIOS page, I will put HPET setting there for you I think

No problem, thank you :).
I have attached bios photos, it’s all good?

@jonasdanys - Please zip those images, thanks - Also, is that BIOS F9? If not, please link me to that BIOS. Those images don’t match AMIBCP or setup module structure, layout, names etc

My edited bios and photos (F9 BIOS) :

@jonasdanys - why you’re edited BIOS too?? I am on limited internet, and only need the images zipped. Did your BIOS edit disable HPET for you? If yes, can you use that for a little bit >>
Since that is F9 BIOS, and due to what I mentioned above at post #8, if you want to be 100% everything will be OK, do you mind to wait until I get a Gigabyte Z390 myself? That way I can test edits on my end and make sure all is OK before I send you any BIOS.
I plan to order one (Z390 M Gaming) soon from Amazon, but am still a little short on $$, so may have to wait a little longer, or take risk and purchase one of their “Used” boards which probably come with bent pins I have to fix and no I/O shield

I’m just trying to disable hpet, because this setting causes input lag on my PC. But probably my edit didn’t work.

I don’t know why, but my edited bios not saving after changes by amibcp.

This BIOS is probably not fully compatible with AMIBCP, sorry, I thought you knew how to same edit outside of AMIBCP and did that already. I assumed, hadn’t looked, that this BIOS didn’t even open properly in AMIBCP (I see it does now)
What do you mean “edited bios not saving after changes by amibcp.”?? Do you mean you edited BIOS with AMIBCP, then saved, and flashed it, and then BIOS is messed up and wont save changes anymore?

I will make you BIOS with just HPET disabled, that I can do anytime, will edit it into this post in few minutes

* Edit @jonasdanys - Flash via Qflash, choose in-tact if asked, and once flashed clear CMOS, then reboot to BIOS and load optimal defaults
If that fails to disable it, send me your BIOS region dumped with FPT, then I will edit all additional NVRAM areas too…634626152955930

Yes, after flashed bios (edited with AMIBCP) no changes at all. I tried disable hyperthreading just for look, but same results.
After flashing yours bios, same :/. NO changes

You need bios by dumped by AFUWIN? Its correct ?

P.S sorry for my english :D.

@ jonasdanys - No, please test BIOS I linked above in #12 - Flash via Qflash, choose in-tact if asked, and once flashed clear CMOS, then reboot to BIOS and load optimal defaults
Then, if HPET still enabled, I need FPT BIOS region dump (AFU should never be used on this system to flash BIOS)

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64
Then on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C.2” download the matching ME System Tools Package
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder.
Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error >> FPTw.exe -bios -f biosreg.bin
If you do get error, show me image of the command entered and the error given
^^ This is important step, don’t forget ^^

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)…creators-update…menu-windows-10…ator-privileges

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required…134606820377175

Yep i did everything. Flashed via qflash and cleared cmos. No changes. :confused:
Dumped bios FPT:

@jonasdanys - Then loaded optimized default?? How and where are you checking HPET is enabled or not?

I checked your BIOS region dump, all 100% disabled now, there is no way this is enabled at the BIOS level.
Here’s my notes as I extracted and double checked all previous changes, and checked for anything new in full NVRAM dumps that may need edited

Suppress If {0A 82}
False {47 02}
High Precision Timer, VarStoreInfo (VarOffset/VarName): 0xA1B, VarStore: 0x1, QuestionId: 0x875, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 A7 10 A8 10 75 08 01 00 1B 0A 10 10 00 01 00}
One Of Option: Disabled, Value (8 bit): 0x0 (default) {09 07 04 00 30 00 00}
One Of Option: Enabled, Value (8 bit): 0x1 {09 07 03 00 00 00 01}

This is how it’s stored in NVRAM (last byte, easier to find this way) You can search BIOS directly via UEFITool hex search to find all locations for each item)
01 00 00 00 01 02 00 01 01 00 00 01 01 02 03 00 00 01 00 00 00 00 << Controlling byte for this setting
00 = Disable
01 = Enabled

NVRAM 1 >> x27
01 00 00 00 01 02 00 01 01 00 00 01 01 02 03 00 00 01 00 00 00 00

NVRAM 2 >> X3
01 00 00 00 01 02 00 01 01 00 00 01 01 02 03 00 00 01 00 00 00 00

NVRAM - Internal STD >> X1
01 00 00 00 01 02 00 01 01 00 00 01 01 02 03 00 00 01 00 00 00 00

Shadow NVRAM - 77D3DC50-D42B-4916-AC80-8F469035D150 >> x1
01 00 00 00 01 02 00 01 01 00 00 01 01 02 03 00 00 01 00 00 00 00

01 00 00 00 01 02 00 01 01 00 00 01 01 02 03 00 00 01 00 00 00 01 << No where in BIOS

Additionally, AMITSE/SetupData (BODY @ 0x3CCC4h - 0x3CCC5h, what AMIBCP Changes = both bytes Fail Safe/Optimal = 00 00 (I changed previously)

And, Setup Default >> Change to Disabled previously.

If BIOS HPET Disabled + bcdedit /set useplatformclock true, then in CPU-z Timers @ QPC Should be around 3.xx unless windows older than 1709 version, then >> 10.xx
If BIOS HPET Enabled + bcdedit /set useplatformclock true, then in CPU-z Timer you will see HPET Timer and or QPC will be around 14.xx -21.xx

To disable HPET directly in Windows run the command bcdedit /deletevalue useplatformclock

@st1cky - Can you confirm for me, I translated all that from “timers” image correctly into a text form? ^^ Thanks

No changes needed, 100% disabled at BIOS Level

Hello,thanks for the help (ye hpet off). It took me a while to realize that mobo runs gpu x4 3.0 speed at x16 slot. I tried another motherboard and another one works great. it’s a defect or something i can do?
i tried f5,f6,f9,f10b bios… and gpu drivers latest
GPU: 1080 ftw2
Mobo: Aorus ultra z390

btw x8 slot works great.


Bios photo:

@jonasdanys - Maybe power save feature, click that checkmark and run 3D test, see if it increased from x4 to x16. if not, it may be the card itself is only x4, or you are sharing that slot with another card you have installed, or maybe shared PCIE Lanes with M.2 slots? Check manual about that, it will tell you
Yes, I see you have two x4 M.2 NVME installed, and one of the slots on your board is 16 length but only x4 electrical + specs below (See manual for more details on which slots are affected by M.2/NVME installations etc)…#support-manual

1 x PCI Express x16 slot, running at x16 (PCIEX16)
* For optimum performance, if only one PCI Express graphics card is to be installed, be sure to install it in the PCIEX16 slot.
1 x PCI Express x16 slot, running at x8 (PCIEX8)
* The PCIEX8 slot shares bandwidth with the PCIEX16 slot. When the PCIEX8 slot is populated, the PCIEX16 slot operates at up to x8 mode.
1 x PCI Express x16 slot, running at x4 (PCIEX4)
* The PCIEX4 slot shares bandwidth with the M2P connector. The PCIEX4 slot operates at up to x2 mode when a PCIe SSD is installed in the M2P connector.

1 x M.2 connector (Socket 3, M key, type 2242/2260/2280/22110 SATA and PCIe x4/x2 SSD support) (M2M)
1 x M.2 connector (Socket 3, M key, type 2242/2260/2280/22110 SATA and PCIe x4/x2 SSD support) (M2A)
1 x M.2 connector (Socket 3, M key, type 2242/2260/2280 PCIe x4/x2 SSD support) (M2P)
6 x SATA 6Gb/s connectors
Support for RAID 0, RAID 1, RAID 5, and RAID 10
* Refer to “1-8 Internal Connectors,” for the installation notices for the PCIEX4, M.2, and SATA connectors.

It may all just be your cards power saving feature, since in BIOS it says x4 and PCIE 1.0 even! Run the 3D test in GPU-z and see if it goes up

i have:
1 - m.2 (970 evo 250gb)
1 - ssd (ssd 860 evo 500gb)
2- hdd

I tried to disconnect everything and same… x4…:

Gpu-z test:

Nvidia power m. mode: prefer maximum performance
Windows power options: high performance

Card on another mobo runs fine at x16 (I tried on a friend’s computer)

Few things to try. Clear CMOS, then load optimized defaults, and then keep testing for now with single card and single NVME, unless you know by manual the NVME is not affecting. Could possibly be blown resistor or something on the slot?
Does card run at x4 on the x8 slot too, with nothing in the top x16 slot? If yes, then maybe not blown resistor/fuse for the slot. Can you test other card in the top slot, to see if other card is OK and you see x16 there? Maybe some compatibility issue?
If you think maybe it’s a compatibility issue after testing you will need to email them and give exact card model, full # of card details, then they can test