[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

As the MMTool 5.x reports successful insertion of the Small variant, regarding volume space (besides the pad error) i would be using the UEFI_tool0.28 to insert the same variant.


Or if you wish to use the standard variants, you may try the method of removing unnecessary drivers, related to UEFI DXE network boot drivers.

Im not providing any files here, because it seems you’re a capable user and fully understands the processes, give it a try and ensure you have backups and recovery methods, good luck.

EDIT: I made another test with older MMTool 4.x and the insertion of the small variant is also OK with original Pad still present, so plenty to choose.

@Fernando - No worries. Thank you for taking the time to take a look.

@MeatWar - No need to apologize. Thank you for offering to help.

@MeatWar - Thank you for taking a look and providing advice. I’m still struggling to make sure that the Pad-files are retained from the pure image. I’ve tried to insert the NVMe module using MMTool4.x instead of MMTool5.x as you suggested. Below is specific version information.


As you have mentioned, the Pad-File after the DXE Volume appears to be intact with both MMTool and UEFITool as illustrated below.

However I now seem to be losing the Pad-Files before the DXE Volume as illustrated below. MMTool further seems to remove records with GUID 05CA01FC-0FC1-11DC-9011-00173153EBA8.

I’m all ears for any other advice you may have.

Humm… didnt checked those ones, usually we check end volume.
Indeed all options i elaborated will remove them and they got data… even getting more space and using other variants…
Tried to extract/insert/replaced, neither worked also, the volume is always modified…


The ROM holes change offset when their gone…

  • Even after UBU their gone…
  • An Hex edit data maybe… a bit painful here

We can try another method, make an FPT dump of the bios_region only, not AMI AFU backups.
Then try again all the methods we already know here… but do not get many hopes, this one is tricky.
Its a risk but it still could work if flashed… but dont do it if you cant recover it.

EDIT: Tomorrow il check other Supermicro X10 confirmed success reports here on forum and will analyse their structure ori/mod, this was never noticed and it works or this one is a damm pain…

1 Like

@MeatWar - Thank you so much for spending all this time to investigate. I am going to hold off from flashing anything until I have a higher degree of confidence that this will work. I will eagerly await any updates from you, regardless of whether you have good or bad news.

I have now successful results to share… but i would like to test the FPT dump as i stated/requested in my previous post, before final report.
Do you have knowledge to perform the dump operation/ME FW tools, you can share a private link/file to me, in the message system, if you dont want it public.

Read: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15) - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

Your system uses ME9, perform dumps/backups with the Intel FPTtool (CMD Admin from a temp root folder) from the correct package:

You need to enable JPM2 jumper for the operation, jumper back to initial position for normal operation, after system shutdown.

fptw64 -d spi.bin
fptw64 -bios -d bios_reg.bin

@MeatWar - I unfortunately don’t have the tools to perform the dump. If there are any instructions that outline the steps/tools, I might be able to figure it out.

Thank you for providing the guide. I did a quick read through - looks like I need to create a portable Win10 installation that I can boot into, install the tools/drivers, and get the dump. I’ll take a stab at this tonight when I have time and access to the server.

I was able to grab the FPT dumps you requested. I just tried send them to you via PM, but received an error indicating that you aren’t accepting messages at the moment.

I had no success working in latest bios .525 or dump from it, look at the highlighted Padding file, the only one always non-existent in the mod.
Tried several, manual edits related to MicroCodes… no luck.


I believe that its OK in the bios version 223, at least regarding the previous issues reported, download it and you should give yourself a good look into it, as im not responsible for any damage done by this files to the system board, if you really decide it to try them… i personally would only risk it, if it was not my primary system and having an SPI programmer with full backups aside.


Maybe… another user can spare some time to further look into this, good luck, all the best.

@MeatWar - Thank you so much for spending time to work on this. I’ll take a look at the 223 Mod that you have shared and determine if I want to try flashing. This system is one of my daily drivers for now, so I am not sure if I want to risk bricking it.


Firstly, I’d like to extend my thanks to you, Fernando, for your amazing work and forum. I’ve been a long-time reader, particularly of the Intel RST drivers discussions.

My Problem:

I own an Asus GL552VW-DM149 I5-6300HQ, which has a SATA port and an M.2 port, but theoretically, it supports only SATA and not NVMe. Currently, I have a Samsung SSD SATA connected to it.

In the past, I tried connecting an NVMe to this port, but it didn’t show up in BIOS, tried a win11 clean install just to test but the installer couldn’t locate a drive to proceed.

  1. Initially, I sought to enable “above 4G decoding” and realized the only way was to unlock the BIOS.
  2. After unlocking the BIOS successfully, the guide I followed led me to this thread to enable NVMe.
  3. I’ve followed the guide, but using my stock unlocked BIOS. There wasn’t any CSMCORE, so I used DXECORE as a reference instead.
  4. I wasn’t able to flash the modded BIOS using the onboard Asus easy flash utility. Despite renaming the modded BIOS the same as stock BIOS and changing file extensions, for some reason, the flash page could only detect the OEM BIOS file, none of the modded ones. Maybe there are some additional check options?
  5. Decided to flash using FPTW64 tool and, theoretically, it worked.
  6. Swapped the SSD SATA disk for the NVMe disk, enabled CSM on BIOS, saved, rebooted, and there wasn’t any PATA or even a disk available to select to boot.
  7. With a USB, I attempted a clean Win 11 install, but the installer couldn’t find any NVMe disk.
  8. Swapped the disk again, and made a new dump just to confirm that the NVMe injected BIOS was correctly flashed. Apparently, it was.

I’m at a loss as to what’s gone wrong.

For further details, I’m attaching four different BIOS:

Stock dump BIOS

The stock unlocked BIOS

The stock unlocked and NVMe modded BIOS

The latest PC BIOS dump, to verify if the BIOS was properly injected/flashed.
The Nvme that I’m trying to use is a Toshiba that came in a dell xps laptop

Looks like as new user I can’t upload files, so I’ve uploaded the bios to onedrive

Bios pack

Thank you in advance for any insights or assistance!

This is a know issue on some Skylake models from Asus and other vendors, the bios contains the AMI NVMe driver and no mods are needed.

The main culprit here on this subject is the OEM system board hw design/slot electrical connection circuit that doesnt support PCIe NVMe drives, only PCIe AHCI SATA disks.
This is no subject for a mod as fix and im not aware of anything related with success.

Hi. I realize this is an old thread. But if you still have the bios files. Could you please post a link to these bios files?

Thank you

@nonyabizzness Welcome to the Win-Raid Forum!
Your post is absolutely off-topic. This thread is designed just for users, who want to modify their mainboard BIOS themselves.
If you have a personal question to a specific Forum member, you should better post it via PM. Alternatively you can start a BIOS Modding Request thread within the related Forum Category.
Good luck!
Dieter (alias Fernando)

Ok. Thank you. My mistake. Apologies

very thanks for this guide.
It possibile insert this nvme module into old Aption III Bios, with MMTool 3.26?
I search CMSCORE, but ther’isnt.

I have external programmer , not problem to try.

Thanks advance for all help.

There is no AMI Aptio III… its AMIBIOS8 generation, and no, the guide referes to a DXE driver for AMI Aptio V UEFI bios generation.

Theres this option for it, you may try it: [Experimental] NVMe Option ROM - BIOS/UEFI Modding / BIOS modules (PCI ROM, EFI and others) - Win-Raid Forum (level1techs.com)

Experimental Modded VMware-NVME Option ROM for AMIBIOS8 Core ( Legacy ) - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

very Thanks for all info!

The issue for the ‘ASUS M5A97 R2.0 AM3+’
Followed **Only for ASUS BIOSes with the suffix .CAP:
To avoid problems while trying to flash later on the modded *.CAP file via the ASUS USB Flashback method, it is recommended to extract the “Body” of the original *.CAP BIOS. This can easily be done with the UEFITool by opening the *.CAP file, doing a right-click onto the “AMI Aptio Capsule”, choosing the “Extract body…” option and saving it as *.ROM file.’

Extracted rom done, insert Nvme, save as the new *.rom file done.
However how to replace .rom back the .cap file?
Asus EZ flash, only accept the cap file, however how to replace back the Nvme inserted rom file back to the cap file? thank you

You dont need such mess… anyway for AMD bios, this mb CAPSULE size is 800h (2048), the extracted UEFI image can be later pasted/merged with an HEX editor.

The M5A97 R20 has USB BFB feature, so you can mod the .CAP file for NVMe according the guide and flash it, this is the correct method for flash the mod, not EZ.
The procedure will preserve the mb original data.

EZ feature method only for mbs without USB BFB and no security issues with mod files, usually older mbs.
Theres also in the forum ready to flash mod files for this model shared by users.

Thank you for your reply.
I have read the ‘[Guide] How to flash a modded AMI UEFI BIOS

Usage of the ASUS “USB Flashback” feature

However, my question is how to prepare the moded .cap file?

I have the original A.cap file.
extract body to A.rom file
MMtool, open rom file, insert Nvme to A.rom file, save as, get the ready flast B.rom file.

What is the next step please?
How to convert B.rom back to B.cap?
Or just flash B.rom file by ASUS “USB Flashback” feature?

many thanks