[OFFER] ASUS Z87-DELUXE updated BIOS v2103 NVMe mod

Delighted you are out of the woods and no longer being mauled by the technology "grizzlies"!

ZOOM, ZOOM!! Yes it gives a nice boost



Recently you advised hexem to disable CSM in BIOS. When I setup my Z87-WS board with your modded BIOS, I always had CSM enabled. Everything was fine then. The reason is that I also have a Z97 Sabertooth board which enabled CSM enables you to access NVME drive on your PCIE slot.

Lately I had severe lag in accessing my HDD drives and launching programs (this is when CSM is enabled). The symptoms were not all the time. Now that I have CSM disabled, the system is smooth and as fast, havent notice any lag yet. The lag symptoms I am describing, is this due to enabled CSM?

Please shed some light on this, thank you.


In general, CSM is set to DISABLED for all NVME boot drives to achieve maximum functionality.

Some of the early NVME drives had OPROMs built in like the Samsung 950 PRO 512GB SSD, which allowed them to be ‘seen’ by the BIOS but not boot from them.

However, the industry as a whole has moved to the UEFI environment as the BIOS/MBR environment is capped at a maximum of 2.2TB drives.

UEFI supports the GUID Partition Table (GPT), a more flexible partitioning scheme. GPT disks use 64-bit values to describe partitions, allowing
larger partitions. GPT also fixes other issues related to MBR (data integrity, backup tables, maximum number of partitions, …).
Using 64-bit values, GPT can handle disks of up to 9.4 x 1021 bytes or 9.4 zettabytes (ZB).

see here for more: https://uefi.org/sites/default/files/res…_Fact_Sheet.pdf

In short, for maximum compatibility and the fact that MBR disks and GPT partitioned disks don’t play nicely in a mixed environment; CSM is routinely set to DISABLED for the UEFI.

Lastly, you are comparing the Z87 chipset with the Z97 chipset where NVME functionality was built in by the manufacturer in the case of the Z97 chipset and not contemplated in the Z87 chipset. Thus you will have some variability in specifics according to the chipset in question.

Regardless, NVME full functionality is achieved when CSM is set to DISABLED.


Or, if BIOS offers, you can leave CSM enabled (if you don’t have UEFI graphics this would be necessary), and then set storage driver option to UEFI.
That would be same as CSM disabled to the NVME part of it all, loading the UEFI/EFI rom for the NVME functionality. Some BIOS do not offer this though, so in certain systems you may be stuck, and have to get mod vBIOS if that is stopping you from using full CSM disabled.

Hi, I installed your mod driver in my Asus Z87 moderboard and so I can use and boot from a samsung 970evo M2 disc.
But I have a problem that I cannot solve also after read and apply your tips.

I have a win 8.1 sytem on a samsung SSD 840pro disk with GPT partition.
Then I installed win10 pro in my 970evo disc with GPT partition.
In bios I disabled CSM.
Computer starts and boot with the two win system and I can use both very well.

Here is my problem :
From one of the system I reboot the computer, system restart but after BIOS POST I recive a Blue Screen (BOSD) with some options:
- F9 go on to the next system
- ESC go to UEFI (bios)
- ENTER retry

But this happens not every times! Sometimes the boot works well !
If I come from WIN10 I recive almost always the BSOD
If I come from WIN8.1 The sistem almost always works well.

Usually I go back to bios with ESC and the bios shows me this image ==> I attach the file <==

then I must press F1 to enter in bios screen.
In bios screen I can choice the disk to boot and I choice "UEFI : WINDOWS BOOT SYSTEM" that is the same from witch boot with the BOSD on rebbot !!!
Then the system boot well.

I need Some help…

P.S. : In BIOS I do not see the 970evo M2 disk !

That is normal for all users of an NVMe SSD without native NVMe support. The name of the SSD manufacturer and the model are not shown within the BIOS. Nevertheless the NVMe SSD is bootable, but listed within the BIOS as "Windows Boot Manager".

@TJJ @poisonknife

UPDATE to first POST Date: Feb 17, 2020

Updated bios on first post includes:



Latest microcode for Spectre/Meltdown/MDS vulnerability mitigation, also overclocks nicely to a breezy 4.7Ghz on all cores.
Also stable with one core @ 4.8Ghz with the other three cores @ 4.7Ghz.


Worked like a charm on first try, thankfully I even remembered to save my bios settings as well, cheers

@FrankB @maxbox @TJJ @poisonknife @deejaytnk @hexem @Lost_N_BIOS

minor updates to Network EFI’s, see first post

Great, thanks! Will try tomorrow :slight_smile:

solved it

thanks for this!

@hancor :

Thanks for the pre-patched and renamed BIOS for the Asus Z87-PRO. I had already done a patch myself but 1) it didn’t have the proper naming convention for Asus Flash restore and 2) it looks like your patch has additional functionality. Now running W10 on an M.2 on an 8-year old MB.

Thanks so much!

Can I buy you a beer?


Network EFI ROM updates Sept 15 2020 see post #1


Please help to modify BIOS for ASUZ Z87-Expert.


You’ll find your fully modded and NMVe enabled BIOS/UEFI here:

[OFFER] Asus Z87 Expert BIOS/UEFI v2103 mods

Enjoy and cheers

Network EFI ROM updates Jan 04 2021 see post #1



on bios v2103 NVMe mod for Z87-DELUXE, memory G.Skill RipjawsX, DDR3, 16 GB, 2133MHz, CL9 (F3-2133C9D-16GXH) cannot be set to 2133MHz in bios without modifying the old 1504 works on both xmp profiles. Is it possible to run it in v2103 NVMe mod


I’m running 2400Mhz G.Skill Trident X 32GB (F3-2400C10Q-32GTX) without issue on the same bios/uefi. I didn’t bother with XMP settings and ran it with the regular 2400Mhz setting unlinking it from automatic overclocking as I can overclock my i7-4470K to 4.8Ghz at single core settings. If you set the overclocking from AUTOMATIC to MANUAL you can independently run the memory and CPU without the BLK hook. Give that a try…
Hope that helps.



I don’t know much about that, there are a lot of settings here.
‘’ Ai Tweaker menu ‘’ I set Ai Overclock Tuner to Manual, DRAM Frequency DDR3-2133Mhz did nothing


Okay here are my upload BIOS/UEFI settings for the AI Tweaker page your mileage may vary…I had no trouble enabling XMP settings.

[[File:Asus Z87_Deluxe_HWINFO.png|none|auto]]

Here are my settings for AI Tweaker page, you may have to dial them back depending on whether you want to overclock your CPU, CPU cache, CPU cache voltage, RAM.


I am running the UEFI version with CSM = DISABLED on the Boot Tab.

Also verify your memory is on the QVL (Qualified Vendors List) which you can find on the Asus support page for this board: