[Outdated] USB 3.0/3.1 Drivers (original and modded)

Personal Statement: (dated 09/25/2022)
The start posts of this thread has been written and formatted by me, but I am not responsable for its currently bad appearance and readability. Due to incompatibilities of the Forum Software the formatting and some parts of the text have gone lost during the Forum move.
Since I am neither able nor willing to repair this issue, I have stopped the support of this thread.
We need someone else who starts a new thread and supports it.
Thanks in advance!
Dieter (alias Fernando)

Preliminary notes:
Although the Windows Operating Systems from Win8 up natively do support many USB 3.0 Controllers by using a generic Microsoft USB 3.0 driver, it is often better to install the specific USB 3.0 drivers, which have been developed, optimized and released by the manufacturer of the related USB 3.0 Controller.
Unfortunately some manufacturers of USB 3.0 Controllers offer just a compressed Drivers & Software Set, but not the "naked" drivers, which can be integrated into an OS image or manually installed from within the Device Manager.
To make it easier for you to find the latest USB 3.0 drivers in an already extracted format, I have started this thread, where you can find direct download links to the latest available drivers for the most popular and still produced USB 3.0 Controllers.
Additionally I am offering here some USB 3.0 drivers, which have been modified by me to make them usable with USB Controllers and Operating Systems, which are not supported by the original drivers.

Tips for the manual installation of USB 3.0/3.1 drivers:

  1. Before starting with the installation, you should make sure, that your input devices (keyboard and mouse) are connected with USB ports from another manufacturer or - if available - to PS/2 ports. Another option is to use a "Virtual Network Computing" (VNC) Tool and to execute the installation of the USB 3.0/3.1 drivers from another Mobile system (look >here<).
  2. Expand the "Universal Serial Bus Controllers" section of the Device Manager and check the HardwareIDs of the listed USB Controllers (right click onto them > "Properties" > "Details" > "Property" >"HardwareIDs") to find out, which of the Controllers is the one, where you want to update the driver software.
  3. As first step you have to update the driver software of the USB 3.0/3.1 Controller.
  4. After the reboot the Device Manager will show within the "USB Controllers" section devices with missing drivers. These are the USB 3.0/3.1 Hub Devices, which belong to the USB 3.0 Controller, where you just have updated the driver software.
  5. Now you can easily install the missing USB Hub Device drivers by navigating to the related driverpack.
  6. Users with an on-board Intel USB 3.0 Controller may have to update the "USB 3.0 Switch Driver" as third step (see below).
  7. After the next reboot everything should work fine.

Latest USB Drivers

for USB Controllers and their Hub Devices
(Last updated: 04/15/2022)

A. AMD USB 3.0/3.1/4.0 Drivers
Download links and infos:
  • latest AMD USB 3.0 drivers:
    • pure Drivers:
    • for AMD Zeppelin Chipsets (with Ryzen CPU):
      • >64bit AMD USB 3.0 Controller and Hub Drivers v2.0.0.60 WHQL for Z-Systems< (>MIRROR<)
      • Notes:These 64bit AMD USB 3.0 drivers are dated 03/05/2020, WHQL certified and designed for being used with Win7 x64, but may work with Win8/8.1/10 x64 as well. Supported are the AMD USB 3.0 Controllers DEV_145C and DEV_145F.
        Tip: To make the installation as easy as possible for you, I have added the 64bit DPInst files. Right-click onto the DPInst64.exe file and choose the option "Run as Administrator". This way the installation may work automaticly.

  • latest AMD USB 3.1 drivers:
  • first AMD USB 4.0 drivers:
    • pure Drivers:
      • >64bit AMD USB4 Drivers v1.0.0.19 WHQL< (>MIRROR<)
        Notes:These drivers are dated 03/30/2022, WHQL certified and designed for systems with the upcoming AMD Ryzen 6000 Series running Win11 x64. Supported are the AMD USB4 Controllers DEV_162E and DEV_162F. Thanks to westlake for the source package.

  • B. ASMedia USB 3.0/3.1 Drivers
    Download links and infos:

    C. Etron USB 3.0 Drivers
    Download links and infos:
  • complete Drivers and Software Set:

  • D. Fresco Logic USB3 Drivers
    Download links and infos:
  • Other "pure" Fresco Logic USB3 drivers:
  • latest complete Drivers Installer Set:

  • E. Intel USB 3.0/3.1 Drivers
    Important notes:
    • The latest Intel USB 3.0/3.1 driverpacks do contain at least 3 different USB 3.0/3.1 drivers:
      1. an "Intel(R) USB 3.0/3.1 eXtensible Host Controller Driver" named iusb3xhc.sys, has to be installed by pointing to the file named iusb3xhc.inf (after the installation the related device is named "Intel(R) USB 3.0/3.1 eXtensible Host Controller"),
      2. an "Intel(R) USB 3.0/3.1 Hub Driver" named iusb3hub.sys, has to be installed by pointing to the file named iusb3hub.inf (after the installation the related device is named "Intel(R) USB 3.0/3.1 Root Hub") and
      3. an "Intel(R) USB 3.0/3.1 Host Controller Switch Driver" named iusb3hcs.sys (only usable/needed for systems with an USB Controller "Switch").
      4. Notes: The related USB Switch device is usually named "PCI Express Root Complex" and listed within the "System Devices" section of the Device Manager. It has to be installed by pointing to the file named iusb3hcs.inf. After the installation the Switch device may be renamed to "PCI bus".

    Download links and infos:
    A. Latest original Intel USB 3.0/3.1 drivers:
    1. only for Intel Chipsets from 8-Series up running Win7:
      • "pure" 32/64bit drivers:
      • complete Drivers and Software Set (with recently updated installer):
      • only for Intel 7-Series/C216 Chipsets running Win7:
        • "pure" 32/64bit drivers:
        • complete Drivers and Software Set:
        • only for systems with an Intel Titan Ridge USB 3.1 Controller running Win7:
          • "pure" 32/64bit drivers:
          • complete Drivers and Software Set:
          B. Latest modded Intel USB 3.0/3.1 drivers:
          (usable with all Windows Operating Systems from Win7 up)

          New: The content of the associated INF files has been slightly altered by me according to the idea of our Forum member Jodec (for details look >here<).
          Advantage compared to the previously offered mod+signed drivers: The ranking of these mod+signed drivers during the installaton procedure may be boosted and the risk minimized, that they will be replaced later on by any updated generic MS drivers.

          1. for Intel 7-Series Chipset systems (DeviceID of the USB 3.0 Controller: DEV_1E31):
          3. for Intel Chipset systems from 8-Series up to 200-Series:
          5. for Intel Chipset systems from 300-Series up (DeviceID of the USB 3.1 Controller: DEV_A36D):
            • You can find working Intel USB 3.1 drivers within the start post of >this< thread.

          Important notes regarding the usage of the mod+signed drivers:
          • Before starting with the installation of the mod+signed drivers, the attached Win-RAID CA Certificate has to be imported (not required, if already previously done on the same system). For details look into the start post of >this< thread.
          • It is urgently recommended to use the attached 32/64bit DPInst file instead of trying to get the different drivers installed manually (mouse and/or keyboard may not work after having installed the Controller driver, because the Hub driver is still missing at that stage of installation).
          • To prevent any problems while booting it is a good idea to DISABLE the "Secure Boot" option within the BIOS before going to install any mod+signed driver (look >here<).
          • If you want to recover the ability to boot in "Secure Mode" after having installed the mod+signed drivers, you can find >here< a solution (thanks to kevindd992002).

          Instructions regarding the DPInst installation method
          This new fully automatic procedure to get the above listed "pure" USB drivers properly installed by using the MS tool DPInst.exe has been found out and layed down >here< by our Forum member Zwulf. All credits go to him.
          Since I have tested this procedure successfully with my Z170 Destop system running Win10 x64, I decided to offer it here for everyone.
          Warning: Due to the big variety of systems and on-board Intel USB 3.0/3.1 devices there is no guarantee, that the DPInst procedure will work for everyone, whose system has an on-board USB 3.0/3.1 Controller.
          That is why I recommend to let the OS set a Restore Point before starting the installation procedure. This will give the affected users the option to restore the system as it was before starting the driver installation.

          Short usage guide:
          1. Optional: Set a restore point (for the case of an installation failure or later problems).
          2. If not already previously done, you have to import the Win-RAID CA Certificate by running the related CMD file from within the Command Prompt (Admin) or Windows PowerShell (Admin).
          3. Right-click onto the 32/64bit DPInst.exe file and choose "Run as Administrator" and confirm, that you want to get these drivers installed.
          4. Wait until you get the message, that the installation has been successfully completed. Then click onto the "Finish" button.
          5. Reboot.
          6. Make sure, that all related Intel USB 3.0/3.1 devices now use the desired Intel USB driver.

          If the installation of the Intel USB drivers should fail or if you are not satisfied with the result, you can easily restore the generic MS USB 3.0 drivers:
          • Run the Device Manager, expand the section "USB Controllers", right click onto the listed Intel USB 3.0 Controller, choose the options "Update Driver Software" > "Browse my Computer…" > "Let me pick…" and highlight the listed compliant MS USB Controller, then click onto "Next".
          • After the reboot the Intel USB 3.0 Controller and Hub devices will use the generic MS drivers.
          • The MS driver for the Intel USB device named "PCI bus", which is listed within the section "System Devices", has to be manually restored the same way to the device named "PCI Express Root Complex".

          F. Renesas USB 3.0 Drivers
          Download links and infos:
        • Modded drivers:
        • b) latest 32/64bit drivers for Renesas Gen2 USB 3.0 Controllers (uPD720201/µPD720202 ):
          (for all Windows Operating Systems from XP up)
        • >Renesas Gen2 USB 3.0 Drivers & Software Set v3.0.23.0 WHQL< (>MIRROR<)

        • The included drivers are dated 08/21/2012 and WHQL certified. Supported are the Renesas Gen2 USB 3.0 Controllers with the DeviceIDs DEV_0014 and DEV_0015 with their related Hub Devices.

          G. Texas Instruments USB 3.0 Drivers
          Download links and infos:

          H. VIA USB 3.0 Drivers
          Download links and infos:
        • complete Drivers and Software Set:

        • I. ZhaoXin USB 3.0 Drivers
          Download links and infos:
        • complete Drivers and Software Set:

        • Note: All uploaded files are packed with the tool WinRAR v5.xx and have to be unzipped with WinRAR v5.xx or 7-ZIP v2xxx before being usable.

          If you should find download links to any newer or other popular USB 3.0 drivers, please let me know it and post the link.

          Dieter (alias Fernando)

          This is really nice.
          For my system, Win8.1 and Z77, i used 64bit Intel USB 3.0 Drivers v3.0.4.65 mod by Fernando and it’s working.
          But i didn’t do any benchmarks.


          Thanks for your report!
          A benchmark comparison would be fine, but even more important than the read/write speeds of USB 3.0 ports are the stability and reliability of the USB connections.

          There’s a small typo under the Intel USB 3.0 section:

          Thanks for the info!
          It is corrected now.

          Hi Fernando,
          On my P87Z77-V Deluxe , W7 x64,
          I have updated ASMEDIA USB 3.0 driver from V to V No problem. It works fine.

          I have tried to update INTEL USB 3.0 Controller V to your modded driver CONTROLLER V Windows 7 detects that driver is not numerical signed (not WHQL) and ask in a red warning message if i want to force or not.
          Do i have to force ? Is it correct ?

          Yes, the installation of a modded (=not digitally signed) driver generally has to be forced by using the “Have Disk” button.
          Why didn’t you read the “Notes”, which are just beneath the offered modded drivers?

          Yes, i had read the Notes and used the "have disk" option. I was only surprised by the red warning menu provided by Windows.
          So, i have successfully updated Intel Controller driver and Intel Hub concentrator driver.
          All is working well.
          Here are bench results of two USB 3.0 SANDISK Extreme 64GB keys connected respectively on an INTEL port and on an ASMEDIA port.
          Thanks for this very helpful USB 3.0 part on your forum.





          Hi Fernando,

          and Happy Easter to all of you out there!

          Here is the driver for Etron USB 3.0 chip, which is used on ASRock mainboards with 6/7 chip set: http://station-drivers.com/index.php/dow…roller/Drivers/

          What is the reason for using a modded 8/9 chip set driver on a 7 chip set instead of using the original 7 chip set driver: http://www.station-drivers.com/index.php…WHQL-(Serie-7)/

          As far as I know, from a business standpoint, that’s what Intel always do, limiting newer controller/chipset drivers to their latest line of product, making them seem “up-to-date” even though the driver itself is usable on legacy chipsets with some minimal modifications. Along with the change in CPU socket, that’s how they and the manufacturers gently force people into replacing your CPU + MB combo every few years.
          If you wanted a technical answer, there are no differences between an USB 3.0 controller on a Z77 or a Z97 chipset. They’re all USB 3.0, and if you don’t choose to use “modded” drivers (not really modded anyway, the driver is still intact, we only allow it to exist on legacy hardware), you allow Intel to handicap yourself. We’re power users after all.

          Thanks for the info and the link.
          I will add these Etron USB 3.0 drivers to the start post of this thread, although I am pretty sure, that we will never see newer USB 3.0 drivers from this Company (the latest ones are dated 10/29/2013). AFAIK they stopped the production of USB 3.0 Host Controllers already in 2013.

          The answer has already been given by Hakuryuu. I totally agree with him/her.
          By the way: Your linked USB 3.0 drivers, which were designed by Intel for their 7-Series Chipsets, are dated 09/17/2013, that means, that they are very old.

          They are rather old, that’ true. But they are the “latest” for the respective chip available.

          I think I found a bug in your first post:

          Isn’t Windows 8 the first Microsoft OS with native USB 3.0 support?

          Isn’t Windows 8 the first Microsoft OS with native USB 3.0 support?

          You are absolutely right - it was no bug, but a typo, which has already been corrected.
          Thanks for the info!

          @Fernando , do you plan to make Intel 4.0.18 modded drivers for Z77 and Windows 8? Thanks!

          I have them already modified and running on my Z97 system (OS: Win8.1 x64). What I do not know is, if they will support the older Intel USB 3.0 Controllers (DEV_1E31.
          Are you interested to test them?

          I have them already modified and running on my Z97 system (OS: Win8.1 x64). What I do not know is, if they will support the older Intel USB 3.0 Controllers (DEV_1E31.
          Are you interested to test them?

          Sure, previous version worked like a charm for me! Im on Z77 and Win 8.1 64 bit…

          hi, im trying to install >32bit Intel USB 3.0 Drivers v3.0.4.65 mod by Fernando<
          to my travelmate p246m (OS is XP)

          Device status tells me that windows cannot load the device driver for this hardware. The driver may be corrupt or missing

          Steps done:
          - No devices inserted in usb ports
          - Installed using have disk
          - restarted laptop, still getting error

          @ gpvecchi:
          The requested modded 32/64bit Intel USB 3.0 drivers v4.0.0.18 are attached.
          Please report within this thread, whether they work for you or not.
          Good luck!

          @ jdvallar:
          Provided, that you didn’t confuse the 32bit and 64bit driver, I suspect, that Windows XP doesn’t accept these new Intel USB 3.0 drivers.

          32bit Intel USB 3.0 Drivers v4.0.0.18 mod by Fernando.rar (384 KB)

          64bit Intel USB 3.0 Drivers v4.0.0.18 mod by Fernando.rar (442 KB)

          aww. too bad. okay thanks for the help

          Hi Fernando,
          Installed (have disk method) controller driver then hub driver V x64 on my PC ASUS P8Z77-V Deluxe W7 SP1 x64.
          Here below are the bench results.
          Working OK for me.
          Many thanks.