[Request] Bios modding for Alienware 15 Models

Hi all!i ask help for unlock my bios…I Need to use my laptop with a external monitor and the lid close…but for Power ON the laptop i don’t want open lid and press the button…it’s possible to unlock WAKE ON LAN or WAKE ON AC?

i have done a bump of my bios

thanks for your help


update: i have open a bump with AMIBCP but i don’t know what edit for unlock al

AMIBCP Image.png



Edit by Fernando: Thread title customized

biosreg.zip (3.08 MB)

I tried to change the various options in user and then flash with the ami tool but it doesn’t work … it tells me error … I would do the modding myself but I can’t find a guide for Aptio V and Alienware … not I would like to make a mistake and break everything … please give me a little help … if you don’t have time to do my bios mode at least explain me what to do … thanks …

You can wake on LAN or Wake on AC (State after G3 setting) if those are in the BIOS. But you may need to leave laptop lid open, just shut it off. I think there is sensor in the click when you close it, so you have to have it open to power on, I think anyway.
Wake on LAN may only work with Ethernet, otherwise you’d want wake on Wifi

Anyway, I can probably unlock this BIOS for you so you can see and change all this stuff in Chipset directly in the BIOS. What is your exact model, and what BIOS version are you using?
I may have already unlocked this BIOS

I see you attached “biosreg.bin” is that from FPT dump? If yes, what error do you get, if any, when you try to write back the dump (without modifying it)?

Really Thanks for your help…i have done a bump with ftp…but i can do with AMIFLASH if Better…i try to flash with AMIFLASH but don’t work…I was hoping to be able to do everything with the official tool but when I press on start it immediately gives me an error … maybe because I tried with the lid closed? however I would like to unlock all the menus that could be used to carry out this operation … I saw that there should also be the power ac (I think it’s called Power loss …)
My Alienware Is ALIENWARE 15 R2 i think…i have buy on 2015…for security I also leave the link of my computer https://www.dell.com/support/home/en-us/…are-15/overview
the bios Is A12 https://dl.dell.com/FOLDER05862098M/1/AAP10A12.EXE
unfortunately having the Graphic Amplifier disables me from Windows the possibility to put the suspension … I saw that this thing was corrected through a BIOS update from Dell but only for models after mine … maybe they stopped supporting it … I don’t know if there would be a way to do what they didn’t do in Dell

I steer clear from using AFU anything, whenever possible. I would help you do mod BIOS via Intel Flash Programming Tool.
What do you mean you “think” it’s 15 R2?? You have to be sure, look on the bottom of it, there should be a sticker.
So, you’re saying the above A12 BIOS is the BIOS you flashed and are using now?

On the graphics and sleep issue, maybe I can fix with ME FW update for you, or you can do that yourself directly without BIOS editing (it will be a lot of work for you to flash it with FPT or AFU, so not ideal really)
If you want to see if ME FW update will help with the graphics/sleep issue, then I will show you how to do that eventually too. For that, you will use ME FW update tool.

If you do have 15 R2 model, you should be able to flash in 17 R3 BIOS too, these are same systems. If that model has updated BIOS with fix for this issue, then try that and see if it will let you flash it in via exe
If not flash BIOS from within the BIOS and add /forceit after the bios name is selected (if this is kind of within BIOS flash where you can adjust the command used)

yes sorry … on the back it only says Alienware 15…so it’s R1…probably there is an error on the Dell site because when I put my service tag and go to the BIOS section it tells me that the update is for Alienware 15 R2…but if I then go directly to look for Alienware 15 R2 it gives me another BIOS version …I tried to install via the exe of the bios for alienware 15 r2 but it tells me that the version is not correct … anyway I have the A12 version

IMG_20201219_083020.jpg



if instead I try to search the BIOS for Alienware 15 R2 it gives me this version of the BIOS … so as I told you there is an error on the Dell site:

IMG_20201219_083923.jpg



however if you manage to fix the sleep mode you will give a big help to many people because many have this limit …

The site may give you different R2 version BIOS, depending on how you look at the site, but one of the ways you can pull up all BIOS for R2 latest and then all down to oldest.
So that may be why you see different versions. I will look at your dumped BIOS region and see if I can find for sure what model BIOS you are currently using. Or, have you already flashed in the exe you linked, without issue?
Can you install the 15 R2 17 R3 BIOS (1.11)? Sounds like you cannot use the 15 R2 17 R2 (?) A12 BIOS, correct? If not, what did you flash that gave you current A12 version?

Sleep mod issue can be a BIOS settings/internal issue, which I can’t fix unless you knew the exact setting causing issue, or it can be as simple as a ME FW update that I mentioned.
Please look on the board itself, for a 2-3 pin jumper (may be 2, or 3), that says Service, Management, FD, FDO, or ME. Do you see anything like that anywhere on the board?
If your ME FW is healthy, then this is not critical, we can update it via ME FW update tool.

Using HWINFO64 as shown below, can you currently see ME FW version properly, or do you see N/A or 0.0.0.0 (or nothing here).
You will have to install ME drivers from the driver download page first, before you’d see this

HWINFO-MEFW-New.png



** Also - you never replied to this >> I see you attached “biosreg.bin” is that from FPT dump? If yes, what error do you get, if any, when you try to write back the dump (without modifying it)?

* Edit - I checked BIOS, and yes, you have 15 R1 - same as this users thread - Alienware 15 R1 corrrupt ME firmware Help.
And for that A10 is latest BIOS, I’ve unlocked this BIOS for several users too.

All drivers/downloads are here, but you need to look at this page in browser that wont allow a redirect (Dell auto-redirects) - http://downloads.dell.com/published/pages/alienware-15.html
A10 is here - https://www.dell.com/support/home/en-ca/…&driverId=RTRRK
Is that the one A12 version that you cannot install, the 15 R2 17 R2? If yes, that is not correct A12, so that’s why it’s failing. I will see if I can find A12 for 15 R1 (No luck there, seems it’s not an actual thing, only A12 is for the 12 R5 17 R2 (15R1, but oen that is not same as your 15R1, what a mess dell!)
I’m not sure how you got A12 on your system, but it shouldn’t have been able to flash, at least not the A12 that is currently out there (I can’t find A12 for your correct 15 R1 type)
But, no worries, I can unlock your BIOS as it is, and we can mess with ME FW to see if that fixes the issue with sleep.

Out of curiosity, can you flash back to A10 I linked above, or it tells you no? That BIOS may be better for you to use if you can flash it, due to it may not have sleep issue, and I have already unlocked for many users.



If i use my service tag on Dell Support it tells me that the latest update of my bios is A12. i don’t know why…maybe it was built between r1 and r2 … boh … I don’t know what to say. i have try to install a 1.11 but it say “non-compatible”

bios.png






I have seen by many other users and asking Dell support, that the sleep mode is disabled when connecting the external graphics amplifier. this thing has been corrected with the bios update but only the one from R2 onwards.



me.png





yes i have use Flash Programming Tool v.9.1 r7 …
i tried to rewrite with amiflash but it just told me error without any code



i can try to downgrade… if you want i give a service tag on PM…

update: i can downgrade but obviously Dell warns me it is not recommended… what do you think? is it better to downgrade? I would not like to have made some updates regarding the functioning of the graphic amplifier … for the sleep mode it does not work anyway even with the A10 version … obviously if I remove the graphic amplifier everything works correctly …

Yes, there is some oddities here with 15R1 and “other” 15R1 that is same as 17R3 (maybe even one that is same as 17R2 too)
I can tell by your BIOS FID (Flash ID) that is is the one where I linked above that shows only A10 being latest. They must have pulled A12, possibly due to the issues you mentioned.
I do suggest you see it you can downgrade to A10 without issue, via normal method.

About sleep mode, you can test update ME FW now via ME FW update tool in ME System Tools folder and latest 9.1 ME FW from the ME FW thread here
You will need to download Intel ME 9.1 1.5MB Firmware v9.1.40.1000
here is command you will run, after you copy ME FW file into the ME FWUpdate folder >> FWUpdLcl -f update_file_name.bin

Then if still not working, try A10 BIOS.

About this >> ** Also - you never replied to this >> I see you attached “biosreg.bin” is that from FPT dump? If yes, what error do you get, if any, when you try to write back the dump (without modifying it)?
You still did not answer my question there. I don’t care about, or suggest using anything AFU related, unless it’s the dead last only option. And to add to this, never use AFU anything for FPT, and never use anything FPT for AFU
I only wanted to know what error you get in when trying to write back your BIOS region dump with FPT (this is how we will flash in mod BIOS eventually, so just getting ahead of us here, we’ll have to disable some locks probably, unless your board has service jumper - I forget)

If A10 is broken for sleep same as A12, and ME FW update did not help, then I can unlock BIOS for you in either version, then maybe you can find some setting that needs changed to fix the sleep issue (Along with being able to directly changes the settings you asked about initially)

So strange!! I see other users folders I have helped, their dumps all have same FID and related info, but they can and have flashed AAP10A12.EXE << This one tells you no too, correct, from the 15 R2 17 R2 page?

@ViolentKain - Do you have the stock A12 BIOS EXE for this?



i will try now
Update: i have update but no sleep mode…
I only noticed one thing … which now makes me select screens (both integrated and external) even if the lid is closed.




yes sorry :frowning: i have dump with "FPTW64 -bios -d biosreg.bin"

fpt.png



If i use the command "fptw -d mybios.bin" i have "error 26"




this is the version it tells me to install by putting my service tag… i wrote it in the 4 post


UPDATE: i have downgrade to A10 with ME update but always no sleep mode

Considering that I did the downgrade and then the upgrade again I put the dump done with fpt … doing the flash brings me back the same things as the screenshot I put above

biosreg.zip (3.08 MB)

Hi, i have a big problem…i have try to dump and check bios from DOS for try to see if i have error and now when i Power On, restart for a few times and then i listen 7 beep… What i need to do? I have use the same command ftp BIOS -d biosreg.bin and then ftp -bios -f biosreg.bin…i have see the same error region…

I have buy this:

IMG_20201220_130509.jpg



It Will come tomorrow…i have only a Raspberry to use…but i don’t know how fix…

I suggest you DO NOT use PFPTW64, it cause random issues sometimes. You should not see error 26 when using FPTw.exe, unless you leave out -bios flag (Which sounds like you did in DOS now too )
This is what I wanted to know error from >>
1. FPTw.exe -bios -d biosreg.bin << Dump BIOS region (Preferably always do right before you do #2)
2. FPTw.exe -bios -f biosreg.bin << Test write back BIOS region, it will either happen and = same/same since nothing is changed, or you will get error due to BIOS Lock or other setting restricting you from writing it back until that is changed.

SLOW DOWN now!!! Don’t do anything with programmer, until after I say go, and give you files to fix this!
Once programmer arrives, here on how to use - [GUIDE] Flash BIOS with CH341A programmer
And here is software package - http://s000.tinyupload.com/index.php?fil…213094641136166
Raspberry pi not needed here, you need another computer to use, setting beside this messed up one

Find and read off BIOS chip ID from the chip for me (look with your eyes and a flashlight, magnifying glass may be needed)
Then I will tell you what software/version is best to use so we don’t have failed dump or failed writes.
IF FPT is correct, you have W25Q64FV and for that chip you need to use 1.30 or 1.34 and W25Q64BV ID

Once programmer arrives do this ONLY, then send me the file and wait >> Read >> Verify >> Save
DO NOT USE AUTO FUNCTION for anything!! And, before you connect to BIOS chip, w/ programmer connected, you should open Auto function via dropout menu and uncheck erase and blank check just to be sure no erase accidents happen!

To clarify above, you were now using updated ME FW, and A12 BIOS, or A10 BIOS?

I have 2 chip:
This near the CMOS battery 25Q80DVS01G 1453

IMG_20201220_201547.jpg



And this upper the cpu: (25Q54FVS1Q 1507)? I think

IMG_20201220_201431.jpg



I have A12 with ME update…i hope the last dump can help…

My second computer is a Raspberry…i can install Windows on it, but if possible can i use linux?

I’m in your hands :slight_smile:

Read rest of 25Q64… * Edit - OK, I can see your images now, that is W25Q64FV as FPT showed us, you should use 1.30 and BV ID as I mentioned above.
Yes, I can help you fix BIOS with latest dump above, once you have programmer, make a dump and send to me. Don’t worry, we will fix, and I will unlock your BIOS at same time.

Ohh, if you can use raspberry pi to install OS to, then it may be OK. Not sure about Linux, and drivers etc. I know you can use flashrom from there, but not sure if you can use other tools (which I am familiar with)
May be best to install windows so you can use CH341A software, unless you’re already familiar with linux and flashrom usage?

* Edit 2 - Due to what you mentioned about selecting screens, is that a problem for you? Do you want to go back to some older ME FW? If yes, which version do you want, the one shown in post #8?

I have read only a tutorial…it’s my First Time with the programmer…
I don’t know why even though I saw the computer die in front of me … I’m excited to use the programmer and fix the situation … I had to be a repairman in life given this excitement in seeing something broken :slight_smile:

Edit. For me it’s ok with the last ME firmware and the A12 bios if can…it’s possible to downgrade if i want later the fix BIOS?
You see 25Q64? For me it’s 25Q54 or not?

I have read the tutorial for FlashRom and i think it’s Easy to flash…
Command to backup:
"sudo flashrom --programmer ch341a_spi -r backup.bin"

Command to flash:
"sudo flashrom --programmer ch341a_spi -w <new bios name>"

I have seen that it’s a Little difficult to install windows on Raspberry… because i need a Windows pc for install Os…

It’s OK, you’ll get it figured out. Toughest thing is getting the clip perfect. Make sure items are close together, so cable is not stretched out. Then it may take 10+ tries to get clip perfect and get a good connected.
Some systems need power cable and main battery attached, some need them removed, some need only one or the other. I suggest you try with nothing first, then if no luck after a while, add main battery, then if no luck still, add PSU cable too.

I assume this happened because you left out -bios flash while using FPT, this would then take the BIOS region and start writing it at the first unlocked region instead of at the BIOS region start.
But, not sure, since FD should be locked and not let you write to FD or ME, so not sure what happened. I’ll be able to tell once you can dump chip and I can look at current BIOS contents.

Yes, if you could downgrade from A12 before to A10, then you will be able to later as well.

Yes, I see 25Q54 too, but this is just misprint, it’s 25Q64 chip >> 64 refers to size 64Megabit = 8MB and 54 is not a chip size or thing, so just misprint during production

Ok…tomorrow i Will do my best… however i have seen this guide too : [Guide] Using CH341A-based programmer to flash SPI EEPROM

I can use a programmer software on linux i think…I’ll try both methods and send you the backup…
I have buy a 1.8 v adapter but I don’t know if it is needed …
anyway I connect the programmer to the usb … put the clip on the chip … and do the backup right? do not I have to put other adapters?

Yes, but that version 1.29 may not read or write properly to your chip, I have not tested it in windows or Linux for this chip.
I can test 1.29 and this chip in windows if you want, but that wouldn’t help anything about you doing it in Linux because that’s a different software altogether (and you can just use flashrom in linux anyway).
Often read is OK, not always, but more importantly write fails with this chip and various versions (and actual ID too). That is why I gave you specific version and not-exact ID to use, because I know for sure this works for read and write.
You do not need 1.8V adapter for this chip, it’s 3V chip.

You connect cable to programmer, clip on chip, then do the read >> verify >> save
I linked you to the other guide because it has a lot of images, so you can be sure to connect everything the correct way

* Edit - Here is other guides too, if you just want to read more info/guides First one is Linux based
[GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher (With Pictures!)
https://www.techinferno.com/index.php?/f…grammer-ch341a/
https://weborus.com/guide-flash-bios-spi…ini-programmer/

Ok thanks… i Hope tommorow is a nice and lucky day!!



My friend, l hope the backup it’s ok, i’m waiting you for flash…
Verify for the file it’s ok:

IMG_20201221_173343.jpg



when I do the flash do I have to remove the CMOS battery? to read the bios I didn’t have to remove it …I leave everything attached so I don’t have to put the clip back … even if on the second attempt I succeeded

backup.zip (4.41 MB)