[Request] Lenovo Legion T730-28ICO Bios settings locked down

Hello!! I have a Lenovo Legion T730-28ICO, which uses a lenovo made z370 motherboard, Lenovo has the motherboard completely locked down, they have little to no BIOS options, and you cannot change the memory voltage or apply an XMP profile through windows. I was hoping either just to get everything unlocked, or get it unlocked and also add the overclocking and XMP options. But worst case scenario just getting it unlocked so I can apply an XMP profile would be really nice. I bought RAM on cyber Monday but aam unable to run it at the right speeds :-(. A gentleman tried to help me on the bios-mods forum, he told me I needed a reader to retrieve the bios as it was locked, so I purchased one and was able to get the bios dump, however he mentioned its a newer AMI bios and that isn’t his specialty and He recommended I come here as you are better equipped in this area :slight_smile: . Please help!! and Thank You for reading :slight_smile:

https://www.dropbox.com/sh/ytihcm7jpufzz…laBJ2D5cRa?dl=0 <— images of bios

attaching bios dump in this post


Bump, plz help!

legion.rar (5.28 MB)

Slow down, bumping threads doesn’t help anything here

Please wait, I will look at your BIOS Meantime, I need you to give me images of your BIOS in a zip, please show me one image of each main BIOS page.

Thank you! Here you go:

BIOS pages.zip (3.82 MB)

Thanks - Never mind previous comment that was here if you saw it, I forgot you had programmer

Please wait, let me see what’s going on in there

* edit @Motion - What error did you get when trying to use FPT here? I don’t see anything stopping you, did you guys try it when you were checking things out at bios-mods?
It would be best, if you can use FPT, so lets check that out, so I can unlock it if possible in the BIOS I send you to program back in.
That way if more than one test BIOS is needed before final, and I usually send three to start with before I even start actual mod, that way you don’t have to keep using programmer.

Go to this thread and in the section “C” download the V11 ME System Tools Package
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder.
Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error >> FPTw.exe -bios -f biosreg.bin
If you do get error, show me image of the command entered and the error given
^^ This is important step, don’t forget ^^

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required

he had me run BACKUP_Tools19n , and it creates a folder with results, posting the results here, have to split it up though as its 9mb all together

Results 1.zip (38.1 KB)

Sorry, heres the other parts, going to try to follow the steps you posted

Edit* I’m not seeing the option to "open command window"

Edit 2* I apologise for my ignorance but I dont know what FPT is

Ressults 3.zip (4.33 MB)

results 2 2.zip (5.53 MB)


Please read what I mentioned in the spoiler for Win10 Admin CMD, you’ll need to do one of the fixes mentioned there to add back Admin CMD since they removed it
I suggest the last link registry fix, then you only have to right click anywhere you want and open one no shift or anything needed.
You may need to reboot after you merge the registry file.

I can’t do split files with the way this forum downloads things to users (random garbage names). Please upload as single package to here http://tinyupload.com/

FPT is what you are trying to use (Intel Flash Programming tool). You can wait on this if you want, what I need to know may be in your “results” stuff

Trying command fix, did you take a look at the files he had me create? doesn’t give you what you need?

Yes, see my edit above, sorry, I removed that part of my comment early on, guess you caught it

http://s000.tinyupload.com/?file_id=52739380549097478656 Sorry Just saw the tiny upload message, here’s that results file

Edit: Posted the error i got after following your steps


Thanks, you do not need programmer from what I see in those results. The only thing I see stopping you from FPT flash is error 368 (BIOS Lock), which you can easily disable on your end using grub and setup_var, I made a guide for that here

BIOS Lock, VarStoreInfo (VarOffset/VarName): 0x998 << This is what you edit if you use the above guide

Rename your .efi file to >> Shell.efi

At grub prompt you type the following (case sensitive) >> setup_var 0x998 0x0

Ahh, the “Launch EFI Shell from filesystem device” is on the hidden exit page of your BIOS, you’ll have to use this method to get to grub (unless you already know how to from other uses)
Alt boot to grub when no boot to EFI on exit page - [Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN (2)

I’ll disable this in the first mod BIOS I send you, then after that we can flash via FPT instead, that way you aren’t risking anything with the programmer and it will last you longer.
The cheap clips can only be used so many times before they wont grip BIOS, so less you use the better

* Edit - to your edit above, yes, that’s same I see in the results info.

Ahhh, Okay, I’ll wait until i receive the mod BIOS before attempting the steps you sent. Also I don’t think I’ve ever used Grub

OK. Some people use grub for various things, so thought maybe you’ve used it for something.

Once I send you a mod BIOS, program it on, then try the FPT dump/write again to confirm I removed BIOS lock

Okay, to load the mod bios do i just connect to the chip like i did to copy the data, then just overwrite the information with the file you give me? Or do i need to clear the chip then load the mod bios

You will erase, then blank check, then open BIOS file and write/verify
What is your BIOS chip ID? And what software version did you dump the BIOS with?

the bios chip is a winbond W25Q128FV, I used CH341A Programmer 1.18 I think, its what came with the programmer

Edit* Ahh, its ancient isnt it, should I use 1.4?

1.4 is not latest (That is really 1.31Free), 1.34 is latest that is freely available
But no, for that chip you need to use either 1.18 or ASProgrammer 1.40 or 1.41, otherwise write fail.
So you are all set with 1.18

Here, please program this BIOS in, then we test FPT as I outlined. This BIOS may or may not already have a new Advanced menu in it, within original advanced, this is test one of three I would make usually for you to test at first, but sending you just this one now so we can check if BIOS Lock is now removed.

Open CH341A software, on Auto Function uncheck erase and blank check, then do as follows
1, Erase chip
2. Blank Check
3. Open BIOS file
4. Hit Auto (which now has only Write/verify checked)

Boot to BIOS, load optimal defaults, save and exit, reboot back to BIOS, make any changes you need to make (and see if new advanced there or not), and then head into windows for the FPT stuff.

Sounds good, going to try it now. Sorry Fell asleep last night, was 1:30 am here haha

Still getting the same error 368, i have every option ever now in the BIOS which is amazing, but it still gives me the same issue if i try to set an xmp profile, doesnt post. Did the same thing if I tried to use the intel utility in windows. then if I tried to manually set RAM voltage or clock multiplier it would say it failed when i restarted.



@Motion - No good on the 368 error, this means it’s not really a normal BIOS lock error, or the lock is being enforced from a non-settings stand-point in a BIOS module instead.
I could try to bypass it for you there, but that may take several tries, and some may brick, all for nothing in the end as I may not be able to get it disabled.
So, for now, we proceed with the programmer, and hopefully I can minimize the amount of BIOS edits I send you for testing.

Ohh! Great, no further edits/flashing needed, got you unlocked with that first edit, awesome! I hoped it would be that easy, to unlock that menu was only one by FF’d out

Your memory may not have XMP profiles, or you may need to change other BIOS settings first as well (such as any freq limiter settings, or any duplicate of same XMP/Custom/Auto type setting, I’ll have to look it over and get back to you)
It could also be your XMP profiles in memory are incorrectly configured, or version that is not compatible with this BIOS (maybe too modern of memory sticks, XMP too new etc). You can set yourself manually anyway, you do not need XMP now
Failed when set manually means you are setting something that is not working, ie too high of a freq for the rest of your hardware or not enough voltage or timings too tight for the speed you are setting etc. What are you trying to set exactly?
What chipset is this motherboard, and what CPU do you have? With below, show me CPU-z main window, and then motherboard tab too.

Meantime, show me an image of SPD tab of CPU-z, and show me an image of HWINFO64, showing the little CPU-z like window

* Edit - looking at the BIOS again, I see You need to enable >> OverClocking Feature at root of OverClocking Performance Menu before anything else.
Then, rest, I need to know what you are trying to set first, before I can advise. Also, set CMD Rate to 1 instead of default of 3, rest I need to wait until I know what you are trying to do.

Its Corsair memory, 32 GB (2x16) of DDR4 3200, just trying to set the 3200 profile. I dont think theres a problem with the ram but its always possible, i guess i lucked out cuz the memory chips are samsung b dye which i hear are good quality. Thanks for pointing out those BIOS settings, trying now!

that overclocking option you mentioned is on by default, where can i find the CMD rate setting?

*edit Also the intel extreme tuning utility still cannot modify the voltage, doesnt matter what you enter will still fail, cant even go up .5

any time i set xmp it gets a bad memory beep code, any time i set the settings manually it applies the timings no problems but wont change the voltage. from what i can tell it does not set the cmd rate to what you said by default, its set to auto which is 1t or 2t. and the overclocking function is also on by default. Im a noob when it comes to overclocking x.x